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VOLUME – I 1.AN INTRODUCTION TO STAR OFFICE WRITER 

I. Choose the correct answer:         

1. _______________ is an application that is designed to work on different operating systems 

 a) MS office  b) C++   c) star office   d) visual basic  

2. __________ is full-featured office productivity suite with powerful standalone applications.  

a) C++   b) star office   c) visual basic  d) MS office  

3. The term _______________ refers to the activity carried out using computer. 

 a) MS word   b) MS excel   c) text editing d) Word processing 

4. To start star office________ command is used.  

a) Start → All Programs → StarOffice8  b) Start → All Programs → StarOffice9 

c) Start → All Programs → StarOffice0  d) Start → All Programs → StarOffice 

5. _______________ applications are grouped together in to an integrated environment in 

which one can do several things 

 a) MS office  b) C++   c) star office   d) visual basic  

6. _______________ is a word processor. 

 a) star office writer b) star office calc  c) star office draw  d) all  

7. A document may contain_______________ 

 a) text   b) charts   c) pictures   d) all  

8. Which one of the following is not a word processing packages 

 a) Lotus AmiPro b) Word Perfect  c) MS Word   d) MS Excel  

9. The File → New → ____________ command can be used to open a new document 

 a) word document  b) blank document  c) empty document  d) text document  

10. When the characters are typed the insertion point, moves to the _______________  

 a) right   b) down   c) left    d) upward  

11. To move the insertion point to end of the line_______________ key is pressed  

 a) End   b) Shift + End  c) Alt + End   d) Ctrl + End  

12. The _______________ key must not be pressed at end of the each line  

 a) Ctrl   b) Shift   c) Enter   d) Alt  

13. Flashing vertical bar is called the _______________  

 a) key point   b) mouse point  c) word point  d) insertion point  

14. When the text being typed reaches the end of the each line, star office _______________ 

will automatically wrap the text to the next line. 

 a) writer   b) calc   c) base   d) word  

15. The _______________ key should be pressed only at the end of a paragraph 

 a) Enter   b) Ctrl   c) Alt    d) Shift  

16. The _______________ is always indicates where the new text will appear 

 a) insertion point  b) mouse point  c) key point   d) word point  

17. To move the insertion point with the mouse, the _______________ is moved to the required 

spot and the mouse button is clicked 

 a) mouse point  b) insertion point  c) key point   d) none  

18. Which one of the following is used to open a document  

 a) Ctrl + O   b) File → open  c) Open icon   d) all  

19. When a page is filled up, star office ___________ automatically creates a new page  

 a) calc   b) impress   c) draw   d) writer  

20. To move the insertion point to beginning of the document ___________ key is pressed 

 a) Home   b) Shift + Home  c) Ctrl + Home  d) Shift + Begin  
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21. The _______________ key is pressed only when a blank line is to be inserted  

 a) Enter   b) Ctrl   c) Alt    d) Shift  

22. _______________ is the keyboard shortcut for saving the document.  

 a) Ctrl + A   b) Shift + S   c) Ctrl + C   d) Ctrl + S  

23. The save document file name is appears in the ____________ bar. 

 a) menu   b) tool   c) title   d) status  

24. Which one of the following is used to save a document  

 a) File → Save  b) Save button  c) Ctrl + S   d) All  

25. The _______________ command can be used to close a document 

 a) File → Exit  b) Edit → Exit  c) File → Close  d) all  

26. The _______________ command can be set to quit from star office application. 

 a) File → close  b) File → Quit  c) File → Exit  d) All  

27. To reopen a document that has been saved and closed, the _______ command can be used 

a) Edit → open  b) View → open  c) File → open  d) all  

28. Click on the _______ menu option and select the file from the list of documents displayed 

a) window   b) edit   c) insert   d) file  

29. To move the insertion point to anywhere in the document either the ________ can be used 

a) mouse   b) keyboard   c) a or b   d) none  

30. The thick- horizontal line in the page area is called the _______________ marker.  

 a) bottom   b) end   c) insertion point   d) end of document 

31. The _______________ cannot be beyond the horizontal line  

 a) mouse point  b) insertion point  c) key point   d) none  

32. To move the ______ with the keyboard arrow keys and other key combination can be used  

a) mouse point  b) insertion point  c) key point   d) none  

33. The key combination is joined with a ______________ sign 

 a) minus   b) opposite   c) multiply   d) plus  

34. To move the insertion point to end of the document _______________ key is pressed 

 a) Ctrl + Begin  b) Ctrl + Shift  c) Alt + End   d) Ctrl + End  

35. If the document is long the text can be scrolled through without moving the ___________ 

 a) characters   b)scroll arrows  c) mouse point  d) insertion point  

36. There are _______________ sets of scroll arrows in star office writer  
 a) 1    b) 2    c) 3    d) 4  
37. To scroll up and down the _______________ arrow respectively should be clicked 
 a) left and right  b) up and down  c) a or b   d) none  

38. The mouse click should be used to get the _______________ at the required place.  

 a) J- beam   b) S – beam   c) T- beam   d) I – beam  

39. If a mistake is identified it can be corrected in _______________ways  

 a)1    b) 2    c) 3    d) 4  

40. Which key is pressed down and the movement keys are used to highlight the required text.  

 a) Ctrl   b) Alt + Ctrl   c) Shift   d) Enter  

41. The user in the _______________ mode, if the text existing to right of the insertion point 

disappears, while typing a new text.  

 a) type-over   b) switch   c) insert   d) all  

42. The user can toggle between type over mode and the insert mode by using the_______ key. 

 a) window   b) insert   c) enter   d) status.  

43. The _______________ bar gives the information about the current mode. 

 a) title   b) menu   c) tool   d) status  
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44. _______________ mode is the default mode in star office writer. 

 a) insert   b) type over   c) toggle   d) switch  

45. The _______________ key deletes the characters to the left of the insertion point. 

 a) delete   b) back space  c) erase  d) all  

46. The _______________ key deletes the characters to the right of the insertion point. 

a) delete   b) back space  c) erase  d) all 

47. For selecting text the _______________ can be used  

 a) mouse   b) keyboard   c) a or b   d) none  

48. _______________ is moved to start of the text to be selected  

 a) mouse   b) mouse point  c) ball point   d) insertion point  

49. When the intended text is selected, the _______________ should be released 

 a) mouse button  b) start button  c) a or b   d) none  

50. The ___________ mouse button should be clicked, held down and dragged across the text to 

be selected   

a) right   b) left    c) center   d) all  

51. To unselect the wrongly selected text _______ should be made outside of the selected text  

a) a click   b) double click  c) copy   d) none.  

52. The _______________ command is used to cut the selected text.  

 a) Edit → Cut  b) File → Cut  c) View → Cut  d) none  

53. The _______________ command is used to paste the selected text.  

a) Edit → paste  b) File → paste  c) View → paste  d) none  

54. The _______________ can be made to select a particular word 

 a) double click on a word    b) one click on the word   

c) press shift key     d) press enter 

55. The _______________ shortcut can be used for copying the text.  

 a) Shift + C   b) Ctrl + C   c) Alt + C   d) Shift + Ctrl + Alt 

56. The _______________ command is used to copy the selected text. 

 a) Edit → copy b) File → copy c) View → copy d) none  

57. The _______________ key combination is used to select a entire document.  

 a) Ctrl + A   b) Ctrl + S   c) Shift + S   d) Ctrl + X  

58. The _______________ shortcut can be used for paste the text.  

 a) Shift + P   b) Ctrl + P   c) Ctrl + V   d) Shift + v  

59. The _______________ shortcut can be used for cut the text.  

 a) Shift + C   b) Ctrl + C   c) Ctrl + X   d) Shift + X  

60. To get Find and replace dialog box, choose _______________ Find & Replace  

 a) File   b) View   c) Edit   d) Format  

61. In the _______________ box, type the text that you want to find in your document  

 a) replace   b) replace with  c) search for   d) search  

62. To replace the found instance of the text with what you entered in the Replace with box, then 

click ___________ 

 a) replace   b) replace all  c) search for   d) search   

63. How many combo boxes are there in Find and Replace dialog box 

 a) 1    b) 2    c) 3    d) 4 

64. In the _______________ box, enter the replacement word or phrase.  

a) replace   b) replace with  c) search for   d) search 
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65. The text that you selected is automatically entered in the _______________ box.   

a) search for   b) replace  c) find   d) search  

66. Entering a new text or modifying the existing text in a document is known as ___________ 

 a) page ending  b) spelling   c) correction   d) text editing 

67. Copy, cut, paste, find and replace are some of the commonly used________ functions 

 a) Formatting  b) editing   c) sorting   d) compiling 

68. The default name for a new document of star office is__________ 

a) Untitled1  b) No name  c) Default  d) New document 

69. The ________ pointer is different from insertion point. 

a) Mouse  b) Key   c) Insertion  d) Indicating 

70. Star office was developed by___________ 

 a) Microsoft     b) Sun Micro system   

 c) apple     d) lotus corporation 

71. In star office writer, you can switch between the documents in __________ ways. 

 a) 2   b) 3   c) 4   d) 5 

72. To scroll a relative distance in the document the __________ should be drawn up or down 

 a) insertion point    b) mouse pointer   

 c) scroll arrow    d) scroll box 

73. Star office consists of ___________ applications 

 a) 6   b) 3   c) 5   d) several 

74. Which of the following one some of the commonly used editing functions? 

 a) cut, copy, save    b) cut, copy, paste  

 c) cut, copy, close    d) cut, copy, scroll 

75. To skip the found text and to continue the search click .. again 

 a) ignore  b) ignore once c) find next  d) find 

76. To move the insertion point one word to the right … movement keys are used 

 a) left arrow     b) right arrow  

 c) ctrl + left arrow    d) ctrl + right arrow 

77. Identify which is not the editing function. 

 a) copy  b) cut   c) open  d) paste 

78. Text document can be created using 

a) Star Office Calc    b) Star Office Impress  

c) Star office Base    d) Star Office Writer 

79. To replace all the found instance of the text with what you entered in the Replace with box, 

then click ___________ 

 a) replace   b) replace all   c) search for   d) search   
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VOLUME – I        2.TEXT FORMATTING 

I. Choose the correct answer:         

1. The formatting options available under ____________ menu.  

 a) file    b) format   c) insert   d) tools  

2. The ____________ key combination is used to make text italic  

 a) Ctrl + I   b) Alt + I   c) Tab + I   d) Shift + I  

3. A ____________ command is used to open the character dialog box. 

 a) insert → character    b) edit → character  

c) format → character    d) tools → character  

4. A ____________ is a set of characters and numbers in a certain style.  

 a) font   b) point   c) text   d) button  

5. The ____________ key combination is used to make text bold  

 a) Ctrl + B   b) Alt + B   c) Tab + B   d) Shift + B 

6. The ____________ fonts look professional and are suited for business documents.  

 a) Fajita   b) wing dings  c) Arial   d) Times New Roman  

7. The size of the font is measured in ____________ 

 a) points   b) number   c) integer   d) character  

8. The ____________ key combination is used to make text underline   

 a) Ctrl + U   b) Alt + U   c) Tab + U  d) Shift + U 

9. The ____________ fonts are used to decorative  

 a) fajita   b) wing dings  c) Arial   d) Times New Roman  

10. There are ____________ points to an inch  

 a) 6 points   b) 70 points   c) 84 points   d) 72 points  

11. The ____________ fonts are actually sets of symbols  

 a) Fajita   b) Wingdings  c) Arial   d) Times New Roman 

12. ____________ inches to an size of a character  

 a) 1/6    b) 1/72   c) 1/80   d) none  

13. The ____________ font can be used to insert special characters in the document 

a) Fajita   b) Wingdings  c) Arial   d) Times New Roman 

14. ____________ can be use to call attention to key ideas or pointers in a document. 

 a) highlight   b) font size   c) Font color   d) none  

15. To remove the highlighting, select the  text and select the _______ from the color palette 

 a) cancel   b) color remove  c) no fill   d) remove  

16. A paragraph is any text followed by a ____________  

 a) line breaks  b) soft return   c) alignment   d) hard return  

17. The ____________ key combination is used to make text a centered  

 a) Ctrl + C   b) Ctrl + E   c) Shift + C     d) Shift + I  

18. ____________ are inserted as line breaks by star office 

 a) line breaks  b) soft return   c) alignment   d) hard return  

19. The ____________ key combination is used to make text a justify 

 a) Ctrl + J   b) Ctrl + U   c) Shift + J   d) Shift + U  

20. A hard return is inserted every time when____________ key is pressed   

 a) Shift   b) Backspace   c) enter  d) Shift + Ctrl + Alt 

21. Which is the default alignment in star office writer  

 a) centered   b) justify   c) right   d) left  
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22. The ____________ key combination is used to make text as right alignment  

 a) Ctrl + H   b) Ctrl + R   c) Shift + R   d) Shift + h   

23. There are ____________ types of alignments in star office writer 

 a) 2    b) 4    c) 7    d) 8  

24. The ____________ key combination is used to make text as left alignment  

 a) Ctrl + R   b) Shift + R   c) Shift + L   d) Ctrl + L 

25. ____________ changes are most appropriate for headings or other special paragraphs in the 

document  

 a) highlight   b) alignment   c) colour   d) indent  

26. A special kind of indent is called a ____________ 

 a) negative indent  b) text indent  c) positive indent  d) hanging indent  

27. Click the increase indent icon, the paragraph is indented ____________ inch  

 a) ¼    b) ½    c) 2/3    d) 1/6  

28. There are ____________ types of indents in star office writer 

 a) 1    b) 2    c) 3    d) 4  

29. Move the ____________ to the beginning of the paragraph to be indented.  

 a) insertion point  b) mouse point  c) enter   d) insert key  

30. ________command is used to get the indents & line spacing tab in the paragraph dialog box  

 a) format → paragraph    b) file → paragraph  

c) insert → paragraph          d) tools → paragraph  

31. To indent from the left, give the amount to be ________ spin box  

 a) before text   b) after text  c) above text   d) below text  

32. The ____________ option can be used to indent the line of the paragraph 

 a) first line   b) second line  c) middle line  d) last line  

33. A negative value will result in ____________ indent  

 a) increase   b) first line   c) hanging   d) none  

34. If a ____________ value is specified, the first line will be indented  

 a) increase   b) negative   c) binary   d) positive  

35. The default line spacing in star office writer  is ____________  

 a) double   b) single   c) 1.25 lines   d) none  

36. There are ____________ types of line spacing on star office writer 

 a) 4    b) 8    c) 9    d) 7  

37. Which one of the following is not a type of line spacing  

 a) 1.5    b) leading   c) 2.5 lines   d) none  

38. Which one of the following is a type of line spacing  

 a) proportional  b) at least   c) fixed   d) all  

39. ____________ are used to list the important points and messages  

 a) special characters  b) symbol  c) bullets and numbering  d) none of these 

40. One way to set a list of points or topics in a document is to create a ____________ list  

 a) bulleted   b) numbered   c) series   d) filtered  

41. ________ lists of work well for directions or other points one want to present in sequence 

 a) bulleted   b) numbered   c) series   d) filtered  

42. Star office _________ automatically numbers all the items in a list, and the text is indented 

 a) base   b) calc   c) draw   d) Writer 

43. The fastest way to create a bulleted list is to be use the bullets button on the _______ tool bar  

 a) formatting   b) inserting   c) viewing   d) editing  

44. To remove number from a list, select the list and click the ____________ button  
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 a) numbering  b) bulleting   c) removing   d) deleting  

45. A ____________ is named set of defaults for formatting text.  

 a) font   b) highlighting  c) styles   d) bullets and numberings  

46. There are ____________ types of help system in star office 8.  

 a) 3    b) 5   c) 1    d) 4  

47. ____________ function key is used to get the star office help  

 a) F2    b) F9    c) F1   d) F5  

48. Click the ____________ appears automatically when you perform a complex task  

 a) help agent   b) extended help  c) online help  d) help tip  

49. Rest the mouse pointer over a menu command or over any icon to display a ____________ 

a) help agent   b) extended help  c) online help  d) help tip  

50. There are ____________ types of formatting in star office writer 

 a) 1    b) 2    c) 4    d) 6  

51. To view a brief description of what the command or icon does, press _______ to display an 

extended tip   

 a) F1    b) Shift + F1   c) Ctrl + F1   d) Alt + F1  

52. The ____________  is displayed on the screen in a small window 

  a) help agent  b) extended help  c) online help  d) help tip  

53. ____________ helps in providing the document in more readability  

 a) color text   b) indent   c) highlight   d) none  

54. Star office ____________ facility can be used by clicking on the help menu 

 a) help agent   b) extended help  c) online help  d) help tip  

55. The ____________ printer is required to get the hard copy of the document in colour. 

 a) white   b) colour   c) white and black   d) all  

56. ____________ feature is used to mark the important portions of the document.  

 a) highlighting     b) bullets & numberings   

c) indent      d) paragraph alignment  

57. Which command is used to opens the line spacing drop down list box under Indents & 

spacing tab  

 a) Format → paragraph    b) file  → paragraph 

c) insert → paragraph    d) tools → paragraph  

58. ____________ command is used to create the bullets & numbering list.  

 a) tools→ bullets & numbering  b) insert → bullets & numbering  

 c) Edit → bullets & numbering  d) format → bullets & numbering  

59.  ____________ command is used to opens the star office help  

 a) Format → star office help   b) insert → star office help    

c) view → star office help    d) Help → star office help   

60. Click the ________ icon, the paragraph is indented ½ inch from the left margin 

 a) increase indent    b) decrease indent  

c) hanging indent    d) lower indent 

61. The__________ icon is clicked to decrease of undo the indent 

 a) increase indent    b) decrease indent  

c) hanging indent    d) lower indent 

62. The ________ icons are useful it is needed to indent text from the left 

 a) increase indent  b) decrease indent c) hanging indent d) both a and b 

63. Bullets and numbering option is available under? 

a) Format  b) Edit   c) File   d) View 
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64. Which key is used to select the required portion of the text 

 a) ctrl   b) alt   c) enter  d) shift 

65. To indent from the right, type the amount to be indented in the _________ box 

 a) from left  b) from right  c) after text  d) before text 

66. Which of the following list box  displays the options bold, italic, underline? 

 a) type face  b) font   c) size   d) none of these 

67.  A _____ is any text followed by a hard return 

 a) sentence  b) word  c) document  d) paragraph 

68. Which of the following can be used to indent the line of the paragraph 

 a) indent   b) first line  c) spacing  d) line spacing 

69. Which command is used to format the text? 

 a) format → page    b)format→ paragraph     

 c) format → character   d) format → text 

70. Which of the following is true to change the fonts in Star Office Writer? 

a) Format → Character    b) Insert → Font  

c) View → Font     d) Format → Font 

71. Which button is clicked on the formatting toolbar to remove bullets from a list 

 a) remove bullet     b) delete bullet   

c) erase bullet     d) bullets and numbering  

72. To undo the change ____________ key combination is used  

 a) Ctrl + Z   b) Ctrl + U   c) Shift + Y   d) Ctrl + Y  

73. Long document can be formatted easily with__________  

a) shortcut keys b) bullets  c) F1 key  d) styles 

74. ____________can be used when making entire formatting changes  

a) styles  b) indentation c) auto format d) none of these 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

VOLUME – I        3.CORRECTING SPELLING MISTAKES 

I. Choose the correct answer:         
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1. __________includes a dictionary and spell-check program.  

a) Star office calc    b) Star office draw   

c)Star office base    d) Star office writer 

2. Star office writer compares each word with the_________ 

 a) Dictionary  b) book  c) document  d) file 

3. Star office writer underlines the misspelled with squiggly ______line. 

a) black  b) blue  c) red   d) green 

4. The misspelled word can be corrected in_________ ways 

a) 2   b) 4   c) 1   d) 3 

5. __________key is pressed to delete a misspelled word and the word is retyped 

a) delete  b) back space  c) erase  d) all  

6. To spell check a document _____is clicked  

a) format → spelling check   b) table → spelling check 

            c) tools → spelling → check  d) file → spelling  check 

7. The _________key may also be pressed to select the spelling command  

a) F1   b) F5   c) F9   d) F7 

8. In the spell check dialog box, the ______text area displays the misspelled word   

a) not in dictionary  b) dictionary  c) replace  d) suggestions 

9. There are how many combo boxes in spell check dialog box.  

a) 4   b) 6   c) 2   d) 8 

10. In spell check dialog box _______is clicked to skip this occurrence but stop on the next one. 

a) change  b) ignore  c) delete  d) ignore once 

11. In spell check dialog box________ is clicked to replace all occurrence of all word 

a) change all  b) change once c) replace   d) replace all 

12. In spell check dialog box, the________ text area displays any alternative spellings.   

a) not in dictionary  b) dictionary  c) replace d) suggestions 

13. If none of the replacements is correct, correction can be made in manually in the ________. 

a) not in dictionary  b) dictionary  c) replace d) suggestions 

14. _________button is clicked to add the word to the dictionary.  

a) insert  b) change  c) add   d) join 

15. In spell check dialog box ________button is clicked to replace the word with one of the 

selected spellings. 

a) change all  b) change  c) replace  d) replace all 

16. In spell check dialog box ________is clicked to skip this occurrence of all the word  

a) ignore all  b) ignore once c) change  d) replace all 

17. An error and its correction are added to __________option.   

a) auto correct   b) auto format c) auto list  d) auto display  

18. The ________command is used to open the auto correct dialog box. 

a) format→  auto correct   b) tools → auto correct  

c) insert→ auto correct   d) none 

19. In the auto correct dialog box the replaced word is typed in the _________text box. 

a) replace    b) exceptions  c) with  d) replace all 

20. How many tabs in are there in auto correct dialog box.   

a) 3   b) 7   c) 5   d) 10  

  

21. How many combo box or text box there in auto correct dialog box.  

a) 2   b) 5   c) 3   d) 6   
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22. In the auto correct dialog box the replacement word is typed in the ________text box.  

a) replace    b) exceptions  c) with  d) replace all   

23. _____________option can be used to automatically replace the misspelled word with the 

correct spelling 

a) auto correct b) auto format c) replace  d) suggestions  

24. The only check box in the auto correct dialog box is_________.  

a) match case    b) numbers  c) text only  d) whole words only  

25. Which tab selected in the auto correct dialog box for creating autocorrect entry 

 a) spelling  b) auto correct c) with  d) replace 

 

VOLUME – I        4.WORKING WITH TABLES 

I. Choose the correct answer:  

1. The ___________command is used to create the simple table    

a) Table → Insert → Table     b) Insert → Table → Table 

c) Insert → Table → rows   d) Insert → Table →Columns 

2. Star office writer displays the table as a ____________     

a) cell   b) square  c) border   d) grid 

3. By default each cell includes a___________ 

a) border  b) name     c) row   d) column 

4. In the insert table dialog box, in the -------- text box the name of the table is given.  

a) row   b) column  c) name  d) none 

5. The number of columns and rows are entered in the columns and rows text box by            

using the __________  

a) Command  b) arrow key  c) spin arrows d) none 

6. _____ command is used to get the insert function floating tool bar 

a) Format → Insert    b) File → insert  

c) Insert → Insert    d) View → tool bar → Insert 

7. A _____ is a intersection of a row and a column  

a) Border            b) table  c) grid   d) cell 

8. To delete more than one columns in the table , using _____  

a) Delete → table → columns  b) Table → add → columns 

c) Table → delete → columns  d) table → columns → delete 

9. The simplest way to add a row is to press ______ in the last row of the table  

a) Enter     b) tab   c) bake space  d) insert 

10. Star office writer places the insertion point in the _____ of the table 

a) First cell  b) above the table c) below the table d) last cell 

11. When Table → insert → table is selected from the menu bar, the _____ dialog box appears 

on the screen 

a) table insert  b) table icon   c) table format  d) insert table  

12. _________ key is pressed to move forward or right through the cells 

a) Enter   b) tab    c) ctrl + tab   d) shift + tab 

13. To insert more than one row in the table , using _____ 

a) table → insert → rows    b) Table → add → rows 

c) Table → rows → insert    d) insert → table → rows     

                    

14. __________ key pressed to delete only entries in the selected table 

a) back space  b) Shift + delete c) table → Delete  d) delete     
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15. __________ key is pressed to move backward or left through the cells   

a) Enter   b) tab    c) ctrl + tab   d) Shift + tab  

16. To delete more than one row in the table , using ________   

a) delete → table → rows    b) Table → delete → rows   

c) Table → row → delete    d) table → delete  

17. To resize a column, hold down __________ and then press the left or the right arrow  

a) ctrl   b) tab    c) alt    d) enter  

18. To insert more than one column in the table, using  ____________ 

a) table → insert → columns   b) Table → add → columns  

c) Table → column → insert   d) insert → table → rows  

19. To resize a row, hold down ___________ and then press the up or the down arrow  

a) ctrl   b) shift   c) alt    d) tab 

20. The __________ command is used to delete the entire table  

a) table → delete      b) table → delete → table   

c) delete → table → table    d) table → table → delete  

21. To resize the column without changing the width of the table, hold down ____________ and 

then press the left or the right arrow  

a) alt   b) tab    c) shift + ctrl   d) alt + ctrl  

22. To delete more than one column in the table, using  ____________ 

a) table → delete → columns   b) Table → remove → columns  

c) Table → column → delete   d) delete → table → rows 

23. The __________ command is used to get a table format dialog box  

a) table → properties    b) table → insert → properties  

c) table → table properties    d) insert → table → properties  

24. How can we make the all columns even  

a) column → space equally   b) insert → column → space equally 

c) format → column → space equally  d) space equally → column  

25. Once a click is made inside a table a _____ toolbar for tables appears at the top of the screen  

a) format  b) insert   c) table   d) table formatting 

26. How can we make the all rows even   

a) row → space equally    b) insert → row → space equally  

c) format → row → space equally  d) space equally → row  

27. A table is a grid with a  specified number of _____ and _____ 

a) cells, borders  b) rows, cells  c) columns, borders   d) rows, columns  

28. _____ dialog box can be used to set the width of the column to an exact size  

a) Table fix   b) table format  c) format table  d) auto format  

29. The _____ icon in the table formatting tool bar is used to change the different borders of the 

table 

a) insert  b) table   c) optimize   d) border  

30. Which can be easily inserted at any point in the document 

a) formulas  b) icons   c) tables   d) none 

31. ____________ command is used to select the entire table. 

a) Table → insert → select   b) table → select →table 

c) insert →table →select   d) table → select → row 

 

32. ________tool bar is used to change the borders of the table 

 a) table insert     b) table border   
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c) table formatting    d) table delete 

33. Which command is used to change the width of the column in a table? 

 a) table → column → width  b) table → table properties 

 c) table → width → column  d) format → width → column 

34. In the insert floating tool bar, _______ is the first icon  

a) inset table  b) insert row  c) insert column d) merge cells 

35. In insert table dialog box, ______ text box is used to give the name of the table. 

 a) table  b) name  c) row   d) column 

 

 

VOLUME – I        5.PAGE FORMATTING 

I. Choose the correct answer:         

1. ____________ control how close star office writer prints to edge of the page.  

a) page   b) documents  c) margins   d) dialog box  

2. The default margins are ________ inch top and bottom and ________ inches left and right  

a) 1, 1.25  b) 1.50, 1.25   c) 1, 1.50   d) 1.25, 1  

3. How many ways the margin can be changed  

a) 5    b) 1    c) 4    d) 2  

4. If the users know the exact value for the margins then the _______ dialog box can be used to 

make a change  

a) margin   b) page style   c) ruler   d) page format   

5. ____________ option in the file menu can be used to see the change before printing   

a) page preview  b) page view   c) print view   d) print preview  

6. If the ruler is not displayed in the screen ____________ option is clicked   

a) file → ruler  b) edit → ruler c) view → ruler d) format → ruler 

7. There are ____________ types of page orientation in star office writer   

a) 2    b) 4    c) 7    d) 3  

8. The ____________ command is selected to open the page style dialog box  

a) file → page  b) insert → page c) view → page d) format → page 

9. If the user is not having the exact value for the margin then the ____________ option can be 

used to change the margins   

a) page style dialog box  b) ruler  c) none   d) page format dialog box 

10. The page preview option under ____________ menu   

a) format   b) edit   c) view   d) file  

11. The default page orientation is called   

a) portrait   b) landscape   c) document   d) header  

12. The ruler option under ____________ menu   

a) file    b) edit   c) view   d) format   

13. The ____________ is moved in between the gray and white area of ruler   

a) insertion point  b) mouse pointer  c) word point  d) key pointer  

14. The width of the document is more than the length of the document is called __________ 

a) portrait   b) landscape   c) document   d) header  

15. The default width of the default orientation is _________ inch by _________ inch paper   

a) 8.5, 11   b) 11.5, 8   c) 8, 11.5   d) 11, 8.5  

 

16. The length of the document is more than the width of the document is called _________ 

a) portrait   b) landscape   c) document   d) header  
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17. In page style dialog box, select the necessary paper format from the format drop down list in 

the _________ section  

a) format   b) header   c) margin   d) paper format  

18. ____________ dialog box is used to set the width of the paper   

a) page   b) auto correct  c) page style   d) auto format  

19. ____________ is an area at the top of the page  

a) footer   b) margin   c) header   d) document   

20. ____________ is an area at the bottom of the page   

a) footer   b) margin   c) header   d) document  

21. To create a header, the ____________ check box is clicked from the header tab on the page 

style dialog box  

a) header   b) header list   c) header on   d) option (a) and (c)  

22. To create a footer, the ____________ check box is clicked from the header tab on the page 

style dialog box  

a) footer   b) footer list   c) footer on   d) option (a) and (c) 

23. When the header tab is clicked on the page style dialog box ____________ spin boxes are 

also displayed  

a) 1    b) 7    c) 4    d) 2  

24. There are ____________ tabs in the page style dialog box  

a) 2    b) 10    c) 12    d) 8  

25. The ____________ command is used to insert page numbers on every page   

a) insert → field → page numbers  b) insert → page number   

c) insert → field     d) insert → page number → field  

26. Once the page numbers have been inserted, their format can be changed using the 

____________ dialog box  

a) page format  b) page style   c) format page  d) auto list   

27. The required style can be selected from the list of styles displayed in the ____________ 

combo box on the page style dialog box  

a) insert   b) borders   c) margins   d) format  

28. __________ are some reference remarks added at every page of the document of the top and 

bottom margins respectively. 

a) header  b) footer  c) margins  d) header and footer 

29. In the page style dialog box, format combo box available in________ section 

a) format  b) layout settings c) section  d) insert  

30. Page tab is available under____________ menu 

a) Format  b) Insert c) Edit  d) File  

31. In page style dialog box, _____ tab is used to change the margin settings of star office writer 

 a) format  b) margin  c) margin format d) page 

32. ___________ command is used to change the page orientation of the document  

 a) format → orientation b) format → page setup c) format → page d) edit → page 

33. _________ dialog box can be used to create a header or footer 

a) header  b) footer  c) page setup  d) page style 

34. Which command is used to change the margin? 

 a) edit → margin b) format → margin c) format → page   d) format → margin 

 

VOLUME – I        6.SPREADSHEET 

I. Choose the correct answer:         
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1. The personal computer first appeared in __________ 

a) 1975  b)1982  c) 1970  d)1979 

2. Dan Bricklin and Bon Frankston invented VisiCalc for __________  

a) Apple  b)Apple I  c) Apple II  d)Apple III 

3. Commercial electronic spread sheet packages are in use since late  _________  

a) 1975  b) 1982  c) 1970   d) 1979 

4. _______________ is the first Commercial electronic spread sheet package  

a) star calc  b) excel  c) lotus   d) VisiCalc 

5. ______________ is powerful spread sheet program included in star office    

a) MS excel  b)VisiCalc  c) star calc  d) all 

6. The ___________ bar have shortcut icons for frequently done tasks   

a) menu bar    b)main tool bar c) status bar  d) object bar 

7. __________ bar is used to display the current cell and its content    

a) function bar  b) toolbar  c) formula bar d) object bar 

8. Name of the first cell in star office calc ____________   

a) A    b) Ctrl + A   c) Al    d) Shift + Al 

9. The ________ operator combines sections of text to the entire text   

 a)&   b):   c)!   d)&& 

10. A continuous group of cells in a worksheet is called a _________  

a) cells   b) range   c)reference   d) group 

11. Which is the correct order of arithmetic operator   

a) ( ^ , - , * , / , + , - )    b) ( - , * , / , ^ , + , - )  

c) (  + , - , * , /, ^ , - )    d) none of these 

12. The first commercial spread sheet package developed for _________  

a) mini computers       b)super computers   

c) micro computers     d) analytical engine  

13. Lotus development corporation introduced Lotus 1 – 2 -3 in______  

a) 1975  b) 1982  c)1970  d) 1979 

14. A range address is followed ___________    

a) dot   b) colon  c) semi colon  d)arrow 

15. A ________ is  a tool for working with numbers   

a) work sheet  b) spread sheet  c) empty sheet  d)rough sheet 

16. Dan Bricklin and Bon Frankston invented VisiCalc for Apple II  in __________  

a) 1975  b) 1982  c) 1970  d) 1979 

17. Spread sheets are made up of _______ and ____________  

a) gird , cell  b) cell , row  c) row ,column d) column ,cell 

18. The cells are addressed in terms the row and column _______  

a) tables   b) data   c) formula  d) labels 

19. An electronic spread sheet is a ______ used in a computer    

a) work sheet  b) spread sheet  c) empty sheet  d) rough sheet 

20. The intersection rows and columns creates _______  

a)tables   b)cells   c) border   d)all 

21. Spread sheet contains_____  

a)numbers   b) text   c)formulae  d) all 

 

22. VisiCalc contained __________ rows and _______ columns   

a) 254,63  b) 255,32000  c) 32000,254  d) 63,254 
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23. A spread sheet is like a __________ of cells with a programmable calculator attached to 

each cell   

a) grid   b) table  c) row and column  d) border 

24. _________ package became very popular because of its ability to combine data base 

management and graphics features with its spread sheet   

a) excel   b)Quattro pro  c) lotus 1 – 2 – 3  d)done 

25. The first commercial spreadsheet package developed in _________  

a) 1980  b)1979  c)1975  d)1982 

26. Star office calc contained 1 to ________ rows 

 a) 3200  b) 35000  c) 254   d) 32000 

27. _____________ package developed from Borland international   

 a) excel  b) Quattro pro c) lotus 1 -2 -3  d)star  office calc 

28. The cells A4, A5, A6, B4, B5 and B6 can be referred to as ______________ 

a) A4 + B6  b) A4!B4  c) A4:B6   d) A4& B6 

29. The arithmetic operators return ___________ results 

 a) true or false b) logical  c) numerical  d) positive 

30. Below the ________ bar are the column headings of the work sheet  

 a) formula bar b) function bar c) scroll bars  d) toolbar 

31. At extreme bottom are the ________and________ bars  

 a) tool bar and object bar   b) function bar and formula bar   

 c) status bar and scroll bar   d) menu bar and tool bar 

32. The active cell is identified by__________ 

 a) cell    b) mouse pointer c) insertion point d) cell pointer 

33. Which of the following keys are also used  to move around the worksheet   

 a)tab , arrow key    b) home, end    

c) page up and page down   d) all of these 

34. ______________ also allows you to enter dates and time in the work sheet  

 a) star office calc     b) star office writer   

c) star office draw     d) star office impress 

35. How can you enter the date in the worksheet 

 a) DD/YY/MM     b) MM/YY/DD   

c)YY/DD/MM     d) MM/DD/YY   

36. How can you enter the time in the work sheet 

 a) HH:MM:SS     b) SS:MM:HH   

c) HH:SS:MM     d) MM:SS:HH  

37. To save the worksheet created, go to the ____ menu and select the save or the save as option 

 a) file    b) view   c) format   d) edit  

38. To close the worksheet click close button under __________ menu  

 a) format   b) tools   c) edit   d) file  

39. To open a worksheet that has been saved, select the open option from the _______ menu 

 a) format   b) tools   c) edit   d) file  

40. The __________ option under the file menu can be used to quit from star office  

 a) close   b) end   c) quit   d) exit  

 

 

41. To edit the data present in a work sheet, by clicking __________  

 a) file → open     b) format →  open   

www.Padasalai.Net                                                                                                                    www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

         J.P.MURUGAN, M.Sc., B.Ed.,         Cell:9789633793,  9488832229 Page 18 

 

c) view →  open     d) edit →  open  

42. To create formula, first know the _____ that describes the format of specifying the formula 

 a) ruler   b) syntax   c) calculations  d) operators  

43. The formula begins with an _________ sign followed by a combination of values 

 a) less than   b) plus   c) equal   d) exclamation   

44. Comparative operators return the result _________ 

 a) true   b) numerical   c) false   d) true or false  

45. The _________ operators are used to combine areas in star office calc. 

 a) ! and #   b) & and %   c) ! and :   d) none  

46. _________ automatically generates a data series based on a defend pattern  

 a) auto format  b) edit fill   c) auto fill   d) all  

47. ___________ cell addressing is the default type of cell addressing used by star calc 

 a) relative  b) logical  c) arithmetic  d) absolute 

48. ____________ are predefined formulate that are available in star office calc 

 a) cell addressing  b) functions  c) values  d) tables 

49. A cell addressing can be made absolute by using the _______ sign in front of row and 

column  names 

 a)+   b) #   c)$   d)@ 

50. ____________ cell address do not change when copied 

 a) relative   b) logical   c) arithmetic   d) absolute  

51. Which of the following is not a arithmetic operator   

 a) ^   b) +   c) #   d) % 

52. The functions are available in star calc in the pull down menu of _____________ window 

 a) formula wizard    b) category wizard  

c) sum Wizard    d) function wizard 

53. To select a function go to ____________ menu and select the function option  

 a) file    b) insert   c) table   d) format  

54. A list of all functions is displayed in the function box when All is selected in the 

____________ box. 

 A) category box  b) spin box   c) function box  d) combo box  

55. ____________ function is used to find the square root of number 

 a) SQR( )   b) SQT( )   c) SQRT( )   d) SQUARE ROOT( ) 

56. Star office calc suggests a ____________of cells for which sum is calculated  

a) range   b) copy   c) format   d) sum  

57. ____________ function calculates the sum of a given set of numbers  

 a) add    b) total   c) sum   d) calc  

58. Press __________ to accept this suggested range or press ____________ key and type in the 

range that you want  

 a) backspace   b) delete   c) enter   d) clear  

59. Which of the following is not a comparative operator  

 a) <=    b) !=    c) >=    d) <> 

60. ____________ icon provides to generate a scrolling screen within a worksheet 

 a) insert floating frame    b) insert chart    

c) insert formula     d) insert  

 

61. ____________ icon is used to insert objects from other application in to a worksheet  

 a) insert object     b) insert applet   
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c) insert formula     d) insert OLE object  

62. Star office calc software is the ability to generate charts based on ____________ data  

 a) integer   b) numeric   c) floating   d) all  

63. The ____________ command is used to insert a chart in worksheet  

 a) view   → chart     b) insert  → chart    

c) format  → chart     d) tools  → chart  

64. The cursor becomes a ____________ sign with small picture of the graph 

 a) /   b) -    c) *    d) +  

65. In star office calc, a spreadsheet contains ____________ sheets  

 a) single   b) multiple   c) hierarchical d) hybrid 

66. In star office calc, list of sheets appears as tabs at the ____________ of the window 

 a) left corner   b) top    c) bottom   d) right corner  

67. Select the range to be printed and click ____________ command  

 a) format →  print range → edit   b) file →  print range → edit   

 c) view →  print range → edit   d) tools →  print range → edit 

68. To remove the print range setting click on ________ command  

 a) file →  print range → delete   b) format →  print range → remove   

 c) view →  print range → cancel   d) tools →  print range → edit  

69. Which is pressed while editing the contents of cell 

 a) F1    b) F2    c) F5    d) F7  

70. The operator <> is used to check __________  

 a) equal   b) greater than  c) less than   d) inequality  

71. Which of the following formulae calculates the sum of the numbers in the cell A1 of sheet1 

and A2 of sheet2   

 a) =sum(sheet1.A1+sheet2.A2)   b) =sum(sheet1:A1;sheet2:A2)   

 c) =sum(sheet1.A1;sheet2.A2)  d) =sum(sheet1:A1:sheet2:A2) 

72. To do the calculations for different worksheets in a particular sheet, we use __________ 

 a) 2D formula  b) function   c) 3D formula  d) selection  

73. The key combination used to open print dialog box in star office calc is ________  

 a) Ctrl + shift + p b) Ctrl +P   c) Alt + P   d) Shift + P 

74. Which facility of star office calc helps to format the work sheet with different predefined 

styles and colours  

a) chart     b)auto format   

c) applet     d)multiple sheets 

75. Fill command in star office calc is available under the menu _________ 

 a) edit   b) format  c) file   d) view 

76. The first electronic spread sheet is __________ 

a) VisiCalc  b) star calc  c) lotus  d) excel 

77. Which menu can be used to change the column width and row height 

 a) edit   b) tools  c)file   d) format 

78. Which is used to print the work sheet with gird lines______  

 a) dialog box  b) gird text box c) check box  d)gird check box 

79. The separating the cells of the same sheet adds up the values 

 a):    b);   c)!   d), 

 

80. The _________ adds up the sum of different sheet values  

 a):    b);   c)!   d), 
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81. You can use a _______ calculate and analyze sets of numbers  

 a) spread sheet  b) work sheet  c) line sheet  d) none 

82. Graphic representations of numbers are known as ________ 

a) spread sheet  b) graph  c)chart  d) diagram 

83. A _______ refers to the file you create with spread sheet software 

 a) rough sheet  b) function  c) cells   d) work sheet 

84. Non – numerical entries are called _______ 

a) text   b) graph  c) label  d) formula 

85. The ________ is the sequence  of characters used in a formula 

 a) formula  b) syntax  c)operator  d)numbers 

86. You can automatically perform specialized calculations using _________  

a)functions  b) work sheet  c)formula  d) chart 

87. The __________ command is used to generate a series 

 a) auto   b) fill   c) auto format d) format 

88. Later in __________ when more usable PC started appearing ,it attracted a wider population  

 a) 1975  b) 1983  c) 1977  d) 1877 

89. __________ is a powerful computational tool could save time ,help avoid endless and brain 

numbering arithmetic and eliminate mathematical errors  

 a) spread sheet  b) Presentation  c) Multimedia d) Calculation. 

90. The _________ can perform calculations at a blinding spread   

 a) calculator   b) computer  c) Presentation  d) Audio player 

91. Electronic spread sheet can also be used for presenting the worksheet data in an impressive 

manner such as ________ and other visual forms . 

 a) bar- charts and pie charts   b)line graphs   

c) three- dimensional charts   d) all of these 

92. The term _________ has come to refer specifically to the software package   

 a) spread sheet  b) work sheet  c) empty sheet d) rough sheet 

93. There are numerous applications possible using __________ 

a) Electronic spread sheet    b) VisiCalc  

c) Calculator      d) Electronic work sheet. 

94. Which of the following is a spread sheet application  

 a) payment of bills     b) invoices  

c) tender Evolution     d) all of these 

95. Worksheet data can be viewed in the form of ____ 

a) graphs   b) charts   c) picture  d) graphs or charts 

96. The work sheet information can be transferred to any __________ software  

 a) data base     b) word processing  

c) presentation    d) Data base  or word processing 

97. _____________ was essentially a financial analysis program 

 a) star calc   b) VisiCalc  c) Ms excel  d) Quattro pro 

98. Creating a work sheet is a process that involves ________ 

a) entering data    b) creating formula   

c) labels      d) all of these 

 

 

99. To work with star office calc ,open star office and choose _______ 

a) File → new → work sheet   b) File → new → spread sheet     
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c) view → new → spread sheet   d) new → spread sheet 

100. At the top of the window is __________  

a) menu bar   b) Tool bar  c) formula bar d) function bar 

101. To begin with the ______ is always in cell A1 

 a) insertion point b) cell pointer  c) mouse pointer  d) none 

102. __________ key is used to delete the data or exit the data in the cell . 

 a) delete key  b) erase key   c) back space key  d) space bar key 

103. The syntax followed by a combination of __________ 

a) values   b) operators  c) cell references  d) all 

104. ____________ command is used to generate a series of data directly in the work sheet 

a) Edit → Fill → Direct   b) Edit → Fill  → series   

c) Tools → series     d) Format → Fill→ series 

105. ________ allows you to insert one or more cells rows and column in the work sheet 

 a) Star office draw    b) Star office calc  

c) Star office writer     d) star office impress 

106. Which command is used to get the insert cell floating tool bar  

 a) insert → insert cell    b) table → insert cell   

c) view → toolbars → insert cell   d) view → insert 

107.  How many icons available in insert cell floating tool bar  

 a) 3    b) 5     c) 4    d) 6 

108. Which of the following icon is not available in the insert cell floating toolbar  

 a) insert cell down     b) insert cell right   

c) insert cell left     d) insert rows 

109.  In  order to insert an empty cell in a column and move the existing cells down ,click on the 

___________ icon 

 a) insert cell down     b) insert cell right   

c) insert column     d) insert rows 

110. In order to shift the content of a cell to right click on ________ icon 

a) insert cell down     b) insert cell right   

c) insert cell left     d) insert rows 

111. In order to insert an empty row in a work sheet select the _________ icon   

a) insert cell down     b) insert cell right   

c) insert cell left     d) insert rows 

112. In order to insert an empty column in a work sheet select the __________ icon 

 a) insert cell down     b) insert cell right   

c) insert column    d) insert rows 

113. _______  specifies the contents to be deleted from a cell or cell range 

 a) Delete contents   b) back space  c) Edit contents  d) delete 

114. _______ command is used to open the delete contents dialog box 

 a) Insert → delete contents    b)format→ delete contents     

 c) Edit →delete contents    d) File → delete contents 

115. ________ fills the space produced by the deleted cells with the cells under neat it   

 a) shift cells up    b) shift cells down   

c) shift cell left     d) shift cells right. 

 

116. ____  fills the resulting space by the cells to the right of the deleted cells 

 a) shift cells up    b) shift cells down   
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c) shift cell left     d) shift cells right. 

117.  If you want to delete an entire row or column choose  

 a)Edit → delete cells     b) Format → delete cells   

c) Tools → delete cells    d) view → Delete cells  

118. Delete entire Row( s)  or Delete entire column (s) are available in the _______ dialog box  

 a) insert cells     b) Delete  cells   

c) Merge cells     d) split cell 

119. How many option are available in the delete cells dialog box 

 a) 3    b) 4    c) 5   d)6 

120. Star office calc provides the facilities for drawing lines, circle, ellipse, square ,rectangle ,etc 

in your work sheet click ______ icon in the standard tool bar 

 a) functions   b) drawing   c) clip art   d) show draw functions 

121. Star office calc provides tools  for inserting object like ________ in a work sheet 

 a) Chart   b) image   c) formula   d) all of these  

122. Star office calc provides tools for inserting objects like chart ,image ,formula, etc … in a 

work sheet click  

a) View → tool bars → insert object  b) View → insert object     

c) Tools → insert object    d) Format → tool bars → insert objects 

123. Which command is used to open the insert object floating tool bar  

a) View → tool bars → insert object  b) View → insert object     

c) Tools → insert object    d) Format → tool bars → insert objects 

124. How many icons are available in the insert object floating tool bar 

 a) 3    b) 4    c)8   d)6 

125.  To select a different sheet ,click the tab with the _______ 

 a) row   b) column  c) sheet’s name  d) cell 

126. The tab of the selected sheet appears in ______ 

a) red   b) black  c) white   d) gray 

127. In star office calc ,cells contain ________ 

a) values   b) labels   c) formula   d) all 

128. ___________ can be formatted are currency presents and displayed with or without decimals 

 a) Number   b) alphabet   c) formula   d) all of these 

129. Which command is used to format the cells in your work sheet 

 a) Format → page    b) format → cells   

c) view → toolbar → formatting   d) Tools → format 

130. How will you find the difference between two dates  

 a) = minus ( first cell – second cell )  b) = second cell – first cell  

 c) = minus ( second cell – first cell)  d) = first cell – second cell 

131. Column width and row height can be changed using  

 a) edit menu   b) tools menu  c) format menu  d) file menu  

132. In page style dialog box, the grid check box is available under__________ tab 

a) grid   b) page  c) format  d) sheet 

133. The combined cell column and row headings are known as the cell’s_________  

a) cell   b) address  c) pointer  d) insertion point 

 

 

134. The________ option on the file menu can be used to preview a worksheet before printing  

a) page view  b) print preview c) page preview d) print view 
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135. __________are used to make data easier to understand  

 a) highlight   b) picture  c) chart  d) special characters 

136. A_____ lets you create a value in one cell that is calculated based on the values in other cells 

 a) syntax  b) formula  c) sum( )  d) fill command 

137. In the print dialog box, the__________ option allows you to print only the selected area in a 

worksheet 

a) Pages  b) copies  c) select range d) selection 

138. The cells are addressed in  terms of __________ 

a) row label      c) column label   

c) cell label      d) both (a) and (b) 

139. Which of the following is the sequence of characters used in a formula?   

a) values      b) operators    

c) cell referencing     d) all of these  

140. Which operator does not return numeric results in star calc?   

a) ^    b) +    c) =    d) –(negation)  

141. How many formatting options available in number format section in the function bar 

 a) 2   b) 10   c) 7   d) 5 

142. Which command is used to change the column width of a worksheet in star calc?   

a) format→ column → width   b) insert → column → width    

c) format → width → column   d) insert → width → column  

143. PC means 

 a) personal calculator   b) pocket computer 

 c) personal computer   d) pocket calculator 

144. The ____ option under the ___ menu can be used to print the worksheet 

 a) file, print  b) print, file  c) tools, print  d) format, print 

145. In spreadsheet, the columns are designated package was developed by lotus corporation? 

 a) lotus 123     b) lotus AmiPro   

 c) improve     d)all of these 

146. In star office calc, the formula = A3+A4 can be typed as 

 a) a=add(A3:A4)    b) =sum(A3:A4)  

 c) =sum(A3;A4)    d) =sum(A3+A4) 

147. ___________ command is used to print the worksheet with gird lines 

 a) format→ sheet    b) format→ page  

 c) format → grid    d) file→ print → grid 

148. Which of the following mouse action in used to edit the data in the work sheet 

 a) click     b) click & drag  

 c) double click    d) file → exit all 

149. The intersection operator in star office calc is  

 a)&   b) ?   c) !   d) : 

150. Clicking on this icon will display the contents of the selected cells in default format 

 a) currency     b) standard   

 c) add decimal    d) delete decimal 

151. A ______ is like a grids of cells with a programmable calculator attached to each cells. 

 a) spreadsheet    b) document   

 c) database     d) presentation 

152. An application that is designed to work on different operating systems is 

 a) star calc     b) star office   
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 c)Linux office    d) ms office 

153. Function wizard shortcut icon is on the___________  

a) menu bar     b) object bar   

c) formula bar    d) function bar 

154. Number of cells are available in the worksheet range A1:B6 is__________  

a) 6   b) 10   c) 8   d) 12 

155. In star office calc, references to cells can be 

 a) absolute     b) relative   

 c) comparative    d) both (a) and (b)  

156. The operator that combines two texts as a single text is 

 a) =   b)&   c) +    d) $ 

157. Which command is used to print the work sheet with grid lines?  

 a) Format → Page  → Grid   b) Format → Sheet   

c)File → Print  → Grid         d) Format → Grid 

158. The Spread sheet developed by Microsoft is   

 a) Quattro Pro     b) Excel  

c) Improve     d) VisiCalc 

159. Which command is used to print the work sheet with grid lines?  

a) Format→ sheet     b) Format → Page→ sheet tab  → grid  

c) Format → Grid    d) File → Print → Grid 

160.  Which check box is used to print the work sheet with grid lines?  

a) text only  b) grid   c) format  d) sheet 

161. Which of the following function is most commonly used in star office calc? 

a) SQRT( )  b) SUM( )  c) SUBTRACT( ) d) ADD( )  

162. Which of the following symbol is used to separate the date, month, year in a worksheet  

a) :   b) \   c) /   d) ! 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

VOLUME – I        7.DATABASE 

I. Choose the correct answer:         
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1. The Star Office base applications may be _______ 

a) scientific     b) data processing  

c) manual     d) scientific or data processing  

2. Which of the following such as applications _________ 

a) payroll   b) banking  c) railway ticket d) all 

3. The term data comes from the word  

a) data   b) datum  c) date   d) information 

4. The _________ is a fact about people, places or some entities. 

a) data   b) operators  c) information d) symbol 

5. In computers ,data is simply the value assigned to a _______ 

a) currency  b) operators  c) information d) variable 

6. The term _____ refers to the name of a memory location that can contain only one data at any 

point of time. 

a) variable  b) operators  c) information d) DBMS 

7. In star office base, the data types can be classified into _______ types 

a) 3   b) 4   c) 5   d) 6 

8. Which of the following are the types of numeric data type   

 a) integer  b) date   c)time   d) all 

9. Which of the following are the types of data types 

 a) character  b) number  c) Boolean  d) all 

10. The programming languages and packages provide their own built in ________ data types 

a) negative  b) positive  c) primitive  d) typedef 

11. The primitive data type such as ______ and _________  

a) int, float  b) int, char  c) float, char  d) float, data 

12. Data base systems provide a facility by which users can define their own more __________ 

data type 

a) Communicated b) sophisticated c) numerical  d) alphabetical  

13. The sophisticated data types are referred, which are known as _________. 

a) user defined b) built-in  c) derived  d) enumerated  

14. _________ is defined as a set of processed data that convey the relationship between data 

considered 

a) data base  b) information c) data   d) data types 

15. ________ means to do some operations or computations on the data of different variables to 

relate them so that these data when related covey some meaning 

a) processing  b) collection  c) verifying  d) simplifying 

16. __________ is as group of related data conveying some meaning. 

a) data base  b) information c) data   d) data types 

17. _____________ may relate to any field of application. 

a) data processing b) collection  c) verifying  d) simplifying 

18. _________ involves data collection verification and validation of data and report generation 

a) verifying   b) collection  c) data processing d) simplifying 

19. Store data ,process the stored data for analyzing the results and print the results in a desired 

format this type of data processing as _________ data processing 

a) computerized b) manual  c) actual  d) formal 

 

20. How many ways the data can be processed  

 a)4   b) 5   c)2   d)3 
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21. The work has been carried out by long –hand effort is called ______ data processing 

a) computerized b) manual  c) actual  d) formal 

22. A ____________ is a repository of collections of related data or facts. 

a) data base  b) information c) data   d) data types 

23. Data in a data base in most commonly viewed in _________  dimensional tables  

a) one   b) two   c) three  d) four 

24. The entire collection or related data in one table is referred to as a _______ 

 a) file    b) table   c) file  or table d) none 

25. Each row in a table represents a __________ 

a) record  b) operators  c) field  d) data types 

26. Each column in a table represents a _________ 

a) record  b) operators  c) field  d) data types 

27. _________ is a set of data for each data base entry. 

a) record  b) operators  c) field  d) data types 

28. _______ is a groups each piece or item of data among the records into specific categories or 

types of data 

a) record  b) operators  c) field  d) data types 

29. How many ways the data can be manipulated 

 a)7   b)8   c) 5    d)6 

30. Which of the following is not a types of manipulation of a data base  

 a) sorting  b) searching   c) data processing d) editing the data base 

31. _______ is the process of arranging the data in a table in some order 

a) searching  b) sorting  c) merging  d) filtering 

32. ________ is a process  to select a desired specific data from a data base. 

a) searching  b) sorting  c) merging  d) filtering 

33. __________ is done using data base commands on the relevant fields 

a) searching  b) sorting  c) merging  d) filtering 

34. How many ways you can sort the data in the database  

 a) 5   b) 3   c) 2   d)4 

35. ___________ is a process of joining data from two or more tables of the same or different 

data bases 

a) searching  b) sorting  c) merging  d) filter 

36. You may do any kind of ___________ calculations on the data stored in the data base. 

a) relational  b) comparative  c) arithmetic  d) logical 

37. A _________ is a way of limiting the information that appears on screen 

a) searching  b) sorting  c) merging  d) filter 

38. ___________ are a feature for displaying and browsing a selected list or subset of records 

from a table 

a) filters  b) searching  c) sorting  d) merging  

39. The __________ records satisfy the condition that the user sets. 

a) hidden  b) visible  c) abstract  d) unconditional 

40. Those that do not satisfy the condition are _________ 

a) hidden  b) visible  c) abstract  d) unconditional 

41. ________ is a process of performing corrections on the existing data ,deleting the existing 

data field(s) or records (s ) ,adding new data field (s ) ,record (s ) ,or changing the format of 

the database. 

a) searching  b) sorting  c) editing  d) filter 
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42. Based on the conceptual structure, the database can be classified as _________ types. 

a) 4   b) 5   c) 6   d) 7 

43. A data base file that consists of a single data table is a ________ database. 

a) relational  b) network   c) flat-file  d) hierarchical  

44. _________database can be quite useful for certain single user or small groups’ situations, 

especially for maintaining lists such as address lists or inventories. 

a) relational  b) network   c) flat-file  d) hierarchical 

45. ________ is the example of flat file data base 

a) presentation    b) word processing   

c) multimedia    d) spreadsheet 

46. Data that is stored, managed and manipulated in spreadsheet is the example of ____________ 

data base. 

a) relational  b) network  c) flat-file  d) hierarchical 

47. ___________   databases do have a significant limitation over data bases consisting of 

multiple tables. 

a) relational  b) network   c) flat-file  d) hierarchical 

48. ________ database is fine if you merely need to locate a part or verify an address. 

a) relational  b) network   c) flat-file  d) hierarchical 

49. You need to process more extensive information from multiple data tables which is not 

possible in _____ data bases. 

a) relational  b) network   c) flat-file  d) hierarchical 

50. A __________ data base structure represents a database made up of a set of related tables. 

a) relational  b) network   c) flat-file  d) hierarchical 

51. In a ____________ database, one or more common fields existing in two or more tables 

create a relationship between these tables. 

a) relational  b) network   c) flat-file  d) hierarchical 

52. The common field or fields are called the ________ 

 a) field  b) row   c) record  d) keys 

53. A _________ is a key that uniquely identifies a record in a database table. 

a) secondary key b) primary key c) normal key d) higher key 

54. In ______________ database, a primary key can consist of one or more fields. 

a) relational  b) network   c) flat-file  d) hierarchical 

55. The __________ data base structure is the most prevalent database in today’s business 

organizations. 

a) relational  b) network   c) flat-file  d) hierarchical 

56. The _________ databases structures were primary used on main frame computers 

a) relational  b) network   c) flat-file  d) hierarchical 

57. In _____________ databases, records are organized in a tree like structure by type. 

a) relational  b) network   c) flat-file  d) hierarchical 

58. The relationship between record types is said to be a ________ relationship, in which any 

child type relates only to a single parent type. 

a) parent-child b) child-parent c) child-grandfather  d) none 

59. The ________ database is very similar to the hierarchical structure expect that any one record 

type can relate to any number of other record types. 

a) relational  b) network   c) flat-file  d) hierarchical 

60. An _________ database is a new structure that has been generating a great deal of interest in 

recent years. 
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a) relational  b) network   c) object oriented d) hierarchical 

61. ____________ database represents very different approach to the way data is reacted by data 

base develops and users. 

a) relational  b) network   c) object oriented d) hierarchical 

62. The object oriented structure groups data items and their associated characteristics ,  attributes 

, and procedures into complex items called _______ 

a) data   b) object  c) information d) field 

63. An object defined by its ______ 

a) characteristics  b) attributes  c) procedures  d)all of these. 

64. An object __________ can be text, sound, graphics and video. 

a) characteristics  b) attributes  c) procedures  d)all of these. 

65. Colour, size, style, quantity price are the example of object ___________. 

a) characteristics  b) attributes  c) procedures  d)all of these. 

66. ____________ refers to the processing or handing that can be associated to the object. 

a) characteristics  b) attributes  c) procedures  d)all of these. 

67. A ____________ is a program ,or collection of programs that allows any number of users to 

access data modify it and construct simple and complex requests to obtain and work with 

selected records. 

a) variable  b) operators  c) information d) DBMS 

68. The biggest assets  of the _____ is its ability to provide extremely quick access and retrieval 

from large database 

a) variable  b) operators  c) information d) DBMS 

69. The data management takes in a DBMS fall into _________ general categories. 

a) 4   b) 5   c) 8   d) 3 

70. DBMS also provide the means for multiple for multiple users to access and share data in the 

same data base by way of ___________ computer systems 

a) linked  b) networked  c) computerized d) manual  

71. To open star office base or if a star office window is open click __________ 

a) file → new → database     b) edit → new → database      

c) format → new → database   d) tools → new → database 

72. How many options (or) steps in the data base wizard window  

 a)4   b) 5   c) 8   d)2 

73. Select  the ___________ option in the database wizard window for creating a new database. 

a) open an existing database file  b) create a new database  

c) modify existing database   d) none 

74. Select the _________ option in the database wizard window for opening an existing database. 

a) open an existing database file  b) create a new database  

c) modify existing database   d) none 

75. ________ allows you to design forms query the database and prepare reports. 

 a) star office calc    b) star office writer  

c) star office base    d) star office draw 

 

76. Type the database file name in the _______ text box. 

a) file name  b) character  c) search for  d) replace with 

77. ________ is the shortcut key for saving the database table. 

a) alt + s  b) ctrl + s  c) shift + s  d) tab + s 

78. In star office base how many options in the database pane  
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 a)4    b)3    c)8    d)10 

79. The pane on the right top is _________ 

a) table pane  b) center pane c) database pane d) task pane 

80. The pane on the ________ changes to tables ,queries ,forms or reports accordingly 

a) right bottom b) top   c) middle  d) corner 

81. A __________ is a collection of related tables 

a) data base  b) information c) data   d) data types 

82. To create a new table ,click on the table icon in the _________ pane and click on the ‘create 

table design in view’ in the task pane. 

a) table pane  b) center pane c) database pane d) task pane 

83. To create a new table in star office base select table design from _____ menu. 

a) tools  b) insert  c) format  d) table 

84. ________________ command is used to create a table in star office base 

a) tools → table design        b) insert → table design  

c) format → table design   d) table → table design 

85. Star office base allows you to use _______ different fields type. 

a) 10   b) 18   c) 20   d) 22 

86. Which of the following is a type of field type  

 a) number  b) date   c)yes / no   d) all of these 

87. Which of the following is not  a type of field type 

 a) time   b) memo  c)Real   d) Picture 

88.  _________ data type can accepts only whole numbers. 

a) integer  b) small int  c) floating point d) double 

89. ___________ accepts small integers values up to a few thousands. 

a) integer  b) small int  c) floating point d) double 

90. ‘single’ and  ‘ double ‘ means ___________ numbers with single and double precision. 

a) integer  b) small int  c) floating point d) char 

91. Decimals values are accurate up to a length of ______ places in the case of single precision. 

a) 7   b) 10   c) 14   d) 20 

92. Decimals values are accurate up to a length of _____ places in the case of double  precision. 

a) 7   b) 10   c) 14   d) 20 

93. Press the _____ key to move the next column the field type. 

a) enter  b) shift  c) alt   d) tab 

94. Star office base displays a _________ list box with the different fields types. 

a) format  b) drop-down  c) text only  d) exchange 

95. In the lower part of the window the _______ pane is displayed) 

a) row properties b) field properties c) table properties d) record properties 

96. The __________ pane allows you to further customize the field 

a) row properties b) field properties c) table properties d) record properties 

97. It the field type is text how many options available in the field properties pane  

 a)4   b)5   c)8   d)6 

 

98. It the field type is number, how many options available in the field properties pane  

 a)4   b)5   c)8   d)6 

99. A_________ is a field in a table that uniquely identifies every record in the table. 

a) secondary key b) primary key c) normal key d) higher key 
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100. In the field properties pane ____________ option is used to specify if the user should always 

enter a value for that field 

a) length  b) format example c) entry required  d) default value 

101. In the field properties pane the____________ option is used to specify the maximum 

character that can be entered in that field 

a) length  b) format example c) entry required  d) default value 

102. In the field properties pane the____________ option is used to specify  the default value to 

be assigned to that field 

a) length  b) format example c) entry required  d) default value 

103. In the properties pane ____________ option allows you to specify the number format and 

alignment of the text (or) number with in the column 

a) length  b) format example c) entry required  d) default value 

104. If the field type is ______ the length option in the field properties determines the length of 

this field) 

a) number  b) decimal places c) single place d) text 

105. If the field type is number ,the ______ option specify the number of decimal places 

permitted in this field) 

a) number  b) decimal places c) single place d) text 

106. After specifying the field properties ,you can press the _________ key to move the next 

column ,Description. 

a) enter  b) shift  c) alt   d) tab 

107. The ______ becomes very important when there are multiple tables ,with common fields. 

a) secondary key b) primary key c) normal key d) higher key 

108. Every table in Star Office base must have a ________ 

a) secondary key b) primary key c) normal key d) higher key 

109. A __________ appears to the left side to move it as the primary key. 

a) primary key b) green key  c) higher key  d) small yellow key 

110. If you want to enter the data in the data base table selecting the open data base object from 

______ menu. 

a) file   b) edit   c) view  d) format 

111. Each field can only accept data corresponding to the specified ___________ 

a) column  b) row type  c) data type  d) field type 

112. ___________ may include changing a value of a field in a record or appending a record 

a) searching  b) sorting  c) merging  d) editing 

113. Star office base allows you to change the font type font size and the height of the rows is 

called____________ 

a) searching  b) editing  c) merging  d) filter 

114. If you want to edit the data in a table click on the _________ value and retype the new value. 

a) row   b) field  c) record  d) file 

115. If you right click on the record pointer of the selected record , a sub menu appear with 

__________ option. 

a) two   b) four   c) three  d) five 

 

116. To edit the record ,first select the record by clicking on the __________ 

a) record pointer b) mouse pointer c) insertion point d) key point 

117. The record pointer is a _________ on the left mouse column of the table. 

a) large circle  b) small triangle c) large triangle d) rectangle 
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118. Using __________ dialog box, the font type, style, size, colour can be changed in the data 

base table. 

a) paragraph  b) page  c) page style  d) character  

119. When you enter data into the _________ a new blank row is automatically appended 

a) first row  b) second row c) last row  d) middle row 

120. To view or modify the design of an existing table ,click the tables from the _________ pane. 

a) database  b) task   c) center  d) bottom  

121. You can sort the record in _______ orders based on any field in the table. 

 a)ascending     b)descending   

c)ascending or descending   d) multiple sorting 

122. To sort the records in the ascending order select the field and click __________ icon. 

a) sort ascending    b) sort descending  

c) ascending or descending   d) multiple sorting 

123. To sort the records in the descending order select the field and click __________ icon. 

a) sort ascending    b) sort descending  

c) ascending or descending   d) multiple sorting 

124. _______________ means sorting on more than one field of a table at the same time. 

a) ascending     b) descending  

c) ascending or descending   d) multiple sorting 

125. Specify the fields you want to sort on by selecting them from the ___________ drop down 

list boxes in slide order window. 

a) filed name  b) record name c) length  d) order 

126. For each field specify the order in which you want to sort, in the _____ drop down list box in 

the slide order window. 

a) filed name  b) record name c) length  d) order 

127. To display the records in the original order chick on the _______________ icon. 

a) remove filter    b) remove sort  

c) remove filter/sort    d) remove sort/filter 

128. Every _______ supports a language that is similar to a programming language. 

a) database  b) DBMS  c) spreadsheet d) presentation 

129. Which language is used to querying a data base  

 a)C++   b)Pascal  c)SQL   d)Java 

130. SQL stands for _________ 

a) structured query language   b) structured query level  

c) single query language   d) simplified query level. 

131. Which of the following you can do using a query language 

a) list a subset of records    b) Perform calculations   

c) delete obsolute records    d) All of these 

132. ______________ are special views of the data in a table. 

a) tables  b) queries   c) forms  d) reports 

133. To create a query in star office base right click on the _________ in the data base pane. 

a) tables  b) queries   c) forms  d) reports 

 

134. If you click on the queries, how many options displayed on the task pane. 

 a)4   b)5   c)3   d)6 

135. Click on ________ option in the task pane for create a query wizard window. 

 a) use wizard to create query  b) create query in design in view   

www.Padasalai.Net                                                                                                                    www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

         J.P.MURUGAN, M.Sc., B.Ed.,         Cell:9789633793,  9488832229 Page 32 

 

c) create query in SQL view  d) none. 

 

136. How many steps available in query wizard window 

 a)4   b)6   c)8   d)10 

137. How many combo available in first step of the query wizard 

 a)1   b)2   c)3   d)4 

138. How many text box are available in first step of the query wizard 

 a)1   b)2   c)3   d)4 

139. Automatically, the list of fields available in the selected table appears in the____________ 

text area  

a) available fields b) tables  c) grouping  d) fields in the query 

140. Sort order window allows you to specify ______ fields on which the results should be stored 

 a) 3   b) 6   c) 4   d) 5 

141. The radio buttons on the right allow you to specify if the sort should be in the_______ order 

a)ascending     b)descending   

c)ascending or descending   d) multiple sorting 

142. In the sort order window which order is default selected  

a)ascending     b)descending   

c)ascending or descending   d) multiple sorting 

143. The_____ window specify the fields and the conditions on which the query should be based 

a) sort order  b) create query c) search condition d) field selection  

144. In the search conditions window, select_______ to display the records that satisfy any one of 

the search criterion 

 a) match the following        b) match any of the following  

c) match all of the following  d) none 

145. In the search condition window, select_________ to display records that satisfy all the 

search criterion  

 a) match the following       b) match any of the following  

c) match all of the following  d) none 

146. In the query wizard window _______ step specifies whether to display all records of the 

query or only the results of aggregate functions 

 a) field selection    b) sort order   

c) search condition     d) detail or summary 

147.  In the query wizard window ____________ step allows you to provide the alias names for 

the fields 

 a) field selection    b) aliases    

c) search condition     d) detail or summary 

148. A __________ is also a type of query. 

a) filter  b) form  c) table  d) auto pilot  

149. _______ is used to select and display records which match a certain condition 

a) filter  b) form  c) table  d) auto pilot  

 

 

150. Star Office base allows you to use _______ types of filters. 

a) 3   b) 4   c) 2   d) 5 

151. Filter used with a condition called ____ filter 

a) auto   b) default  c) standard  d) default or standard  
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152. The _________ window is very similar to the one used for specifying conditions in a query. 

a) filter  b) form  c) table  d) auto pilot  

153. To remove the filter click on the ____________ icon. 

a) remove filter    b) remove sort   

c) remove filter/sort    d) remove sort/filter 

154. A _______ is simply a screen that displays the fields of a record in well spaced of manner. 

a) filter  b) form  c) table  d) auto pilot  

155. A form can be associated with a __________ tables.  

 a) single     b) multiple   

c) single or multiple    d) none of these 

156. Designing a form using the _____ option is very similar to creating a query using auto pilot 

a) filter  b) form  c) table  d) auto pilot 

157. Select the field names that you would like to include in the form using the __________ 

button. 

a) >   b) >>   c) < or <<  d) > or >> 

158. If you want to insert another form with in this form select the _________ 

a) add form  b) add sub form c) insert sub form d) merge sub form 

159. How many steps are available in the form wizard window 

 a)5   b)8   c)10   d)4. 

160.  The page style decides the font attributes like ______________ of the text in the form.   

a) font type     b) size and colour    

c)background     d) all of these 

161. In the form wizard the __________ specifies the field border style for the form. 

a) field border  b) border c) line style  d) coloring  

162. A ________ is printed information that is assembled by gathering data based on user 

supplied criteria 

a) filters  b) searching  c) report  d) merging  

163. ________can range for simple list of records to customized formats for specific purposes. 

a) report  b) searching  c) sorting  d) merging  

164. The _____________ can use selected data and criteria to carry out automated mathematical 

calculations as the output is being printed 

a) information    b) record   

c) report generators    d) form designing 

165. In fact report generators in most DBMS create reports from _______  

a) filter  b) form  c) table  d) queries   

166. creating a report in star office base is very similar to creating a __________ 

a) query  b) form  c) table  d) query or a form 

167. How many steps in the Report wizard window. 

 a)5   b)8   c)7   d)6 

168. In the report wizard dialog ______ window is used to modify the labels for the 

corresponding fields if you want. 

a) labeling fields b) grouping  c) choose layout d) border style 

169. In the report wizard dialog the ________ window is used to specify the fields based on 

which the records can be grouped together. 

a) labeling fields b) grouping  c) choose layout d) border style 
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170. In the report wizard dialog the ________ is used to customize the report by selecting the 

layout of data layout of selecting the layout of data layout of headers and footers and 

orientation options for the report. 

a) labeling fields b) grouping  c) choose layout d) border style 

171. How many reports are there in star office base  

 a)1   b)2    c)3    d)4 

172. You can create and store multiple reports for a _________ 

a) query  b) form  c) table  d) table or query  

173. You can use a stored report in the same way as you used in stored _________ 

a) query  b) form  c) table  d) form or query 

174. ___________ applications are tightly integrated so that you can easily use the contents of 

one application in another applications. 

a) star office  b) MS office  c) lotus AmiPro d) excel 

175. Which command is used to paste the calc cell range into the text document  

 a)Edit → paste     b) copy  → paste   

c) Edit → paste special    d) Tools → paste special 

176. In the paste special dialog select _________ for insert calc cell range into the text document 

a) hyper link  b) DDE link  c) cyber link  d) none 

177. In the text document that contains the outline choose __________ 

a) file → send → outline to presentation  b) send → outline to presentation   

c) file →send → auto abstract to presentation d) send → auto abstract to presentation 

178. ______________ in the heading hierarchy are displayed as bullets on the slide 

a) heading 1  b) heading 2  c) heading 3  d) heading 4 

179. Add more text to the outline or switch to ________view to add objects 

a) outline  b) normal  c) notes  d) slide 

180. If you want to transfer each heading together with its accompanying paragraphs select the 

____________ command  

a) file → send → outline to presentation  b) send → outline to presentation  

c) file →send → auto abstract to presentation d) send → auto abstract to presentation 

181. You can use ________ to copy text and objects between star office applications. 

a) drag  b) drop  c) drag and drop d) edit fill 

182. Use ________ to open the presentation window then just drag - and –drop the selected range 

into the presentation. 

a) shift + tab  b) ctrl + tab  c) alt + tab  d) tab 

183. The Calc menus and tool bars are displayed when you are _______ mode even through you 

are  in impress presentation. 

a) edit   b) format  c) tools  d) insert 

184. To exit the edit mode click outside the __________ 

a) plug out  b) layout  c) plug in  d) database 

185. Select ____________ command is used to insert a database table into a writer document 

a) file → paste b) view → paste c) format → paste d) edit → paste 

186. ______ heading specifies whether to insert a heading line for the columns in the text table.  

a) delete table b) insert table  c) format table d) merge table 

 

187. Data such as names, addresses, and phone numbers are stored in a (n) ________ 

 a) file   b) table  c) record  d) file or table 

188. A screen that displays data for a single record is called a (n) _________ 
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 a) record  b) form  c) screen  d) query  

189. _______key combination is used to print a file 

 a) ctrl + p  b) alt + p  c) ctrl + print  d) shift + p 

190. A set of processed data is  

a) Application b) Program  c) Database  d) Information 

191. Which of the following is used for data processing? 

a) Star Office Impress   b) Star Office base  

c) Star Office calc    d) Star Office writer 

192. Data types defined by the user for their own use is 

a) Primitive data types   b) System defined data types 

c) User defined data types   d) Built in data types 

193. Star base is an integral part of 

a) DBMS  b) MS Office  c) Star Writer  d) Star Office 

194. A collection of program that allows any number of user to access data is 

a) Management system   b) Star base 

c) Database management system  d) Database system 

195. A report is a_________ 

a) Query     b) Sorted arrangement of information 

c) Screen of data    d) Printed information 

196. Ina query the search conditions window is useful to specify 

a) Data  b) Conditions  c) Value  d) Statement 

197. Which data types can be integer, float, double precision date, time, etc…  

a) Enumerated data types   b) User-defined data types 

c) Numeric data types   d) Primitive data types 

198. Which of the following database structures are conceptual models for older systems that 

define databases used on main frame systems? 

a) Network     b) Hierarchical  

c) Hierarchical and network  d) Flat-file 

199. The process of making correction on exciting data is called 

a) Changing  b) Adding  c) Appending  d) Editing 

200. Which buttons are used to include the selected field names in the form 

a)>   b)>>   c) (a) or (b)  d) ^ and + 

201. Which of the following is not a step in data processing? 

a) Collection  b) Verification c) Computation d) Validation 

202. Which of the following provide the means for multiple users to access and share data? 

a) MMS  b) SMS  c) DBMS  d) None of these 

203. Data types can be 

 a) character  b) number  c) a or b  d) object 

204. Which of the following cannot be done using a query language? 

 a) list of subset of records   b) perform calculations 

 c) delete absolute records   d) editing the records 

 

 

 

205. Reports created in star office can be classified into  

 a) static or dynamic    b) ordinary or scientific  

 c) static or scientific   d) dynamic or scientific 
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206. A _____ is a software tool allows users to create database tables and that provides access to 

multiple users 

 a) SQL  b) DBMS  c) Query  d) Filter 

207.  A Special language for communicating with a database is called 

 a) SQL  b) DBMS  c) Query  d) Filter 

208. In star office base, ___________ dialog box can be used to change the font type, style, size 

and color 

 a) font format b) record format c) database format d) table format 

209. Which icon is used to sort more than one field of a table? 

 a) sort ascending b) sort descending c) multi sort  d) sort 

210. A ______ is used to assemble information form data 

 a) OLE object b) DBMS  c) OOPS  d) Chart 

211. Which of the following in a database is most commonly viewed in one   or more tables? 

 a) file   b) records  c) information d) data 

212. Which key is used to move from one field to next in a database table?  

a) alt   b) ctrl   c) shift  d) tab 

213. Which one of the following radio button when clicked displays the records in the query 

 a) preview  b) display query c) records  d) view 

214. _________ option is used to delete the selected records in the data base table 

 a) delete  b) delete all  c) delete rows d) delete contents 

215. _________ sorting means sorting on more than one field of a table 

 a) single  b) double  c) multiple  d) none of these 

216. _________let you browse through selected records 

 a) sorting  b) filters  c) forms  d) report 

217. ________ user constructed statements that set conditions for selecting and manipulating 

data in one or more tables 

 a) filters  b) report  c) queries  d) forms 

218. _________view is used to create a table’s structure 

 a) design view b) data sheet view c) table   d) b & c 

219. _________ data base are very powerful because they have the ability to form relationship 

between tables 

 a) network  b) relational  c) flat file  d) object oriented 

220. A_________ arranges data in columns and rows 

 a) data base  b) data base table c) DBMS  d) none of these 

221. __________consists of usable sets of data 

 a) data  b) data base  c) information d) DBMS 

222. Editing the database is a process of performing 

 a) correction  b) deletion  c) addition  d) all 

223. In which of the following data base any one record type can relate to any number of other record 

 a) relational data base   b) network 

 c) hierarchical data base   d) flat file 

224. Which of the following pane displays the tables, queries, forms and reports 

 a) left pane  b) right top  c) bottom  d) right pane 

225. _______ are user defined screens that are used to make it easier to enter, view and edit the 

data in a table 

 a) table   b) report  c) form  d) query 

226. A repository of collections of related facts 
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 a) Database  b) Datum  c) Data  d)Information 

227. Which of the following is not a step in Data Processing?   

a)Collection   b) Network  c) Verification d) Validation 

228. Which of the following is not a valid field type in Star Office Base?  

 a) Text (fix)  b) Project  c) Time  d) integer. 

229. The data management tasks in a DBMS involves  

 a) Entering data into the database   b) Reordering records in the database  

 c)obtaining subsets of the data   d) all of the above 

230. ________inserts an empty heading line into the next table 

 a) apply column name   b) create row only  

 c) auto format    d) none of these 

231. How many panes in the new data base window 

a) 1   b) 2   c) 3   d) 4 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

VOLUME – I        8.INTRODUCTION TO MULTIMEDIA 

I. Choose the correct answer:         

1. __________ is a computer based presentation technique 

 a) presentation b) multimedia c) spreadsheet d) base 
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2. Which of the following is a multimedia element 

 a) text   b) graphics  c) animation  d) all 

3. ________ applications are being used in a variety of different fields 

 a) multimedia    b) star office writer   

c) spreadsheet    d) presentation 

4. Which of the following fields where multimedia is commonly used 

 a) entertainment    b) research   

c) business communication   d) all of these 

5. In the field of________, multimedia is widely used to add special effects to movie 

 a) education  b) research  c) business  d) entertainment 

6. Which of the following animated films are popular with adults and children 

 a) Ice Age  b) Polar Express c) Hanuman  d) all of these 

7. _______ and _______ are frequently used to make computer games thrilling and realistic  

 a) low-end graphics and animations b) graphics and films  

c) high-end graphics and animations d) none 

8. A High-end extension of these games is the________ that is used to train pilots 

 a) flight simulator b) Polar express c) rendering  d) animating 

9. What is the abbreviation for MMS_________ 

 a) Multimedia Message System  b) Multimedia Memory System    

c) Multimedia Messaging System  d) Multimedia Messaging Service 

10. ________is an application that allows you to send and receive messages over cell phones  

 a) MMS  b) SMS  c) AMS  d) KMS 

11. ____are used to send and receive jokes, music, ring tones, pictures and sometime even videos 

 a) SMS  b) AMS  c) KMS  d) MMS 

12. _________ also has an enormous impact on education 

 a) multimedia    b) star office writer   

c) spreadsheet    d) presentation 

13. ________is heavily used in the entertainment industry 

 a) presentation b) multimedia c) spreadsheet d) base 

14. ________is also used for corporate communications and presentations  

 a) multimedia b) spreadsheet c) base  d) presentation 

15. The most common version of e-learning packages are the_________ 

 a) CBT  b) WBT  c) CBT and WBT d) none 

16. ______are self-placed learning aids that are either available on CD-ROMs or on the internet 

 a) flash  b) dream wear c) CBT/WBT  d) maya 

17. _______today are used to cover wide range of topics including orienting new employees 

joining an organization, training employees on new software applications and systems used in 

an organization 

 a) CBT/WBT  b) dream wear c) flash  d) maya 

18. _______is also being extensively used to train and educate children in schools and colleges 

 a) presentation    b) multimedia based training  

c) flight stimulators        d) education based training 

19. _______are very effective in explaining difficult concepts and facts. Such media make 

learning more fun and effective 

 a) multimedia software       b) multimedia presentations    

  c) multimedia simulations       d) flight simulators 

20. The use of _________ in such material makes it easier to search for and view related content 
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 a) hyperlinks     b) multimedia  

c) internet protocol     d) animation 

21. Multimedia games are popular pastime and these are software programs available either as______ 

 a) CD-ROMs     b) internet   

c) online     d) CD-ROMs or online 

22. Multimedia applications that allow users to actively participate instead of just sitting by as 

passive recipients of information are called______ 

 a) intensive multimedia   b) general multimedia  

c) interactive multimedia   d) virtual reality 

23. The various multimedia components are coordinated with a technique is called_________  

a) impact of education   b) virtual reality  

c) animating     d) modeling 

24. ________provide an environment which is experienced by users as similar to reality 

 a) rendering  b) morphing  c) modeling   d) virtual reality 

25. The ________ technique is used in some arcade games and also in flight simulators, to impart 

training to pilots, without having to go for a real flight 

 a) warping  b) sampling  c) virtual reality d) graphics 

26. Which of the following are help in grabbing the viewers attention and highlighting critical 

pieces of information in corporate presentations  

a) context-relevant animations  b) images   

c) charts     d) all of these 

27. Multimedia elements are also used in________ 

 a) advertisements    b) product catalogs   

c) online magazines    d) all of these 

28. Multimedia applications are also widely used in the fields of________ 

 a) engineering     b) medicine   

c) scientific research    d) all of these 

29. The multimedia environment is created by using_______ devices 

 a) input  b) output  c) software  d) input and output 

30. The multimedia environment is created by using input devices like the ________ 

 a) joystick   b) sensors  c) monitor  d) joystick and sensors 

31. The multimedia environment is created by using output devices like the ________ 

 a) head phones    b) goggles   

c) head phones and goggles   d) none of these 

32. GIF and JPG formats compress ________ images 

 a) music  b) animated  c) static bitmap d) bitmap 

33. Which one of the following is an image format 

 a)animated GIF files    b) shockwave files   

c) Nx View files    d) all of these 

34. The two most common by far are_______ files   

 a) GIF   b) MPEG files c) Shockwave d) GIF and JPG 

 

35. ________are typical examples of static images 

 a) photographs b) videos  c) images  d) recorder 

36. A________ file uses a much more complex technique 

 a) GIF   b) MPEG files c) Shockwave d) JPG 

37. In_______ file the color of every pixel is different when compressed 
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 a) MPEG files  b) GIF   c) Shockwave d) GIF and JPG 

38. A _______ file creates a perfect reproduction of the original 

 a) MPEG files    b) Shockwave c) GIF   d) Nx View 

39. GIF is limited to an_______ bit palette 

 a) 4   b) 16   c) 8   d) 2 

40. ________is best suited for storing simple images with relatively few colors 

 a) GIF   b) MPEG files c) Shockwave d) JPG 

41. GIF means______ 

 a) Graphic internet file   b) Google input format     

c) Graphic information format  d) Graphic Interchange Format 

42. ________is not well photographic works 

 a) MPEG files    b) Shockwave c) GIF   d) Nx View 

43. Despite of this _______ is still used extensively on the internet and multimedia applications 

 a) MPEG files  b) GIF   c) Shockwave d) GIF and JPG 

44. The JPEG image files are________ format 

 a) loss less  b) lossy  c) animated  d) mixture 

45. JPEG means________ 

 a) Joint Photographic Experts Group b) Joint Photo Exported Group   

c) Joint Picture Emerging Group  d) Joint Photographic Emerging Group 

46. All digital cameras have the to save images in _______ format 

 a) GIF   b) MPEG files c) Shockwave d) JPEG 

47. The_______ format supports full color and produces relatively small the sizes 

 a) JPEG   b) MPEG files c) Shockwave d) GIF and JPG  

48. The image file compression is categorized into _______ types 

 a) 2   b) 3   c) 4   d) 5 

49. The _______ compression algorithm takes advantages of limitations of the human visual 

senses and discards information that would not be sensed by the eye 

 a) loss less  b) lossy  c) animated   d) compression 

50. _______ is a lossy compression of image 

 a) GIF   b) JPEG files  c) Shockwave d) MPPG 

51. ________help in rendering the image effectively on the screen 

 a) sound  b) animated films c) vector graphics d) compression 

52. Many vendors provide special hardware called________  (or) _________ to improve the 

efficiency in the display of images 

 a) vector graphic card   b) image compression  

c) video compression   d) none of these 

53. The sounds that you hear are ________ wave patterns 

 a) analog  b) digital  c) comport  d) frequent 

54. How many attributes control the characteristics of sound 

 a) 4   b) 5   c) 2   d) 3 

 

 

55. ________are the attributes that control the characteristics of sound 

 a) pitch  b) amplitude   c) frequency  d) both b and c 

56. The frequency is also called as_______, is the distance between the crests of the wave 

 a) amplitude  b) pitch  c) waves  d) sound 

57. The greater the distance, the lower is the________ 
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 a) sound  b) animations  c) amplitude  d) none 

58. Conversion of analog sound waves to a digital format is called_________ 

 a) modulation b) conversion  c) sampling  d) animations 

59. Which editing programs or software is used to add the special effects to the multimedia 

 a) forge     b) animation effects   

c) vector graphics    d) sound forge 

60. Which kind of effects to add the sound 

 a) echo  b) fade in  c) fade out  d) all of these 

61. ________ are primarily used to illustrate or demonstrate an idea or concept 

 a) animations  b) drawings  c) sound effects  d) video 

62. ________are based on drawings 

 a) animations  b) drawings  c) sound effects  d) video 

63. Animations can be_______ dimensional 

 a) 2-D   b) 1-D   c) 3-D   d) 2-D or 3-D 

64. Based on 2-D animations are created, they can be classified into_______ categories 

 a) 3   b) 2   c) 4   d) 5 

65. _______animations are the types of 2-D animations  

 a) object based and column based  b) cell based and row based 

 c) row based and column based  d) cell based and object based 

66. _______animations consist of multiple drawings 

 a) cell based  b) row based  c) column based d) object based 

67. _________animations when displayed in rapid sequence, these drawing appear to move  

 a) row based  b) column based c) cell based   d) object based 

68. ________animations, also referred to as slide or path animations, are created by moving an 

object across a screen 

 a) row based  b) column based c) cell based   d) object based 

69. _______type of animations are usually seen in computer games 

 a) row based  b) column based c) cell based   d) object based 

70. “A ball moving across the screen” is the example of _______ animations 

 a) row based  b) column based c) object based d) cell based 

71. To create a 3-D animations is a ________ step process 

 a) 1   b) 3   c) 4   d) 2 

72. Which of the following step to creating a 3-D animation 

 a) modeling  b) animating  c) rendering  d) all of these 

73. To create a 3-D animation, you have to create the_______ of the 3-D objects 

 a) broad shapes b) sound  c) structures  d) broad shapes and structures  

74. You have to render them by giving attributes, such as________ to the objects   (or) Which 

attributes giving to the objects of 3-D animations? 

 a) colors  b) textures  c) row and column d) colors and textures 

75. You can adding special effects to the animation such as_________ 

 a) morphing  b) rendering  c) warping  d) morphing and warping 

  

76. ________is a technique by which you can blend two or more images to form a new image 

 a) morphing  b) rendering  c) warping  d) morphing and warping 

77. ________ is the technique of distorting a single image to represent something else  

 a) morphing  b) rendering  c) warping  d) morphing and warping  

78. Particularly games, combine_______ techniques with virtual reality to create an environment 

www.Padasalai.Net                                                                                                                    www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

         J.P.MURUGAN, M.Sc., B.Ed.,         Cell:9789633793,  9488832229 Page 42 

 

 a) morphing  b) rendering  c) warping  d) morphing and warping  

79. Video is also recorded and played back as an ________ signal 

 a) analog  b) digital  c) comport  d) frequent 

80. _______files tend to be very heavy 

 a) audio   b) sound  c) video  d) photograph 

81. Which element s determine the size of the video files 

 a) frame rate  b) image size  c) color depth d) all of these 

82. Reducing the color depth to less than 256 colors results in the image looking_______ 

 a) murky  b) sampling   c) jerky  d) morphing 

83. Reducing the frame count to less than 15 frames per second causes the video to look________ 

 a) murky  b) sampling   c) jerky  d) morphing 

84. Reducing the color depth to ________ colors results in the image looking murky 

 a) >250  b) <256  c) >256  d) <=250 

85. Reducing the frame count to ________ frames per second causes the video to look  

a) <15   b) <20   c) >15   d) >16 

86. You can also reduce the size of the videos by ________ them 

 a) morphing  b) warping  c) compressing d) animating 

87. _________is a technique by which a recurring set of information is identified and replaced by 

a single piece of information 

 a) sampling  b) compression c) warping  d) realizing 

88. There are ________types of video compressions 

 a) 2   b) 4   c) 3   d) 6 

89. Which of the following are the types of video compressions  

 a) lossless  b) cell based  c) object based d) lossless and lossy 

90. _______compression retains the exact image throughout the compression 

 a) lossy  b) cell based  c) object based d) lossless 

91. _____compression provides a comparatively higher ratio of compression but results in some 

loss of quality  

 a) lossy  b) cell based  c) object based d) lossless 

92. Which of the following is a multimedia format 

 a) midi  b) wave  c) quick time   d) all of these 

93. Which of the following format is used to store only sound (audio) 

 a) SND  b) MP3  c) AIFF  d) all of these 

94. Which of the following format is used to store videos 

 a) AVI  b) Quick Time c) MPEG  d) all of these 

95. Which of the following format was developed by apple 

 a) Quick Time b) SND  c) AIFF  d) all of these 

96. Which of the following format was developed by Microsoft  

 a) WAVE     b) AVI  

c) Windows Media Format   d) all of these 

 

 

97. Which of the following format was developed by Macro Media 

 a) Real Audio  b) Quick Time c) Shock Wave d) all of these 

98. Which of the following format was developed by IBM and Microsoft 

 a) WAVE  b) AVI  c) MIDI  d) all of these 

99. MIDI stands for_______ 
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 a) Musical Information Device Interchange b) Musical Interface Digital Instrument 

 c) Musical Interchange Digital Interface  d) Musical Instrument Digital Interface 

100. MIDI format commonly used for transferring music information between electronic music 

devices like_________ in computers  

 a) synthesizers     b) sound card   

c) data card     d) synthesizers and sound card 

101. MIDI format was developed in_______ 

 a) 1992  b) 1982  c) 1975  d) 1985 

102. ________ is very flexible format can be used for a wide range of musical applications 

 a) AVI  b) SND  c) AIFF  d) MIDI 

103. The MIDI format cannot contain sounds- it contains only ________ 

 a) audio  b) video  c) digital notes d) frequency  

104. A MIDI file that plays for approximately 5 minutes may be only_______ KB (or) Size of the 

MIDI file is_____ KB 

a) 15   b) 256   c) 125   d) 25 

105. Sound files in the MIDI format have the extension ________ 

 a) .mid  b) .midi  c) .mdi  d) .mid or .midi 

106. The Real Audio format was developed by _______ 

 a) apple  b) macromedia c) flash  d) real networks 

107. The Real Audio format was developed in ________ 

 a) 1995  b) 1982  c) 1975  d) 1985 

108. The Real Audio format is supports __________ 

 a) sound      b) video   

c) both sound and videos   d) digital notes 

109. The Real Audio format is more popular for transfer data over the internet and allows you to 

stream files even over internet connections with________ 

 a) low bandwidths    b) high bandwidths  

c) normal bandwidths   d) equality bandwidths 

110. Files in Real Audio/Real Video format have the extension________ 

 a) .rm   b) .ram  c) .rarv  d) .rm or .ram 

111. The AU format is used for store ________ 

 a) video  b) sound  c) picture  d) all of these 

112. File in the AU format have the extension ________ 

 a) .au   b) .Au   c) .auf   d) .AU 

113. The AIFF stands for________ 

 a) Audio Interchange File Format    b) Audio Information File Format    

c) Audio Include Fixed File     d) none 

114. The AIFF format was developed by _______ 

 a) macro media b) Microsoft  c) Apple  d) IBM 

115. File in the AIFF format have the extension_________ 

 a) .aif   b) .aiff   c) .aif or .aiff  d) none of these 

 

116. The SND stands for_________ 

 a) audio  b) video  c) Sound system d) Sound 

117. The SND format was developed by _________ 

 a) macro media b) Microsoft  c) Apple  d) IBM 

118. File in the SND format have the extension_________ 
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 a) .snd   b) .sn   c) .sdf   d) all of these 

119. The WAVE format was developed by _________ 

 a) macro media b) Microsoft  c) Apple  d) IBM and Microsoft 

120. File in the WAVE format have the extension_________ 

 a) .wave  b) .wav  c) .WAVE  d) .wae 

121. The________ format was developed by the Moving Pictures Experts Group 

 a) AVI  b) MP3/MPEG  c) WAVE  d) SND 

122. The MPEG format was developed for store________ files  

 a) sound  b) graphics  c) video  d) music 

123. The MP3 format was developed for store________ files  

 a) sound  b) graphics  c) video  d) image 

124. ________are the most popular format on the internet in recent years 

 a) SND  b) AIFF  c) MP3/MPEG d) none of these 

125. The ________ format have the good compression and high quality 

 a) SND  b) AIFF  c) MP3/MPEG d) none of these 

126. ________format are cross-platform and supported by most popular web browsers  

 a) SND  b) AIFF  c) MP3/MPEG d) none of these 

127. Sound files stored in the MP3 format have the extension________ 

 a) .mp3 or .mpga b) .mp3  c) .mpga  d) .mpg or .mpeg 

128. Video files stored in the MPEG format have the extension________ 

 a) .mp3 or .mpga b) .mp3  c) .mpga  d) .mpg or .mpeg 

129. AVI stands for_________ 

 a) Audio Visual Interleave      b) Audio Video Interchange      

 c) Audio video Interleave   d) Audio Video Information 

130. The AVI format was developed in_______ 

 a) 1992  b) 1982  c) 1975  d) 1985 

131. The AVI format was developed by _________ 

 a) macro media b) Microsoft  c) Apple  d) IBM and Microsoft 

132. Video files stored in the AVI format have the extension________   

 a) .AVI  b) .aiv   c) .avi   d) .mov 

133. The Windows Media format was developed by _________ 

 a) macro media b) Microsoft  c) Apple  d) IBM  

134. Files stored in the Windows Media format have the extension________   

 a) .wmv  b) .win  c) .wmf  d) .mov 

135. The Quick Time format was developed by _________ 

 a) macro media b) Microsoft  c) Apple  d) IBM  

136. Files stored in the Quick Time format have the extension________  

 a) .qt   b) .qtf   c) .wmf  d) .mov 

137. The Shockwave format was developed by _________ 

 a) macro media b) Microsoft  c) Apple  d) IBM  

 

 

138. Files stored in the Shockwave format have the extension________   

 a) .soc   b) .swf  c) .wmf  d) .SWF 

139. ________format requires an extra component to play  

a) SND  b) AIFF  c) MP3/MPEG d) Shockwave 
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140. For Shockwave format, additional component comes preinstalled with the latest versions 

of_________ 

 a) Netscape     b) internet Explorer  

c) dream wear    d) Netscape and internet Explorer  

141. Shock wave format is used to store multimedia components created using________ 

 a) wave  b) flash  c) dream wear d) none of these 

142. Some additional hardware and_______ monitors would greatly enhance effectiveness of 

using multimedia 

 a) low resolution    b) better resolution  

c) high resolution    d) resolution 

143. Special software such as_________ would help in viewing the multimedia presentations 

 a) SND     b) AIFF   

c) Windows Media Player   d) MIDI 

144. Which of the following are some commercial multimedia content development software 

are__________ 

 a) flash  b) Maya  c) dream weaver d) all of these 

145. Sounds and video in multimedia applications can be played_______ or by using a_______ 

 a) inline, helper    b) inline, media file  

c) helper, online    d) inline, online 

146. When sound or video is included as part of a web page, then it is called________ 

 a) inline sound or video   b) online sound or video  

c) online media    d) none of these 

147. You can add inline sound to a web page by using the _________ tags 

 a) <bgsound> b) <img>  c) <colour>  d) <bgsound> and <img> 

148. A helper application, also called_____ is a program that can be launched by the browser to 

“help” play sound or video 

 a) plug  b) plug-in  c) plug-out  d) inline 

149. Helper applications can be launched using the _________ tags 

 a) <embed>  b) <applet>  c) <object>  d) all of these 

150. Files in the multimedia elements tend to be________ 

 a) very heavy  b) very less  c) low   d) normal 

151. A 5 second audio file can be as heavy as_________ 

 a) 25MB  b) 120MB  c) 5Mb  d) 1MB 

152. A heavy video or animation file in a WBT may not load because of ________ 

 a) high bandwidth    b) poor bandwidth  

c) large bandwidth     d) heavy bandwidth 

153. Multimedia applications include_________ to produce high quality products 

 a) text   b) sound  c) video  d) all of these 

154. Popular uses of multimedia are in the areas of__________ 

 a) education  b) entertainment c) presentation d) all of these 

155. How many versions of e-learning packages are most commonly used? 

a) 4   b) 5   c) 2   d) 7 

 

156. Which of the following is not a step to create 3D animations? 

a) Modeling  b) Rendering  c) Animation  d) Accessing 

157. Which of the following is called frequency? 

a) resistance  b) amplitude  c) modulation d) pitch 
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158. Which of the following sound format is used for transferring music information between 

electronic music devices? 

a) Wave  b) MIDI  c) AC   d) MP3 

159. CBT are available on the  

a) CD-RAM  b) CD-ROMs  c) CD-CAM  d) CD-RWT 

160. The video files are heavy because of the following 

a) Image size  b) Color depths c) Frame rate  d) all the above 

161. In CBT/WBT the ________ need not have to travel to a locations a attend the classes 

a) Trainer  b) Instructor  c) Trainee  d) Learner 

162. Which of the following is not commercial multimedia content development software? 

a) Flash     b) Maya   

c) Dream viewer    d) MS-Power point 

163. Which tag is used to add in line sound to a web page? 

a)<Sound>  b)<Inline>  c)<Bgsound> d)<Helper> 

164. WBT are available on the 

a) Intranet  b) CD-CBT  c) Internet  d) CD-ROMs 

165. The video compression that provides a comparatively higher ratio of compression but result 

in some loss of quality is 

a) Loss less compression   b) Low less compression 

c) Less loss compression   d) Lossy compression 

166. Which of the following tags is not used to launch helper applications? 

a)<embed>  b)<name>  c)<applet>  d)<object> 

167. Video files tend to be very. 

a) Heavy  b) Hard  c) Soft   d) Light 

168. Which is multimedia software? 

a) Designer  b) Dream weaver c)AmiPro  d) Lotus 1-2-3 

169. The ___ is the height of each crust in the wave. 

 a) valley  b) cycle  c) volume  d) frequency 

170. The quick time format was developed by apple primarily to store 

 a) audio  b) video  c) a & b  d) none of these 

171. A helper application that can be launched by the browser to help play sound or video  

 a) AVI  b) Plug –in  c) SWF  d) MMS 

 

 

 

 

 

 

 

 

 

VOLUME – I        9.PRESENTATION 

I. Choose the correct answer:         

1. ________allows you to create attractive and professional-looking presentations  

 a) star office calc    b) star office writer  
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c) star office impress   d) star office draw 

2. _______allows you to import and modify Microsoft power point presentations 

 a) star office impress   b) star office writer  

c) Micro soft presentation   d) star office draw 

3. How will you create a new impress presentation from within any star office application, by 

choosing  

 a) File → New → Open   b) File → New → Presentations  

c) File → Edit → Open   d) None 

4. You can also create a new presentation by launching star office impress by choosing________ 

 a) Start→ All Programs → Star Office 8 → Star Office Impress  

b) Start → Star Office Impress   

c) Start → All Programs → Star Office 8   

d) Start → Star Office 8 → Star Office Impress 

5. How many steps for creating a presentation  (or)  How many pages for creating a presentation  

 a) 2   b) 5   c) 4   d) 3 

6. The first page of the presentation wizard displays ________ options  

 a) 3   b) 5   c) 4   d) 2 

7. _______page of the presentation wizard window, allows you to select a background for all the 

slides in the presentation, while creating the presentation 

 a) first page  b) second page  c) third page  d) fourth page 

8. In the second page of the presentation wizard window, a drop-down list on the left provides 

_________ categories of presentation backgrounds for you to choose from 

 a) three  b) five   c) four   d) six 

9. A________ check box in the presentation wizard window that allows you to view a preview 

of the slide with the selected background 

 a) view  b) page preview c) print preview d) preview 

10. If you do not see a preview, the________ check box is clicked 

 a) delete view    b) remove preview   

c) preview     d) cancel preview 

11. The_______ section in the lower half of the second page of the presentation wizard window, 

allows you to specify the final output medium for the presentation 

 a) select an output medium   b) select a slide design  

c) from template    d) empty presentation 

12. How many sections in the third page of the presentation wizard window  

 a) 3   b) 5   c) 4   d) 2 

13. _______page of the presentation wizard window, allows you to specify the transition effects 

to be used in the presentation 

 a) first page  b) second page  c) third page  d) fourth page 

14. The_______ section at the top of the third page of the presentation wizard window, allows 

you to choose the transition effect and speed in the slides 

 a) select an output medium   b) select the presentation type  

  c) from template    d) select a slide transition 

15. The_______ section at the third page of the presentation wizard window, allows you to 

specify if the slide transition should be manual or automatic 

 a) select an output medium   b) select the presentation type      

c) from template    d) select a slide transition 
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16. The _______ option in the third page of the presentation wizard window, allows you to 

manually control the transition of slides using options such as mouse clicks  

a) default  b) automatic  c) manual  d) show logo  

17. The _______ option in the third page of the presentation wizard window, allows you to 

specify the duration for each slide and will automatically flip through the slides at the 

specified speed  

 a) default  b) automatic  c) manual  d) show logo  

18. ________check box will display the message, “Created with Star Office” during the pause 

between each presentation 

 a) default  b) automatic  c) manual  d) show logo  

19. The ________ spin box in the third page of the presentation wizard window allows you to 

specify the duration for the slides  

 a) automatic     b) duration of page   

c) manual     d) duration of pause   

20. The ________ spin box in the third page of the presentation wizard window allows you to 

specify the duration for which the presentation will pause before it starts again  

 a) automatic     b) duration of page  

 c) manual     d) duration of pause   

21. _________provides several default presentation formats 

 a) star office calc    b) star office writer  

c) star office impress    d) star office draw 

22. ________command is used to create a new presentation using a template, choose 

 a) File → New → Open       b) File → New → template and documents       

c) File → Edit → Open   d) None 

23. Which shortcut key is used for create a new presentation 

 a) Ctrl + N     b) Shift + N  

 c) Ctrl + Shift + N    d) Shift + Ctrl + N 

24. The_______ pane displays the slides in the presentation 

 a) middle   b) right  c) left   d) top 

25. How many panes in the middle pane of the star office impress window 

 a) 5   c) 4   c) 3   d) 2 

26. The_______ pane on the left displays a thumbnail image of the slide and allows you to 

rename, delete, or rearrange them 

 a) middle pane b) task pane  c) center pane d) slide pane 

27. The_______ pane allows you to view the slides in the presentation  

 a) left pane  b) task pane  c) center pane d) slide pane 

28. The center pane displays ________ tabs at the top that allow you to view the presentation in 

different formats 

 a) 5   c) 4   c) 3   d) 2 

29. There are ________ views in the star office impress  

 a) 2   c) 4   c) 3   d) 5 

 

 

30. The________ pane allows you to specify the effects for the objects on your slides 

 a) left pane  b) task pane  c) center pane  d) slide pane 

31. The task pane on the right displays _________ types of pages 

 a) 2   b) 4   c) 3   d) 5 
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32. The ________view allows you to create and edit slides 

 a) notes  b) handout  c) normal  d) outline 

33. The________ view allows you to reorder slides, edit slide titles and heading 

 a) notes  b) handout  c) normal  d) outline 

34. The______ view allows you to add notes to the slides or view any existing notes for the slide 

 a) notes  b) handout  c) normal  d) outline 

35. The________ view allows you to add notes are typically used by a presenter to add additional 

information to a slide 

 a) slide sorter  b) handout  c) normal  d) notes 

36. _________ view allows you to scale the slides so that several slides can fit into a page 

 a) notes  b) handout  c) normal  d) outline 

37. ____view is typically used when the presentation is to be printed and distributed as a handout 

 a) notes  b) normal  c) handout  d) outline 

38. The________ view allows you to view miniature images of all slides in the presentation 

 a) notes  b) handout  c) normal  d) slide sorter 

39. The_______ page can be used to specify background information that needs to be included in 

all the slides 

 a) layouts  b) slide transition c) master  d) custom animation 

40. If you insert a company logo to the ________ slide and it will appear in all the slides 

 a) first   b) master  c) second  d) presentation 

41. ________ page displays the various layouts provided by star office impress  

 a) layouts  b) slide transition c) master  d) custom animation 

42. _______ page displays various options that allow you to add or modify animation effects to 

elements of a slide 

 a) layouts  b) slide transition c) master  d) custom animation 

43. _______ page displays various transition effects that can be attached to a slide along with 

other options that allow you to control the transition of the slide 

 a) layouts     b) slide transition  

c) master     d) custom animation 

44. Which command is used to save a presentation 

 a) edit → save    b) file → save  

c) ctrl → save    d) shift → ctrl → save 

45. Which of the following command is used to start a presentation or start slide show  

 a) slide show → slide show   b) format → slide show 

 c) insert → slide show   d) slide show → custom slide show 

46. Which of the following function key is used to start a presentation or start slide show  

 a) F1   b) F5   c) F7   d) F11 

47. The on-screen presentation starts automatically in the_________ screen mode 

 a) half   b) low   c) full   d) high 

48. After the last slide, you will see a _________ slide 

 a) white  b) black  c) red   d) green 

 

 

49. End the presentation by pressing the________ key 

 a) enter  b) backspace  c) escape  d) tab 

50. Presentation settings can be adjusted under_________ command 

 a) slide show → slide show settings b) format → slide show settings   
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c) insert → slide show settings  d) slide show → custom slide show 

51. To run a custom slide show in the order that you defined in_________ 

 a) slide show → slide show   b) format → slide show    

 c) insert → slide show   d) slide show → custom slide show 

52. Which command is used to insert a new slide 

 a) slide → insert slide   b) new → slide  

c) insert → slide    d) insert → new slide 

53. If you want to delete a slide, select the slide, and press________ key 

 a) delete  b) remove  c) back space  d) cancel 

54. To rename a slide, select the slide, and choose_________ 

 a) slide → rename slide      b) rename → slide  

c) insert → rename slide   d) insert → slide rename 

55. To change the slide order, click the slide sorter in the _________ tab 

 a) switching tab    b) view tab  

c) slide sorter tab    d) switching presentation view tab 

56. In the________ mode, all slides in the presentation document are displayed in reduced size 

 a) notes  b) slide sorter  c) presentation d) handout 

57. A vertical ________ indicates the position where the slide will be inserted 

 a) green  b) red   c) yellow  d) black 

58. Normal, outline, notes, handout, slide sorter views are available in the ________ tab 

 a) switching tab    b) view tab  

c) slide sorter tab    d) switching presentation view tab 

59. To insert a picture in a slide, choose_________ command 

 a) insert → picture → from file      b) insert → picture   

  c) insert → from file → picture     d) picture → insert 

60. To insert a picture in a slide, click the insert picture icon from the________ toolbar 

 a) insert  b) object  c) picture  d) format 

61. To insert movie in a slide, choose __________ command 

 a) Tools → movie and sound  b) format → movie and sound   

c) insert → movie and sound  d) edit → movie and sound 

62. To insert a movie in a slide, click the insert movie and sound icon from the________ toolbar 

 a) insert  b) object  c) picture  d) format 

63. ________icon in the media playback toolbar is used to adjusts the size of the movie playback 

 a) repeat icon  b) play icon  c) position slider d) zoom 

64. ________enables media player where you can preview movie and sound files as well as insert 

these files into the current presentation slide  

 a) star office impress   b) star office writer 

c) Micro soft presentation  d) star office draw 

65. Which command is used to open the media player window 

 a) Tools → Media Player   b) insert → Media Player  

c) view → Media Player   d) slide → Media Player 

 

 

66. Which of the following can preview movie and sound files in a presentation 

a) Movie audio player   b) multimedia player 

c) media player    d) movie player 

67. ________provides tools for inserting objects like charts, formula, etc) 
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 a) star office calc    b) star office writer  

c) star office impress   d) star office draw 

68. Which command is used to insert an object in a slide 

 a) tools → object    b) insert → object  

c) format → object    d) view → object 

69. ________is used for inserting a formula into the presentation for performing calculations 

 a) insert OLE object    b) insert object  

c) insert formula    d) insert function 

70. ________is used to import from other application into a presentation  

a) insert OLE object    b) insert object  

c) insert formula    d) insert applet 

71. Which of the following object can be inserted into a slide 

 a) formula     b) star office spreadsheet    

c) text      d) all of these 

72. If you want to insert a Microsoft word document into a slide, choose_________ and create 

new option in the insert OLE object dialog box 

 a) further object    b) star office 8 spreadsheet   

c) Microsoft word    d) MS Office 

73. ________ automatically saves the document and inserts it into the slide 

 a) star office impress   b) star office writer  

c) Micro soft presentation   d) star office draw 

74. ________ is used to import applets into the presentation 

 a) insert OLE object    b) insert object   

c) insert formula    d) insert applet 

75. The easiest way to assign slide transition effects to slides is in _________ view 

 a) slide sorter  b) notes  c) handout  d) slide 

76. Which command is used to open the slide view floating window 

 a) view → toolbars → slide view  b) insert → toolbars → slide view   

 c) tools → toolbars → slide view  d) insert → slide view 

77. In the slide view floating window, the number of slides to be listed in the ________ spin box 

 a) slides per slide    b) slide per column   

c) slide per row    d) slide per cell 

78. The number of slides in the slide view changes according to the number specified in the 

_______ spin box 

 a) slide per row    b) slide per column   

c) slides per slide    d) slide per cell 

79. The _____ view displays the slides in certain numbers specified in the slides per row spin box 

 a) slide  b) notes  c) handout  d) slide sorter 

80. The objects in your slide can have various effects can be assigned using the________ view 

 a) slide sorter  b) notes  c) normal  d) slide 

81. In the page settings dialog box, click______ to change the background fill for a single slide 

 a) no   b) yes   c) yes or no  d) none 

 

82. Which command is used to open the normal view 

 a) view → normal view   b) tools → normal view   

   c) insert → normal view   d) file → normal view 

83. Which command is used to open the custom animation window 
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 a) slide show → slide show   b) format → custom animation    

c) insert → custom animation  d) slide show → custom animation 

84. Which command is used to change the slide background 

 a) Format → page → background  b) insert → background  

c) format → background   d) tools → background 

85. If you want to change the background fill for all of the slides, click ________ when the 

‘Background setting for all slides’ dialog box appears 

 a) no   b) yes   c) yes or no  d) none 

86. A_________ slide determines the text formatting style for title, outline and background 

design for individual slides, or for all the slides in a presentation 

 a) first   b) master  c) new   d) second 

87. Which command is used to apply a new slide design  

 a) format → slide design       b) insert → slide design   

  c) slide → slide design   d) tools → slide design 

88. To apply the slide design to all of the slides in your presentation, select the______ check box 

 a) exchange page    b) remove background page 

  c) exchange background page        d) cancel background 

89. To apply the slide design to the current slide only, clear the _________ check box  

 a) exchange background page  b) remove background page  

c) exchange background    d) cancel background 

90. How many check box in the slide design dialog box 

 a) 3   b) 5   c) 2   d) 4 

91. To preview the template, click_________, and the select the preview check box 

 a) load   b) more  c) categories  d) template 

92. Along with the slide design you can also assign a whole set of _______ to your slides 

 a) presentation styles   b) text formatting   

c) style     d) outline levels 

93. Open the________ to see a list of the pre-defined styles 

 a) text   b) style list  c) slide style  d) none 

94. The styles __________ enables you to give the outlined headings and topics on your slides a 

uniform look 

 a) outline   b) outline 1  c) outline 5  d) outline1 through outline9 

95. Open a new, empty presentation with a slide layout that allows________ 

 a) outline levels b) outline 1  c) outline 5  d) outline9 

96. The slide layout called_________ 

 a) “Title, Text” b) “Text, Title” c) “Word, Title” d) “Title, Outline” 

97. Activate the outline view mode by choosing menu________ 

 a) tools → outline view   b) insert → outline view  

c) view → outline view   d) format → outline view 

98. Which command is used to open the stylist 

 a) Format → style and formatting  b) insert → style and formatting   

 c) tools → style and formatting  d) view → style and formatting 

 

99. Which function key is used to get the stylist 

 a) F1   b) F2   c) F7   d) F11 

100. If you press the _____ key, a small icon for slide2 appears in the next line of the outline view 

 a) tab   b) enter  c) shift  d) backspace 
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101. By pressing _______ key, you move the line down one level 

 a) tab   b) enter  c) shift  d) backspace 

102. By pressing _______ key, you move the line up one level 

 a) tab   b) enter  c) shift + tab  d) backspace 

103. ______ also allows you to start slide shows from the current slide as well as hide slides 

during a slide show 

a) star office impress    b) star office writer  

c) Micro soft presentation   d) star office draw 

104. Hold down _________ select the range of slides  

 a) tab   b) enter  c) shift  d) ctrl 

105. Hold down ___________ to select multiple slides 

a) tab   b) enter  c) shift  d) ctrl 

106. To start a slide show from the current slide, choose_________ 

 a) tools → options → Star Office Impress → general  

b) Star Office Impress → general   

c) tools → general    d) none of these 

107. In the general settings in Star Office impress dialog, under the start presentation area, select 

___________ check box  

 a) current page    b) always with current page  

c) current slide    d) first slide 

108. How many sections available in the general settings dialog box in Star Office impress 

 a) 5   b) 4   c) 8   d) 6 

109. To hide a slide, choose__________ 

 a) slide show → show slide   b) slide show → hide slide 

 c) slide show/hide → show slide  d) slide show → hide/show slide 

110. To show a hidden slide, choose__________ 

 a) slide show → show slide   b) slide show → hide slide  

c) slide show/hide → show slide  d) slide show → hide/show slide 

111. Star Office assists you in defining the right _________ for automatic slide changes 

 a) run the slide    b) rehearse timings   

c) custom slide    d) slideshow 

112. To record a show with rehearse timings, open presentation, and switch to________ view 

 a) outline  b) normal  c) handout  d) slide sorter 

113. Start the show with the rehearse timings from ________ menu 

 a) slide show  b) tools  c) insert  d) format 

114. Star Office has recorded the display time for_______ slide 

 a) only one  b) last   c) each  d) single 

115. If you want the whole presentation to auto-repeat, open the menu _________  

a) slide show → slide show settings b) format → slide show settings  

c) insert → slide show settings  d) slide show → custom slide show 

 

 

 

116. To set the default printing options for Star Office impress, choose________ 

 a) tools → options → Star Office Impress → print  

b)Star Office Impress → print   

c) tools → print    d) file → print 
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117. Which command is used to print a presentation   (or)   Setting printer options for the current 

presentation  

 a) tools → options → Star Office Impress → print   

b) Star Office Impress → print  

c) tools → print    d) file → print 

118. In Star Office, you can print the current document by clicking the ________ icon in the 

function bar 

 a) print icon     b) print file icon  

c) print file directly icon   d) file → print 

119. In the page setup dialog box, in layout settings area, select the________ check box for 

printing a slide to fit a paper size 

 a) paper format    b) fit object to paper format   

c) margins     d) paper tray 

120. If you want to provide handouts you can use the________ mode  

 a) notes view  b) handout view c) normal view d) outline view 

121. The _________ contain both the individual slides and space for notes, they can be a very 

helpful presentation aid  

a) notes  b) handouts  c) normal  d) outline  

122. Choose a ________ to specify how many slides are printed on a single sheet of paper 

 a) notes  b) slide sorter  c) layout  d) outline  

123. Enter the notes for individual slides in the ________ view 

 a) notes  b) handouts  c) normal  d) outline  

124. You can access the notes view in the ________ bar 

 a) file   b) edit   c) view  d) slide 

125. In the printer option dialog, select notes in the________ area 

 a) heading   b) title   c) content  d) outline 

126. To check the ________ check box in the printer options dialog, if you do not want to include 

notes in the print out  

a) notes  b) slide  c) printing  d) outline  

127. If you want specific settings for all presentations, choose_________ 

a) tools → options → Star Office Impress → print   

b) Star Office Impress → print  

c) tools → print    d) file → print 

128. Using the ________, you can move from slide to slide quickly 

 a) export  b) navigator  c) inner slide  d) function 

129. Open the navigator by choosing _________ 

 a) Edit → Navigator    b) File → Navigator   

c) format → Navigator    d) view → Navigator  

130. ________automatically starts a wizard to help you to produce an attractive HTML 

presentation 

a) star office calc    b) star office writer  

c) star office impress   d) star office draw 

 

131. A number of HTML pages are created that are connected to one another by________ 

 a) email  b) hyperlinks  c) data card  d) program 

132. The graphics are saved as________ images 

 a) GIF   b) JPEG  c) AVI  d) GIF or JPEG 
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133. Which command is used for open the export dialog box 

 a) File → Export  b) Edit → Export     c) Tools → Export  d) view → Export  

134. In the HTML Export dialog, publication type option, select ________ to create html pages 

without frames 

 a) HTML format    b) High HTML format 

 c) Standard HTML format   d) Low standard format 

135. The ________ resolution setting is the standard resolution 

 a) low   b) medium  c) high  d) Export 

136. In the HTML Export dialog, how many options are in the monitor resolution section 

 a) 1   b) 2   c) 3   d) 4 

137. Select _________, to apply the colors supported by browsers to HTML pages 

 a) use browser colors   b) HTML colors  

c) font colors     d) alignment colors 

138. An automatic presentation flips through the slides at a defined duration until the _______ 

key is pressed  

 a) alt   b) shift  c) escape  d) tab 

139. A presentation can contain different types of objects like__________ 

 a) picture  b) movie  c) chart  d) all of these 

140. A presentation can be exported in different format like________ 

 a) PDF     b) SWF   

c) Web page and JPEG   d) all of these 

141. ________ allows you to display important slides during a presentation 

 a) slide show      b) custom slide show  

c) custom animation    d) master slide 

142. The _________ embedded in Star Office impress supports different audio and video file 

formats 

 a) media player b) image player c) graphics player  d) none of these  

143. A ‘slide show ‘ is a series of pages that are _________ 

a) information on a specific topic  b) data types  

c) slide show settings   d) none of these 

144.   A presentation can be created from scratch or from___________ 

a) data value  b) presentation c) slide show  d) template 

145. __________ gives effect to an object in a slide. 

a) slide sorter  b) sound effect c) master page d) custom animation 

146. By pressing _________ key in the keyboard the view of the slide can be enlarged 

a) plus   b) minus  c) astrix  d) divide 

147. In _______ view mode ,all the slide titles will appear in a list along with the headings and 

sub – topics 

a) normal  b) outline  c) notes  d) handouts 

148. To select an object that is covered by another object, hold down __________ key and click 

the object. 

a) Alt   b) ctrl   c) shift  d) tab 

149. _________ window allows us to quickly jump from one slide to other slide or move between 

open files. 

a) export  b) navigator  c) exponentiation  d) object 

150. ___________ is used preview movie or sound files in a slide. 

a) media player    b) image player  
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c) graphics player    d) none of these 

151. Star Office Impress allows us to modify and view presentation as 

a) Sorter  b) Side pages  c) Slide show  d) slides 

152. Which is appeared at the top of the window 

a) Toolbar  b) Manu bar  c) Title bar  d) Status bar 

153. Which command is used to print a slide to fit a paper size? 

 a) File → print    b) format → page   

 c) edit → page    d) tools → print 

154. Which of the following option is not available in the background fill combo box 

 a) gradient  b) bitmap image c) hatching  d) picture 

155. Which of the following are one of the most powerful and effective ones 

 a) worksheets    b) database   

 c) custom slide show   d)presentation 

156. To change the order in the slide show, click on 

 a) view  b) slide sorter  c) slide show  d) custom slide show 

157. …. Command is used to insert chart in a presentation 

 a) insert → graph    b) insert → object  

 c) insert → picture from file  d) insert → ole object 

158. To assign slide transition effects to slides is in  

 a) normal  b) master  c) slide  d) outline 

159. Which views used to rearrange slides  

a) Normal, Outline    b) Handouts, Slide sorter  

c) Normal, Notes    d) Outline, Slide sorter 

160. Which command is used to create a custom slide show  

a) slide → custom slide show  b) slide show → custom slide  

c) slide → custom slide  show  d) slide show → custom slide show → new 

161. A .. is a series of slides, or pages, that present information on a specific topic 

 a) slide show    b) slide settings  

 c) slide view     d) none of these 

162. The saved document file name appears in the 

 a) status bar  b) title bar  c) menu bar  d) tool bar 

163. To produce HTML presentation ,choose  

 a) File → HTML    b) File → Export   

c) Edit → Export     d) Edit → HTML 

164. Which among the following is used to display various transition effects that can be attached 

to a slide? 

 a) Custom animation   b) Slide transition   

c) Animation effects    d) Slide sorter 

165. By pressing _________ key in the keyboard the view of the slide can be enlarged 

a) F2   b) F5   c) F11   d) F7 

 

 

VOLUME – II   1.OBJECT ORIENTED CONCEPTS USING C++ 

I. Choose the correct answer:         

1. A___________ is a tool to solve a wide range of problems 

a) system  b) calculator  c) computer  d) printer  

2. The solutions to the problems are in the form of___________ 
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 a) computer programs    b) application software  

c) a or b     d) none of these 

3. A computer program operates on a set of known_________ data items 

 a) output  b) calculate  c) computerized d) input 

4. In the early programming languages the input and output data items were represented as  

 a) variable  b) constants  c) operators  d) calculation 

5. ________categorized these input data items 

 a) identifiers  b) data types  c) strings  d) operation 

6. ________provided a way of instructing the computer on the operations that need to be 

performed on the data items 

 a) control statements    b) decision   

c) variable     d) constants 

7. _______help us in organizing our ideas about the solution of the problem 

 a) conditions     b) developing languages  

c) programming languages   d) multi languages 

8. The solution of a problem has ________ separate segments  

 a) 3   b) 2   c) 6   d) 5 

9. _______ and ________are the segments of the solution of a problem 

 a) data, operation    b) variable, constants  

c) data, variable    d) constant, data 

10. Which of the following is object oriented programming language 

 a) C++  b) Pascal  c) Fortran  d) visual basic 

11. The relationships are like________  

a) part of the whole    b) a type of  

c) part of the whole or a type of  d) none of these 

12. ________facilitates this way of problem solving by combining ‘data’ and ‘operations’ that 

are to be performed on the data  

 a) object programming   b) looping programming   

c) object oriented programming  d) structure programming 

13. The group of data and the operations together are termed as ________ 

 a) class     b) object   

c) encapsulation    d) computer 

14. The operations represent the behavior of the ________ 

 a) class     b) computer   

c) encapsulation    d) object 

15. An_________ attempts to capture a real world object in a program  

 a) object     b) class   

c) encapsulation    d) computer 

16. An__________ is a group of related functions and data that serves those functions  

 a) class     b) object   

c) encapsulation    d) computer 

 

17. An_________ is a kind of self-sufficient “subprogram” with a specific functional area 

 a) object     b) class   

c) encapsulation    d) computer 

18. The process of grouping data and its related functions into units called as objects paves way 

for_______ 
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 a) class     b) computer   

c) encapsulation    d) object 

19. The mechanism by which the data and functions are bound together within an object 

definition is called as________  

a) encapsulation    b) operator   

c) object     d) class 

20. _________make it easy to represent real systems in software programs 

 a) class     b) computer   

c) encapsulation    d) object 

21. The function and object behavior is the key factor of ___________   

a) object programming   b) looping programming   

c) object oriented programming  d) structure programming  

22. ________communicate with one another by sending data as inputs 

 a) class     b) object    

c) encapsulation    d) computer 

23. The data type _________conventionally represents an objects in the real world 

 a) class     b) object   

c) encapsulation    d) computer 

24. _________is a template for entities that have common behavior  

 a) encapsulation    b) operator   

c) object     d) class 

25. the ability of an object to respond differently to different messages is called as_________  

 a) inheritance     b) object   

c) polymorphism    d) encapsulation 

26. The________ are power packed, as they include the functionality of the base class along 

with their own unique features  

 a) base class     b) derived class  

c) abstract class    d) super class 

27. The process of acquiring the base class properties is called_________ 

 a) inheritance     b) object  

 c) polymorphism    d) encapsulation 

28. Inheritance increases the functionality of a ___________ 

 a) base class     b) super class   

c) abstract class    d) derived  class 

29. Which of the following is advantages of oops 

 a) data abstraction    b) polymorphism  

c) data hiding     d) all of these 

30. _________provides security to data, as unrelated member functions 

 a) data hiding     b) data abstraction  

c) data hiding or data abstraction  d) inheritance 

 

31. ________reduces software complexity as multiple definitions are permitted to an operator or 

functions 

 a) inheritance     b) object  

 c) polymorphism    d) encapsulation 

32. ________allows a class to be derived from an existing class  

 a) inheritance     b) object   
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c) polymorphism    d) encapsulation 

33. _________promoting reusability of code 

 a) encapsulation    b) object  

 c) polymorphism    d) inheritance 

34. _____promote insertion of updated modules to meet the requirements of the dynamic world  

 a) inheritance     b) object  

 c) polymorphism    d) encapsulation 

35. __________ model entities in the real world  

 a) class     b) computer   

c) encapsulation    d) object 

36. Binding of data and member functions together is called as ________ 

 a) class     b) computer  

 c) encapsulation    d) object 

37. _________data type allows programs to organize as object that contain both data and 

functions 

 a) class     b) object  

 c) encapsulation    d) computer 

38. Which operators on a set of known input data items? 

 a) application software   b) computer programs 

 c) computer     d) all of these 

39. Which is split into smaller groups such that a set operations can be performed on it without 

calling any function 

 a) set of control statements   b) set of data items 

 c) subprograms    d) set of variables 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

VOLUME – II   2.OVER VIEW OF C++ 

I. Choose the correct answer:         

1. C++ was developed at ________ laboratories 

 a) Microsoft     b) scientific   

c) AT & T bell    d) AT bell 

2. C++ was developed in_______ 
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 a) 1980  b) 1990  c) 1985  d) 1988 

3. C++ was developed by________ 

 a) Rick Mascitti    b) Bjarne Stroustrup  

c) Dennis Ritchie    d) Charles Babbage    

4. The name C++ was coined by_______ 

 a) Rick Mascitti    b) Bjarne Stroustrup  

c) Dennis Ritchie    d) Charles Babbage    

5. C++ also comprises a________ from which are the tokens are constructed 

 a) operator  b) alphabets  c) constants  d) character set 

6. Which one of the following is a character set  

 a) white space b) horizontal tab c) %   d) all of these 

7. The basic types are collectively called as________ 

 a) constants  b) tokens  c) variables  d) identifier 

8. A_______ is the smallest individual unit in a program 

 a) tokens  b) constants  c) keywords  d) operators 

9. __________have special meaning to the language compiler 

 a) tokens  b) constants  c) keywords  d) operators 

10. Keywords are _________for special purpose  

 a) tokens  b) keywords  c) strings  d) reserved words 

11. _________ cannot be used as normal identifier 

 a) keywords  b) string literal c) variable  d) constants 

12. ________are also called as variables 

 a) reserved words    b) identifiers   

c) operators     d) constants 

13. __________ are the memory boxes that holds values or constants 

 a) constants  b) tokens  c) variables  d) operator 

14. A variable name must begin with an_________ followed by alphabets or numbers 

 a) alphabets     b) underscore   

c) alphabet or underscore   d) numbers 

15. Which one of the following is not a valid identifiers  

 a) _test  b) sum12  c) test   d) 12sum 

16. _________are data items whose values cannot be changed 

 a) tokens  b) constants  c) keywords  d) operators 

17. Constant consist of________ types 

 a) three  b) two  c) five  d) four 

18. ________constant consist only numbers, either whole numbers or decimal numbers 

 a) non-numeric b) character  c) numeric  d) integer 

19. Numeric constant consist of________ types 

 a) two   b) four   c) three  d) six 

 

 

20. Numeric and non-numeric are the type of________ 

 a) keywords  b) string literal c) variable  d) constants 

21. integer constant and floating point constant are the types of ________ constant 

 a) character  b) numeric  c) non-numeric d) whole number 

22. _________ constant is the type of non-numeric constant 

 a) integer  b) floating point c) whole number d) character 
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23. ________constant must have at least one digit and must not contain any fractional part 

 a) floating point b) character   c) integer  d) string 

24. ________constant may be prefixed with + sign or – sign  

a) character   b) integer  c) string  d) floating point  

25. A sequence of digits starting with 0 (zero) is treated as_______ constant 

 a) floating point b) decimal  c) hexadecimal d) octal 

26. A sequence of digits starting with 0X is treated as_______ constant  

 a) floating point b) decimal  c) hexadecimal d) octal 

27. _______constant is a signed real number 

 a) integer  b) floating point c) whole number d) character 

28. While representing a________ constant the integer portion or the decimal portion can be 

omitted but never both 

 a) character   b) integer  c) string  d) floating point  

29. The letter_______ is used to represent the floating point constant in exponent form 

 a) E   b) e   c) E or e  d) none 

30. _________constant is a constant that contains a single character 

 a) character   b) integer  c) string  d) floating point  

31. Character constant is enclosed within_________ quotes  

 a) double  b) single  c) square bracket d) semicolon 

32. ________constant can be any character as defined in the character set of C++ language 

 a) integer  b) floating point c) whole number d) character 

33. Which of the following is a character constant or non-graphic character constant  

 a) backspace  b) line feed  c) null   d) all 

34. ________character constant are represented using escape sequence 

 a) non-graphic b) double  c) graphic  d) integer 

35. Escape sequences are represented using character prefixed with a_______ 

 a) backspace  b) enter  c) backslash  d) linefeed 

36. ________is a sequence of characters surrounded by double quotes 

 a) identifiers  b) operator  c) string literal d) constants 

37. String literals are treated as _______ 

 a) identifiers  b) array of characters c) strings d) array of objects 

38. Each string literal is by default added with a special character_______ 

 a) ‘\a’   b) ‘\n’   c) ‘\x’   d) ‘\0’ 

39. _______character is used to marks the end of the each string 

 a) ‘\0’   b) ‘\a’   c) ‘\n’   d) ‘\x’ 

40. _________specifies an operation to be performed that yields a value  

 a) keywords  b) operators  c) identifiers  d) data types 

41. An_________ is an entity on which an operator acts 

 a) operand  b) character  c) keywords  d) operator 

 

 

42. Which of the following operator are specific to C++  

 a) ::   b) .*   c) ->*   d) all 

43. The operators ________ are used only by the preprocessor 

 a) #   b) *#   c) ##   d) # and ## 

44. There are_________ type of operators in C++ 

 a) 12   b) 8   c) 10   d) 13 
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45. Based on the operand requirements, operators are classified as_________ types 

 a) 3   b) 5   c) 2   d) 4 

46. __________operators are used to perform mathematical operations 

 a) conditional  b) arithmetic  c) logical  d) relational 

47. _________ operator gives the remainder of an integral division 

 a) + (plus)  b) / (minus)  c) / (divide)  d) % (modulus)  

48. Arithmetic expressions are formed using _________ 

 a) arithmetic operator   b) numerical constants/variables  

c) function call    d) all of these 

49. _______are executed in the order of precedence 

 a) constants  b) variables  c) keywords  d) operators 

50. The operands and the operators are grouped in a specific logical way for evaluation is 

called________ 

 a) association  b) communication c) data types  d) enumeration 

51. ________ operators are used to compare values 

 a) conditional  b) arithmetic  c) logical  d) relational 

52. Arithmetic expressions are formed using arithmetic operator, numerical constants/variables 

and function call connected by________ operator 

 a) arithmetic  b) logical  c) conditional  d) relational 

53. Relational operators are used to compare _________ values 

 a) numeric  b) non-numeric c) graphical  d) none 

54. A relational expression is constructed using any_______ operands connected by a relational 

operator 

 a) five   b) two   c) three  d) many 

55. The result of the relational operator is returned as________ 

 a) true   b) false  c) null   d) true or false 

56. The numeric constants 0(zero) represents ________ value 

 a) false  b) null   c) true   d) true or false 

57. Any non zero constants represents ________ value 

 a) false  b) null   c) true   d) true or false 

58. The ________ operator have lower precedence than the arithmetic operators 

 a) arithmetic  b) logical  c) conditional  d) relational 

59. The________ operators combines the result of one or more conditions 

 a) arithmetic  b) logical  c) conditional  d) relational 

60. The _________ operators have lower precedence to relational and arithmetic operators 

 a) conditional  b) arithmetic  c) logical  d) relational 

61. Conditional operator ( ?: ) is also called as_________ operator 

 a) unary  b) binary  c) arithmetic  d) ternary 

62. ________ is the simplest assignment operator in C++ 

 a) = =   b) +=   c) =   d) != 

 

63. ________operators are used to assign the values of an expression to the variable 

 a) assignment  b) conditional c) relational  d) binary 

64. In addition to the simple assignment operator there are, ________ shorthand assignment 

operator 

 a) 12   b) 1   c) 10   d) 9 

65. ________ are the characters with a specific function 
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 a) keywords  b) punctuators  c) identifier  d) data types 

66. _________are the kind of data that variables hold in a programming language 

 a) keywords  b) punctuators  c) identifier  d) data types 

67. The ability to divide the data into different types in C++ enables one to work with________ 

 a) classes  b) operators  c) complex object  d) derived class 

68. For______ reasons the data is grouped into different categories 

 a) five   b) two   c) three   d) ten 

69. The________ may be use the proper internal representation for each data type 

 a) condition  b) operator  c) control   d) compiler 

70. The programmer designing the programs may use appropriate ________ for each data type 

 a) constants  b) variables  c) operators   d) condition 

71. Data type can be broadly classified into ________ categories 

 a) five   b) three  c) two    d) seven 

72. The_____ data type enables a programmer to invent his/her own data type and define values 

it can assume 

 a) derived  b) built-in  c) user defined  d) basic 

73. The ________ data type helps in improving readability of the program 

 a) user defined b) derived  c) basic  d) built-in 

74. The___________ helps in improving the readability of the program 

 a) typdef     b) user defined data type   

c) class     d) all of these 

75. __________ improves the credibility and readability of the program 

 a) structure  b) class  c) functions  d) none 

76. Combining the data requirements and its associated functions in the form of _________ 

 a) variable  b) constants  c) identifiers  d) data types 

77. ________ allow users to define such user defined data type identifier 

 a) type definition b) class  c) operator  d) integer 

78. ________ helps in creating meaningful data type identifiers, that would increase the 

readability of the program 

 a) integer  b) typdef  c) function  d) struct 

79. The________ data type helps users can creating a list of identifiers  

 a) structure  b) enumerated c) union  d) built-in 

80. Enumerated data type also called as _________ constants of the type int 

 a) numeric     b) symbolic non-numeric  

c) symbolic numeric    d) symbolic character 

81. The enumeration constants are given integer constants starting with_______ by the compiler 

 a) one   b) zero  c) three  d) non-numeric 

82. Users can define these integer constants by assigning __________ values to the enumeration 

constants 

 a) explicit  b) implicit  c) binary  d) octal 

 

83. _________ is another qualifier that can be added to a variable declaration  

 a) punctuators b) operators  c) storage class d) identifier 

84. There are_________ types of storage class in C++ 

 a) 2   b) 3   c) 8   d) 4 

85. ________variables are automatically initialized to zero when they are declared 

 a) static  b) register  c) extern  d) static and register  
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86. _______variables are not initialized with appropriate values based in their data type 

a) static  b) auto  c) extern  d) register 

87. _________variables get undefined values known as garbage 

 a) auto   b) register  c) static  d) none 

88. _________variables defines local variable known to the block in which they are defined 

 a) extern  b) static  c) register  d) auto 

89. The default storage class is_______ 

 a) register  b) extern  c) auto   d) static 

90. _________modifier allows the variable to exist in the memory of the computer, even if its 

function or block within which it is declared losses its scope  

 a) register  b) extern  c) auto   d) static 

91. _________variable known to all functions in the current program 

a) register  b) global  c) auto   d) static 

92. ________variables are defined in another program 

 a) register  b) extern  c) auto   d) static 

93. The modifier________ instructs the compiler to store the variable in the CPU register to 

optimize access 

 a) register  b) extern  c) auto   d) static 

94. The_________ data types are also called as fundamental or basic data types 

 a) user defined b) built-in  c) derived  d) basic 

95. The_______ data types are predefined in the compiler 

 a) user defined b) derived  c) basic  d) built-in 

96. Built-in or basic or fundamental data types are classified into________ types 

 a) three  b) four   c) two   d) one 

97. Integral type further divided into_________ types 

 a) three  b) four   c) two   d) one 

98. _______ type cannot hold any fractional value 

 a) char   b) int   c) float  d) char and int 

99. _______ data type that can hold both the character data and the integer data 

 a) char   b) int   c) float  d) char and int 

100. The________ data type can hold only integer value   

 a) int   b) char  c) double  d) float 

101. The ASCII values of ‘A’ is _________ 

 a) 66   b) 35   c) 55   d) 65 

102. Floating type further divided into________ types 

 a) three  b) four   c) two   d) one 

103. _________ data type can store values with fractional part 

 a) float  b) int   c) char   d) void 

104. _________data type used to Indicate the function does not return a value 

 a) float  b) int   c) char   d) void 

 

105. ________data type used to declare a generic pointer 

 a) void  b) char  c) int   d) float 

106.  ________data type indicates that it holds nothing 

 a) int   b) float  c) void  d) char 

107. The_______ data types are built from the built-in type or user defined type 

 a) derived  b) built-in  c) user defined d) all 
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108. A________ is a variable that holds a memory address 

 a) simple  b) default  c) pointer  d) parameter 

109. _________provide the means through which the memory locations of a variable can be 

directly accessed 

 a) pointer  b) integer  c) default  d) floating point 

110. The address of the variable starts at________ and goes up 

 a) negative  b) binary  c) null   d) -1 

111. The memory size of the 640kb will have addresses commencing from null and goes up 

to________ 

 a) 32,767  b) 65,535  c) 7,26,789  d) 6,55,358 

112. When a program is compiled, some memory is allocated to the variable by the________ 

 a) user   b) default  c) compiler  d) input 

113. The amount of memory allocated to each variable depends on the _________ of the variable 

 a) constants  b) data type  c) identifier  d) operator 

114. Every variable will be referred by its ________ 

 a) data type  b) identifier  c) address   d) coding  

115. Addressing is done using the _________ system 

 a) hexadecimal b) octal  c) binary  d) decimal 

116. The________ is used to declare a pointer variable 

 a) #   b) %   c) &   d) * 

117. The _______ is used to display the contents stored at a location 

 a) *   b) &   c) $   d) % 

118. The asterix (*) is a _________ operator 

 a) unary  b) binary  c) ternary  d) conditional 

119. The name assigned to a data field that can assume any of a given set of values is defined as 

the________ 

 a) constants  b) data types  c) operators  d) variables 

120. _______are user defined named entities of memory locations that can store data 

 a) variables  b) constants   c) data types  d) operator 

121. Names are_______ sensitive, which means that it differentiate between lower case and upper 

case letters 

 a) name  b) case  c) typical  d) mistake  

122. _______are allocated memory to store data  

 a) constants  b) operator  c) data types  d) variables 

123. _______allocates memory, based on the data type of the variable 

 a) compiler  b) operator  c) data types  d) variables 

124. There are_______ words for data types   (or) There are_______ words used for declaring a 

data types 

 a) ten   b) eight  c) nine   d) five 

 

 

125. ________ are used to modify a built-in data type with the exception of void 

 a) modifier (or) qualifier   b) storage class  

c) data types     d) operators 

126. More than one variable of the same type can be declared in a single statement. But every 

variable should be separated by________ 

 a) dot   b) comma  c) semicolon   d) arrow mark 
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127. Integer values are stored in_______ format in binary form 

 a) 16 bit  b) 15bit   c) 8bit   d) 12bit 

128. Staring from right extreme, _______bits are used to store data 

 a) 10   b) 8   c) 16   d) 15 

129. Maximum value stored in an integer variable is________ 

 a) 65,535  b) 32767  c) 256   d) 1 

130. minimum value stored in an integer variable is________ 

 a) -65,535  b) -32767  c) -32768  d) 0 

131. The 16th bit is also called as MSB or _______ 

 a) sign bit  b) unsign bit  c) numeric bit d) non-numeric bit 

132. MSB stands for_________ 

 a) most sign bit         b) member of signed bit 

c) most significance bit   d) memory sign bit 

133. The 16th bit is used to store the_______ 

 a) numbers  b) sign   c) variable  d) negative number 

134. The 16th bit will have 1 ,if ___________value is stored 

 a) complex  b) negative  c) integer  d) positive 

135. The 16th bit will have 0 ,if ___________value is stored 

 a) complex  b) negative  c) integer  d) positive 

136. When the modifier unsigned is used with the integer data type will store only______ values 

 a) positive  b) negative  c) integer  d) positive integer 

137. When the modifier ________ is used with the integer data type the range is goes upto 216 

 a) signed  b) unsigned  c) long  d) double 

138. When the modifier unsigned is used with the integer data type the maximum value will 

be__________ 

 a) 32767  b) 32768  c) 65535  d) 254 

139. The________ alerts the base data type to yield new data type 

 a) modifiers  b) variables  c) data types  d) identifier 

140. _________modifiers the range of the integer value as the sign bit is also used to store data  

 a) signed  b) unsigned  c) long  d) double 

141. _________increases the bytes for a particular data type, thus increasing the range of values 

 a) signed  b) long  b) unsigned  d) bytes 

142. The ________ data types only prefixed with the modifier 

 a) base data type    b) built-in data type   

c) fundamental data type   d) all of these 

143. Prefix the data type with_________ at the time of declaring variables 

 a) modifiers  b) variables  c) data types  d) identifier 

144. The_____________ qualifier specifies that the value of a variable will not change during the                  

run time of the program 

 a) long  b) signed  c) unsigned  d) const 

 

145. Any attempt to alter the value of a variable defined with this qualifier will throw an________ 

message by the compiler 

 a) free   b) error  c) default  d) compile 

146. The________ qualifier is used like any other modifier where the variable is prefixed with the 

keyboard const followed by data type 

 a) const  b) signed  c) unsigned  d) long  
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147.  The declaration statement int*ptr may be read as ptr is a pointer variable of the type_______ 

 a) float  b) int   c) long  d) char 

148. _________operator is used to instructs the compiler that the variable is pointer 

 a) &   b) %   c) *   d) # 

149. _________ are initialized to a specific  value at the time of declaration 

 a) constants  b) variables  c) operators  d) data types 

150. Variable initialization is done ________ 

 a) twice  b) three times  c) only once  d) many times 

151. int num = 10; in the statement the variable num is initialized to_______ 

 a) 0   b) 1   c) 10   d) 11 

152. int fun(5); in the statement the variable fun is initialized to 5 through a_________ 

 a) overloading b) constructor c) destructors  d) default function 

153. _________ refers to data type changes brought about in expressions by compiler 

 a) implicit conversions   b) data type conversion  

c) conflict conversions   d) none of these 

154. float = 7.6; 

int x = f; the value stored in the variable x is________ 

 a) 8   b) 7.6   c) 7   d) 10 

155. If one operand is double, then the other value is also converted to_________ 

 a) long double b) double  c) int   d) float 

156. If one operand is long int, then the other value is also converted to_________ 

 a) long int  b) double  c) int   d) float 

157. sizeof is an_________ 

 a) identifier  b) variable  c) operator  d) constant 

158. int a = 5,   

float b = 3;  

cout<< a * b;     What is the output of the above snippet  

a) 5   b) 4   c) 15   d) 8 

159.  int a = 5,   

float b = 3;  

cout<<sizeof(a * b);     What is the output of the above snippet  

 a) 5   b) 4   c) 15   d) 8 

160. ________variable can store the address of the variable 

 a) different  b) size of  c) pointer  d) address 

161. int * iptr; 

float num1 = 10.5; 

iptr = &num1;  what is the output of the given snippet 

 a) 10   b) 10.5  c) 100   d) error  

162. _______operator returns size in terms of bytes, of the given expression or data type 

 a) default  b) sizeof  c) signed  d) implicit conversion 

 

163. ________variables are sensitive to the data type they point to 

 a) ordinary  b) simple  c) default  d) pointer 

164. Initializing pointer variable pointing to integer data type with address of float variables 

would throw an______________  

a) integer variable b) float variable c) error  d) none 

165. ________refers to the process of changing the data type of the value in a variable 
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 a) conversions b) size of  c) type cast  d) data type 

166. _______is achieved by prefixing the variable or value with the required data type 

 a) type cast  b) data type  c) variable  d) constants 

167. Type cast is restricted only to__________ data type 

 a) derived  b) user defined c) fundamental d) class 

168.  Type cast is restricted only to__________ data type  

 a) built-in  b) basic  c) fundamental d) all 

169. The statement x = 8 % 7.7 will through an________ on compilation 

 a) identify  b) error  c) mistake  d) none 

170. Modulus operator (%) operates on_________ data only 

 a) character  b) integer  c) float  d) all 

171. x = 8 % (int) 7.7; what is the output of the given statement 

 a) 8   b) 7   c) 0   d) 1 

172. The_________ escape sequence is used to backslash   

a) \n   b) \a   c) \t   d) \\ 

173. The_________ escape sequence is used to linefeed   

a) \n   b) \a   c) \t   d) \\ 

174. Which of the following operator is called bitwise operator     

a) &   b) !   c) ~   d) | 

175. The________ is used to terminates a C++ statement   

a) ;   b) }   c) :   d) , 

176. How many bytes are allocated to an long int variable  

a) 10   b) 4   c) 2   d) 8 

177. How many bits for long double data type    

a) 10   b) 8   c) 60   d) 80 

178. What is the range of unsigned int 

 a) -128 to 127    b) 0 to 255   

c) -32768 to 32767    d) 0 to 65535 

179. 5 + 6/3 What is the result of the given arithmetic expression 

 a) 5   b) 0   c) 7   d) 3.33 

180. fun = 1; 

sum = 2; 

final = --fun + ++sim – fun;  What value is stored in the variable final 

 a) 0   b) 1   c) 2   d) 3 

181. The range of short int is _____ to ____ 

a) -32768 to 32768    b) -32678 to 32678  

c) -32768 to 32767    d) -32687 to 32686 

182. What will be the value of the expression c=++a, if a=5? 

a) 5   b) 6   c) 4   d) 0 

 

 

183. Which of the following is a ternary operator? 

a) ::   b) .*   c) ->*   d) ?: 

184. What will be the value of the expression (num1+num2-num3)/5*2<(num1%10) where 

num1=99, num2=20, num3=10? 

a)0   b) 1   c) 100   d) 99 

185. Which of the following can be represented in exponent form as 5864E-2? 
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a) 58.64  b) 5.864  c) 0.5864  d) 5864.00 

186. What will be the value of the expression c=d*a+b, if a=5,b=3 and d=5 

 a) 28   b) 40   c) 20   d) 30 

187. ___ is the escape sequence for printing hexadecimal number 

 a) \n   b) \h   c) \0   d) \x 

188. int a1,a2,a3; 

 a1=6; 

 a2=7; 

 a3=(a1++)-(--a2); 

 cout<<a3; What is the output of the snippet.  

 a) 0   b) 9   c) 11   d) error 

189. Which of the following is treated as hexadecimal number? 

 a)xOF  b)OxF  c)FxO  d)FOx 

190. What will be the value of the expression a = 6; if a%=2? 

 a) 5 b) 6   c) 4   d) o 

191. If a=5 what will be the value of the following expression a%=2 

 a) 2 b) 1   c) o   d) error  

192. _______ are treated as single dimensional array of characters 

 a) pointer  b) function  c) class  d) strings 

193. Which of the following modifier allows the variable to exist in the memory of the computer, 

even if lists function or block within which it is declared loses its scope? 

 a) auto  b) extern  c) local  d) static 

194. Which one of the following is not a type of token used in C++ 

 a) keywords  b) identifiers  c) structures  d) punctuators 

195. Floating point constant include 

 a) fractional portion    b) exponent  

 c) integer     d) all of the above 

196. What is the value assigned to x? float x; int a=7,b=3; x=a/(float)b; 

 a) 2.0   b) 2.333  c) 3.0   d) error 

197. If a=5 and b=4, the value of the expression a+b/2*6 is _________ 

 a) 15   b) 16   c) 17   d) 18 

198. Evaluate the following expression 

 where a=10, b=5, c=5         find the value of the expression c*=a+a/b; 

 a) 70   b) 60   c) 50   d) 40 

199. Identify the inequality operator in C++  

a) <>   b) #   c) !=   d) ~ 

200. If a = 5, b = 20;   c = (a > b) ? a + 5:b + 7  then c = ?   

a) 10   b) 27   c) 12   d) 25 

201. ________variables retains the last assigned value  

a) auto   b) static  c) extern  d) register 

 

202. Which is an example of octal constant  

a) 018   b) 0x18  c) 0xF   d) 18 

203. Which operator require only one operand  

a) <=   b) ++   c) &&   d) << 

204. What will be the value stored in x,   x = (a < b) ? a*a : b%a,  where a = 10 and b = 10?  

a) 100   b) 1   c) 0   d) 20 
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205. What will be the value of the following expression  a += b*c,  where a = 5, b = 6, c = 7?  

a) 77   b) 47   c) 57   d) 74  

206. Which of the following is used create user defined list of identifiers 

 a) enum  b) class  c) structure  d) type definition 

207. Range of enum data type is 

 a) 0 to 255     b) -128 to 127  

 c) 0 to 6535     d) -32768 to 32767 

208. Evaluate the following expressions where a=7, b=6, c=10,  b+=a%2*c 

 a)20   b) 10   c) 7   d)16 

209. How do you represent the number 8564 x 10-2 in exponential form 

a) 8586E2  b) 8564E-2  c) 85.64E-2  d) 8.564E3 

210. Which of the following is the invalid variable declaration  

a) inta,b;  b) int a;  c) int a;  d) int a; b; 

       int b;      float b;  

211. int i = 6; 

unsigned int j = 10; 

cout<<sizeof(i*j); 

the output when the above code is executed is________ 

a) 2   b) 4   c) 8   d) error 

212. The statement    int A; b;  is invalid because_________  

a) only one variable should be given  

b) capital A is not allowed    

c) variables should be separated by comma(,)  

d) all of these  

213. Value of 1 + Pow ( 3, 2 ) is 

a)7   b) 6   c) 10   d) 13 

214. What is the Range of unsigned char data type is 

 a) 0 to 255     b) -128 to 127  

 c) 0 to 65355    d) -32768 to 32767 

215. Variables name may contain________  

a) letters  b) numbers  c) underscore  d) all of these 

216. Which of the following is a invalid variable declaration  

a) sum1+2  b) include  c) void  d) all of these 

217. int side, float hypotenuse, area;   hence the compiler throws an error stating 

that___________  

a) statement missing    b) undefined symbol float  

c) logical error    d) comma is expected after float 

218. The internal representation of   -15 is__________  

a) 1111     b) 1111 0000 0000 0000  

c) 1000 0000 0000 1111   d) -1111 

219. Long, short, signed and unsigned are qualifiers or modifiers that modify a built-in data type 

with the exception of________  

a) int   b) void  c) char   d) float 

220. Initialization of variables are done in________ ways  

a) 2   b) 3   c) 4   d) 5 

221. What is value of the hexadecimal number OXF is________  

a) 21   b) 16   c) 8   d) 15 
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222. Which if the following is unary operator  

a) &   b) ++   c) -   d) all of these 

223. (‘a’ >= ‘z’) What is the of the given expression  

a) 1   b) 0   c) 64   d) 38 

224. Which of the following is not a keyword  

a) struct  b) protect  c) virtual  d) this 

225. What is the floating point constant of the exponent form is 586.4E1  

a) 58.64  b) 5864  c) 5.864  d) 58640 

226. If   a = 5, b = 2, c = 3  then find the value of      a + pow(b , c) * 2  

a) 21   b) 23   c) 26   d) 28 

227. typedef char grade;   from this statement, which is the user defined identifier  

a) typedef  b) char  c) grade  d) all of these 

228. If   x = 5 % 2.5;   What value stored in the variable x?  

a) 2   b) 2.5   c) 0   d) error 

 

 

 

Note: 

� Refer the keywords table  

� Refer the data type size & range of values 

� Refer the C++ data types structure 

� Refer the Punctuators table 

� Refer the table of Operators in C++ 

� Refer the Unary operators and Binary operators table  

� Refer the Escape sequence table 

� Refer the rules for implicit conversion 

 

 

 

 

 

 

 

 

 

 

 

VOLUME – II   3.BASIC STATEMENTS  

I. Choose the correct answer:         

1. Basic statements in C++ are constructed using_________ 

 a) keywords  b) input/output c) tokens  d) variables   

2. How many methods for assigning data to the variable 

 a) 3   b) 2   c) 6   d) 4   

3. Data is read from the keyboard during the run time by using the ________ object 
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 a) input  b) cin   c) int   d) cout 

4. cin is a predefined object that corresponds to a standard_________ stream.  

 a) input  b) output  c) cin   d) cout 

5. Input stream represents the________ of data from the standard input device – the key board 

 a) flow of data b) processed data c) accessing   d) all 

6. The declarations for the object cin are available in a header file called as_________ 

 a) iostream.h  b) istream.h  c) stdio.h  d) ostream.h 

7. The declarations for the object cout are available in a header file called as_________ 

 a) iostream.h  b) istream.h  c) stdio.h  d) ostream.h 

8. _________ header file comprises the combined properties of istream and ostream  

 a) iostream.h  b) istream.h  c) stdio.h  d) ostream.h 

9. A_________ comprises of all standard declarations and definitions for predefined functions 

 a) conio.h  b) main function c) header file  d) input/output 

10. One can include a the header file in the program by using a________ 

 a) statements     b) preprocessor directive  

c) main coding    d) all declarations 

11. A preprocessor directive starts with_________, which instructs the compiler to do the 

required job 

 a) @   b) *   c) $   d) # 

12. #include<iostream.h> is a ________ preprocessor directive, that instructs the compiler to 

include the header file iostream.h  

 a) input/output b) defined  c) declaration  d) typical 

13. Which one of the following is not a header file 

 a) iomanip.h  b) ctype.h  c) fstream.h  d) hstream.h   

14. The ______ is the extraction or get from operator  

 a) <<   b) >>   c) <#   d) ## 

15. The__________ extracts data from the input stream object and places the value in the 

variable to its right 

 a) put to operator    b) insertion operator   

c) output operator    d) extraction operator 

16. Multiple values can be read from the input stream and placed in the corresponding variables, 

by cascading the_________ operator 

 a) extraction  b) interaction  c) put to  d) insertion 

17. _______is a predefined object of standard output stream 

 a) cin   b) cout  c) output  d) write 

18. The standard_________ normally flows to the screen display 

 a) output stream b) input stream c) control  d) data 

19. The operator________ is called the insertion operator or put to operator 

 a) >>   b) ##   c) ?:   d) << 

 

20. The insertion operator directs the contents of the _______ to its right to the object to its left  

 a) variable  b) constant  c) pointer  d) object 

21. Cascading of_______ operator facilitates sending of multiple output via a single statement 

 a) extraction  b) insertion  c) get from  d) all 

22. A C++ program primarily ________ sections 

 a) 3   b) 2   c) 5   d) 4 

23. Which of the following is a sections of C++ program 
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 a) include files    b) declaration of variables  

c) main() function    d) all of these 

24. On successful compilation, when the program is executed the___________ will be 

automatically executed 

 a) void( )     b) sum( ) function  

c) main( ) function    d) call by value 

25. _______ used in the declaration statements need to be declared and defined before they are 

used in a program 

 a) variables  b) constants  c) data   d) compiler 

26. If a declaration also sets aside memory for the variable it is called as_______ 

 a) definition  b) statement  c) variable  d) none 

27. Declaration of a variable introduces a_______ and its associated data type 

 a) constant     b) variable’s name  

c) statement name    d) function name 

28. ________variable are defined only when memory is fetched to store data 

 a) simple  b) default  c) pointer  d) flexible 

29. ________statements are used to declare user defined data type identifiers, function headers, 

pointer variables and like. 

 a) declaration  b) control  b) assignment d) conditional 

30. int num; this statement is called as definition statement because memory is set _______ to 

store data 

 a) aside  b) default  c) outside  d) exist 

31. _______ statement assigns value on the right hand side of an expression to the variable 

 a) control  b) arithmetic  c) declaration  d) assignment 

32. ________in a program need not necessarily be executed in sequential order 

 a) condition  b) statements  c) variable  d) constants 

33. Some segments in a program are executed based on a________ 

 a) condition  b) statements  c) processor  d) variable 

34. The flow of________ jumps from the one part of the program to another 

 a) condition  b) statements  c) compiler  d) control 

35. Program statements that cause such jumps are called as________ 

 a) control statements   b) condition   

c) loops     d) decision making 

36. Program statements that cause a jump of control from one part of a program to another is 

called______ 

 a) decision making     b) condition   

c) control structures    d) loops 

37. control structures are classified into________ major categories 

 a) 1   b) 2   c) 3   d) 4 

 

38. The control structures are implemented in C++ using _______ 

 a) program     b) control statements  

c) switch statements    d) assignment 

39. There are ______ types of entry controlled loop in C++ 

 a) 1   b) 2   c) 3   d) 4 

40. In a program________ causes a onetime jump to a different part of a program 

 a) statement  b) decision  c) control  d) looping 
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41. The if…else… statement which chooses between ________ alternatives 

 a) two   b) three  c) one   d) four 

42. The________ statements creates branches for multiple alternatives sections of code, 

depending on the value of a single variable 

 a) if   b) if..else  c) switch  d) while loop 

43. _______is the simplest of all decision making statements 

 a) if..else  b) simple if  c) switch  d) switch case 

44. The if statement is implemented in_______ forms 

 a) one   b) three  c) two   d) multiple 

45. Once the true block is executed in an ____________ statement, then the else block will not 

be executed 

 a) for   b) switch  c) if..else  d) do-while 

46. _______statement which chooses between two alternatives, executes the chosen block based 

on the condition 

 a) for   b) switch  c) if..else  d) do-while 

47. ________statements can be nested within one another 

 a) if..else  b) switch  c) if   d) all 

48. In an nested if..else statement, “Each else matches with the nearest unmatched 

preceding______”  

 a) if   b) else   c) if-else  d) switch 

49. The________ statement is a multiple branching statement 

 a) switch  b) nested if..else c) simple if  d) if..else 

50. The_________ statement based on a condition, the control transferred to one of the many 

possible points  

 a) if..else  b) switch  c) for   d) if 

51. The switch expression should be evaluated to an________ constant only 

 a) integer  b) floating point c) double  d) decimal 

52. The switch expression should be evaluated to an________ constant only 

 a) int   b) enum  c) char   d) all 

53. Case label should have only one_________ value 

 a) floating point b) character  c) integer  d) all 

54. Every action block should be terminated with a_______ statement 

 a) return  b) continue  c) break  d) exit 

55. Include break; in action block, in order to exit from ________ statement 

 a) switch  b) nested if  c) for   d) do-while 

56. Case label should have only________ integral value  

 a) two   b) one   c) three  d) many 

57. ________are execute a set of instructions repeatedly for a certain number of times 

 a) switch  b) if   c) nested if  d) loops 

 

58. A looping block therefore consists of________ segments 

 a) two   b) three  c) one   d) four 

59. The program to execute a set of instructions repeatedly, based on the condition of the 

_______ expression 

 a) arithmetic  b) logical  c) relational  d) all 

60. A looping block consist the_________ and _________ segments 
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 a) body of the loop and control statement  b) condition and statement   

 c) variable and constant    d) none 

61. The__________ checks the condition. 

 a) variable  b) constant  c) initialization d) control statement 

62. Loops are unconditionally executed________, if the condition is placed at the end of the 

body of the loop 

 a) two times  b) at least once c) many times d) all 

63. Based on the position of the condition, the loops are classified as________ types 

 a) two   b) three  c) four   d) one 

64. The entry check loops are classified as_________ types 

 a) one   b) three  c) two   d) none 

65. The exit check loop is also called as_________ 

 a) while  b) do-while  c) for   d) a and c 

66. Tests the condition variable in the form of a________ expression 

 a) arithmetic  b) relational  c) unary  d) Boolean 

67. Based on the value of the relational expression the_________ is either transferred to the 

beginning of the block, or it quits the block 

 a) condition  b) variable  c) statements  d) control 

68. There are _________ kinds of loops in C++ 

 a) one   b) two   c) three  d) many 

69. ________ loop, as the condition marks the last statement of the body of the loop 

 a) do-while  b) for   c) while  d) nested loop 

70. Incrementing / updating the_________ that is linked to the test expression in the loop 

 a) condition     b) control variable  

c) statements     d) expression 

71. The body of the___________ loop will be executed only if the test expression results true 

placed in the while statement 

 a) for   b) do-while  c) switch  d) while 

72. The control Exits the loop once the test expression is evaluated to_________ 

 a) true   b) false  c) true or false d) none 

73. ________is an entry controlled loop and is used when an action is to be repeated for a 

predetermined number of times 

 a) for loop  b) while loop  c) do-while loop d) switch loop 

74. The___________ is initialized the first time when the control enters the loop for the first 

time 

 a) control statements   b) control variable  

c) body of the loop    d) condition 

75. The body of the loop is executed only the condition is _______ 

 a) true   b) false  c) true or false d) true and false 

 

76. The_______ is incremented and the test condition will be evaluated before the body of the 

loop is executed 

 a) control statements   b) control variable  

c) body of the loop    d) condition 

77. The first segment of the for loop is_________ 

 a) test condition     b) increment  

 c) variable declaration   d) initialization 
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78. _________segment is executed before the commencement of new iteration (or) _______ 

segment is executed before the test condition is evaluated 

 a) initialization    b) increment/decrement   

c) test condition    d) statements  

79. __________ is evaluated before the commencement of every iteration (or) ________ is 

evaluated before the body of the loop is executed 

 a) test condition b) increment  c) statements  d) initialization 

80. Initialization is executed_________, when the loop is executed for the first time 

 a) many     b) only three times  

 c) four times     d) only once 

81. Each segment in a _______loop can comprise a set of instructions 

 a) while  b) for   c) do-while  d) all 

82. In the for loop each instruction should be separated by__________ operator 

 a) semicolon  b) dot   c) colon  d) comma 

83. Each segment in the for loop should be separated by_______ 

 a) colon  b) comma  c) semi colon  d) dot 

84. Semicolon is placed after the for loop, hence the body of the for loop is________ by the 

compiler 

 a) treated  b) executed  c) evaluated once d) not treated  

85. The________ statement forces the next iteration of the loop to take place 

 a) break  b) continue  c) switch  d) return 

86. Skipping any code following the________ statement in the loop body 

 a) continue  b) return  c) break  d) goto 

87. The_________ statement would exit the current loop only 

 a) goto  b) break  c) nested if  d) continue 

88. The_________ statement accomplishes jump from the current loop 

 a) break  b) continue  c) goto  d) switch 

89. An outer loop and inner loop cannot have the_______ control variable 

 a) same  b) different  c) another   d) equal 

90. The inner loop must be completely nested_________ the body of the outer loop 

 a) outside  b) another side c) between  d) inside 

91. If an outer loop and inner loop control variable is same, as it will lead to_______ 

 a) semantically error    b) logical error  

c) statement missing    d) undefined variable 

92. Programs are written in ________ using the grammar of a computer language 

 a) middle level language   b) low level language  

c) high level language   d) none 

93. An object file is created from an__________ source code 

 a) error free  b) object  c) program read d) error check 

 

94. A program written in high level language is called as the______ 

 a) source code    b) object file   

c) machine readable form   d) computer language 

95. The_______ has to be converted to machine readable form 

 a) object file     b) machine readable form  

c) executable file    d) source code 

96. The machine readable form of a program is called as________ 
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 a) source code    b) object file   

c) machine readable form   d) executable file 

97. Compilers create object files from________ 

 a) machine readable form   b) source code   

c) object file     d) none 

98. Compilers are translator programs that create a machine readable program from 

the_______ 

 a) source code    b) object file  

 c) machine readable form   d) executable file 

99. _______checks for the grammar of language(syntax) 

 a) instructor  b) compiler  c) object file  d) source code 

100. The different statements of C++ are________ 

 a) control  b) assignment c) input /output d) all of these 

101. Converting one data type automatically to another is called__________ conversion 

 a) manual  b) explicit  c) conversion  d) implicit 

102.  ________<condition> is called as the entry-check loop 

 a) for   b) while  c) switch  d) do-while 

103.  A loop embedded within another loop is called_______ 

 a) nested  b) loop  c) break  d) continue 

104.  How many times the loop will be executed for(i=1; i<6; i++) 

 a) 6   b) 5   c) 0   d) 4 

105. Nested if..else statement can be replaced by the statement of________ 

 a) select-case  b) switch-case c) for   d) do-while 

106. The object file is linked with the essential libraries to generate an _________ file. 

a) Source  b) Object  c) Executable  d) C++ 

107. __________ is a control statement 

 a) switch  b) while  c) if else  d) all the above 

 

108. How many times the following loop will be executed? 

 s=11; 

 while(s<=20) 

 cout<<s++; 

 a) 10   b) 9   c) 20   d) None of these 

 

 

 

 

 

 

Read the following snippet and answer the questions  113 to 115 

 v=101 

 i=1; 

 do 

 { 

 cout<<v++; 
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 i++; 

 }while(i<10); 

109. __________ is used as control variable 

 a) v   b)i   c) both i and v d) none of these 

110. _____________ type of loop is used in the program 

 a) entry check loop    b) exit check loop  

 c) both a and b    d) none 

111. How many times the above loop will be repeated? 

 a) 10   b) 9   c) 11   d) 101 

112. Which of the following loop will be executed unconditionally at least once 

 a) do-while  b) while  c) for   d) b & c 

113. What will be the output of the program 

 intctr=1; 

 for(; ctr<10 ; ctr++) 

 { 

 cout<<ctr; 

 } 

 a) 1 and indefinite    b) 12345678910  

 c) 123456789    d) 111111111 

114. Which of the following is executed only once 

 a) test condition    b) increment   

 c) initialization    d) decrement 

115. Declaration of a variables introduces a variable name and its associated 

 a) data type     b) data value  

 c) operator     d) operation 

116. The variable used in for loop is called  

 a) Static variable    b) counting variable   

c) control variable     d) for variable 

117. How many times the following loop will be executed      for(i=1;  i<30;  i++)  

a) 1  b) 29  c) 30  d) 31 

 

 

 

 

 

 

 

 

 

Read the following C++ program carefully and answer the questions from 122 to126 

  #include<iostream.h> 

  void main() 

  { 

  int num = 2; 

do 
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{ 

cout<<num * num<<’\t’; 

num+=1; 

} 

while(num<6); 

}   

118. Name the control variable used in the program 

a) num  b) +=1   c) \t   d) none of these 

119. What is the test expression ( condition) used  

a) num  b) num*num  c) (num<6)  d) none of these 

120. How many times the loop will be executed  

a) 6   b) 4   c) 5   d) 3 

121. What is the output of the following program  

a) 24    9 16    25   b) 2   4    6 8        

c) 4 9   16     25    d) 0     4  9 25 

122. What type of loop statement used in the program 

a) entry check loop b) exit check loop c) entry controlled loop d) selection loop 

123. What is the error thrown by the compiler for the following snippet 

if(a>b); 

cout<<”greater”; 

else 

cout<<”lesser”;  

 a) misplaced if    b) misplaced else  

c) misplaced if….else   d) misplaced else….if   

 

 

Note: Read & learn all programs and Read Exercises 

 

 

 

 

 

 

 

 

 

VOLUME – II   4.FUNCTIONS 

I. Choose the correct answer:         

1. _________are the building blocks of C++ program 

 a) data type  b) functions  c) constants  d) data type 

2. ________are also the executable segments in a program 

 a) functions  b) variable  c) prototype  d) compiler 

3. The starting point for the execution of a program is________ 
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 a) void  b) statements  c) variable  d) main() 

4. ________are used to reduce the size of the program  

 a) coding  b) data type  c) functions  d) getch() 

5. ________are used to induce reusability of code 

 a) data type  b) functions  c) constants  d) data type 

6. A_________ can be shared by other programs by compiling it separately and loading them 

together 

 a) function   b) statement  c) method  d) variables 

7. _________statement marks the end of the function 

 a) break  b) end   c) getch()  d) return 

8. The_________ statement is used to transfers control to the statement after call statement 

 a) return  b) goto  c) break  d) end 

9. _________ should be declared before they are used in a program 

  a) coding  b) data type  c) functions  d) getch() 

10. Declaration of a function is made through a_______ 

 a) arguments     b) function prototype   

c) data types     d) calling type 

11. The prototype provides the information about the function to the________ 

 a) argument  b) compiler  c) parameter  d) variable 

12. The main purpose of function prototype is to help the _______ to check the data 

requirement of the function 

 a) compiler  b) parameter  c) arguments  d) function 

13. With function prototyping, a______ is always used when declaring and defining a function 

 a) template  b) inheritance  c) prototype  d) function 

14. When a function is called, the compiler uses the __________ to ensure that proper 

arguments are passed, and the return value is treated correctly 

 a) parameter  b) arguments  c) function  d) template 

15. Any violation in matching of the arguments or the return type will be treated a________ 

by compiler, and flagged at the time of compilation 

 a) logical  b) errors  c) function  d) arguments 

16. In a function declaration, the names of the arguments are_______ variables and they are 

optional 

 a) dummy  b) main  c) own   d) extract  

17. The_________ in the prototype act as place holders 

 a) constants  b) variables  c) functions  d) strings 

18. The function may include  a set of actual parameters, enclosed in parentheses separated 

by_______ 

 a) colon  b) comma  c) semi colon  d) dot 

 

19. The__________ are required in function definition, as the arguments are referenced inside 

the function 

 a) arguments type    b) data type   

c) arguments name    d) array identifier 

20. A function can be called or invoked from another function by using its________ 

 a) data   b) arguments  c) name  d) data type 

21. The__________ communicates with the function through arguments or parameters  

 a) call statement    b) function declaration  
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c) called statement    d) arguments 

22. ________are the channels through which data flows from the call statement to the function 

 a) parameters  b) statements  c) functions  d) variables 

23. In C++, functions that have arguments can be invoked by_________ ways 

 a) three  b) ten   c) two   d) four 

24. In______ method, the called function creates new variables to store the value of the 

arguments passed to it 

 a) call by reference    b) call by value  

c) function prototype   d) function 

25. In the________ method copies the values of actual parameters into the formal parameters 

 a) call by reference    b) call by value  

c) function prototype   d) function 

26. The________ parameters associated with the call statement 

 a) actual  b) formal   c) call by value d) call by reference 

27. The_________ parameter associated with the function header 

 a) actual  b) formal   c) call by value d) call by reference 

28. In________ method, the flow of data is always from the call statement to the function 

definition 

 a) call by reference    b) call by value  

c) function prototype   d) function 

29. When arguments are passed by value, the ________ creates new variables of the same data 

type as the arguments passed to it 

 a) called function    b) call function  

c) variable function    d) input function 

30. The values of these ________ are copied into the newly created variables  

 a) functions  b) variables  c) prototype  d) arguments  

31. In________ method, any change made in the formal parameter is not reflected back to the 

actual parameter 

 a) prototype     b) calling function  

c) call by value    d) call by reference 

32. In________ method, the called function arguments – formal parameters become alias to the 

actual parameters in the calling function 

 a) prototype     b) calling function  

c) call by value    d) call by reference 

33. Which of the following operator is called reference operator in C++? 

 a) #   b) *   c) &   d) *& 

 

 

34. In______ method the function is working with its own arguments, it is actually working on 

the original data 

 a) call by reference     b) call by value  

c) arguments     d) call by method 

35. In call by reference method, the formal and actual parameters in______ type point to the 

same storage area 

 a) data type     b) reference type  

c) value type     d) method type 
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36. In________ method, any change made in the formal parameter is reflected back to the 

actual parameter 

 a) prototype     b) calling function  

c) call by value    d) call by reference 

37. ________ method is the value type method 

 a) argument type    b) call by value 

 c) constants type    d) call by reference 

38. ________ method is the reference type method 

 a) call by reference    b) call by method  

c) call by value    d) call by arguments 

39. The actual parameters can be passed in the form of_______ to the formal parameter which 

are of value type 

 a) constants or expressions   b) variables  

c) arguments      d) constants or variables or expressions 

40. The actual parameter can be passed only as________ to formal parameters of reference type 

 a) variables  b) constants  c) expressions d) variables or constants 

41. In C++, one can assign default values to the _________ parameters of a function prototype 

 a) actual  b) formal  c) method   d) arguments 

42. The default value is given in the form of variable_________ 

 a) declaration  b) increment   c) initialization d) prototype 

43. The_________ argument facilitate the function call statement with partial or no arguments 

 a) default   b) formal  c) actual  d) b or c 

44. The default values can be included in the ________ form right to left 

 a) function argument   b) function parameter  

c) function prototype   d) either a or b 

45. The actual parameters are matched with formal parameters on the basis of________ 

correspondence 

 a) one-to-one  b) one-to-many c) many-to-one d) many-to-many 

46. In the absence of actual arguments, the formal parameters takes the_______ arguments 

 a) own   b) copy  c) actual  d) default 

47. The function that return no value is declared as_______ 

 a) int    b) float  c) char   d) void 

48. The data type of a function is treated as_______, if no data type is explicitly mentioned 

 a) int    b) float  c) char   d) void 

49. The default return value of a function in C++ is of type_______ 

 a) float  b) char  c) int   d) double 

50. What is the return type of float power (float, int) 

 a) int   b) char  c) float  d) enum 

 

51. What is the return type of char * success( ) 

 a) float  b) char  c) int   d) pointer to character 

52. A function returning a reference can appear on the _________ of an assignment 

 a) right-hand side b) left-hand side c) bottom side d) left or right side 

53. The formal parameter for a reference function should always be of ______ parameter type 

 a) reference  b) formal  c) actual  d) value 

54. ________function is used for reusability of code leading to saving of memory space 

 a) inline  b) online  c) outline  d) get line 
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55. The__________ functions execute faster but require more memory space 

 a) normal  b) online  c) outline  d) inline 

56. ________that would save certain special instructions pertaining to function call, return and 

its arguments  

 a) functions  b) parameter  c) stacks  d) prototype 

57. ________reduces the speed of program execution 

 a) inline  b) stacks  c) arguments  d) actual parameter 

58. When the functions are small, the compiler replaces the function call statement by 

its_______ 

 a) definition  b) arguments  c) stacks  d) formal parameter 

59. An_________ looks like a normal function in the source file but inserts the function’s code 

directly into the calling program 

 a) inline  b) online  c) outline  d) getline 

60. To make a function inline, one has to insert the keyword inline in the _________ 

 a) function header    b) actual parameter  

c) arguments     d) main function 

61. Inline keyword is just a request to the _________ 

 a) user   b) program  c) compiler  d) parameters 

62. _________ refer to the accessibility of a variable 

 a) function  b) prototype  c) scope  d) inline 

63. There are________ types of scopes in C++ 

 a) 4   b) 5   c) 7   d) 3 

64. A__________ variable is defined within a block 

 a) function  b) local  c) file   d) class 

65. The scope of a _________variable is the block in which it is defined 

 a) class  b) file   c) function  d) local 

66. A local variable cannot be accessed from__________ the block of its declaration 

 a) outside  b) inside  c) next side  d) bottom side 

67. The life time of a _________ variable is the life time of a block in its state of execution 

 a) local  b) file   c) function  d) class 

68. ________variables die when its block execution is completed  

 a) class  b) file   c) function  d) local 

69. ________variables are not known outside their own code block 

 a) function  b) local  c) file   d) class 

70. A block of code begins and ends with________ 

 a) curly braces{ }    b) square bracket [ ]   

c) parenthesis ( )     d) { } & [ ] 

 

 

71. _______variables exist only while the block of code in which they are declared is executing 

 a) class  b) file   c) function  d) local 

72. A_________ variable is created upon entry into its block and destroyed upon exit 

 a) class  b) file   c) local  d) function 

73. A_________ scope of variables declared within a function is extended to the function 

block, and all          sub-blocks therein 

 a) local  b) file   c) function  d) class 

74. The life time of a_________ scope variable, is the life time of the function block 
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 a) function  b) file   c) local  d) class 

75. The scope of________ parameters in function scope 

 a) actual  b) formal  c) main()  d) arguments 

76. A variable declared above all blocks and functions is called________ scope (or)           

_______scope variable is declared above all blocks and functions 

 a) function  b) file   c) local  d) class 

77. The scope of a________ scope variable is used in the entire program 

 a) function  b) local  c) file   d) class 

78. The life time of a file scope variable is the life time of a_________ 

 a) action block b) end of class c) function   d) program 

79. The_________ operator reveals the hidden scope of a variable 

 a) scope  b) membership c) plus   d) conditional 

80. ________is called as scope resolution operator 

 a) # #   b) ?:   c) ::   d) @ 

81. The_________ operator is used to refer variables declared at file level 

 a) relational  b) reference  c) conditional  d) scope resolution 

82. The_________ operator is helpful only under situations where the local and file scope 

variables have the same name  

 a) scope resolution     b) relational   

c) reference     d) conditional  

83. The calling function parameter is also called as_________ parameter 

 a) formal  b) actual  c) dummy  d) duplicate 

84. The data flows from call statement to function by using 

 a) data type     b) function name  

c) parameter     d) operators 

85. In call by value method, actual and formal parameters have _________ memory locations 

 a) one   b) different  c) many  d) same 

86. In call by reference method, actual and formal parameters have _________ memory 

locations 

 a) one   b) different  c) many  d) same 

87. In the following code, the scope of the variable is 

if( x < y ) 

{ 

int a; 

a++; 

} 

a) local variable    b) class variable  

c) function variable    d) file variable 

88. In a function declaration the _____ of the argument are dummy variables and before they 

are optional 

a) Name  b) Data type  c)both a & b  d) None of these 

89. The return type of the function prototype exam (float, int) is 

 a) char   b) double  c) int    d) float 

90. How does the call statement communicate with the function/ 

a) data type     b) parameters or data type  

 c) parameters    d) arguments or parameters  

91. The parameters that associated with call statement is 
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 a) Format parameter   b) actual parameter 

 c) dummy parameter   d) default parameter 

92. If no data type is explicitly mentioned, the data type of a function is treated as 

 a) int   b) void  c) char   d) float 

93. Which keyword can be used to make a function inline function? 

 a) inline  b) inline( )  c)in-line  d)inline_function 

94. The actual parameters can be passed in the form of ________ to the formal parameter which 

are of value type. 

 a) constant  b) variable  c) expressions d) all of these 

95. What is the return type of the function prototype add(int, int) 

 a) void  b) int   c) no return type d) float 

96. The function that return used in the entire program is called 

 a) static  b) void  c) extern  d) null 

97. The main purpose of function prototype is 

 a) to check memory availability  b) to check the data requirement 

 c) to check data type   d) to check the program size 

98. Which of the following variable cannot be accessed from outside the block of its declaration 

 a) global variable    b) class variable  

 c) local variable    d) none of these 

99. Which of the following function prototype is used to increment the value of a variable of 

type float? 

 a) void incr(float)    b) void incr( )  

 c)int incr(float)    d) float incr(float) 

100. Which of the following about functions is false?  

 a) Functions provide data security  b) Functions reduce the size of the program  

 c) Functions induce reusability of code  d) Functions are executable segments in a program. 

101. Which of the following function prototype used to compute xy Where x and y are both 

integers? 

 a) power(int)     b) int power(int, int)   

 c) power(int, int)    d) float power(float, float) 

102. Which of the following is not a valid function prototype 

a) void fun (int x);   b) void fun (int x, int y);  

    void fun (int y);   void fun (int x, float y);        

c) int fun (int x);    d) void fun (char x); 

void fun (float x);     void fun (char x, int y); 

 

103. Which of the following is valid function prototype  

a) float average(a, b);    b)float product(int a, b);  

c) int fun(int a, int b, double pi = 3.14); d) int display(int a = 2, int b); 

104. The return type of the function prototype     fact(float, char, double) is________  

a) char  b) float  c) int  d) double 

105. Which option is invalid when related to functions of C++?   

 a) Actual  parameter can be passed in the formal parameter of value type  
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b) The actual parameter can be passed only  as variable to the formal parameter of reference type 

 c) The default value in the formal parameter is given of variable initialization   

d) The default value for an argument can be given in the between the arguments list. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

VOLUME – II   5.ARRAYS 

I. Choose the correct answer:         

1. An array in C++ is a _______ data type 

 a) built-in     b) user defined 

 c) structured     d) derived 

2. The________ can hold several values of the same type 

 a) array     b) class  

 c) query     d) functions 
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3. In order to handle large data with ease, elements belonging to the same data type are 

declared as_______ 

 a) functions     b) class  

 c) array     d) arguments 

4. An_____ is a collection of variables of the same type that are referenced by a common name 

 a) functions     b) array  

 c) statements     d) class 

5. Arrays can be classified as________ types 

 a) two   b) three  c) four   d) five 

6. _______ dimensional array is comprising of finite homogenous elements 

 a) multi  b) two   c) three  d) one 

7. ________dimensional array is comprising of elements, each of which is itself a one-

dimensional array 

 a) multi  b) two   c) three  d) one 

8. _______are suitable ways for processing of lists of items for identical types 

 a) single dimensional array   b) two dimensional      

c) multi dimensional array   d) three dimensional array 

9. The size of the array should always be ________ 

 a) negative     b) integer   

c) whole number    d) positive 

10. Each element of the array is accessed by the____ and the position of the element in the array 

 a) array size     b) array type   

c) array name     d) all of these 

11. The array subscripts always commences from________ 

 a) zero   b) one   c) non-zero  d) negative 

12. cin>>number[4]; how many elements read this statement 

 a) 2   b) 5   c) 4   d) 1 

13. int a[10]; is the example of________ dimensional array 

 a) two   b) three  c) one   d) multi 

14. int b[3][3]; is the example of _______ dimensional array 

 a) six   b) three  c) one   d) two 

15. One can rearrange the data in a given array either in ascending or descending order is 

called_______ 

 a) arranging     b) sorting   

c) reorder     d) none 

16. Strings are otherwise called as________ 

 a) variables     b) characters   

c) literals     d) identifiers 

 

17. Strings are treated as single dimensional _______ 

 a) array of characters   b) characters   

c) array of objects    d) null characters 

18. The declaration of string is same as_______ array 

 a) non-numeric    b) numeric  

 c) character     d) null 

19. A character array should be terminated with a _________ character 

 a) ‘\0’   b) ’\b’   c) ‘\n’   d) ‘\s’ 
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20. The instance cin, treats white space or carriage return as________ 

 a) terminator for string   b) starting string  

c) between for string    d) all of these 

21. White space is treated as string_______ 

 a) separator  b) terminator  c) a or b  d) a and b 

22. To treat spaces as part of string literal, then one has to use________ function 

 a) cin   b) getch( )  c) cout   d) gets( ) 

23. The gets( ) function defined in________ header file 

 a) stdio.h     b) conio.h  

 c) iostream.h     d) ctype.h 

24. To treat spaces as part of string literal, then one has to use________ function 

 a) gets( )  b) getline( )  c) a or b  d) none 

25. getline( ) is a member function of standard________ stream  

 a) output  b) cout  c) cin   d) input 

26. getline( ) member function is defined in the________ header file 

 a) ctype.h     b) ostream.h   

c) istream.h     d) stdio.h 

27. There are________ methods to display the contents of string 

 a) two   b) three  c) one   d) four 

28. write( ) is a member function of standard________ stream 

 a) input  b) output  c) cin   d) cout 

29. write( ) is a member function defined in the_________ header file 

 a) ctype.h     b) ostream.h  

 c) istream.h     d) stdio.h 

30. All member functions of a class, should be accessed through an_________ of class 

 a) object  b) instance  c) a or b  d) none 

31. The______ parameters required for write( ) function are identifier string characters, and 

no.of characters to be displayed 

 a) three  b) four   c) two   d) one 

32. Strings can be manipulated element by element like a_________ 

 a) one dimensional character array  b) two dimensional character array   

c) three dimensional character array d) multi dimensional character array  

33. String functions(manipulators) are defined in__________ header file 

 a) conio.h     b) string.h  

 c) iomanip.h     d) manip.h 

34. Which function returns the number of characters stored in the array  

 a) strlen( )     b) strcpy( )  

 c) strcmp( )     d) strcat( )   

 

35. ________function is used to compares the two given strings 

 a) strlen( )     b) strcpy( )   

c) strcmp( )     d) strcat( )   

36. ________function is used to copies source string to target string 

 a) strlen( )     b) strcpy( )  

 c) strcmp( )     d) strcat( )   

37. strcmp(“abc” , “abc”) this function returns 

 a) 0   b) 1   c) -1   d) none 
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38. strcmp(“Abc” , “abc”) this function returns 

 a) -0.5   b) 0   c) -1   d) 1 

39. strcmp(“abc” , “Abc”) this function returns 

 a) 1   b) 0   c) -1   d) -0 

40. A_______ array is an array in which each element is itself an array  

 a) one dimensional    b) two dimensional  

c) three dimensional    d) none 

41. An element in a 2-D array is referred as_________ 

 a) [column]     b) [row]  

 c) [column][row]    d) [row][column] 

42. The dimensions(rows / columns) of an array can be indicated as_________ 

 a) using integer constants   b) using char constants  

c) using enum constants   d) all of these 

43. The dimensions(rows / columns) of an array cannot be indicated as_________ 

 a) using const identifier   b) using float constants  

c) using enum constants   d) all of these 

44. A 2-D array is stored in_______ memory blocks 

 a) disorder     b) one by one  

 c) sequential     d) arrange 

45. row-wise manner method is called as_________ order 

 a) column-major    b) row-major   

c) input-manner    d) size-manner 

46. column-wise manner method is called as_________ order 

 a) column-major    b) row-major   

c) input-manner    d) size-manner 

47. In 2-D array the elements are stored in_______ ways 

 a) 1   b) 2   c) 3   d) 4 

48. In 2-D array the elements are stored in ________ manner 

 a) row-wise  b) column-wise c) either a or b d) both a and b 

49. The size of the ________ is optional in array initialization 

 a) second dimension    b) first dimension  

c) third dimension    d) none of these 

50. Arrays can be passed on as_________ to functions 

 a) variable  b) constants  c) arguments  d) identifier 

51. The_________ parameter is passed only by the identifier, ignoring dimensions 

 a) actual  b) default  c) formal  d) array 

52. _________ parameters by default behave like a reference parameter 

 a) actual  b) default  c) formal  d) array 

 

53. The array identifier represents the________ of the array 

 a) character     b) base address  

c) variable     d) value 

54. A matrix is a set mn numbers arranged in the form of a ____ array of m rows and n columns 

 a) square  b) rectangular c) box   d) circle 

55. The________ can be represented through 2-D arrays 

 a) matrices  b) series  c) values  d) angles 

56. An array of string is a _________ dimensional character array 
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 a) one   b) two   c) three  d) all 

57. The size of the________ determines the number of strings in the given array 

 a) first index     b) second index  

c) column     d) row and column 

58. The size of the________ determines the maximum length of the each string 

 a) first index     b) second index  

c) row      d) row and column 

59. Attaching the _________ to each string literal is optional 

 a) size      b) null character  

c) positive number    d) variable 

60. The C++ compiler will automatically attach _________ to each string 

 a) size      b) null character  

c) positive number    d) variable 

61. An integer array with indexes from 0 to 4, all having value 1 may be declared and initialized 

as______ 

 a) int x[4] = {1};    b) int x[4] = {1, 1, 1, 1};  

c) int x[5] = {1, 1, 1, 1, 1};   d) int x[] = { }; 

62. the function strcpy( s1, s2)_________ 

 a) copies s1 to s2    b) copies s2 to s1  

c) append s1 to end of s2   d) appends s2 to end of s1 

63. The number of elements of a 2-D array is calculated as________ 

 a) rows x columns    b) rows x columns x size  

c) size x data type    d) size x byte 

64. The size of the 2-D array is calculated as __________ 

 a) number of elements x size of the array     

b) rows x columns    

c) number of elements x memory req. for one element    

d) row byte x column byte 

65. float num[4][6] – how many elements are stored in the given array 

 a) 10   b) 30   c) 24   d) 96 

66. int sales[5][6] – what will be the size the given array 

 a) 11 bytes  b) 60 bytes  c) 21 bytes  d) 30 bytes 

67. intnum_array[5]; how many elements can be stored? 

a) 5   b) 1   c) 3   d) 2 

68. if string2 is greater than string1, strcmp ( ) returns 

a)>0   b)<0   c) =0   d) ‘\0’ 

69. Which is stored in sequential memory block? 

a) Variables  b) 1 D array  c) Constants  d) 2 D array 

 

70. Which does the C++ compiler automatically attach to end of the string? 

a) -1   b)‘\n’   c) ‘\0’   d) Both (b) and (c) 

71. Which is a 2D character array 

a) Matrix  b) String  c) Marks  d) All of these 

72. int num_array[5] stores 

 a) 5 integer values    b) 5 character values  

 c) 6 integer values    d) 4 numeric values 
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73. Which of the following statement assigns the contents of the 3rd element of the array to its  

4th element? 

 a) number[3]=number[4]   b) number[3]=number[2] 

 c) number[4]=number[3]   d) number[2]=number[3] 

74. Which of the following string function is used for string concentration? 

 a) strcat( )  b)catstr( )  c)concat( )  d)stradd( ) 

75. int days[ ] = { 1,2,3,4,5,6,7 }; in this statement what is the size of the array 

 a) 4   b) 5   c) 6   d) 7 

76. In the array num[3]=99, it stores the value 99 as the ____ element in the array num 

 a) 3rd   b) 2nd   c) 5th   d) 4th 

77. ____ are treated as single dimensional array of character 

 a) integers  b) constant  c) strings  d) characters 

78. strcmp( ) compares the two given string and returns … if sting 1 is lesser than sting 2 

 a) 0   b)<0   c)>0   d) 1 

79. Array parameters by default behave like a .. parameter 

 a) actual     b) dummy   

 c) reference     d) none of these 

80. The instance .. treats white space or carriage return as terminator for string 

 a) cout  b) cin   c) gets ( )  d)getchar ( ) 

81. The function gets ( ) take … number of argument 

 a) 1   b) 2   c) 3   d) 4 

82. number[3]++; in this array processing which increments the value stored as ___ element by 1 

a) fourth  b) fifth  c) third  d) second 

83. Which of the following is an invalid array declaration  

a) int array[100];    b) int array[];  

c) int array[i];    d) constint i= 10; int array[i]; 

84. The appropriate declaration statement to initialize the variable ‘name’ with the value ‘Abdul 

Kalam’ is_________  

a) char name = ‘Abdul Kalam”;  b) char[] name = “abdulKalam”;  

c) char name[] = Abdul Kalam;  d) char name[] = “Abdul Kalam”; 

85. cin>>num[3];   it reads which element  

a) fourth  b) third  c) second  d) first  

86. cin>>num[3];   how many elements read this statement  

a) 1   b) 2   c) 3   d) 4   

 

 

 

 

 

 

VOLUME – II   6.CLASSES AND OBJECTS 

I. Choose the correct answer:         

1. The most important feature of C++ is the________ 

 a) data type  b) class  c) array  d) inheritance 

2. Class significance is highlighted by the Bjarne Stroustrup initially gave the name _______ 

 a) class  b) C++ classes c) objects  d) C with classes 

3. A class is a new way of creating and implementing a___________ data type 
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 a) user defined b) built-in  c) derived  d) structured 

4. _________ provide a method for packing together data of different types 

 a) classes  b) functions  c) arrays  d) objects 

5. The class data type can be further extended by defining its associated________ 

 a) arrays  b) functions  c) structure  d) objects 

6. Functions are also called as_____, as they define the various operations that can be 

performed on the data 

 a) attributes  b) literals  c) variable  d) methods 

7. A________ is a way to bind the data and its associated functions together 

 a) variable  b) arrays  c) attributes  d) class 

8. A class specification has________ parts 

 a) five   b) one   c) two   d) three 

9. The keyword class specifies user defined data type ________ name 

 a) class  b) functions  c) strings  d) character 

10. The body of the class is enclosed within_______ 

 a) ( )   b) ;   c) { }   d) [ ] 

11. The body of the class is terminated by a __________ 

 a) .   b) :   c) ;   d) ?: 

12. The body of the class is enclosed with in ________ 

 a) {;   b) };   c) }?   d) ]; 

13. The class body contains the declaration of________ 

 a) variables  b) functions  c) operator  d) variables and functions 

14. The class body has _______ access specifiers 

 a) 3   b) 2   c) 1   d) 4 

15. Which of the following is not a visibility label 

 a) private  b) friend  c) protected  d) public 

16. Which of the following is a visibility label 

 a) protect  b) public  c) friend  d) a and b 

17. ________visibility label is optional  (or) _________ is the default access specifier 

 a) public  b) protected  c) private  d) all 

18. Default the members will be treated as _______ if a visibility label is not mentioned 

 a) private  b) friend  c) protected  d) public  

19. The members that have been declared as______ can be accessed only from within the class 

 a) private  b) friend  c) protected  d) public 

20. The _______ members cannot be accessed from outside the class 

 a) public  b) protected  c) private  d) all 

21. The members that have been declared as________ can be accessed only from within the 

class and the inherited class  

 a) private  b) friend  c) protected  d) public 

 

22. The private data of a class is accessible by only its own members and certain special 

functions called as________ functions 

 a) member  b) private  c) friend  d) own 

23. The protected data of a class is accessible by members of_________ class  

 a) inherited  b) base  c) derived  d) private 

24. The________ data of a class is access allowed by other members in addition to class 

members and objects 
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 a) private  b) friend  c) protected  d) public 

25. The objects declared outside the class cannot be access members or functions defined 

under________ 

 a) private  b) protected  c) public  d) private or protected  

26. The objects declared outside the class can be access members or functions defined 

under________ 

 a) private  b) protected  c) public  d) private or protected  

27. The functions declared under_________ can be accessed by the object of that class 

 a) private  b) friend  c) protected  d) public 

28. The members of a class are accessed using the________ operator 

 a) semicolon  b) dot   c) colon  d) comma 

29. The binding of data and functions together into a single entity is referred to as _________ 

 a) data abstraction    b) data hiding  

 c) encapsulation    d) polymorphism 

30. The members and functions declared under private, is referred to as_________ 

 a) data abstraction    b) data hiding  

 c) encapsulation    d) polymorphism 

31. Instruments allowing only selected access of components to objects and members of other 

classes is called as________ 

 a) data abstraction    b) data hiding  

 c) encapsulation    d) polymorphism 

32. data abstraction is achieved through________ 

 a) data abstraction    b) data hiding  

 c) encapsulation    d) polymorphism 

33. Data hiding is the key feature of _______ programming languages 

 a) object     b) structured oriented 

 c) object oriented    d) class oriented 

34. Class comprises of_______ members (or) Members are further classified as_______ types 

 a) three  b) two   d) four   d) one 

35. _________ are the data variables that represent the features or properties of class 

 a) data members    b) object member 

 c) member functions    d) member class 

36. _________ are the functions that perform specific tasks in a class 

 a) data members    b) object member 

 c) member functions    d) member class 

37. Member functions are also called as________ 

 a) attributes  b) constants  c) object  d) methods 

38. Data members are also called as_________ 

 a) attributes  b) constants  c) object  d) methods 

 

39. Classes include special member functions called as________ 

 a) constructor  b) inheritance  c) destructor  d) constructor and destructor  

40. student stud;   From the given statement stud is an________ of the class student 

 a) constructor  b) object  c) instance  d) instance or objects 

41. Class object is also called as ________ 

 a) instance  b) constructor c) destructor  d) object 

42. Once a class has been declared, ________ of that type can be declared 
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 a) constants  b) variables  c) operator  d) none 

43. In C++ class variables are known as________ 

 a) variables  b) constants  c) objects  d) data members 

44. _______can also be created by placing their names immediately after the closing braces of 

the class declaration 

 a) objects   b) variables  c) constants  d) data 

45. The declaration of an object is similar to that of a variable of any________ type 

 a) derived  b) basic  c) structure  d) query 

46. Methods of a class can be defined in________ ways 

 a) two   b) three  c) six   d) four 

47. The members defined within the class behave like________ functions 

 a) friend  b) inline  c) nesting  d) outline 

48. The_________ operator is used for defined the functions outside the class 

 a) ;   b):   c) ?:   d) :: 

49. The ________ tells the compiler that the function belongs to the class 

 a) membership label    b) dot operator  

 c) object     d) attributes 

50. The scope of the function is restricted to the class specified in the_________ 

 a) object     b) function header  

c) void main      d) compiler 

51. Several different classes can use the _______ function name 

 a) same  b) copy  c) reference  d) single 

52. The_______ will resolve their scope 

  a) membership label   b) dot operator  

 c) object     d) attributes 

53. The________ can access the private data of a class 

 a) objects     b) variable  

 c) member functions    d) attributes 

54. A member function can call another member function directly, without using dot operator is 

called _______ functions 

 a) friend functions    b) inline functions  

c) nesting of member functions  d) outline functions 

55. The_________ can receive arguments of a valid C++ data type 

 a) member functions    b) objects  

c) variable     d) attributes 

56. Objects can also be passed as__________ 

 a) constant  b) data type  c) arguments  d) keywords 

57. The return type of a member function can be of________ data type 

 a) attributes  b) object  c) class  d) structure 

58. The________ are created and placed in the memory spaces only when they are defined as a 

part of the class specification 

 a) objects  b) variable  c) attributes  d) member functions 

59. Memory spaces required for the ________ are only allocated separately for each object 

 a) objects  b) attributes  c) classes  d) member variables 

60. The__________ will hold different data values for different objects  

 a) classes   b) objects  c) attributes  d) member variables 

61. Member functions belong to the________ 
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 a) variables  b) objects  c) common pool d) attributes 

62. The objects will have access to the code area of the________ 

 a) common pool  b) variables  c) objects  d) attributes 

63. Member functions of a class can handle arguments like any other_________ 

 a) methods     b) non-member functions  

c) class variables    d) arguments 

64. A________ of a class can be qualified as static 

 a) data member    b) objects  

 c) member functions    d) constants 

65. The static member variable is initialized to_______, only when the first object of its class is 

created 

 a) one   b) two   c) zero   d) bytes 

66. ________ copy of the member variable is created and is shared by all the other objects of its 

class type 

 a) only one  b) zero  c) three  d) five 

67. The static member variable is considered by the compiler as part of the_________ 

 a) common pool  b) variables  c) objects  d) attributes 

68. The static member variable scope (or) visibility is _________ 

 a) within the class    b) outside the class  

 c) whole class    d) after the class 

69. The static variable life time is the lifetime of the________ 

 a) function  b) class  c) program  d) object 

70. The static variable is initialized to zero________ 

 a) all times  b) only once  c) zero times  d) only five times 

71. The initial value to a static member variable is done________ the class 

 a) inside  b) before  c) outside  d) object 

72. OOP stands for 

a) Online Objects programming  b) Object Oriented Programming 

c) Object Oriented Process   d) Object to Object Programming 

73. One copy of the following data members of a class are shared by all objects of that class 

a) Inline  b) Private  c) Public  d) Static 

74. Which of the following initial value to a member variable is done outside the class? 

a) extern  b) register  c) static  d) auto 

75. Private access specifier is accessible by special functions called 

a) Void  b) Inline  c) Friend  d) All of these 

 

 

 

 

76. class example 

{ 

intx,y; 

float m,n; 

 }p[4]; 

 By the above code how many objects of the class example are created? 

 a) 1   b) 3   c) 4   d) 5 

77. The class contain the declaration of  
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a) Variables and functions   b) Pointers and functions 

c) Function and arrays   d) Variables and arrays 

78. The private data of a class can be accessed only through 

a) member function    b) friend function  

c) either (A) or (B)    d) neither (A) and (B) 

79. All member function of a class, should be accessed through an ____ of these 

a) Object  b) Instance  c) a & b  d) Member 

80. The keyword of class specifies user defined data types___ 

a) Class name b) Class type  c) Class  d) None of these 

81. Members are classified into 

a) Data members and member functions   

b) Data Member and Friend Functions 

c) Member Function and Member Constructor  

d) Data Members and Function Members  

82. Member functions can be of _____ type. 

a) auto   b) extern  c) static  d) private 

83. The special member function used in the class is 

 a) inline function b) constructor c) void function d) main function 

84. Member functions defined outside the class has the prototype as 

 a) type class_name::function name( ) b) type function_name ( ) :: class name 

 c) void function_name( )   d) void class_name( ) 

85. A member function which is declared as private is called as 

 a) constructor    b) destructor   

 c) friend function    d) data function 

86. By default the members in the class will be treated as  

 a) public  b) protected  c) private  d) local 

87. The data variable that represent the features or properties of a class is 

 a) member function    b) data members  

 c) access specifies    d) visibility labels 

88. Which member variable are initialized only once when the first object of its class is created? 

 a) private  b) inline  c) static  d) public 

 

89. Which of the following provides security to data? 

 a) data hiding    b) data abstraction  

 c)either a or b    d) overloading 

 

 

 

 

90. class student 

{ 

int x, y; 

} s1, s2;  

 From the above code s1, s2 are 
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a) object of class student   b) similar classes of student   

 c) super class of student   d) sub class of student 

91. void sum :: input( ); This statement tells__________ 

a) function sum is declared within the class input     

b) function input is declared within class sum    

c) function sum is sub function of input   

d) function input is sub function sum 

92. class A1 

{ 

int x, y; 

}; 

From the above code, x and y are____________ 

a) methods  b) attributes  c) properties  d) dimensions 

93. int ex :: output( )      which of the following is true with reference to the above line? 

a) the function ex returns integer type of data  

b) the class output returns integer type of data 

c) the function output returns ex type of data  

d) the function output returns integer data type   

94. class product 

{ 

int c, q; 

float p; 

}p1;  

The number of bytes occupied by p1 is________ 

a) 7   b) 8   c) 9   d) 10 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Read the following declarations and answer the questions from 104 to 106 

 class vehicle 

{ 

int wheels; 

public: 

void inputdata (int, int); 
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void output data( ); 

protected: 

int passenger; 

}; 

class heavy_vehicle: protected vehicle 

{ 

intdiesel_petrol; 

protected: 

int load; 

public: 

void readdata (int, int); 

void writedata( ); 

}; 

class bus: private heavy_vehicle 

{ 

char marks[20]; 

public: 

void fetchdata(char); 

void displaydata(); 

}; 

95. Which is the base class of the class heavy_vehicle 

a) heavy_vehicle b) bus   c) vehicle  d) both a and c 

96. The data member that can be accessed from the function display data( ) is_______  

a) passenger  b) load  c) marks  d) all of these  

97. The data member that can be accessed by an object of bus class is________  

a) inputdata  b) readdata  c) fetchdata  d) all of these 

outputdata  writedata  displaydata 

98. class product 

{ 

int a, b; 

float p; 

public: 

void display( ); 

}; 

void main( ) 

{ 

product P1, P2; 

} 

The number of memory bytes allotted for the variable P1 is________  

a) 12  b) 10    c) 8   d) 4 

 

Read the following program carefully and answer the question from 108 to 110 

#include<iostream.h> 

#include<conio.h> 

class item 

{ 

int code, quantity; 
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float price; 

void getdata( ) 

{ 

cout<<”\n Enter code, quantity and price”; 

cin>>code>>quantity>>price; 

} 

protected: 

void compute( ) 

{ 

if(quantity>100) 

tax = 2500; 

else 

tax = 1000; 

} 

public: 

float tax; 

void putdata( ) 

{ 

cout<<”\nCode:”<<code; 

cout<<”\nQuantity:”<<quantity; 

cout<<”\nTax:”<<tax; 

} 

}; 

void main( ) 

    { 

item i; 

          }   

99. Memory allocation for instance “i” is________  

a) 12 bytes  b) 10 bytes  c) 8 bytes  d) 16 bytes 

100. Public data member in the above class definition is______  

a) code   b) quantity  c) price  d) tax 

101. Method that can be accessed by object “i” is_______  

a) getdata( )  b) quantity  c) putdata( )  d) quantity( ) 

102. Which of the following is not true?  

 a) Member functions can be of static type   

b) The Return type of a member function cannot be of object data type   

c) A non – member function cannot access the private data  of a class   

d) Several different classes can use the same function name. 

 

 

 

VOLUME – II   7.POLYMORPHISM 

I. Choose the correct answer:         

1. The word polymorphism means_________ forms 

 a) many  b) one   c) two   d) four 

2. Polymorphism is achieved through_________ 

 a) overloading    b) overriding   
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c) operator overloading   c) function overloading 

3. Polymorphism is achieved through_________ 

  a) overriding     b) operator overloading 

 c) function overloading   d) both b and c 

4. Polymorphism is achieved through________ ways 

 a) one   b) two   c) three  d) four 

5. The term_________ means a name having two or more distinct meanings 

 a) operator  b) function  c) overriding  d) overloading 

6. The________ function refers to a function having more than one distinct meaning 

 a) overloaded  b) parameter  c) default  d) overriding 

7. __________one of the facets of C++ that supports object oriented programming 

 a) methods     b) operator overloading  

c) function overloading   d) both b and c 

8. The ability of the function to process the message or data in more than in one form is called 

as________ 

 a) methods     b) operator overloading  

c) function overloading   d) both b and c 

9. Each function prototype differs by their number of _________ 

 a) arguments  b) operators  c) functions  d) data type 

10.  ________for each prototype can be of different data type 

 a) arguments  b) operators  c) functions  d) data type 

11. The__________ adopts the best match strategy  

 a) user   b) compiler  c) function  d) operator 

12. Look for the exact match of a function prototype with that of a_________ statement 

 a) function call b) called  c) operator call d) compiler 

13. In case an exact match is not available _________ looks for the next nearest match  

 a) function call b) called  c) operator call d) compiler 

14. The_________ will promote integral data promotions and then match the call statement                               

with function prototype  

 a) compiler  b) function  c) operator  d) none 

15. Integral promotion are purely _________ oriented 

 a) function   b) operator  c) compiler  d) variable 

16. The double data type cannot be converted to__________ 

 a) float  b) integer  c) char   d) all 

17. ________data type can be converted to integer/ float/ double 

 a) char   b) int   c) float  d) double 

18. ________data type can be converted to char/ float/ double 

 a) char   b) int   c) float  d) double 

19. ________data type can be converted to integer/ char/ double 

 a) char   b) int   c) float  d) double 

 

20. ________data type can be converted to float/ integer 

 a) a) char  b) int   c) float  d) double 

21. double data type can be converted to________ 

 a) integer  b) char  c) float  d) integer or float 

22. Each overloaded function must differ either by the number of its_______ or their data types 

 a) actual parameter    b) formal parameters  
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c) reference parameters   d) array parameters 

23. The return type of the overloaded functions _________ be the same data type 

 a) may      b) may not   

c) may and may not    d) may or may not 

24. The_________ arguments of overloaded functions are not considered by the C++ compiler 

as part of the parameter list 

 a) parameterized b) copy  c) default  d) converted 

25. Do not use the_________ function name for two unrelated functions 

 a) different  b) same  c) more  d) none 

26. Improper declarations leading to ________ in a function call statement 

 a) conflict  b) explicit  c) implicit  d) either a or c 

27. Overloaded a function with the help of________ function definitions having a unique 

parameter list 

 a) different  b) same  c) more  d) none 

28. The parameter list differ either by_______ 

 a) number  b) types  c) number or types  d) constants 

29. The term_________ refers to giving additional functionality to the operator 

 a) overloading    b) function overloading 

 c) overriding     d) operator loading 

30. name = test + run;  when you compile the given statement, the compiler would throw an___ 

 a) test   b) run   c) test run  d) error 

31. Which of the following operator that cannot handle concatenation of strings 

 a) +   b) ++   c) --   d) none of these 

32. Which function is used to concatenate the strings 

 a) strlen( )  b) strcpy( )  c) strcat( )  d) strcmp( ) 

33. The functionality of ‘+’ operator can be extended to strings through ________ 

 a) overloading    b) operator overloading  

c) overriding     d) function loading 

34. The operator ‘+’ is given additional function through the ___________ 

 a) member function     b) object function  

c) formal function    d) inline function 

35. Which of the following operator that cannot be overloaded 

 a) .   b) ::   c) ?:   d) all 

36. Which of the following operator that can be overloaded 

 a) ::   b) size of  c) ?:   d) none 

37. Which of the following operator that can be overloaded 

 a) size of  b) +   c) +=   d) both b and c 

38. The overloaded function definitions are permitted for ________ data type 

 a) built-in  b) user defined c) derived  d) integer  

 

 

39. _______ must be either member functions or friend functions 

 a) inline functions    b) normal functions 

 c) operator functions   d) functions 

40. The________ that is provided to an operator does not overrule the original definition of the 

operator 

 a) new definition    b) old definition 

www.Padasalai.Net                                                                                                                    www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

         J.P.MURUGAN, M.Sc., B.Ed.,         Cell:9789633793,  9488832229 Page 102 

 

 c) single definition    d) all of these 

41. In operator overloading ‘+’ operator has been used to ________ two strings 

 a) split   b) add   c) merge  d) separate 

42. The compiler applies user defined definition based on the style of_________ 

 a) call statement     b) called statement  

c) input statement    d) declaration statement 

43. Create a________ that defines the data type that is to be used in the overloading operations 

 a) array  b) inheritance  c) class  d) objects 

44. Declare the operator function operator( ) in the_________ part of the class 

 a) private  b) public  c) protected  d) protect 

45. Define the ________ function to implement the required operations 

 a) operator  b) inline  c) formal  d) actual 

46. Negate the data members of a class using the operator________ 

 a) +   b) _   c) /   d) – 

47. The mechanism of giving special meaning to an operator is called as___________ 

 a) overloading    b) function overloading 

 c) overriding     d) operator loading 

48. Only _________ operators can be overloaded 

 a) derived  b) existing  c) new   d) user defined 

49. The________ operators cannot be created for operator overloading 

 a) derived  b) existing  c) new   d) old 

50. The basic definition of an ________ cannot be replaced 

 a) operator  b) variables  c) constants  d) identifier 

51. One_______ redefine the function of an operator 

 a) can    b) cannot  c) simply  d) needed 

52. One can give additional functions to an__________ 

 a) variables  b) constants  b) operator  d) data types 

53. Overloaded operators behave in the same way as the basic operators in terms of their _____ 

 a) operators  b) operands  c) data types  d) operation 

54. When ________operators are overloaded, the left hand object must be an object of the 

relevant class 

 a) unary  b) ternary  c) binary  d) conditional 

55. Binary operators overloaded through a member function take ________ explicit arguments 

 a) two   b) one   c) three  d) four 

56. There are certain restrictions and limitations in overloading ________  

a) variables  b) constants  c) operator  d) data types 

57. The membership operator is_______ 

 a) ::   b) ?:   c).   d) ; 

 

 

 

58. Which function simply negates the data member of the class 

 a) class operator-()    b) class operator--()  

c) void operator-()    d) void operator--() 

59. Identify the correct statement with respect to operator overloading 

 a) new operator can be created    

b) we can redefine the function of an operator  

www.Padasalai.Net                                                                                                                    www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

         J.P.MURUGAN, M.Sc., B.Ed.,         Cell:9789633793,  9488832229 Page 103 

 

c) one can give additional functions to an operator 

d) existing operators cannot be overloaded  

60. While operator overloading, the operator functions must be ______  

a) member functions   b) inline functions  

c) either a or d    d) friend functions 

61. The overloaded operator must have at least ____ operand of user defined type. 

a) 1   b) 2   c) 4   d) 6 

62. When binary operators are overloaded, the left hand object must be an ________ of the 

relevant class. 

 a) class  b) derived class c) abstract class d) object 

63. Which of the following is not true related to function overloading?   

 a) Each overloaded function must differ by the number of its formal parameter   

b) The return type of overloaded functions may be the same data type    

c) The default arguments are considered by the C++ computer as part of the parameter list

 d) Do not use the same function name for two unrelated functions 

64. Which of the following statement is false in case of operator overloading?  

 a) Only existing operators can be overloaded   

b) The basic definition of an operator can be replaced  

c) the overloaded operator must have at least one operand of user defined type   

d) Binary operators overloaded through member function take one explicit argument 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Read the following C++ program carefully and answer the questions from 72 to 74. 

 #include<iostream.h> 

class negative 

{ 

int i; 
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public: 

void accept( ) 

{ 

cin>>i; 

} 

void display( ) 

{ 

cout<<i; 

} 

void operator-( ) 

{ 

i = -i; 

} 

}; 

void main( ) 

{ 

negative n2; 

n2.accept( ); 

-n2; 

n2.display( ); 

} 

65. Identify the operator that is overloaded 

a) =  b) –(Unary)  c) –(Binary)  d) negative   

66. The prototype of the overloaded member function is________  

a) negative operator-( )   b) void operator minus       

c) void operator-( )      d) void operator-(negative) 

67. Which of the following statements invokes the overloaded member function 

a) negative n1( )    b) - - n2( )  

c) n2+;     d) –n2; 

 

 

 

 

 

VOLUME – II   8.CONSTRUCTORS AND DESTRUCTORS 

I. Choose the correct answer:         

1. When an instance of a class comes into a scope, a special function called the _______ gets 

executed 

 a) constructor  b) object  c) destructor  d) variable  

2. The constructor function initializes the_________ 
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 a) variables  b) constants  c) class objects d) data types 

3. When a class goes out of scope, a special function called the_________ gets executed 

 a) constructor  b) object  c) destructor  d) variable  

4. The constructor and destructor function name have the same name as the_________ 

 a) variable  b) operator  c) identifier  d) class tag  

5. The__________ functions return nothing 

 a) constructor  b) object  c) destructor  d) both a and c 

6. Constructors and destructors are not associated with any _________ 

 a) data type  b) variable  c) operator   d) identifier 

7. constructor is automatically executed when the _________ is created 

 a) variable  b) object  c) destructor  d) constants 

8. ________is automatically executed, when the scope of the object is lost 

 a) constructor  b) object  c) destructor  d) both a and c 

9. ________is automatically executed, when at the time of program termination 

 a) constructor  b) destructor  c) object  d) either a or b 

10. ________function is used to allocate the memory to an object 

 a) constructor  b) friend  c) inline  d) destructor 

11. ________ can be applied for constructors, as constructors are special functions of classes 

 a) inheritance     b) function overloading  

c) operator overloading   d) polymorphism 

12. The constructor is without parameters is called as________ constructor 

 a) default   b) object  c) parameterized  d) copy 

13. The default constructor is also called as________ 

 a) object  b) parameterized  c) copy   d) non-parameterized 

14. Default constructors are referred to_________ constructors 

 a) copy     b) parameterized  

c) compiler generated   d) user defined 

15. Constructors defined by the computers in the absence of________ constructor 

 a) copy     b) parameterized  

c) compiler generated   d) user defined 

16. The________ constructors is automatically generated by compiler, when the absence of the 

user defined constructor 

 a) compiler generated   b) default   

c) non-parameterized   d) all of these 

17. A________ constructor is executed when an object without parameter is declared 

a) object  b) parameterized  c) copy   d) non-parameterized 

18. The constructor add(int s1, int s2) is called as____________ constructor 

a) object  b) parameterized  c) copy   d) non-parameterized 

19. The constructor add(add &a) is called as_________ constructor 

a) object  b) parameterized  c) copy   d) non-parameterized 

 

20. add(int s1, int s2)  to invoke the given constructor, the object should be declared 

with_________ integer constants or variables 

 a) one   b) two   c) three  d) many 

21. char, float, double parameters can be matched with int data type due to_________ type 

conversions 

 a) implicit  b) explicit   c) conflict   d) all 
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22. When an object is passed as a ___________ to any of the member functions 

 a) parameter  b) data type  c) variables  d) constants 

23. When a member function returns an__________  

a) object  b) parameterized  c) copy   d) non-parameterized 

24. When an object is passed by _________ to constructor 

 a) actual  b) copy  c) reference  d) default 

25. Primarily________ are declared anywhere within the program, it can be overloaded 

 a) operators  b) functions  c) constants  d) variables 

26. A________ function can have parameter list  

 a) constructor  b) object  c) destructor  d) both a and c 

27. The________ function can be overloaded 

 a) constructor  b) object  c) destructor  d) both a and c 

28.  The________ function cannot be overloaded 

 a) constructor  b) object  c) destructor  d) both a and c 

29. The________ function cannot have any parameter list 

 a) constructor  b) object  c) destructor  d) both a and c 

30. A_________ is a function that removes the memory of an object 

 a) destructor   b) constructor c) copy  d) object 

31. The destructor has the same name as that of the class prefixed with the________ character 

 a) size of  b) tilde  c) number  d) char 

32. There can be only________ destructor in a class 

 a) one   b) two   c) three  d) four 

33. In the absence of the user defined constructor, the________ generates a constructor 

 a) linker  b) machine code c) compiler  d) source code 

34. In the absence of the user defined destructor, the________ generates a destructor 

 a) linker  b) machine code c) compiler  d) source code 

35. The destructor is automatically executed when the control reaches the end of _______scope 

 a) file   b) class  c) local  d) function  

36. How many forms the constructors can be used in the program 

 a) 2   b) 1   c) 5   d) 3 

37. How many forms the destructors can be used in the program 

 a) 2   b) 1   c) 5   d) 3 

38. Which one of the following is automatically executed when an object is created? 

 a) constructor b) destructor  c) friend  d) inline 

39. Constructor and destructor are associated with 

 a) Boolean type b) character type c) integer type d) no data type 

40. Which of the following constructor is executed when an object is passed as a parameter to 

any of the member function 

 a) copy constructor    b) parameterized constructor  

 c) non parameterized constructor   d) derived constructor 

 

41. In the absence of the user defined .. it is generated by the compiler 

 a) constructor b) destructor  c) a & b  d) none of these 

Read the following C++ snippet carefully and answer the question 42 and 43 

 class simple 

{ 

private: 
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int x; 

public: 

simple(int y) 

    { 

 x = y; 

    } 

~simple( ) 

     { 

     } 

};  

42. What is the name of the constructor  

a) simple  b) ~simple  c) private  d) public 

43. What type of constructor is used in this snippet 

a) non-parameterized   b) copy  

c) parameterized    d) default 

Read the following snippet and answer the questions from 44 and 45 

class simple 

{ 

private: 

int x; 

public: 

simple(int y) 

{ 

x = y; 

} 

}; 

void main( ) 

{ 

simple s(6); 

} 

44. How many objects are created  

a) 0   b) 7   c) 1   d) 6 

45. What type of constructor is used in the snippet 

a) non-parameterized   b) copy  

c) parameterized    d) default 

46. Which of the following prototype can be a copy constructors of class my class 

a) myclass(intmyclass)   b)int copy(myclass me);  

c) myclass copy(myclass-a);  d) myclass(myclass& x); 

 

 

 

VOLUME – II   9.INHERITANCE 

I. Choose the correct answer:         

1. ________is the most powerful feature of an object oriented programming language 

 a) polymorphism b) inheritance  c) class  d) objects 

2. Inheritance is a process of creating new classes called _____, from the existing or base classes 
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 a) existing class b) base class  c) multi class  d) derived class 

3. The__________ inherits all the properties of the base class 

 a) derived class b) super class  c) existing class d) base class 

4. _________is a power packed class 

 a) base class  b) super class  c) derived class d) power class 

5. Derived class can add additional_________ and thus enhance its functionality 

 a) methods  b) attributes  c) variables  c) methods and attributes 

6. We are familiar with the term _________ in real life 

 a) constructors b) destructors  c) inheritance  d) none 

7. A class inherits properties from its _________ 

 a) derived class b) base class  c) super class  d) multi class 

8. Which of the following are the advantages of inheritance 

 a) code sharing    b) reusability of code  

c) consistency of inheritance  d) all of these 

9. ________developed for one application can be reused in another application if such 

functionality is required 

 a) variables  b) constants  c) code  d) operators 

10. ________saves a lot of development time  

 a) code sharing    b) reusability of code 

 c) consistency of inheritance  d) all of these 

11. ________ methods of the base class can be shared by the derived class 

 a) code sharing    b) reusability of code 

 c) consistency of inheritance  d) all of these 

12. The inherited attributes and methods provide a similar interface to the_________ 

 a) functions  b) arguments  c) calling methods d) inheritance 

13. A__________ is a class from which other classes are derived 

 a) derived class b) base class  c) super class  d) multi class 

14. A_________ can inherit members of a base class 

 a) derived class b) base class  c) super class  d) multi class 

15. A_________ is placed between the derived class and the base class  

 a) semi colon  b) single colon c) double colon d) scope resolution operator 

16. The name of the derived class  is to be given after the keyword________ 

 a) protected   b) add   c) public  d) class 

17. ______define how the members of base class can be used by the object of the derived class 

 a) inheritance  b) object  c) accessibility d) none 

18. Access specifier is also referred to as________ 

 a) specification b) inheritance  c) class  d) visibility mode 

19. The default visibility mode is_________ 

 a) friend  b) private  c) public  d) protected 

20. Constructors executed first when an instance of the _______ class is created 

 a) derived  b) super  c) base  d) object 

 

21. There are_______ types of inheritance in C++ 

 a) 3   b) 5   c) 6   d) different 

22. When a base class inherited with private visibility mode the_________ members of the base 

class become ‘private’ members of the derived class 

 a) public  b) private  c) protected  d) public and protected 

www.Padasalai.Net                                                                                                                    www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

         J.P.MURUGAN, M.Sc., B.Ed.,         Cell:9789633793,  9488832229 Page 109 

 

23. When a base class inherited with private visibility mode the_________ members of the 

derived class are not inherited but they continue to exist 

 a) public  b) private  c) protected  d) public and protected 

24. When a base class inherited with protected visibility mode the_________ members of the 

base class become ‘protected’ members of the derived class 

 a) public  b) private  c) protected  d) public and protected 

25. When a base class inherited with public visibility mode the protected members of the base 

class will be inherited as __________ members of the derived class 

 a) public  b) private  c) protected  d) public and protected 

26. When a base class inherited with public visibility mode the public members of the base 

class will be inherited as __________ members of the derived class 

 a) public  b) private  c) protected  d) public and protected 

27. When classes are inherited publicly, protectedly or privately the_________ members of the 

base class are not inherited they are only visible 

 a) private  b) protected  c) public  d) friend 

28. The ________ of the base class are not inherited  

 a) destructors  b) arguments  c) constructors d) parameters  

29. ________ can be derived from classes that are themselves derived 

 a) objects  b) classes  c) variables  d) parameters 

30. Single, multiple, multilevel, hybrid and hierarchical are the types of________ 

 a) polymorphism     b) inheritance   

c) class     d) constructors 

31. When a derived class inherits only from one base class, it is known as________ inheritance 

 a) multilevel  b) single  c) multiple  d) hybrid 

32. When a derived class inherits from multiple base class, it is known as________ inheritance 

 a) multilevel  b) single  c) multiple  d) hybrid 

33. The transitive nature of inheritance is reflected by_________ form of inheritance 

 a) multilevel  b) single  c) multiple  d) hybrid 

34. When a class is derived from a class which is a derived class itself – then this is referred to 

as ________inheritance 

a) single   b) multiple   c) multilevel  d) hybrid 

35. The_________ inheritance is the example of parent – child relationship 

 a) multilevel  b) single  c) multiple  d) hybrid 

36. The constructors are executed in the order of________ 

 a) reverse  b) back to first  c) inherited class d) none 

37. The destructors are executed in the_______ order 

 a) beginning to end    b) first    

 c) reverse     d) inherited class 

38. Classes used only for deriving other classes are called as_______ 

 a) derived class    b) super class   

c) abstract class    d) multi class 

 

39. A class which has no object are called_________ 

 a) abstract class b) derived class c) order class  d) super class 

40. The newly created class from the existing class is known as _________ 

 a) base   b) derived  c) inheritance  d) super class  

41. The class which extend its properties to the derived class is called_______ 
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 a) base  b) derived  c) abstract  d) all the above 

42. Derived class can access________ 

 a) its own properties    b) base class properties  

c) both a and b    d) none 

43. Common items for the more than one class can be initializes in________ 

 a) base  b) derived  c) abstract  d) all 

44. Private base class member function derived as protected will access the member function as___ 

 a) private   b) protected  c) public  d) none 

45. protected base class member function derived as private will access the member function as 

 a) private   b) protected  c) public  d) none 

46. protected base class member function derived as protected will access the member function as 

 a) private   b) protected  c) public  d) none 

47. protected base class member function derived as public will access the member function as___ 

 a) private   b) protected  c) public  d) none 

48. Public base class member function derived as private will access the member function as_____ 

 a) private   b) protected  c) public  d) none 

49. Public base class member function derived as protected will access the member function as 

 a) private   b) protected  c) public  d) none 

50. Public base class member function derived as public will access the member function as_____ 

 a) private   b) protected  c) public  d) none 

51. The order of execution of the destructor is_________ 

 a) base to derived    b) derived to base 

 c) random     d) none of these 

52. The order of execution of the constructor is_________ 

 a) base to derived    b) derived to base  

 c) random     d) none of these 

53. Which of the following is process of creating new classes called derived classes from 

existing or base class 

 a) encapsulation    b) polymorphism  

 c) inheritance     d) none of these 

54. The class from which derived class is created is called________ 

 a) base class     b) power class  

 c) superior class    d) family class 

55. Which of the following derives a new class “sub-class’ from the base “main-class” 

 a) class main_class: public sub_class   

b) class main_class: public main_class   

c) class main_class: class sub_class   

d) class sub_class: public main_class 

56. Which are not inherited but are executed first when an instance of the derived class is 

created? 

a) Inherited     b) Destructor   

c) Encapsulated    d) Constructor 

 

57. The ______ of the base class can be shared by the derived class. 

a) Methods     b) Private data  

c) Protected data    d) None of these 

58. An important feature in inheritance is to know as to when a member of a base class can be 

used by the objects or the members of the derived class is called as  
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 a) Constructor    b) Base Class   

 c) Derived Class    d) Accessibility 

59. A process of creating new class from the existing base class is called as  

 a) inheritance b) object  c) constructor  d) destructor 

60. Inheritance has __________ basic advantages 

 a) 1   b) 2   c) 3   d) 4 

61. Code developed for one application can be reused in another application is 

 a) Reusability of code   b) code sharing 

 c) consistency of interface   d) all of these 

62. ______ are executed first when an instance of the derived class is created 

 a) base class constructor   b) derived class constructor 

 c) base class destructor   d) derived class destructor 

63. Objects for ________ classes are not declared 

 a) sub class  b) base class  c) abstract class d) derived class 

64. ____ inheritance referred when a class is derived from a class which is a derived class itself 

 a) multiple  b) hybrid  c) single  d) none of these 

65. The inherited attributes and methods provide a similar interface to the calling methods is 

 a) reusability of code   b) code sharing  

 c) consistency of interface   d) all of these 

66. The derived class should be indicated as 

 a) class visibility mode der_name::base class-id   

 b)calssder_name:visibility mode base calss-id 

 c) class visibility mode der_name : base class-id  

 d) class visibility mode base class-id:der_name 

67. Which of the following derives a class subtract from the base add 

 a) add : subtract   b) class subtract : public add      

c) class add : public subtract d) none of these 

68. Which members of a class can be accessed by the members of inherited class? 

 a) Public  b) Protected  c) private   d) static 

69. What is wrong with the following statement that derives a B-class from A-class?_______             

class B_class; public A_class 

a) semicolon must be replaced by colon  

b) semicolon must appear at the end of the statement 

c) the word public must be replaced by private  

d) the word public must be replaced by protected 

 

 

 

 

 

 

 

VOLUME – II   10.IMPACT OF COMPUTERS ON SOCIETY 

I. Choose the correct answer:         

1. Who says “India lives in her seven hundred thousand villages”. 

 a) dennisritchie    b) Mohandas Karamchand Gandhi  

c) Bjarnestroustrup    d) Norbert weiner 
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2. To reach out the benefits IT to the common man we need at least ______ technical elements 

 a) 2   b) 5   c) 3   d) 6 

3. Which one of the following is not a IT technical element 

 a) Hardware     b) connectivity  

c) affordable computers or other similar devices    

d) software 

4. ________% of computer usage is “word processing” 

 a) 78   b) 75   c) 80   d) 85 

5. Which of following packages have increased the efficiency at work 

 a) word processing    b) data base and spread sheet   

c) multimedia presentation   d) all of these 

6. ________ and other impressive packages for graphics are adding value to the work done 

 a) desktop publishing   b) monitoring   

c) graphics     d) computerization  

7. Which of the following have changed our life style 

 a) browsing  b) e-mail  c) chat   d) all of these 

8. _______is mounted on the wall to provide better effect and save floor space 

 a) television     b) washing machine   

c) LCD screen     d) printer 

9. Which enables data storage and management  

 a) archive unit     b) personal archives   

 c) emotion containers    d) book shelf 

10. ________ are small compartments with a screen, speaker and a scent to derive emotional 

comfort 

 a) archive unit     b) personal archives   

 c) book shelf      d) emotion containers  

11. ________can prevent people from acquiring bad habits 

 a) personal archives     b) emotion containers   

c) book shelf     d) projection TV 

12. _______store personal details like family photographs and personal treasures 

 a) emotion containers    b) personal archives    

c) book shelf     d) projection TV 

13. _______enables connectivity to other people  

 a) personal archives     b) emotion containers   

c) book shelf     d) projection TV 

14. Which of the following enables picture based personal telephone directory 

 a) memo frame    b) picture phone and pad  

c) archive unit    d) personal creativity tool 

15. The device________feature allows to sing along with audio coming from the original source 

 a) projection TV    b) memo frame 

 c) kara-oke     d) interactive table cloth 

 

16. _______can function as electronic pets 

 a) Robots     b) memo pads  

 c) archeive units    d) ceramic audio 

17. Kara-oke, electronic pets, games over the net are all part of which of the following rooms in 

a computerized room_________ 
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 a) living room    b) dining room  

 c) bed room     d) kids room 

18. ________means easy interaction with other people through touch screen, scanner and 

microphone facilities 

 a) bookshelf     b) memo frame  

c) archive unit    d) kara-oke 

19. Which of the following to manage and study electronic books 

 a) bookshelf     b) memo frame 

 c) archive unit    d) kara-oke 

20. _______is used to draw, capture and work with multimedia elements advanced data 

accessing systems 

 a) memo frame    b) personal creativity tool   

c) archive unit    d) picture phone and pad 

21. _______is projects the TV pictures on the ceiling or walls 

 a) memo frame     b) projection TV  

 c) kara-oke     d) interactive table cloth 

22. ________keeps the food sufficiently warm 

 a) book shelf     b) memo frame 

 c) picture pad     d) interactive table cloth  

23. _______is used to consult with the cook and other kitchen staffs  

 a) memo pad     b) interactive screens 

 c) kara-oke     d) display monitors 

24. _______became a key component in the national economy 

 a) bank     b) internet   

c) security     d) ATM 

25. _______enable withdrawal of money from the accounts in a particular bank at anytime and 

any where. 

 a) internet  b) bank  c) ATM  d) cheque 

26. ________helps user in emergency situations where money is needed during the nights and 

holidays 

 a) credit cards    b) pass book   

c) debit cards     d) ATM 

27. ________permits banking from the comfort of the home by using internet facilities  

 a) ATM     b) e-banking  

 c) e-shopping     d) banks 

28. ________are used in many areas even for shopping  

 a) computer     b) money   

c) e-banking     d) e-shopping  

29. You can purchase any product, any brand, any quantity from anywhere through_______ 

 a) ATM     b) e-banking   

c) e-shopping     d) banks 

 

30. _______and prior registration with the shop are the popular method for shopping 

 a) debit cards     b) pass book  

 c) credit cards    d) ATM 

31. CBT stands for________ 

 a) computer based tutorials   b) computer based training   
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c) common business training  d) compiler basic tutorials 

32. _______that enables online educational programs leading to degrees and certifications 

 a) e-banking     b) e-learning   

c) e-shopping     d) banks 

33. ________is dominated by large amounts of data and limited financial resources 

 a) e-medicine     b) tele-medicine  

c) healthcare     d) medical transcription  

34. ________has improved significantly ever since computers found their way into the hands of 

doctors and health administrators 

 a) e-medicine     b) tele-medicine  

c) medical transcription    d) healthcare  

35. ________is built largely on the foundational systems  

 a) tele-medicine     b) e-medicine   

c) health ministers     d) medical transcription  

36. ________facilitates remote diagnostics  

 a) network     b) internet   

c) computer     d) e-mail 

37. ________ensures expert advice at places where it is not there 

 a) internet      b) network  

 c) computer     d) e-mail 

38. You can reserve or book air and train tickets from your own place through________ 

 a) bank     b) network   

c) e-learning     d) computers 

39. ATM is an example for 

a) e-shopping     b) e-banking  

c) Transcription    d) Digitization 

40. ________ is dominated by large amounts of data and limited financial and human resources 

and need for accountability of those resources. 

 a) Healthcare    b) e-medicine   

 c) Tele-medicine    d) e-hospitals 

41. Which of the following have changed our life style? 

 a) IT      b) Browsing, Email and Chat  

 c) Word Processing    d) Database 

42. __________ permits banking from home 

 a) transcription b) e-banking  c) e-commerce d) e-learning 

43. ______ is used to draw, capture and work with multimedia elements. 

 a) Achieve unit    b) personal achieve  

c) personal creativity tool   d) memo frame 

 

 

 

 

VOLUME – II   11.IT ENABLED SERVICES 

I. Choose the correct answer:         

1. ITES stands for ___________ 

 a) improving technology enlighted services  

b) information technology enabled services 
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 c) information technology extended services   

d) information technology enabled systems 

2. _______that helps in improving the quality of service to the users   

 a) information technology   b) instrument technology   

c) investment technical   d) initial technology 

3. IT Enabled Services are human intensive services that are delivered over telecommunication 

networks or the __________ to a range of business segments  

 a) computer     b) wireless  

 c) information technology   d) internet 

4. ________greatly increases the employment opportunities  

 a) call centers    b) ITES  

 c) e-governance     d) data digitization 

5. A facility that allows the user to speak into a special device while typing a letter using 

computer is called_________ 

 a) cell phone  b) telephone   c) dicta phone d) speaker 

6. Which of the following have ensured that many traditional services are IT Enabled 

 a) word processors b) spreadsheets c) data base  d) all 

7. _____adds value to these services by reducing the learning that needs to be done by the users 

 a) e-commerce    b) ITES   

c) tele-medicine     d) data management 

8. _______has the potential the potential to take the power of IT to users who do not know IT 

 a) ITES     b) e-governance  

c) medical transcription   d) word processors 

9. ITES can improve the quality of the service_______ 

 a) directly     b) either directly or indirectly  

c) both directly and indirectly  d) indirectly 

10. Which of the following are the direct benefits 

 a) improved customer satisfaction  b) better look and feel  

c) improved data base   d) all of these 

11. Which of the following is an IT Enabled Services 

 a) e-governance    b) call centers 

 c) data management    d) all of these 

12. BPO stands for_______ 

 a) business profit outsourcing  b) business process outstanding  

c) business process outsourcing  d) benefits of permanent occupation 

13. ITES requires practical IT skills especially in the area of _________ 

 a) databases      b) good communication skill in English  

c) internet      d) all of these 

14. _________are needed for the effective implementation of ITES 

 a) industry culture    b) professionalism   

c) etiquette     d) all of these 

 

15. ________help you to look at the government websites and the services provided by them 

 a) LCD screen    b) computer   

c) speakers     d) medical transcription 

16. A________ is sometimes defined as a telephone based shared service center for specific 

customer activities 
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 a) call center  b) e-governance  c) banking  d) data management 

17. _______is used for number of customer related functions 

a) call center  b) e-governance  c) banking  d) data management 

18. A_______ has adequate telecom facilities, trained consultants, access to wide data base, 

internet and other on-line information support to provide information  

a) call center  b) e-governance  c) banking  d) data management 

19. _________is a category of IT Enabled services pertaining to collection, digitization and 

processing of data coming from various sources  

a) call center  b) e-governance  c) banking  d) data management 

20. ________services comprise punching data from manually filled forms, images or 

publications; preparing data bases and putting them together 

 a) data management    b) IT services   

c) call center     d) traditional data processing 

21. _________is the key for effective and profitable use of IT in organizations 

 a) e-governance b) call centers           c) data management  d) all of these 

22. Which of the following organization can potentially benefit from ITES 

 a) banking  b) insurance  c) legal  d) all of these 

23. Banking, Financial Services and Insurance sectors are popularly termed _______ 

 a) ITES  b) BPO  c) BFSI  d) Tele-communication 

24. ________ are high growth areas for ITES 

 a) BFSI     b) pension services  

c) data digitization    d) BFSI and pension services 

25. BFSI stands for_______ 

 a) Banking Financial Service and Insurance   

b) Business Financial Service and Insurance    

c) Banking Financial System and Invoice   

d) Business Favorite Service and Insurance 

26. There are ________ important aspects that must be ensured by the ITES provider in this area 

 a) 5   b) 8   c) 6   d) 2 

27. ________ and _________ are the important aspects that must be ensured by the ITES 

provider in this area 

 a) data security, customer privacy  b) data member, cracking   

c) piracy, security    d) none 

28. The________ must be ensure the privacy aspects of every organization 

 a) data security b) compiler c) service provider d) computer crime 

29. _________is critical for the success of ITES 

 a) computer crime b) illegal access c) virus  d) computer ethics 

30. ________is a permanent, legal document that formally states the result of a medical 

investigation  

 a) theft of computer time   b) cracking  

c) medical transcription   d) security 

 

31. ________facilitates communication and supports the insurance claims 

 a) medical transcription   b) cracking  

c) theft of computer time   d) security 

32. How many steps involved in medical transcription 

 a) 5   b) 3   c) 6   d) 2 
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33. In which step, the hospitals that want to use this form of ITES sign up with a service 

provider 

 a) step5  b) step2  c) step3  d) step1 

34. In medical transcription the ________is digitized and sent to the ITES provider 

 a) sound  b) data   c) movies   d) medical allowance 

35. In which step, the digitized data is converted back to sound  

 a) step5  b) step2  c) step3  d) step1 

36. ________refers to the conversion of non-digital material to digital form  

 a) call centers b) ITES  c) e-governance  d) digitization 

37. Which of the following wide variety of materials can be digitized 

 a) maps     b) manuscripts  

c) moving images and sound  d) all of these 

38. ________offers great advantages for access, allowing users to find, retrieve, study and 

modify the material 

 a) call centers b) digitization c) e-governance  d) ITES  

39. Which helps in improving the quality of services 

a) IT   b) BPO  c) ITES  d) BFSI 

40. Which of the following is not an ITES of data management category? 

a) Data entry     b) Character Recognition and processing 

c) Dictaphone    d)  Image keying 

41. Organizations that is not potentially benefit from ITES is 

a) hospital  b) Schools  c) Banking  d) Government agencies 

42. Which of the following service works on all days of the year all round the clock ie.. 

(24x365)?  

 a) call centre  b) e-governance c) hospital  d) municipalities 

43. Introduction of IT in banks reduced the 

a) Queue  b) Time  c) Money  d) Both (a) and (b) 

44. Which of the following organizations that potentially benefit from ITES in data management 

 a) hospital  b) insurance  c) municipalities d) all of these 

45. Which of the following will enables the common man to put computers to  a better use? 

 a) entertainment    b) quality application 

 c) quality hardware    d) quality IT education 

46. Which of the following is not an IT enabled services 

 a) call center  b) e-governance c) programs  d) web based services 

 

 

 

 

 

 

 

 

VOLUME – II   12.COMPUTER ETHICS 

I. Choose the correct answer:         

1. Computer ethics has its roots in the work of ________ during world war II  

 a) Bjarne Stroustrup    b) Dennis Ritche   

c) Norbert Wiener    d) Donn Parker 
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2. There are __________ general guidelines on computer ethics are needed 

 a) 2      b) 5   

 c) 4      d) 3 

3. The security are classified into __________ types 

 a) 3      b) 6   

 c) 2      d) 5 

4. ________security refers to the protection of hardware, facilities, magnetic disks, and other 

items that could be illegally accessed, stolen, damaged or destroyed 

 a) personal     b) physical   

c) personnel     d) memory 

5. The_________ security is usually provided by restricting the people who can access the 

resources  

 a) personal     b) physical  

 c) personnel     d) memory 

6. ________security refers to software setups that permit only authorized access to the system 

 a) personal     b) physical  

 c) personnel     d) memory 

7. ________ and _________ are the common tools for personal security 

 a) User Ids, Data    b) security, password  

c) User Ids, Password   d) Email Id, photograph 

8. ________ security refers to protecting data and computer system against dishonesty or 

negligence of employees 

 a) personal     b) physical  

 c) personnel     d) memory 

9. Which of the following are general guidelines on computer ethics 

 a) protection of personal data  b) computer crime  

c) cracking     d) all of these 

10. A_________ is any illegal activity using computer software, data or access as the object, 

subject or instrument of the crime 

 a) computer crime    b) theft of computer time  

c) cracking     d) virus 

11. Which of the following are common computer crime 

 a) theft of computer time   b) cracking  

 c) virus      d) all of these 

12. _________ of all computer crimes happen from within the company 

 a) 60%     b) 55% 

 c) 85%     d) 80% 

13. ________ of all crimes go unreported 

 a) 60%     b) 55% 

 c) 85%     d) 80% 

 

 

14. Making and using duplicate hardware and software is called_______ 

 a) theft of computer time   b) cracking  

 c) virus      d) piracy 

15. A_______ is a self-replicating program that can cause damage to data and files stored on 

your computer 
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 a) theft of computer time   b) cracking   

c) virus      d) piracy 

16. How many known virus programs are in existence 

 a) 6      b) 54000  

 c) 57000     d) 1024 

17. How many new viruses are found each day 

 a) 6      b) 54000  

 c) 57000     d) 1024 

18. Some other software runs on an idle computer without the knowledge of the organization is 

called____________ 

 a) theft of computer time   b) cracking  

 c) virus      d) piracy 

19. A commonly cited reference is the _______ commandments of computer ethics written by 

the computer ethics institute  

 a) five      b) eight 

 c) six      d) ten 

20. ________require special laws to be formed by the government  

 a) computer crime    b) theft of computer time 

 c) cracking     d) virus 

21. India has ________ laws to prevent computer crimes 

 a) civil     b) criminal  

 c) cyber     d) general 

22. _________ is the illegal access to the network or computer system  

 a) computer crime    b) theft of computer time 

 c) cracking     d) virus 

23. Illegal use of special resources in the system is the key reason for ________ 

 a) computer crime    b) theft of computer time  

 c) cracking     d) virus 

24. _______are other common reasons for committing this crime 

 a) revenge     b) business reasons  

 c) thrill     d) all of these 

25. During ________s many universities introduced formal course in computer ethics 

 a) 1990     b) 1975  

 c) 1995     d) 1980 

26. Who among the following began to examine unethical and illegal uses of computers by 

computer professionals in mid 1960s in Menlo Park, California? ___________  

 a) Donn Parker    b) Norbert Weiner   

 c) Bill Gates     d) Charles Babbage 

27. Which of the following does not refers to authorized access to the computer system  

a) personal     b) physical  

c) personnel     d) piracy 

 

28. By the_________ number of social and ethical consequences of information technology 

were becoming public issues in America and Europe  

a) 1990     b) 1975  

c) 1995     d) 1980 

29. ________is a set of rules for determining moral standards or socially acceptable behaviour 
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 a) standard     b) ethics  

 c) protocols     d) none of these 

30. “Cracking” comes under_________ 

 a) data security    b) computer crime  

c) website service    d) transcription 

31. The set of rules for determining moral standard is 

 a) Piracy     b) Privacy   

 c) Ethics     d) Protocols 

32. Revenge, business reasons and thrill are other common reasons for committing ____ crime 

 a) Virus     b) Cracking   

 c) Piracy     d) Theft of computer time 

33. In the mid ____, Donn parker of SRI International in Menlo park, California began to 

examine unethical and illegal uses of computers by computer professional 

 a) 1990’s     b) 1960’s  

 c) 1978’s     d) 1982’s 

34. General guidelines needed for computer ethics 

 a) Data security and customer piracy  

 b) Protection of data, computer crime and cracking 

 c) computer piracy and virus   

 d) data security and cracking 

35. Which of the following is called as piracy? 

 a) creating virus    b) making long distance call  

 c) making duplicated hardware  d) all of these 

36. _______ is a tools for keeping personal security. 

 a) user ID     b) password  

 c) both a and b    d) none of these 

37. ___ require special laws to be formed by the government 

 a) computer crimes    b) computer ethics  

 c) computer piracy    d) computer software 

38. A_______ is any illegal activity using computer software 

 a) virus     b) computer crime  

 c) crime     d) none of these 

39. The resources may be 

a Software     b) Files   

c) Hardware     d) All the above 

 

 

 

  

 

 

 

COMMANDS WITH USES 

S.NO COMMAND USES 
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1.  Start  → All Programs → Star Office 8 To Open A Star Office 

2.  File → New → Text Document To Open A New Text Document 

3.  File → Save To Save A Document 

4.  File → Close To Close A Document 

5.  File → Open  To Open A Document 

6.  Edit → Cut To Cut A Selected Text 

7.  Edit → Copy To Copy A Selected Text 

8.  Edit → Paste To Paste A Selected Text 

9.  Edit → Find & Replace To Find A Replace Text 

10.  Format → Character To Open A Character Dialogue Box 

11.  Format → Paragraph To Open A Paragraph Dialogue Box 

12.  Format →Bullets And Numberings 
To Apply Bullets And Numberings In A 
Text 

13.  Help →Star Office Help To Open A Help Window 

14.  Tools → Spelling Check To Open A Spell Check Dialogue Box 

15.  Tools → Auto Correct To Open A Auto Correct Dialogue Box 

16.  Table → Insert → Table To Insert A new Table 

17.  View→ Tools Bars→ Insert To Insert Floating Tool Bar 

18.  Table → Insert → Row To Insert Row  In A table 

19.  Table → Insert→ Column To Insert Column In Table 

20.  Table → Delete → Rows To Delete Row In Table 

 

 

S.NO COMMAND USES 

21.  Table→ Delete → Columns To Delete A Column In Table 
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22.  Edit → Select All To Select A Entire Table 

23.  Table → Delete →Table To Delete All The Selected Table 

24.  Table → Table Properties To Open A Table Format Dialogue Box 

25.  
Right Click(Inside The Table)      
Column →Space Equally 

To Make All Columns Even 

26.  
Right Click(Inside The Table)       
Row→ Space Equally 

To Make All Row Even 

27.  Format → Page To Open Page Style Dialogue Box 

28.  File → Page Preview To Show A Preview 

29.  View → Ruler To Display The Ruler 

30.  Insert → Fields 
To Insert Fields On Header And Footer 
Area 

31.  Insert → Fields→ Page Number To Insert A Page Number 

32.  
Start → All Programs→ Star Office8 →                            
Star Office Impress 

To Launch A Star Office Impress 

33.  File→ New → Spreadsheet 
Spreadsheet Open From Other Star 
Office Application 

34.  File → Exit To Quit From Star Office  

35.  File → Close To Quit From Spreadsheet Worksheet  

36.  Edit →Fill Down/Left/Up/Right To Generate A Fill Command  

37.  Edit → Fill Series To Generate A Fill Series 

38.  Insert → Function To Open A Function Wizard 

39.  Format → Cells To Format A Cells 

40.  Format → Auto Format To Open Auto Format Dialog Box 

41.  Format → Column → Width 
To Change A Column Width In Spread 
Sheet 

42.  
Right Click (Selected Row)       Height 
Format →row→ height 

To Change A Row Height In Aspread 
Sheet 

 

 

S.NO COMMAND USES 
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43.  Edit → Delete Contents To Delete Selected Contents In A Cell 

44.  Edit → Delete Cells To Delete Entire Row (Or) Column 

45.  Insert → Picture → From File To Insert A Picture 

46.  Insert → Special Characters To Insert A Special Characters 

47.  Insert → Chart To Insert A Chart 

48.  Insert → Object → Formula To Insert A Formula 

49.  Insert → Floating Frame To Insert A Floating Frame 

50.  Insert → Movie And Sound To Insert Movie And Sound 

51.  Insert → Object → OLE Object To Insert An OLE Object  

52.  Insert → Object → Applet To Insert An Applet 

53.  Format → Print Range→ Edit To Select The Print Range 

54.  Format → Print Range → Remove To Remove The Print Range 

55.  Insert →Table Design 
To Create A New Table On The 
Database 

56.  Edit → Open Database Object 
To Enter The Data In The Database 
Table 

57.  
Right Click(On The Record Pointer)     
Delete Rows 

To Delete A Record In The Database 
Table 

58.  
Right Click(On The Record Pointer)        
Row Height 

To Change A Row Height In The 
Database Table 

59.  
Right Click(On The Record Pointer)       
Table Format 

To Display The Table Format Window 

60.  Edit → Paste Special To Show A Paste Special Dialog Box 

61.  File → Send → Outline To Presentation 
To Select A Text Document In With 
Outline 

62.  
File → Send → Auto Abstract  To 
Presentation Command 

To Select A Presentation Document 
Within A Outline 

63.  File → New → Presentation 
To Create A Presentation (Or) Star 
Office Impress From Other Applications 

64.  
File → New → Templates And 
Documents 

To Create A New Presentation Using 
Template  

 

S.NO COMMAND USES 
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65.  Slide Show → Slide Show To Start A Presentation 

66.  Insert → Slide To Insert A Slide In Presentation 

67.  Insert → Duplicate Slide 
To Insert A Duplicate Slide In 
Presentation 

68.  Slide Show → Custom Slide Show To Run A Custom Slide Show 

69.  
Right Click(On Slide)         Rename 
Slide 

To Rename A Existing Slide 

70.  Right Click(On Slide)        Delete Slide To Delete A Slide In Presentation 

71.  View → Toolbars → Slide View To Select Slide View Floating Window 

72.  Slideshow → Custom Animation To Choose Custom Animation 

73.  Format →Page → Background To Change A Slide Background 

74.  Format →Slide Design To Apply A New Slide Design 

75.  Format →Styles And Formatting To Change A Presentation Styles 

76.  View→ Normal View To Activate Normal Window 

77.  View→ Outline View To Activate Outline View 

78.  
Tools → Options → Star Office Impress    
General 

To Start A Slide Show From The 
Current Slide  

79.  Slide Show → Show/Hide Slide To Hide A Slide 

80.  Slide Show → Show/Hide Slide To Show A Slide 

81.  Slide Show → Rehearse Timings To Select Rehearse Timings 

82.  Slide Show → Slide Show Settings To Select Slide Show Window 

83.  
Tools → Options → Star Office Impress 
Print 

To Set A Default Printing Options For 
Star Office Impress 

84.  File → Print To Show A Printer Dialog Box 

85.  Edit → Navigator To Open A Navigator 

86.  File → Export To Export A Presentation 
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Year and invention 

 

S.NO DETAIL YEAR 

1.  
Donn parker of SRI international in Menlo parker California 
began to examine unethical any illegal uses of computers by 
computer professionals 

1960 

2.  Commercial electronic spread sheet in use since late 1970 

3.  PC first appeared 1975 

4.  More usable PCs started appearing 1977 

5.  VisiCalc developed 1979 

6.  
Number of social and ethical consequences of information 
technology were becoming public issues in America and Europe  

1980 

7.  Lotus 1-2-3 introduced 1982 

8.  MIDI developed 1982 

9.  Many universities introduced formal course in compute ethics 1990 

10.  AVI developed 1992 

11.  Real audio/video 1995 
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File format and Extension 

S.NO FORMAT EXTENSION YEAR  
DEVELOPED 

(COMPANY) 

1.  MIDI 
.mid 
.midi 

1982  

2.  
Real Audio/Real 
video 

.rm 

.ram 
1995 Real networks 

3.  AU .au   

4.  AIFF 
.aif 
.aiff 

 Apple 

5.  SND .snd  Apple 

6.  WAVE .wav  IBM and Microsoft 

7.  MP3 
.mp3 
.mpga 

 
Moving Pictures 
Experts Group 

8.  MPEG 
.mpg 
.mpeg 

 
Moving Pictures 
Experts Group 

9.  AVI .avi 1992 Microsoft 

10.  
Windows media 
format 

.wmv  Microsoft 

11.  
Quick time 
format 

.mov  Apple  

12.  
Shock wave 
format 

.swf  Macro media 
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ABBREVIATIONS 

1. ASCII  : American Standard Code For Information 

2. VISICALC : VISIBLE CALCULATOR 

3. OLE  : Object Linking And Embedding 

4. SWF  : Shock Wave Format 

5. JPEG  : Joint Photographic Expert Group 

6. MPEG  : Moving Pictures Experts Group 

7. JPG  : Joint Photographic Group 

8. GIF  : Graphic Interchange Format 

9. HTML  : Hyper Text Markup Language 

10. XHTML  : Extended Hyper Text Markup Language 

11. HTTP  : Hyper Text Transfer Protocol 

12. CD  : Compact Disk 

13. CD-ROM  : Compact Disk Read Only Memory 

14. AVI  : Audio Video Interleave 

15. MP3  : Media Playback Version 3 

16. IBM  : International Business Machine  

17. SND  : Sound 

18. AIFF  : Audio Interchange File Format 

19. WMV  : Window Media Format 

20. AU  : Audio 

21. KB  : Kilobyte 

22. MIDI  : Musical Instrument Digital Interface 

23. WBT  : Web Based Tutorial 

24. CBT  : Computer Based Tutorial 

25. MMS  : Multimedia Messaging System 

26. DBMS  : Database Management System 

27. SQL  : Structured Query Language  

28. DDE  : Dynamic Data Exchange 

29. IT   : Information Technology 

30. ITES  : Informational Technology Enabled Services 

31. LCD  : Liquid Crystal Display 

32. TV   : Television   

33. BFSI  : Banking Financial Service and Insurance 

34. BPO  : Business Process Outsourcing 

35. ATM  : Automated Teller Machine 
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SOFTWARE & DEVELOPED COMPANY 

S.NO SOFTWARE COMPANY 

1.  VisiCalc Apple – II 

2.  First Commercial Package Microcomputer 

3.  Lotus 1-2-3 Lotus Development Corporation 

4.  Excel Microsoft 

5.  Quarto Pro Borland International 

6.  Improve Lotus Corporation 

7.  Star office Calc Sun Micro Systems 

8.  Real Audio / Video Real Networks 

9.  Aiff Apple 

10.  SND Or Sound Format Apple  

11.  Wave Format IBM And Microsoft  

12.  Mp3/ MPEG Moving Pictures Export Group 

13.  Avi Microsoft 

14.  Windows Media Format Microsoft 

15.  Quick Time Format Apple  

16.  Shockwave Format  Macromedia 
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Different Types 

S.NO TITLE 
NO.OF 

TYPES 
TYPES 

1. Types of scrollbars 2 
� Vertical scroll bar 
� Horizontal scrollbar  

2. 
Switch between multiple 
document 

2 

� Click on the window menu and select 
the list of documents displayed 

� Click on the document button visible 
on the taskbar 

3. Types of formatting 2 
� Hard formatting 
� Soft formatting 

4. 
Types of paragraph 
alignments 

4 

� Left alignment 
� Right alignment 
� Center alignment 
� Justify alignment 

5. 
Different way of 
indenting 

2 
� Indenting text with tool bar 
� Indenting text with paragraph dialog 

box 

6. 
Ways correcting spelling 
mistakes 

2 
� While typing the document 
� After t5he entire document is typed 

7. 
Number of tabs in Auto 
correct dialog box 

5 

� Replace  
� Exceptions 
� Options 
� Custom quotes 
� Word completion 

8. 
Number of ways 
correcting spelling 
mistakes while typing 

2 
� Backspace key 
� Right click on the misspelled word 

9. 
The number of icon 
available in table 
formatting toolbar 

13 

� Table fixed 
� Table fixed, proportional 
� Table variable 
� Merge cells 
� Split cells 
� Optimize 
� Inserting row 
� Inserting column 
� Delete row 
� Delete column 
� Borders 
� Line style 
� Border colour 

10. 
Number option displayed 
in the popup menu when 
clicking optimize icon 

4 

� Space column equally 
� Space rows equally 
� Optimize row height 
� Optimize column width 

11. 
Different ways of 
changing margins 

2 
� Using page style dialog box 
� Using rulers 

12. Types of page orientation 2 
� Portrait 
� Landscape 

 

S.NO TITLE 
NO.OF 

TYPES 
TYPES 
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13. 
The number of spin boxes 
in header and footer tab 

4 

� Left margin 
� Right margin 
� Spacing 
� height 

14. 
Number of ways to edit 
the data in the worksheet 

2 
� Typing the new data 
� Click on the formula bar 

15. 
Types of operators in star 
office calc 

4 

� Arithmetic 
� Comparative 
� Text 
� Reference  

16. Types of cell referencing 2 
� Relative cell addressing 
� Absolute cell addressing 

17. 
Number of icons in the 
insert cell toolbar 

4 

� Insert cell down 
� Insert cell right 
� Insert rows 
� Insert columns 

18. 
Number of options in 
delete cells dialog box 

4 

� Shift cells up 
� Shift cells left 
� Delete entire rows 
� Delete entire columns 

19. 
Number of icons in the 
insert object toolbar 

6 

� Insert chart 
� Insert formula 
� Insert floating frame 
� Insert OLE object 
� Insert applet 
� Insert movie and sound 

20. 
Number of options in the 
print range of print dialog 
box 

3 
� All 
� Pages 
� selection 

21. Types of data processing 2 
� Manual data processing 
� Computerized data processing 

22. 
Types of data in star 
office base 

3 
� Character  
� Number  
� Boolean  

23. 
Ways of manipulation of 
a database 

7 

� Searching 
� Sorting 
� Merging 
� Performing calculations on data 
� Filtering 
� Editing the database 
� Report generation 

24. Types of database 5 

� Flat file database 
� Relational database 
� Hierarchical database 
� Network database 
� Object oriented database 

25. 
The categories of data 
management task 

3 
� Entering data in to the database 
� Re ordering records in the database 
� Obtaining subsets of data 

 

S.NO TITLE 
NO.OF 

TYPES 
TYPES 
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26. 
Types of items in  
<database> pane 

4 

� Tables 
� Queries 
� Forms 
� Reports  

 

27. 
Number of field type in 
star office base 

20 

� Text [VARCHAR] 
� Text[VARCHAR-IGNORECASE] 
� Text(fix) 
� Number 
� Date/time 
� Date 
� Time 
� Yes/no 
� Image  
� Decimal 
� Binary field(fixed) 
� Integer 
� Tiny integer 
� Small integer 
� Big unit  
� Float 
� Real  
� Double  

28. Types of sorting 3 
� Sort ascending 
� Sort descending 
� Multiple sorting 

29. Types of filter 2 
� Auto filter  
� Standard filter or default filter 

30. Types of reports 2 
� Static report 
� Dynamic report 

31. 
Field properties of 
number type 

5 

� Entry required 
� Length 
� Default value 
� Format example 
� Decimal places 

32. 
Field properties of text 
type 

4 

� Entry required 
� Length 
� Default value 
� Format example 

33. 
The two most common 
ways multimedia learning 
package  

2 
� Command based tutorial(CBT) 
� Web based tutorials(WBT) 

34. 
The most common image 
formats 

2 
� GIF 
� JPG/JPEG 

35. 
The categories of the 
image file compression 

2 
� Lossy compression  
� Lossless compression  

36. 
Number of attributes 
control the characteristics 
of sound 

2 
� Amplitude 
� Frequency 

37. Types of animations 2 
� Two dimensional(2-D) 
� Three dimensional(3-D) 

S.NO TITLE 
NO.OF 

TYPES 
TYPES 

38. Types of 2-D animation 2 � Cell based animation 
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� Object based animation 

39. 
Step in creating 3-D 
animation 

3 
� Modeling 
� Animating 
� Rendering 

40. 
Types of video 
compression  

2 
� Lossy compression  
� Lossless compression  

 

41. 
Number of ways to create 
presentation 

3 
� Form with any star office application 
� By launching star office impress 
� Using templates 

42. 
Number options available 
in first page of the 
presentation wizard 

3 
� Empty presentation 
� Form template 
� Open existing presentation 

43. 
Number of categories of 
presentation background 

4 

� Gradient 
� Hatching 
� Bitmap 
� colour 

44. 
The option available in 
the select an output 
medium section 

5 

� Original 
� Overhead sheet 
� Paper 
� Screen 
� slide 

45. 
The drop down list box in 
the select a slide 
transition 

2 
� Effect 
� Speed 

46. 
The number option 
available in the select a 
presentation type section 

2 
� Default 
� Automatic 

47. 

The number of panes in 
the middle pane of 
presentation and 
templates pane 

3 
� Slide pane on the left 
� Pane in the center 
� Task pane on the right 

48. 

The number of tabs in the 
center pane (or) the 
number of view in 
presentation 

5 

� Normal 
� Outline 
� Notes 
� Handouts 
� Slide sorter view  

49. 
The number of page 
display in the task pane 

4 

� Master page 
� Layout page 
� Custom animation 
� Slide transition 

50. 
The option available in 
the background fill 
Combo box 

4 

� Colour 
� Gradient 
� Hatching 
� Bitmap image 

51. 
The checkbox in the slide 
design dialog box 

2 
� Exchange background page 
� Delete unused background 

52. 
The number of styles 
outline 

9 � Outline 1 to outline 9 

 

S.NO TITLE 
NO.OF 

TYPES 
TYPES 

www.Padasalai.Net                                                                                                                    www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

         J.P.MURUGAN, M.Sc., B.Ed.,         Cell:9789633793,  9488832229 Page 133 

 

53. 
The number of 
publication types options 

4 

� Standard HTML format 
� Standard HTML with frames 
� Automatic 
� Web cast 

54. 
Types of monitor 
resolutions 

3 
� Low resolution(640 x 480) 
� Medium resolution(800 x 600) 
� High resolution(1024 x 768) 

55. 
The number of segments 
of viewing the solution of 
a problem are 

2 

 
� Data  
� operations 
 
 

56. Classifications of tokens 5 

� Keywords 
� Identifiers 
� Constants 
� Operators 
� punctuators 

57. Types of constants 2 
� Numeric 
� Non numeric 

58. 
Classification of 
operators in C++ 

13 

� Arithmetic 
� Assignment 
� Component selection 
� Conditional 
� Logical 
� Manipulator 
� Member de-referencing  
� Memory management 
� Preprocessor 
� Relational 
� Scope resolution 
� Shift 
� Type cast 

59. 
Classification of 
operators based on 
operand requirements 

3 
� Unary 
� Binary 
� ternary 

60. 
The classification of data 
type 

3 
� User defined data type 
� Built in data type 
� Derived data typed 

61. 
The number of storage 
specifies 

4 

� Auto  
� Static 
� Extern  
� Register  

62. 
Classification of built in 
data type or fundamental 
or basic data type 

3 
� Integral 
� Float 
� Void 

63. 
Divisions of integral data 
type 

2 
� int 
� char 

64. 
Divisions of float data 
type 

2 
� Float  
� Double 
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65. 
The number of words for 
data types in C++ 

9 

� Char 
� int 
� Double 
� Float 
� Void 
� Short 
� Signed 
� Long 
� unsigned 

66. 
Methods assigning data to 
the variables 

2 
� By using assignment statement 
� Reading data during run time of a 

program 

67. Sections of C++ program 3 

� Include files 
� Declaration of variable data type, user 

defined functions 
� Main(functions) 

 

68. 
The categories of control 
structure 

2 
� Decision making statement 
� Looping statement 

69. Forms of if statement  2 
� Simple if statement 
� If-else statement 

70. Kinds of loops in C++ 3 
� For loop 
� While loop 
� Do while loop 

71. Segment of loop 3 
� Initial value 
� Test condition 
� Increment  

72. 
Number of ways to 
invoke function having 
argument 

2 
� Call by value 
� Call by reference 

73. Types of scopes in C++ 4 

� Local scope 
� Function scope  
� File scope 
� Class scope 

74. Types of array 2 
� One dimensional 
� Multi dimensional 

75. 
The number of methods 
available to display the 
content of string 

2 
� cout 
� cout, write() 

76. 
The number of 
parameters required for 
write() function 

2 
� Identifiers string characters 
� Number of characters to be displayed 

77. Parts of a class in C++ 2 
� Class declaration 
� Class function definitions 

78. 
Number of access 
specifiers or visibility 
labels 

3 
� Private 
� Public 
� Protected 

79. 
Classification of class 
members 

2 
� Data members(attributes) 
� Members functions(functions) 
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80. 
Number of ways defining 
methods of a class 

2 
� Declared and defined within the class 
� Declared within the class and defined 

outside the class 

81. 
Number of ways 
polymorphism achieved 
in C++ 

2 
� Through function overloading 
� Through operator overloading 

82. Functions of constructor 2 
� Initializes the class object 
� Allocation of memory space to an 

object 

83. 
The number of way to 
execute copy constructor 

3 

� When an object is passed as a 
parameter to any of the member 
function 

� When member function returns an 
object 

� When an object is passed by reference 
to constructor 

84. 
Number of visibility 
mode/ accessibility 
specifies 

3 
� Private 
� Public 
� Protected 

85. Types of inheritance 5 

� Single inheritance 
� Multiple inheritance 
� Multilevel inheritance 
� Hybrid inheritance 
� Hierarchical inheritance 
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