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1.What are the steps to be followed for searching a given word and replacing it in a
 document?(0r) How will you find and replace a given word in staroffice writer?

We can use the Find & Replace feature  in StarOffice  writer  to search for  and to 
replace words in text document.
To Find / Search  and Replace Text.
● Choose  Edit →Find & Replace.

 The  Find & Replace dialog box appears.
● In the Search for box, type the text that you want to find in your document.
● In the Replace with box, enter the replacement word or phrase.
● Click Find to start the search.
● When writer finds the first instance of the word or phrase, do one of the following.

1. To replace the found instance of the text with what you entered in the Replace with 
box, click Replace.
2. To replace all instance of the text with what you entered in the Replace with box, 
Click Replace All.
3. To skip the found text and to continue the search, click Find again.

● Click Close when we have finished the search.

 Note: We can also select the word or phrase that we want to search for in the text 
document,  and  then  choose  Edit  →Find  &  Replace.  The  text  that  you  selected  is 
automatically entered in the Search for box.

2. How would you carry out the spell check after the entire doucment is typed? 
To Checking the Spelling  after the Document is Typed.

● Tools → Spelling→Check is selected or           is clicked.
● To check a part of the document only that portion is selected.
● The F7 key may also be pressed to select the spelling command. 
● The Spellcheck dialog box appears.
● Not in dictionary   text area displays the  misspelled word and the  suggestions list 

displays any alternative spellings.
To carry out spell check  do..
Any one of the following  can be done:

1. To Skip this occurrence but stop on the next one.  Ignore Once button is clicked. To 
skip all occurrences of this word. Ignore All button is clicked.
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2. To  replace  the word with one of the selected spellings, in the suggestions list that 
spelling  is  clicked,  and  Change button  is  clicked to  change this  occurrence  and 
Change All button is clicked to replace all occurrence of the world.

3. If none of the replacements is correct, correction can be made manually in the Not in 
dictionary text area. Add button is clicked to add the word to the dictionary.

3. What are the methods can be used to change the margin?
Margins control how close StarOffice Writer prints to the edge of the page.

The margins can be changed by using following methods.
1. Page Style Dialog Box.
2. Changing Margins Using Rulers.

Changing the Margin  using  Page Style Dialog Box.
If the user knows the exact value of the margins then the page style dialog box can be 

used to make a change.  
The following  steps are used.

● Format →Page  command is selected. 
●  A page style dialog box  appears on the screen.
● Click the page tab, if necessary.
● In Margins group, type the new values in the spin boxes or use the spin arrows to 

change the value.
● Click the OK button.
● The page preview option in the File menu can be used to see the change.

Changing the Margins Using Rules.
If the user not having the exact value for the margins then the  Ruler option on the 

View menu can be used to change the margins.

Following steps are used in this method.
● If the ruler is not displayed in the screen, View → Ruler option is clicked.
● The grey area of the ruler indicates the margin's top area.
● The mouse pointer is then moved in between the gray and white area of the ruler.
● When the pointer is in the right spot, it changes into a line with arrows on both sides.
● The margin guide is dragged to a new location.

     This method can be used to change both left and right , top and bottom margins.
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4. Explain the Process of creating Header and Footer.Write how to include the text and 
page numbr.

Header  and  Footer are  some  reference  remarks added  at  every  page  of  the 
document .

Header is an area at the top of the document and Footer is an area at the bottom of 
the page.
To Create Header..
● Format →page

A page style dialog box appears on the screen.
● Click on Header tab on the Page style  dialog box. A screen with various options for 

the header appears.
● In this dialog box, the Header On check box  is clicked.
● Four spin boxes appears. In those spin boxes, distance of the header from the text area, 

the header height, the distance from the left margin and the right margin are entered.
To Create Footer.
● Format →page

A page style dialog box appears on the screen.
● Click on Footer tab on the Page style  dialog box. A screen with various options for 

the footer appears.
● In this dialog box, the Footer  On check box  is clicked.
● Four spin boxes appears. In those spin boxes, distance of the footer  from the text area, 

the footer height, the distance from the left margin and the right margin are entered.
● Finally click on ok button.

Now the document is appeared with Header and Footer.

Including  Text and Page Number in Header and Footer area
Once the header and footer are created, the text to be included  can be specified. This 

can be done in the following steps.
1. Click on Header and Footer area.
2. Click on Insert → Fields . A sub menu with a list of options appears.

Clicking on an option in the list will insert the appropriate text in all the pages.
3. For example, clicking on Insert → Fields→Page Number  will insert page numbers 

on every page.
4. Normal text can also be included in the header and footer. To do so, simply type the 

text where you want it.
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5. What are the advantages of using electronic spread sheet? 
An electronic spreadsheet is a worksheet used in a computer to create and quickly 

perform “what if” analysis of interrelated columnar data in workspaces.

Advantages of using Electronic Spreadsheets.
The electronic spreadsheet offers several advantages over manual one. The following 

are some of the main advantages of electronic spreadsheets,
● Calculations are automated through the built-in mathematical , financial spreadsheets.
● Accurate results to any desired level of decimal points are possible.
● Worksheets can be quite big in size.
● Any part of the worksheet can be viewed or edited.
● Worksheet can be saved and retrieved later.
● Any part or whole of an existing worksheet can be merged with any existing  or new 

worksheet.
● Any part or whole of the worksheet can be printed in a desired format.
● Worksheet data can be viewed in the form of graphs or charts.
● The worksheet  information can be transferred to any database or word processing 

software.
6. What are the formatting options available in StarOffice Calc?

StarOffice Calc provides with several formatting options for formatting the worksheet.
Listed below are some of the formatting options available in StarOffice Calc.

This is the Bold icon and is used to display data in bold.  To use this icon, 
                               highlight the cells and click on the icon.

This icon is used to dispaly the data in italics.
This icon is used to underline the data in highlighted cells.

This is the Change Font icon.  This icon displays list of fonts 
that can be used . Select the font by clicking on it.
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This icon is used to change the Font size of the data. To do so,
 select the data and click on this icon.
This is the Font Colour icon .  This can be used to change the 

                                         font color.
These are the Align Left, Align Center, Align Right and Justify

                                         icons.  They are used to align the content of cells.
This is the Number Format : Currency icon. Clicking on this

                                         icon will display the contents of the selected cells in currency 
                                         form that is with a $ in front and with two decimal digitals.

This is the Number Format : Percent icon.  Clicking on this icon
                                         will display the current contents in percentage format.  Now that it
                                         multiplies the contents of the cell by 100 and displays the result 
                                         with  2 decimals.

This is the Number format : Standard icon.  Clicking on this icon
                                         will display the contents of the selected cells in default format.

These are the Number Format: Add Decimal and 
                                       Number Format: Delete Decimal icons.  They are used to increase
                                         or decrease the number of decimal digits that are to be displayed 
                                          in the  selected cells.
7.Working with Charts in StarOffice Calc.

One of the most popular features of StarOffice Calc software is the ability to generate 
charts based on the numeric data.  The purpose of Chart is to visually present the data for 
easy understanding.

To insert chart, the procedure follows.
● Select the data that we want to provide as chart.
● Click on Insert → Chart  or click on the Insert Chart Icon on the toolbar.
● The cursor becomes a + sign with a small picture of the graph.  Place this cursor 

where we want to insert the chart and click . The Autoformat Chart window appears.
●  It prompts us to enter the area in the worksheet to be charted. Example

Enter the range as C3:F7
● The Next window displays the  different types of charts that can be created along 

with a preview of each.
● Select the type of chart in which we want to present the data.
● The preview window shows the chart. Click on Next.
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● Click the Show text elements in preview check box if it is not selected.
             For each type of the chart (say pie, Bar, Column etc.) there are different formats
           available.Here, select the desired format.
● Click on Next.
● In the next window, we have to provisions to a Title for the Chart, Titles for X and 

Y axes and legends.
● Click on Create. Now our worksheet will look as per data we mentioned.

8. How can you generate a series of values? Explain with an example.
We can use Automatic Fill feature of StarOffice Calc to generate a series of values.
We can  also use the Fill Command to generete a series of data directly from the 

values of the selected cells.
● First select  the cells of the worksheet that we want to fill
● Choose  Edit → Fill →series.
● Fill series dialog box appears on the screen.

In that select  Direction  as  Down.
    Type as Linear.
    Increment as   2  then

by  clicking  ok button  the  values  in  the  subsequent  cells  of  the  column  will  be 
automatically generated.

As another example,  select the range A1 : D6 in the worksheet.
● Click on Edit →Fill → Series.
● Choose  2 as our  Start Value.
● 2 as Our Increment
● Growth as the Type, and Down as the Direction.
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Now click ok and the worksheet filled as shown.

As shown above we can generate a series of dates and times .
  For example.
● Enter the date as 03/05/05 itto a cell.
● Select the cell.
● Select the Edit →Fill →Series.
● In fill series dialog box, select Day as the Date unit and enter increment as 7.
● Click on Ok.

The series of data generated as follows.

● On  a spread sheet by using/dragging the fill handle in the bottom right corner of the 
cell ,we can generate a series of data.

9. Write the advantages of Computerised Data Processing.
The  following  are  some  of  the  advantages  of  the  computerized  data  processing 

system.
1. Once we collect and enter the data into a computer system, we can perform other 

operations with less manual labour.  So man power is considerable saved.
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2. Though it takes some time to develop, test and put the required computer program to 
use, the processing speed is fast, reducing the processing time, in certain cases, from 
man – years and man – months to minutes and seconds.

3. The chances of errors are less in computerized data processing.
4. We can store large amount of data and information in the computer storage medium, 

which is compact.  Hence, we need not store bundles of paper records, thus saving 
spaces.

5. Today computer networks are so common that we can share data and resources from 
one computer system to the other at a very fast speed and with very little effort, as in 
the case of railway and airlines reservation systems.

6. It is easy to edit the data including correction, changes and modifications.
7. Computerized database is highly effective for searching, sorting and merging files and 

for other data manipulation activities.
10. Explain the manipulation of database in starOffice Base.

A database is a repository of collection of related data or facts. It arranges them in a 
specific structure.

We may manipulate the database in one or more of the following ways.
● Searching
● Sorting
● Merging
● performing Calculations on data
● Filtering
● Editing the database
● Report Generation

Searching
Searching is a process to select a desired Specific data from a database. For instance, 

we want  to  select  the  student  ranking first  ina  class  with  respect  to  the  total  marks  or 
individual subjects or we want to see the performance of  a particular student. Searching is 
done using database commands on the relevant fields.
Sorting

Sorting is the process of arranging the data in  a table in some order.  We may arrange 
the list of Staff members in an alphabetical order or according to the seniority in postion or 
date of joining or in any other order we like.
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Merging.
Merging is a process of joining data from two or more tables of the same or different 

database.  For  example in a student database, we may have mark list of different classes. If 
we want to prepare one table that shows all  the first ranking students of each class, we can 
independently search in each table to select the first rank student from each class and merge 
all the names together in a single table/file.

Performing Calculations on data
We may do any kind of arithmetic calculations on the data stored in the database.     For 

example, to obtain the total marks of all the subjects of a student, we may add the marks in 
the concerned fields of the database and store them in a separate field.

Filtering
There are times when viewing the entire table is unwieldy. Using a filter is a way of 

limiting the information that appears on screen.

Filters are a feature for displaying and browsing a selected list or subset of records 
from a table. The visible records satify the condition that the user sets.  Those that do not 
satisfy the condition are hidden.

Editing the Database
Editing  is  a  process  of  performing  corrections  on  the  existing  data,  deleting  the 

existing data, field(s). or record(s), adding new data, field(s) or changing the format of the 
database and so on.

Report Generation
We may generate any desired report, from the data of the database. For example, in 

the case of student database, we may generate a report of all the students who have scored 
marks less than the minimum marks required for a pass, and another report that gives the list 
of passed students and so on.

11. Explain nested if statement with syntax and  suitable example.
Nested if statement

The statement sequence of if or else may contain another if statemet ie., the 
if..else statement can be nested within one another.
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The syntax is 

       if(expression 1)
if(expression 2)
{

     action 1;
}
else
{

      action 2;
}
else
{

     action 3;
} 

 In  an  nested  if..  else  statement,  “Each  else  matches  with  the  nearest  unmatched 
preceding if”

For example

if(grade =='A')
  if(basic>5500)
        incentive =basic*10/100;

else
incentive=basic*5/100;
else
cout<<“Try to attain Grade A”;

Working of the above example:
● Grade ='A' and basic ==5501, then incentive gets the value 550.
● Grade='A' and basic ==5000, then  incentive gets the value 250;

Grade < >'A'  the inner if will not be executed, the outer else will be executed and thus 
prints “Try to attain Grade A”.
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12. Explain if else statement with syntax and example.
 if.. else... statement is a two way braching statement.  

 if ..else.. statement which chooses between two alternatives, executes the choosen block 
based on the condition.

Syntax:
if(condition/expression)
{

action block 1;
}
else
{

action block 2;
}

The following program demonstrates if ...else .. statement.
#include<iostream.h>
#include<conio.h>
void main()

          {
int a;
clrscr();
cout<<''\n Enter a number”;
cin>>a;
if(a%2==0)

{
cout<<“\n The given number “<<a <<”is  even”;
}
else
{
cout<<“\n The given number “<<a<<”is Odd”;
}

getch();
}
In the above program “The given number 10 is even” is printed if the expression is 

evaluted to true, otherwise statement following else option will be executed.
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If the value of the expression is evaluated to >0 then action block 1(true block)
is executed, otherwise 2 is ( else block) is executed.

13. Explain call by value method with example.
In call by value method, the called function creates new variables to store the value of 

the arguments passed to it.   This method copies the value of actual  parameters into the 
formal parameters thus the function creates its own copy of arguments and then uses them.

In call by value method, any change in the formal parameter is not reflected back to 
the actual parameter.

#include<iostream.h>
#include<conio.h>
void swap (int n1, int n2)
{
int temp;
temp=n1;
n1=n2;
n2=temp;
cout<<“\n”<<n1<<“\t”<<n2 <<“\n”
}
void main()
{
int m1=10, m2=20;
clrscr();
cout<<“\n values before invoking swap”<<m1<<“\t”<<m2;
cout<<“\n Calling swap....”;
swap(m1,m2);
cout<<“\n Back to main.. values are”<<m1 <<“\t”<<m2;
getch();
}
Output
Values before invoking swap 10 20
Calling swap....
20 10
Back to main .... Values are 10       20
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  14. Explain inline statement with example.
      Call statement of a function makes the compiler to jum to the functions and also to 
jump back to the instruction following the call statement.
      This forces the compiler to maintain overheads like STACKS that would save 
certain special instructions pertaining to function call, return and its arguments. This 
reduces the speed of program execution.  Hence under certain situations specially, 
when the functions are small, the compiler replaces the function call statement by its 
definition ie., its code during the program execution.  This feature is called as inline of 
a function technically called inline function.

● An inline function looks like a normal function in the source file but
                       inserts the function's code directly into the calling program.

● Inline function execute faster but require more memory spaces.

#inlcude<iostream.h>
#include<conio.h>
inline float convert_float(int x)
{
 return x *12;
}
void main()
{
clrscr();
int inches =45;
cout<<convert_feet(inches);
getch();
}

To make the function inline, we have to insert  the keyword inline in the fucntion 
header as inline float  convert_feet(int x).

Inline  keyword is  just a request to the compiler. Sometimes the compiler will ignore 
the request and treat it as a normal function and vice versa.
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15.Write about the different scope of the variable in C++
 Scope refers to the accessibility of a variable.There are four types of scopes in  C++.

They are
1. Local scope
2. Function scope
3. File scope
4. Class scope

LOCAL SCOPE
A local variable is defined within a block.
 The scope of a local variable is the block in which it is defined.
 A local variable cannot be accessed from outside the block of its declaraction.

#include<iostream.h>
#include<conio.h>
void main()
{
int a=10, b=20;
if(a!=b)
{
int  temp;  // Here the variable temp is local variable to this block
temp=a;
a=b;
b=temp;
cout<<“\n Descending order...”;

cout<<“\n”<<a<<“\n”<<b;
}
getch();
}
Ø Local variables are not known outside their own code block. A block of code begins and ends with 
curly braces{}.
Ø Local variable exists only while the block of code in which they are declared is executing.

FUNCTION SCOPE
       The scope of  variable declared within the function is extended to the function block and all sub – 
blocks there in.
#include<iostream.h>
#include<conio.h>
void  swap(int n1, int n2)//  int n1 and int n2 , temp are under function scope.
{
int  temp;
temp=n1;
n1=n2;
n2=temp;
cout<<“\t”<<n1<<“\t”<<n2<<“\n”;
}
• In above mentioned programme  the variable temp is under function scope . Thus the variable  temp is 
accessible in all sub block of the function swap.
• The life time of the function scope variable is the life time of the function block. The scope of formal 
parameters is function scope.
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FILE SCOPE
If a variable declared above all block and function(precisely above main()) has got the scope of 

scope of a file.
 The scope of a file  scope variable is the entire programme. The life time of a file scope variable is 

the life time of a programme.
#include<iostream.h>
#include<conio.h>
int  temp;  // Here the variable temp is in file scope
void main()
{
int  a=10, b=20;
if(a!=b)
{
temp=a;
a=b;
b=temp;
cout<<“\n Descending order...”;

cout<<“\n”<<a<<“\n”<<b;
}
getch();
}
CLASS SCOPE

#include<iostream.h>
#include<conio.h>

 class student
 {
private:
 int  exno, tam,eng.phy,che,com,mat,tot;
float  average;
char name[50];
 public:
 void input()
{ }
void calc()
{ }
void display()
{ }
}x;

Ø The variables declared inside the class are called data members . 
Ø A data members of a class can be qualified  as static.
Ø Its scope or visibility is within the class but its lifetime is the lifetime of the program.

The data members declared under private visibility mode are not accessible by members outside the 
class. If it is declared as public are accessible from outside of the class. If it  is declared as protected 
are accessible only derived classes.

Ø In above mentioned  programme  student is a  user defined data type  and  x is the 
variable of data type student.
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16. Write the definition of Destructor and write the rules for destructor definition and usage.

A destructor is a function that removes the memory of an object which was allocated by the 
constructor at the time of creating an object.  It carries the same name of the class tag, but with a tilde ( ~) as 
prefixed.

Rules for Destructor definition and usage.

1. The destructor has the same name as that of the class prefixed by the tilde character '~'.

2. The destructor cannot have arguments.

3. It has no return type.

4. Destructors cannot be overloaded i.e., there can be only one destructor in a class.

5. In the absence of user defined destructor, it is genereated by the compiler.

6. The destructor is executed automatically when the control reaches the end of the class scope.

17. Explain the types of inheritance.
Inheritance is the most powerful feature of an object oriented programming language.  It is a process 

of creating new classes called derived classes from the existing or base classes. 

Classes can be derived from classes that are themselves derived. There are different types of 
inheritance , they are

1. Single Inheritance.
2. Multiple Inheritance.
3. Multilevel Inheritance.

1. Single Inheritance  .
When a derived class inherits only from one base class, it is known as single inheritance.

     2. Multiple Inheritance.
When a derived class inherits from multiple base classes it is known as multiple inheritance.
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     3. Multilevel Inheritance.
The transitive nature of inheritance is reflected by this form of inheritance. When a class is derived 

from a class which is a derived class itself – then this is referred to as multilevel inheritance.

18. Debug the following C++ program.
#include<iostreamh>
#include<conio.h>
Class distance
{
int feet, inches;
public;
void distance_assign(int f, int i)
{
feet = f;
inches=i;
}
void display[]
{
cout>>“\n Feet   :”>>feet<<“\t Inches:<<inches;
}
distance operator+(distance d2)
{
distance d3:
d3.feet=feet + d2.feet;
d3.inches=(inches+d2.inches)%12;
d3.feet+=(inches+d2.inches)/12;
return d3;
}
}

void main()
{
clrscreen();
distance dist_1,dist_2;
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dist_1.distance_assign(12,11);
dist_2.distance_assign(24,1);
distance dist_3=dist_1+dist_2;
dist_1.disp();
dist_2.disp();
dist_3.disp();
getch();
}
        Note : Dear Student first read the given program then give line number 
           and identify & underline the errors then write as follows.

Line NO. Error Code Correct code
1 <iostreamh> <iostream.h>
3 Class class
6 public; Public:
12 void display[] void display()
14 cout>>“\n Feet   :”>>feet Cout<<“\n Feet   :”<<feet
18 distance d3: distance d3;
24 } };
27 clrscreen(); clrscr();
32 dist_1.disp(); dist_1.display();
33 dist_2.disp(); dist_2.display();
34 dist_3.disp(); dist_3.display();

                     ------------------------------------All The Best-------------------------------------------

     Prepared by
N.Kothandaraman, B.A.,BCA., B.Ed.,A+N+.,
Saraswathi Vidyalaya Matric. Hr. Sec.School,
Sethuvandai, Gudiyattam. R.S.635 803.
Mobile:9894277739
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