
 

 

Board Portions  - For Moderators - 2016 

Volume  2 marks 5 marks 
Volume I     

      
Chapters 1, 2, 3, 6, 7 & 8 Chapters 1, 4, 6 & 7 

Volume II Chapters 2, 5, 6, 9, 10, 11 & 12 Chapters 3, 4, 8 & 9 

 

Objectives 

 All Board Papers from 2007 to 2015 

 

Volume I 

Star Office 
 

Chapter 1 

Text Editing 

Book Questions 

2 marks 

 

What is meant by Text Editing 

 Entering a new text or modifying the existing text in a document is known as text editing.  

 The common text editing features are cut, copy, find and replace. 

 

How would you select the required portion of the text in a document 

     Text can be selected in 3 ways 

     Using Mouse 

 Insertion point is moved to the start of the text. 

 The left mouse button should be clicked, hold down and dragged across the text. 

 Release the mouse button – the text is selected 

    Using Keyboard 

 Place the insertion point at the start of the text 

 Hold the shift keys and use the movement keys to select the text 

 When the text is selected release the shift key 

   Using Shortcuts 

 Click Ctrl + A  to select the entire document 

 Double click on a word to select a word 

 Click once next to the line to select a line 

 

How would you switch over between insert and type over mode 

 When the user is in insert mode the new text will be inserted and the existing text moves to the right. 

 When the user is in the type over mode the new text is inserted and the existing text disappears. 

 The user can toggle between the insert mode and type over mode using the insert key. 

 The status bar shows the information about the current mode. 

 

5 marks 

 

What are the steps to be followed in Finding and replacing a text 

 To search for a word and replace it star office writer uses the Find and Replace option 

 Click on Edit -> Find & Replace  

 Find and Replace dialog box appears, in the Search For box type the word to be found, in the Replace 

with box type the word to be replaced. 

 Click Replace button to replace the current instance 

 Click Replace All button to replace all the instances 

 To skip the search click Find once again 

 To finish the search click Ok button 

 

Extra Questions 
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2 marks 

 

 How do you switch(working)between multiple documents?               

 Once the documents are open,  we can switch between them in the following two ways. 

 Click on the Window menu option and select the file from the list of documents displayed. 

 Click on the document button visible on the taskbar. 

 

What is Word Processing? 

 The term word processing refers to the activity carried out using a computer and suitable software to create, 

view, edit, manipulate, transmit, store, retrieve and print documents. 

List the Functions of Star Office 

 Create text documents using Staroffice writer 

 Create Spreadsheets using Staroffice calc 

 Create presentations using Staroffice impress 

 Create a database using Staroffice Base 

 Draw using Staroffice draw 
 

Chapter 2 

Text Formatting 

 

Book Questions 

2 marks 

 

What is meant by indenting the text 

 To make a long document easy and inviting to read indenting can be done to each paragraph.  

 Setting off the paragraph from the main body text is called as indenting the text. 

 To Indent a paragraph one can click the increase indent icon – each time the user presses the icon the paragraph 

moves ½ inch from the left margin. 

 If one wants to remove the indent the decrease indent icon is clicked. 

 

What is meant by hard formatting and soft formatting 

Hard formatting 

 Formatting done manually is called as hard formatting.  

 Each time the user presses the enter key it is followed by a hard return. 

Soft formatting 

 Formatting done by star office writer is called as soft formatting. 

Soft returns are inserted as line breaks by star office writer when a text is inserted or deleted. 

 

How is formatting done with respect to fonts 

A font is a set of characters and numbers in certain style. 

Font size 

 The size of the font in measured in points – 72 points make an inch 

 To change the font size the command format->character is used & from the character dialog box the font is 

selected. 

Font color 

 To use a different text color, select the text & click font color icon  

 From the color palette the required color is selected. 

Font style 

 To change the style of the font use format->character  

From the character dialog box choose required font from the fonts combo box. 

 

5 marks 

 

How would create a bulleted and numbered list 

Bulleted list 

 One way to set off a list of points in a documents is to create a bulleted list. 

 The fastest way to create a bulleted list is to use the bullets icon on the formatting tool bar. 

 Select the text for which the bullets has to be added. 

 Click on the bullets icon from the formatting tool bar 
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 Star office writer will add bullets to each paragraph & any blank line within the selection. 

Numbered list 

 For items to appear in a specific order like series of steps one can create a numbered list. 

 Select the text to be numbered. 

 Click on the numbered list icon. 

 Star office writer adds the numbers automatically & also indent the paragraph. 

 Blank lines within the selection also will be numbered. 

Remove bullets & numbers 

 To remove bullets & numbers from a list, select the list & click the bullets or numbered icon once again. 

 

What does indenting the text mean 

 Indenting the text improves the readability of the document. 

 Setting off the paragraph from the main body text is called as indenting the text. 

 To Indent a paragraph one can click the increase indent icon – each time the user presses the icon the paragraph 

moves ½ inch from the left margin. 

 If one wants to remove the indent the decrease indent icon is clicked. 

 If one wants special kind of indenting paragraph dialog can be used 

 Select Format->Paragraph, Paragraph dialog box appears 

 Click Indents & Spacing Tab 

 To move the paragraph towards the right type the value to be indented in the Before Text Spin box 

 To move the paragraph towards the left type the value to be indented in the After Text Spin Box 

 First line of the paragraph can be indented using First line option, Negative value in the first line option will result 

in Hanging Indent, the paragraph will hang outside the margin. 

 

Extra Questions 

 2 marks 

 

 What is meant by highlighting the text 

 Highlighting can be used to call attention to key ideas or points. 

 The highlighted sections are used to review or find the key points in the document.  

 To highlight the selected text the highlighting icon is clicked and the needed color is chosen from the color 

palette. 

 To remove the highlighting, select the text click on the highlighting icon and choose No Fill option from the color 

palette. 

 

What are the 4 paragraph alignments 

     The four types of paragraph alignments are 

 To left align the text    -   ctrl+L 

 To right align the text    -  ctrl+R 

 To justify align the text    -  ctrl+J 

 To center align the text   -   ctrl + E 

 

 How is formatting done with styles 

 This is an alternative way of formatting the text. 

 A style is a named set of defaults. 

 Styles need more advanced planning. 

 The style needs to be created initially only then it can be applied to the text using the typeface list. 

 

 

Chapter 3 

Correcting Spelling Mistakes 

Book Questions 

2 marks 

 

What does automatic spelling correction mean? 

 Star office writer recognizes some common misspelling & typographical mistakes & makes the replacement 

automatically. 

 For eg; if a word is typed as ‘teh’ it is automatically corrected to “the”. 
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 Star office writer has automatic spell-check feature which checks for spelling mistakes even when the document is 

being typed. 

 This feature can be turned on by clicking the AutoSpellcheck icon ON or OFF. 

 When the autospell check feature is on star office writer compares the word typed with the words in the dictionary & 

under lines the misspelled word with a red squiggly line. 

 

5 marks 

What is Autocorrect option? How would you add a word in the Auto correct list box 

 Star office writer automatically corrects some spelling mistakes 

 Star office writer recognizes common misspellings and typographical mistakes and makes the replacement 

automatically 

 For eg :  if a word is typed as “teh”  star office writer automatically corrects the word as “the” 

 In addition to this one can also add the other words to the list. 

 Choose Tools -> Autocorrect 

 Autocorrect dialog box appears. 

 In the replace tab type the word to be replaced in the replace text box 

 And the replacement word in the with text box 

 Click replace / add button to add in the auto correct list box 

 

How would you correct the spelling mistakes after the document is typed 

 Click on Tools->Spelling->check 

 Alternatively F7 key is also pressed  

 Click the   spell check icon – spell check dialog box appears 

 Not in Dictionary text area displays the misspelled words 

 Suggestion list displays alternative spellings 

 To skip the current occurrence click Ignore once button 

 To skip all the occurrences click Ignore all button 

 To replace the current occurrence click Change button 

 To replace all the occurrences click Change all button 

 Correction can be done manually in the Not in Dictionary area if none of the replacement is correct. 

 Add button is clicked to add the word in the dictionary 

 

Extra Questions 

2 marks 

 

How would you correct the spelling mistakes while typing? 

 The mistakes can be corrected in 2 ways 

 Press the backspace key to delete a misspelled word & type the correct word. 

 The misspelled word is right clicked – a pop up menu appears & the correct word is chosen. 

 

Chapter 4 

Working with Tables 

 

5 marks 

 

What are the various functions of the icons of the table formatting tool bar 

 

 
 

The function of each icon in the toolbar is indicated below: 

- Table Fixed 

- Table Fixed, Proportional 

- Table, Variable 

- Merge Cells - This icon is used to combine two or more cell into a single cell. 

www.Padasalai.Net                                          www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



- Split Cells - This icon is used to split a cell into two or more cells. 

- Optimise - Clicking on this icon displays a pop up menu with options like Space columns equally,  

                    Space rows equally, Optimum row height and Optimum column width. 

- Inserting Row - This icon is used to insert a row below the current row. 

- Inserting Column - This icon inserts a column to the right of the current column. 

- Delete Row - This icon deletes the current row from the table. 

- Delete Column - This icon deletes the current Column from the table. 

- Borders - This icon displays a floating toolbar with different border option   for the table. 

- Line Style - This icon is used to choose the style of line to be used for the border. 

- Border Colour - Clicking on this icon displays a palette of colours that can be  used as a border  colour for the table 

 

Chapter 6 

Book Questions 

2 marks 

Define briefly a spread sheet 

 An electronic spread sheet is a work sheet used in a computer to create & quickly perform “what if analysis”. 

Spread sheets are like a grid of cells with a programmable calculator attached to each cell. 

 

 Describe the structure of a spread sheet 

 Open File->new->spread sheet 

 At the top of the window is the menu bar -  displays a list of options 

 Below the menu bar is the main tool bar  -  displays the short cut icons 

 Below the main tool bar is the function bar & the object bar 

 Below this is the formula bar – displays the current cell & its contents 

At the extreme bottom is the status bar & the scroll bar  

 

When entering a formula in a cell does it matter in which order you enter the values & operators? Explain   

 After entering the data in the worksheet you can perform calulations on the data. 

 This is done by entering the formula in the worksheet. 

 The syntax of the formula begins with the equal to sign followed by  the combination of values, operators and cell 

references. 

Can we change the data present in the cell? If so how? 

 Editing the contents of a cell can be done in two ways 

 Type in the new data the new data will overwrite the old contents. 

 Click on the formula bar or press the F2 function key or simply double click the cell 

 A vertical cursor appears on the formula bar, move the cursor using the backspace key or left arrow 

keys and edit the data. 
 

What must you include in a formula to ensure that the formula will operate on a specific value not matte where the 

formula might be moved or copied? 

(or)   types of cell referencing 
Absolute cell addressing 

 A cell address can be made absolute by using the dollar sign in front of the row and column names 

 Absolute cell address do change when copied 

 Eg: $c$4 

 

What is data arithmetic? Give example 

 Date calculations in spread sheet are simple 

 We can add a number to the date, arrive at a new date, find the difference between two dates. 

 Eg: to find the sum type the date 03/04/05 in a cell.  

In the result cell type  = A2 + 79. The date 05/22/05 appears 

 

Explain working with multiple sheets 

 A spread sheet contains multiple sheets, each having its name & a list of tabs. 

 Each sheet can be made dependent on each other by referring to the data in another sheet or using the data from 

another sheet for calculations. 

 To find the sum of cells in two sheets use the 3D formula    Eg;       =sum(sheet1.A1;sheet2.a1) 

 

How would you print a range of selected cells 

 Select the range to be printed and click Format -> print range -> edit  & select the range. 
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 The print option under the file menu is used to print the worksheet. 

 To remove the print range click format->print range->delete. 

 In the print dialog box under the print range choose the option All to print all the sheets. 

 The selection option allows you to print only the selected range. 

 The page view option under the file menu allows you to preview the worksheet. 

To print the worksheet with grid select Format->page -> page style dialog box -> check the grid option. 

 

5 marks 

 

How can you generate a series of values ? Explain with example 

 Auto fill feature of spread sheet automatically generates a data series based on a defined pattern. 

o Type a number in the cell 

o Click in the cell & drag the fill handle  

o Release the mouse button. 

 Fill command allows you to generate a series of data  directly from the values of the selected cells. 

 First select the cells, choose the command edit->fill->series  

 Select the type of series from the options. 

Eg: 

 To create a series in increasing order of 3 

 Enter the number 3 in the initial cell 

 Select the cells,  choose the command edit->fill->series 

 Specify the direction as down, type as linear & the increment value as 3. 

 Click ok button – the values are automatically generated. 

   Eg:          Command  -  Edit->fill->series 

                  2 as start value                          output 

                  2 as increment 

                  Type as growth 
 

 

 

 

 

 

 

List and describe the other features available in spread sheet in addition to its ability to calculate numbers 

The features available in spread sheet in addition to its ability to calculate numbers are : 

 Worksheets are quite big in size, it allows you to save & retrieve the data. 

 Any part of the work sheet can be viewed or edited. 

 Any part of the work sheet can be printed in a specific format. 

 The Work Sheet information can be transferred to any database. 

 Worksheet can also be viewed in the form of graphs or charts. 

 Date arithmetic feature in spread sheet allows you to find the sum & difference between dates. 

 Star office calc has tools for inserting pictures and objects like OLE, Floating frame, Applet, Movie & sound as a 

part of the spread sheet. 

 Spread sheet allows you to work with multiple sheets using the 3 D formula. 

 You can define the range of cells on a spread sheet to be printed. 

 Spread sheet has database management capabilities including sorting, selecting & printing reports. 

 

What are functions and how can you use them in your worksheet 

 Functions are predefined formulae available in star office calc 

 The functions are available in the pull down menu of the function wizard. 

 The different categories are available in the category pull down menu. 

 Functions can be selected using the command Inset -> function  

 A list of functions is displayed in the function box when  is All is selected from the category box. 

 The function wizard icon f(x) on the formula bar can also be used to insert functions. 

 Eg: to insert SQRT function – place the cursor in an empty cell 

 Click the function wizard icon 

 Select mathematical from the category box and select SQRT from the function list. 

 The function wizard box prompts you to enter the number for which the function should work. 

 Type the number 64 and click Ok button, the result will be displayed in the cell in the worksheet. 

2 

4 

8 

16 

32 

64 
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What spread sheet feature allows you to represent the data visually as a data analysis tool? 

 The most popular feature of spread sheet is to generate charts based on numeric data. 

 Select the data and click Insert -> chart or click the Insert chart icon. 

 When the cursor becomes a + sign, place the cursor on the worksheet and drag it, the Autoformat chart window 

appears. 

 Select the type of the chart and click next 

 The next window displays different formats for each type of the chart, select the format and click next. 

 In the next window provisions to enter the title for the chart, X-axis, Y-axis and legends is displayed. 

 Then click create. 

 

Extra Questions 

2Marks 

What is a Worksheet how is it different from a Spreadsheet 

 The term spreadsheet and worksheet mean one and the same.  

 Spreadsheet refers specifically to software packages 

 Worksheet refers to the files created with spreadsheet software. 

 

List some of the commonly used spread sheet packages 

 Visicalc developed for microcomputers from – Apple 

 Lotus 1-2-3 & Improve                                    -  Lotus Corporation 

 Excel                                                               - Microsoft 

 Quattro Pro                                                      - Borland  

 Star Office Calc                                              - SunMIcrosystems 

 

Write a note on different types of operators  (Each operator 2 marks) 

The different types of operators are  

Arithmetic operators   -  These operators return numerical results 

 

 + (plus)  Addition  

 -(minus) Subraction 

 -(Minus) Negation  

 *(asterisk) Multiplication  

 /(slash)  Division 

 %(percent) Percent 

 ^(caret)  Exponentiation 

Comparitive Operators - These operators return either true or false 

  

 = equal 

 > greater than 

 < less than 

 >=  greater than equal to 

 <= less than equal to 

 <> inquality 

Text Operators 

 These operators combines sections of text to the entire text. 

 & (And) text operator 

 

Reference Operators 

 These operators combines areas 

 ! (Exclamation)  intersection 

 : (Colon)  range operator 

 

What is relative and absolute cell referencing (Write a note on different types of cell referencing or cell addressing) 

Relative Cell addressing 

 This is the default type of cell addressing  

 With relative cell addressing formula’s are automatically recalculated every time the contents of the cells used in 

the formula change 

 Eg: a4:c4 

Absolute cell addressing 
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 A cell address can be made absolute by using the dollar sign in front of the row and column names 

 Absolute cell address do change when copied 

 Eg: $c$4 

 

What is autoformat sheet 

The autoformat sheet facility of star office calc helps to format the worksheet with different predefined styles and colors 

Click on Autoformat option from the Format menu 

 

How would you change the row height and column width in star office calc 

 To change the column width select the column and click on Format -> column width 

 Type the new column width in the column width dialog box 

 (OR) click and drag the mouse pointer on the line separating the column 

 To change the row height right click on the selected row and select row height from the pop up menu, type the 

new row height  in the row height dialog box 

 (OR) click on the particular row and drag the line separating the next row 

 

 List some of the spread sheet applications 

 Payment of bills 

 Account statements 

 Financial accounting 

 Result analysis of students 

 Income tax calculations 

 

5 marks 

How would you insert cells, rows & columns in a spread sheet 

 To insert an empty cell, row or a column  click Insert cell from the View toolbar – it displays a floating 

tool bar with 4 options 

Insert Cells Down 

 To insert an empty cell & to move the existing cells down  

 Place the cursor in the cell & click Insert->cells Down icon 

Insert Cells Right 

 To shift the contents of the cell to the right & to create an empty cell 

 Place the cursor in the cell & click Insert->cells Right icon 

Insert Row 

 To insert an empty row in a worksheet  

 Select the row & click Insert->rows icon 

Insert Columns 

 To insert an empty column 

 Select the column & click Insert->column icon. 

Note : Draw the icon given in page 86 

 

Write a note on Inserting objects in spread sheet 

Star office calc provides tools for inserting objects like charts, images, formula’s etc in a worksheet. 

 Click on Insert object from View -> Tool bar 

 Insert char icon - Used for presenting the data in the worksheet in the form of charts 

 Insert formula icon  -  This is used for inserting formula in the worksheet for   performing calculations 

 Insert floating frame icon - This icon is used to generate a scrolling screen within a worksheet 

 Insert movie and sound icon - This icon is used to insert sound or video files into the current worksheet 

 Insert OLE object icon  - This icon is used to insert objects from other applications into a worksheet 

 Insert Applet icon - This icon is used to insert applets written in Java programming 

      Into the worksheet 

 

List the formatting options available in star office calc 

 Note : draw the icons page no : 82 

 Number Format Currency icon - on clicking this icon the contents of the selected cells will be displayed in 

currency format with $ sign in the front & 2 decimal digits. 

 Number Format Percent icon - on clicking this icon the contents of the selected cells will be displayed in 

percentage format, it multiplies the contents of the cell by  

100 and displays the result with 2 decimals 
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 Number Format Standard icon - on clicking this icon the contents of the cells will be displayed in the default 

format 

 Number Format Add Decimal & Delete Decimal    -  these are used to increase or decrease the number of decimal 

digits displayed in the selected cells 

 Font colour icon  - this is used to change the font colour 

 Align Left, Center, Right icon  -  these are used to align the contents of the selected cells 

 

 

Chapter 7 

Database 

 

Book Questions 

2 marks 

 What is a database 

 A database is a repository of collections of related data or facts. 

 It arranges them in a specific structure 

 It is a collection of related tables 

 The biggest asset of the DBMS is its ability to provide extremely quick access and retrieval from large databases. 

Eg:  name = vijay marks in maths  = 80 

 

What is database Management system 

 A DMBS is a program, or collection of programs that allows any number of users to access data, modify it and 

construct simple and complex requests.  

 The biggest asset of the DBMS is its ability to provide extremely quick access and retrieval from large databases. 

 The Three main tasks involved in DBMS 

 Entering data into the database. 

 Reordering records in the database. 

 Obtaining subsets of the data. 

 List and define the three components that make up a database 

 Data in a database is most commonly viewed in one or more two dimensional tables each consisting of rows and 

columns 

 The entire collection of related data in one table is referred to as a File 

 Each row in a table represents a record -  a set of data for each database entry 

 Each column in a table represents a field – groups each item of data among the records into specific categories 

 

What primary characteristics distinguishes the flat file database from a relational database 

Flat File database 

 A database file that consists of single table is a flat file database. 

Flat file database are useful for single user or small group situations  

for maintaining address list 

Flat file databases do not allow more complex requests 

Eg: spread sheets 

Relational Database 

A relational database is made up of related tables 

In a relational database one or more common fields existing in two or more tables create a relationship between the fields. 

The common fields are called as keys 

Eg; Relational database is most prevalent in business organizations 

 

Which database structure is characterized by parent child relationship among record types 

 In hierarchical database records are organized in a tree like structure by type. 

 The relationship between the record types is said to be a parent child relationship where a child type can relate to 

only one parent type. 

 Eg: hierarchical database were used on Mainframe databases. 

 List and describe the characteristics that make up an object oriented database. 

 An object oriented structure is an newer structure that groups data items and their associated characteristics, 

attribute and procedures into complex requests. 

 An object is defined by its characteristics, attributes and procedures 

 An objects characteristics can be text, sound, graphics, video etc. 

 Attributes are colour, size, style, price etc. 

 Procedure refers to processing that can be associated to the object 
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List the various field types that exist in a database 

 There are 20 field types  

Text(fix)  Text(varchar)  Text (varchar ignorecase) Number Date/time 

Date  Time   Yes/no    Binary field(fix) 

Binary field      Integer   Tiny integer   Small integer  

Big integer  Decimal  Float    Real   

Double  Image 

 

What does it mean to filter database record (OR What is a filter and explain its types) 

 A filter is a type of a query, it is used to select and display records which match a condition 

 The remaining records are hidden from the user. 

There are two types of filters 

 Auto filter - clicking on this icon displays only the records that match the value of the current field 

Standard filter – filter used with a condition is called as default filter, on clicking this icon conditions can be 

specified  

 

Describe what a query is and what it is used for 

 Queries are special views of the data in a table.  

 The output of the query does not affect the original table.  

 The result of a query is stored separately and can be viewed at any time. 

Uses  

 Establish relationships between tables to update records 

 List a subset of records 

 Perform calculations 

 Search the database to locate records 

 Delete obsolete records 

 

How will you integrate a spread sheet cell range into a text document 

 To insert a range of cells into a writer document 

 Open the star writer document 

 Open the star calc document that contains the text 

 Select the range of cells  

 Choose edit -> copy 

 In the writer document choose edit -> paste special 

 In the paste special dialog box choose DDE(dynamic data embedding) link and click OK 

 

5 marks 

 

Explain form designing and how it is used 

 A form is simply a screen that displays the fields of a record in a well spaced out manner. 

 Forms are user defined screens that are used to make it easier to enter, view and edit the data in a table or query. 

 Designing a form can be done using the autopilot window similar to creating a query. 

 Select form icon from the database pane and select use wizard to create form. 

 Select the table or query  

 Select the field names using > or >> button. 

 Select the add form check box to insert another form. 

 In the next window choose a style for displaying the fields. 

 In the next window select the data entry mode. 

 Form-wizard apply styles window appears – specify the form style. 

 Set the name of the form window appears asking for a name for the form. 

 Type the name for the form and click finish button. 

 

Explain the process of report generation using a table or a query. 

 A report is a printed information that is assembled by gathering data based on user supplied criteria. 

 To create a report choose – use wizard to create report. 

 Select the table or a query from the table combo box. 

 Select the fields to be included in the report using > or >> button. 

 In the labeling fields window modify the labels for the fields. 

 The next – grouping window specifies the fields based on which the records can be grouped. 
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 You can sort the criteria in the sort option window. 

 In the choose layout window customize the report by selecting the layout of data, header, footer & orientation. 

 In the next window choose the type of report – static or dynamic. 

 Enter the title for the report and click finish button. 

 

Extra questions 

2 marks 

Define a primary key 

 A primary key is a field in a table that uniquely identifies every record in a table. 

 Primary key becomes important when there are multiple tables with common fields. 

 To assign a primary key right click on the left of the field. 

 A shortcut menu appears, choose primary key option. 

 A small yellow key appears to the left of the field. 

 

5 marks  

Explain the steps involved in manipulating the database 

7 Steps involved in manipulating the database are 

 1. Searching  2. Sorting 3. Merging 4. Editing the database 

 5. Performing calculations 6. Filtering  7. Report generation 

Searching 

 Searching is a process to select a desired specific data from a database 

 Eg: Selecting the students ranking first in a class with respect to total marks 

Sorting 

 Sorting is the process of arranging the data in a table in some order either ascending  

 Or descending. 

 Eg: arranging the list of staff members in alphabetical order 

Merging  

 Merging is a process of joining data from two or more tables of the same or  

 Different databases. 

 Eg: preparing a mark list that shows the first ranking students of each class 

Performing Calculations 

 Arithmetic calculations can be done on the data 

 Eg: calculating the total marks of a students for all subjects 

Filtering 

 Using filter is a way of limiting the information that appears on the screen 

 Filters are used to display and browse a selected list or subset of records. 

 The records that satisfy the condition are displayed and that do not satisfy the  

 condition are hidden from the user 

Editing the database 

 Editing is a process of performing corrections, deleting the fields or records, 

 adding new fields or records, changing the format of the database. 

Report generation 

 You can generate any kind of report from the data stored in a database. 

 Eg: generate a report of all the students who scored less than the minimum marks. 

Write a note on different types of database types 

Based on the structure database can be classified as 5 types 

Flat File Database 

 A database file that consists of a single table is called a flat file database. 

 Flat file database are useful for single user or small group situations. 

 Flat file database do not allow complex requests. 

 Eg: spreadsheets – used for maintaining address list or inventories 

Relational Database 

 A relational database structure is made up of related tables 

 In a relational database one or more common fields from two or more tables 

 create a relationship between the tables. 

 The common fields are called keys. 

 Eg: relational database is most common in business organizations 

Hierarchical Database 

 In hierarchical database records are organized in tree like structure by type. 

 The relationship between the record is said to be parent-child relationship, where 

 any child can relate to only single parent type 

 eg: hierarchical database are used in main frame computers. 
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Network database 

 They are similar to hierarchical database 

 Here any one record type can relate to any number of other record types 

Object oriented database  

An object oriented structure is an newer structure that groups data items and their associated characteristics, 

attribute and procedures into complex requests. 

An object is defined by its characteristics, attributes and procedures 

An objects characteristics can be text, sound, graphics, video etc. 

Attributes are colour, size, style, price etc. 

Procedure refers to processing that can be associated to the object 

 

Chapter 8 

Multimedia 

2 marks 

 Differentiate between JPEG and GIF file format 

 GIF and JPEG formats compress static bitmap images 

JPEG 

 This format uses a complex 

technique to compress the 

images where  the color of 

each pixel is different. 

 JPEG – stands for Joint 

Photographic experts group – 

these image files are  a lossy 

format. 

 This supports full color and 

produces relatively small file 

size. 

GIF 

GIF creates a perfect 

reproduction of the 

original. 

GIF- stands for Graphic 

Interchange Format – it 

uses 8-bit color pallete. 

It is used for storing simple 

images with few colors. 

GIF images support 

animation. 

 

What is multimedia 

 Multimedia is a computer based presentation technique that incorporates text, graphics, sound, animations and 

video elements. 

Multimedia applications are being used in a variety of different fields like education, research, entertainment etc. 

 

List some of the applications of multimedia 

 MMS – multimedia messaging system allows you to send and receive messages over cell phones includeing 

music, ringtones videos etc 

 The most common multimedia packages in education are  

                        CBT – computer based tutorial  

                        WBT – Web based tutorial 

 The various multimedia components are coordinated with a technique called virtual reality 

 Multimedia applications are also widely used in the fields og medicine, engineering and scientific research. 

 

What are the different types of 2D animation 

 Animations are used to illustrate or demonstrate an concept. 

 2D animations are classified as cell-based and object based animations 

 Cell Based 

 These consists of multiple drawings. 

 When displayed in a rapid sequence these drawings appear to Move 

 Object Based 

o They are also referred as slide or path animations created by moving an object across a screen. 

They are used in computer games. 

 

Explain the steps involved in creating a 3D animation 

The 3 steps involved in creating a 3D animation are 

 Modeling  - first create the broad shapes & structures of the 3-D objects. 

 Animating – Animate these objects by defining the motions. 

 Rendering  - Render these objects by giving them attributes, colors & textures            

 

What is compression and what are the types of video compression 
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 Compression is a technique by which a recurring set of information is identified and replaced by a single piece of 

information. 

 The 2 types of compression are  

 Lossless Compression – Retains the exact image throughout the compression 

 Lossy Compression – Provides a comparatively higher ration of compression but results in loss of quality 

 

What is CBT & WBT 

 CBT – Computer based tutorials 

 WBT – Web based tutorials 

 These two are self paced learning aids that are available on CD-ROMS or internet.  

 These are used to cover a wide range of topics including orienting new employees, training the employees on new 

software applications. 

 

What is inline sound & video 

 When sound or video is included as a part of the web page then it is called as inline sound or video. 

 The disadvantage of using this is it plays automatically whenever the web page is loaded. 

This can be added to the web page using the <bgsound> and <img> tags. 

 

Write a note on different types of file formats 

 
Format Expansion Year & 

Developer 

Extension Description 

MIDI Musical 

Instrument 

Digital 

Interface 

1982 .midi  or .mid Used for transferring music information between 

music devices like synthesizers & sound cards. 

It contains only digital notes. 

RA /RV Real Audio / 

Real Video 

1995 by real 

networks 

.rm  or .ram Popular for transfer of data over internet. 

Streams files over internet connections 

AU Audio  .au Sound format supported by popular software’s across 

different platforms. 

AIFF Audio 

Interchange 

File Format 

Apple .aif  or .aiff Not supported by all web browsers or cross-platform. 

SND Sound Apple .snd Not supported by all web browsers or cross-platform. 

Wave WAVE  IBM and 

Microsoft 

.wav Most popular format supported by Windows operating 

system. 

MP3/MPEG Moving 

pictures 

experts group  

Moving 

pictures 

experts group 

.mpg  or .mpeg 

.mp3 or .mpga 

(audio) 

MPEG was developed for video files & PM3 is used 

to store sounds. They offer high compression  

AVI  Audio video 

interleave 

Microsoft in 

1992 

.avi Common format on internet & supported by windows 

os. 

Windows 

media format 

 

 

 

Microsoft .wmv This requires installation of additional components in 

non-window computers. 

Quick time 

format 

 Apple .mov To store videos.  Requires installation of additional 

components in non-window computers. 

Shock wave 

format 

 Macromedia .swf Stores multimedia components created using flash. 

Needs extra component to play.  

 

 

 

 

Volume II 

C++ 
 

Chapter 2 

2 marks 

 

What are pointer variables 

 A pointer is a variable that holds the memory address 

 Pointers provide a mean through which the memory location of a variable are directly accessed 

 There are two types of pointers  -  address of (&) and value at (*) 

 Address of Operator reserves the space in the memory and associates the variable name with the 
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memory location 

 Value at Operator is used to declare pointer variables and to display the contents stored in the 

memory location. 

Define Type cast give example 

 Type cast refers to the process of changing the data type of the value stored in a variable 

 Type cast is achieved by prefixing the value or variable with the required data type 

 Syntax    (datatype) <variable/value>        eg:   8%(int)7.7 

What is Size of Operator 

 Size of operator returns the size of the variable or data type in terms of bytes 

 Syntax    size0f(value/variable)             eg: sizeof(long int )   = 4bytes 

Explain ternary operators (or conditional operators )with example 

 A ternary operator is also called as conditional operator 

 The general syntax is  E1 ? E2 : E3  - where e1, e2 and e3 are operands 

 Eg:  max=(num1>num2) ? num1 : num2.  

Write a note on storage classes 

 Storage classes is another qualifier that can be added to variable declaration 

            The four storage specifiers are 

 Auto 

                    Defined local to the block. They are also called as auto variables 

 Static 

                     Static allows the variable to exist in the memory even if the block looses its  

                     Scope. This modifier retains the last assigned value 

 Extern  

                    Global variables known to all the functions in the current program 

 Register 

                     This modifier instructs to store the variable in the CPU register to optimize  

                     Access 

What is the use of void type 

 Void type indicates that a function returns nothing (it holds nothing) 

 It is used to declare a generic pointer 
 

Chapter 5 

2 marks 

Define arrays and explain its types (syntax & example – must) 

 An array is a collection of variables of the same type that are referenced by a 

common name 

 There are two types of arrays 

Single dimensional array 

                 Comprises of finite homogenous elements 

                  Syntax :   

                                 Data type  array_name [size]; 

                  Eg: 

                                 int  a[10]; 

Multi dimensional array 

                 Comprises of elements each of which is a one dimensional array 

                  Syntax :   

                                 Data type  array_name [row][column]; 

                  Eg: 

                                 int  a[3][4]; 
 

Write a note on member function of standard input and output stream 

  Input stream  

 getline() is a member function of standard input stream 

 gets() is a member function of stdio.h       syntax  gets(char *); 

 Eg:   cin.getline(char*, no of characters, delimiter); 

   Output stream 

 write() is a member function of standard output stream    
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eg:  cout.write(char*, number of characters) 

 

Explain the string manipulators defined in string.h 

 strlen(char*)  -     returns the number of characters stored in the array 

 strcpy(char* ,char* )  -  copies the source string to the destination) 

strcpy(n1,n2) – n2 is copied to s1 

 

 strcmp(char *, char*)  -  compares two strings and returns 0 if both the strings are  

equal, will return a value > than 0 if string 1 is greater than the 2nd and will return a   

value < than 0 if string 1 is lesser than string2        
 

How is memory representation of 2-D arrays done 

 A 2-D array is stored in a sequential memory blocks.  

The elements are  stored 

 Row-wise manner – row major order 

 Colum-wise manner – column major order    eg : page no 138 
 

Chapter 6 

2 marks 

 

Write about the specification of a class 

 A class is a way to bind the data and its associated functions together.  

 A class specification has 2 parts: 

 Class declaration  

 Class function definition 
 

What is a class & give the general form of declaring a class 

 A class is a way to bind the data and its associated functions together.  

General form: 

      class class_name 

     { 

               private : 

                     variable declaration 

                     function declaration 

               protected : 

                     variable declaration 

                     function declaration 

             public : 

                     variable declaration 

                     function declaration 

    }; 
 

Write a note on the access specifiers of a class 

 The three access specifiers of the class are  

 Private :   accessible by only its own members and special 

 functions called friend functions 

 Protected : accessible by the members of inherited class 

 Public :   accessible by other members, class members  

                                  and objects          

What is data abstraction 

 Instruments allowing only selected access of components to the objects and members of other 

classes is  

 Called data abstraction which is achieved through data Hiding. 

What does a class consist of ?  

 A class comprises of members. Members are the data members and member functions. 

 Data members are the variables that represent the properties of a class, they are also called as 

attributes. 
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Member functions perform some specific task on the data. They are also called as methods. 
 

How would you access the members of a class 

 The members of the class can be accessed using the object and the dot operator.  

 The private data of a class can be accessed only through the member functions or certain special 

functions called friend functions. 

Eg: 

  Stud.execute(); .............->    member function 

          ^ .......... dot operator 

   ^............................. object  

 

How is memory allocation done to objects 
 No separate space is allocated for the member function when the objects are created.  

 Memory space required for the member variables are allocated separately for each object 

because the member variables will hold different data values for different objects. 

What are static data members 

 The static data members are initialized to 0 only once when the first object of the class is 

created. 

 Only one copy of the static variable is created and is shared by other objects 

 The scope of the static variable is within the class but the lifetime is the life time of the program 
 

 

Chapter 9 

2 marks 

 
What are the advantages of inheritance 

 Reusability of code 

              Code developed for one application can be used in another 

  Code sharing 

             The methods of the base class can be shared by the derived class 

 

 Consistency of interface 

         the inherited attributes and methods provide a similar interface to the calling methods 

 
What are abstract classes 

 Classes used only for deriving other classes are called as abstract classes. 

Objects for these classes are not created 

 

What are base and derived classes 

 A base class is a class from which other classes are inherited. 

The derived class inherits all the properties of the base class and is a power packed class as it can add 

additional attributes and methods. 

 
How are derived classes indicated 
class derivedclass_name  :  visibility mode baseclass_name 

{                                                                             

           data members of derived 

           member functions of derived 

} 
 
Chapter 10 , 11 ,  12 

2 marks 
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List the benefits of IT to reach the common man 

 Connectivity – computer networks and internet facility 

 Affordable computers or similar devices 

Software 

 
What is e-banking and e-shopping 

 E-banking permits banking from the comfort of the home by using internet facilities 

E-shopping allows us to purchase any product, any brand from anywhere. The pictures and the details 

are available on the website of the shop. 

 
What is ITES and list some of the ITES services 

 Information technology that helps in improving the quality of the service to users is called IT 

enabled services. 

 These are human intensive services that delivered over telecommunication networks or internet. 

 ITES increases the employment opportunities 

 Services 

                          e-governance 

                          call centers 

                          medical transcription 

                          data digitization 
 
What is e-governance / call centers 

e-governance 

 Computers help us to look at government websites and services provided by them. 

 These government websites give details about the departments, special schemes, contacts etc. 

Call centers 

 A call center is defined as a telephone based shared service center for specific customer 

activities and are used for customer related functions like marketing, information transfer etc. 

 Call center has adequate telecom facilities, access to wide database and other online information 

to provide support to the customers. 

 

 

 

What is medical transcription and list the steps involved in medical transcription 

Medical transcription is a permanent, legal document that formally states the result of a medical 

investigation. The three main steps are 

 Hospitals that want to use this form of ITES sign up with a service provider. The doctors 

dictates into a special device or a free telephone 

 The sound is then digitized and sent to ITES provider. The trained transcriptionists listen to the 

dictation and transcribe. 

The transcribed files are then sent to the quality control person to check the transcription, corrections 

are made, then the reports are transmitted back to the hospital as word document 
 

Write a note on data security 

Personal data is protected by using personal security, personnel security and physical security. 

 Physical security refers to the protection of hardware which are illegally accessed, stolen or 

damaged. 

 Personal security refers to software setups which permits only authorized access to the system. 

Personnel security refers to protecting data and computer against dishonesty or negligence. 
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What is computer crime and list some of them 

 Computer crime is any illegal activity using computer software data or access as the object, 

subject or instrument of  crime. 

 Common crime includes 

                     Hardware & software piracy 

                    Virus 

                    Cracking 

                    Theft of computer time 

                    Stealing hardware 

 
What is computer virus 

 A virus is a self replicating program that can cause damage to data & files. 

 There are 57000 known virus in existence 

 6 new virus are found each day. 

 

What is computer piracy and list the points that tend to pirate 

 making and using duplicate hardware and software is called piracy. We tend to pirate because 

  we like free things , why pay for something when we get it free. 
 

Define cracking 

 Cracking is the illegal access to the network or computer system. 

 Illegal use of special resource is the key reason for cracking. 

 The resources may be hardware, software, files. 

 

What is data digitization 

 Digitization refers to the conversion of non-digital material to digital form. 

Digitization offers great advantages for access allowing users to find, retrieve, study and modify the 

materials. 
 

5 marks 
Chapter 3 

Explain switch statement with a suitable example? 
It is a multiple branching statement where  based on a condition, the control is 

transferred to one of the many possible points. 

Syntax: - 

                   switch(expression) 
         { 

case 1: action block1; break; case 2: action 

block2; break; case 3: action block3; break; 

default: action block; break; 
         } 

Example: - 

#include  <iostream.h> 

#include  <conio.h> 
main() 
{ 

int no; 
clrscr(); 
cout<<"Enter a Number\n"; 
cin>>no; 

switch(no) 
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{ 
case 1:cout<<" Number  is One";break; 

case 2:cout<<" Number  is two";break; case 

3:cout<<" Number  is thre”; break    case 4:cout<<" 

Number  is four";break; default: cout<<" Invalid”;  
} 
} 
Every action block should be terminated with a break  statement. 

Break statement:  

Break statement would exit the current  loop only. 

It accomplishes jump from the current  loop 

Explain Entry-check loop with example?  

While Loop 

While loop is called as the entry-check loop. 
Syntax- 

while (condition) 

{ 

action block 
} 

The body of the while loop will be executed only if the condition is true. 
The control exits the loop once  the condition is evaluated to false. 

Example:- 
 

main() 
{ 
int num=2; 

while(num<6) 
{ cout<<num;  
num++;    
  } 
    } 

 

Explain Exit-check loop with example?  

do….while is called as exit-check loop. 

The condition marks  the last statement of the body of the loop. 
Syntax:- 
do 

{ 

action block 
} while (condition); 
Example:- 

#include<iostream.h> 
#include<conio.h> 
main() 
{ 
int num=2; 

do 
{ 
cout<<num; 

num++; 
} while(num<6); 
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Explain Entry-controlled loop with example?   

 for loop is an entry controlled loop 

 It is used when an action is to be repeated for a predetermined number of 

times. 
Syntax:-   

for(initial value; test-condition; increment) 

{ 

action block 

} 
The control variable  is initialized first. Test 
condition is evaluated. 
The body of the loop is executed only if the condition is true. 
The control variable  is incremented and the test condition will be evaluated before  the 

body of the loop is executed. 
The loop is terminated when the test condition is false 

 
example 

for(int i = 1; i<=10; i++) 

{ 

cout << i*2 <<”\n”; 

} 
 

Chapter 4 

 

Explain the different kinds of loops with example? (above three answers) 

 

Define scope? Explain the different types  of scopes variables in C++? 

Scope refers  to the accessibility of a variable. There  are four types  of scopes in C++. They 
are 
1. Local scope      2. Function  scope 3. File scope          4. Class scope 
 
1. Local scope: - 

It is defined  within a block 
 It is the block in which it is defined. 
 It cannot be accessed from outside the block of its declaration.         
 A block of code  begins and  ends with curly braces { }. 
  It exists only while the block of code  in which they are declared is executing. 
Function scope: - 
It is declared within a function is extended to function block, and  all sub-blocks. 
It is accessible in all the sub-blocks. 
The lifetime of a function scope variable  is the lifetime of the function block. 
The scope of formal parameters is block function scope. 
 File scope: - 
A variable  declared above all blocks and functions have  the scope of a file. 
 The file scope variable  is the entire program. 

The lifetime of a file scope variable  is the lifetime of a program. 
 Class scope: - 
A Class is a way to bind the data  and its associated functions together. 
Classes provide a method  for packing  together. 
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Explain call by value method with an example?  
In this method, the called function creates new variable  to store the value of the arguments 
passed to it. 
In this method copies the value of actual  parameters into the formal parameters. 
The function creates its own copy of arguments and then uses them. 
In this method, the flow of data  is always  from the call statement to the function definition. 

Example: - 
#include<iostream.h> 

#include<conio.h> 
void sawp(int  n1,int n2) 
{ 
int temp; temp=n1; 
n1=n2; n2=temp; 
cout<<n1<<’\t’<<n2<<’\n’; 
} 
main() 

{int m1=10,m2=20; 
cout<<”Before  swap”<<m1<<’\t’<<m2<<’\n’; 

cout<<”Calling swap\n”; 
swap(m1,m2); 
cout<<”Back  to main values are”<<m1<<’\t’<<m2<<’\t’; 

} 
Output:- 

Before swap 10     20 
Calling swap 
20       10 

Back to main values are  10      20       

 

Explain call by reference method with suitable example? 
In this method, the called function arguments-formal parameters become alias to the 
actual  parameters in the calling function. 
The function is working with its own arguments. 

It is actually working on the original data. 
In this method, any change made in the formal parameter is reflected back in the actual  
parameter. 

Example: - 

#include<iostream.h> 
#include<conio.h> 
void sawp(int  &n1,int &n2) 

{ 
int temp; 
temp=n1; 
n1=n2; n2=temp; 
cout<<n1<<’\t’<<n2<<’\n’; 
} 
main() 
{ 
int m1=10,m2=20; 
cout<<”Before  swap”<<m1<<’\t’<<m2<<’\n’; 
cout<<”Calling swap\n”; 
swap(m1,m2); 
cout<<”Back  to main values are”<<m1<<’\t’<<m2<<’\t’; 
} 
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Output:- 

Before swap  10     20 
Calling swap 
20     10  

Back to main values are  2 0       10 
 
 

 

Explain Inline Functions with an example?  

When the functions are small, the compiler replaces the function call statement by its 

definition ie, its code  during program execution. This feature is called as inline function. 
 An inline looks like a normal function in the source file but inserts the function’s code  directly 
into the calling program. 
Inline functions execute faster  but require more memory space. 
Reusability of code  leading to saving  of memory  space and reduction in code  size 

Example: (To see Page.No.113) 

 

Chapter 8 

Write down the rules for Constructor & Destructor definition and usage 

Constructor 

 When an instance of the class comes into scope a special function called constructor is 

executed 

 The name of the constructor must be the same as the class name 

 A constructor can have parameters 

 The constructors can be overloaded 

 The constructor is executed automatically 

 In the absence of a user defined constructor the compiler generates a constructor 

         Destructor 

 A destructor is a function that removes the memory space allocated by the constructor 

 The destructor has the same name as the class name prefixed by the tilde ‘ ~ ‘ symbol 

 The destructor cannot have arguments 

 The destructor cannot be overloaded, hence there can be only one destructor in a class 

 In the absence of a user defined destructor the compiler generates a destructor 

The destructor is executed automatically when the control reaches the end of the class scope 

 

Chapter 9 

 
Write a note on different types of Inheritance with example 

 The process of creating new classes from already existing classes is known as inheritance 

 There are 5 types of inheritance 

Single level, Multilevel, Multiple, Hybrid & Hierarchical 

 Single  Inheritance 

When a derived class inherits from only one base class it is called as single level inheritance 

Eg: 

 

 

 

 

 

 

 

 

 

Base Class  - Employee 

Derived Class  - Manager 
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 Multiple Inheritance 

When a derived class inherits from many base classes it is called as multiple inheritance 

 

 

 

 

 

 

 Multi Level Inheritance 

The transitive nature of inheritance is reflected by this type of inheritance. 

When a class is derived from a class which is a derived class itself is called as multilevel 

inheritance 

 

 

 

 

 

 

 

 

 

 

What is accessibility? Explain about the visibility mode. 

 

To know when a member of a base class can be used by the objects or the members of the derived class 

is called as accessibility. 

BaseClass 

members 

Derived class 

 

 

Private members  

Private  Protected  Public 

Are not inherited 

but they continue 

to exist 

  

Protected members Inherits protected 

as private members 

Inherits protected 

as protected 

members 

Retains protected 

as protected 

members 

Public members Inherits public as 

private members 

Inherits public also 

as protected 

members 

Retains public as 

public members 

 

Chapter 7 

What are the rules for overloading operators? 

 Only existing operators can be overloaded. New operators cannot be created 

 The overloaded operator must have at least one operand of user defined type 

 The basic definition of an operator cannot be replaced 

 Overloaded operators behave in the same way as the basic operators in terms of operands 

 When binary operators are overloaded , the left hand object must be an object of the relevant 

class 

 Binary operators overloaded through a member function take one explicit argument. 

 

Base Class  - Employee 

Derived Class  - Manager 

Base Class  - Grand Father 

Derived Class  - Father 

Derived Class  - Child 
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CHINMAYA VIDYALAYA HIGHER SECONDARY SCHOOL 

Virugambakkam – Chennai 92 

Volume II – Model Paper  

 

Subject:   Computer Science      Marks : 150 

                   Time   :  3 Hrs 

 

I  Choose the correct Answer         75 X 1 = 75 

1. In early programming languages the input and output data items were 

represented as 

a) text  b) data  c) variables  d) information 

2. The solution of a problem was viewed as two separate segments _______ and 

_______ 

a) data, operations   b) data, instructions          

c) variables, instructions  d) none of these 

3. Which data types allows programs to organize as objects that contain both 

data and functions 

a) derived  b) class c) structure  d) all of these 

4. Which concept of C++ promotes and reduces software complexity  

a) Inheritance b) class c) polymorphism d) object 

5. Which models the real world entities 

a) object  b) functions c) polymorphism d) encapsulation 

6. The term C++ was coined by  

a) Dennis Ritchie b) Bjarne Strousstrup    c) Rick Mascitti d) Tannenbum 

7. This is the smallest individual unit in a program 

a) keywords b) token  c) element  d) identifiers 

8. These are data items whose values cannot be changed. 

a) string  b) variables  c) keywords  d) constants 

9. A sequence of digits starting with 0x is called as  

a) integer         b) constant          c) octal constant         d) hexadecimal constant 

10. This is not a C++ keyword  

a) friend  b) new  c) cin   d) this 

11. These are executed in the order of precedence 

a) operators b) operands  c) statements  d) all of these 

12. Which operators have lower precedence than the arithmetic operators 

a) binary  b) logical  c) relational  d) unary 

13. A ternary operator is also called as 

a) logical  b) conditional  c) assignment  d) none 

14. Which are characters with a specific functions 

a) escape sequence b) punctuators  c) keywords d) all of these 

15. The major category of control structures are 

a) break & continue  statements  b) loops structures  

c) decision & looping statements  d) relational statements 
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16. This data type helps in creating a list of identifiers also called as symbolic 

numeric constants 

a) enumerated    b) type def         c) derived  d) structures 

17. Which qualifier can also be added to variable declaration in addition to its 

type 

a) modifiers b) storage class c) keywords  d) all of these 

18. Memory size of 640kb will have address commencing from NULL and goes 

upto ___ 

a) 655,358  b) 655,356  c) 655,355  d) 655,340 

19. The long int, signed long int has ________ bytes 

a) 2  b) 4   c) 8   d) 10 

20. The ____ operator  reveals the hidden scope of a variable 

a) ::  b) %   c) #   d) * 

21. Parameters associated with function header is called ___________ parameters 

a) function  b) actual   c) formal   d) all of these 

22. How many elements are stored in an array of int x[][2]={0,1,2,3} 

a) 2  b) 4   c) 5   d)6 

23. In a 2D character array which of the following determines the length of the 

string 

a)Rows  b) first index  c) colum  d) last index 

24. Every action block in a switch case structure should be terminated with a ____ 

statement 

a) control  b) switch  c) input/output  d) break 

25. The _____ loop is an entry controlled loop and is used when an action is 

repeated for a predetermined number of times 

a) while  b) for   c) continue  d) a (&) b 

26. ______ creates object file from the source code 

a) computer b) compiler  c) assembler  d) interpreter 

27. There are ____ storage specifiers 

a) 6  b)5   c)4   d)2 

28. An integer array with index 0 to 5 should be declared as  

a) int x[]={5} b) int x[5]  c0 int x[0]={6} d) int x[6] 

29. Which statement is not related to functions 

a) the actual parameters can be passed in the form of constants to 

the formal parameters of the value type 

b) the actual parameters can be  passed only as variables to formal 

parameters of reference type 

c) the default value in the formal parameters can be given in the 

form  of variable initialization 

d) the default argument can be given in between the argument list 

30. if int x = 15 / 4 what is the value stored in x ? 

a) 2  b) 3   c) 2.5   d) 3.5 

31. The special characters like tab, back space and line feed are called as ____ 

character constants 

a) graphic  b) non-graphic  c) string  d) null 
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32. When an object is passed by reference to a constructor which of the following 

constructor is executed? 

a) default      b) parameterized     c) copy d)non-parameterized 

33. Classes used only for deriving other classes are called _______ classes 

a) concrete  b) abstract  c) friend  d) inherited 

34. Which of the following statement is not true 

a) member functions can be of static type 

b) several different classes can use the same function name 

c) the return type of the member function cannot be of static type 

d) a non-member function cannot access the private variables 

35. Class specification has ____ parts 

a) 2  b) 4   c)3   d) 5 

36. When the objects of a class are created separate memory is allocated for 

a) member functions only 

b) member variables only 

c) both member variables and member functions 

d) neither member variables or member functions 

37. The operator functions must be either ________ or _________ functions 

a) inline or friend functions 

b) member or friend functions 

c) binary or relational functions 

d) overloaded or inline 

38. The initial value to a static member variable is done _________ the class 

a) outside  b) inside  c) once in   d) by object of 

39. The private data of the class can be accessed only through the 

a) member function b) friend function c) abstraction d) either a or b 

40. The member of the class can be accessed through the _____ operator 

a) *  b) .  c) ::  d) .-> 

41. The return type of the ________ function may or may not be the same 

a) destructor b) constructor  c) member  d) friend 

42. When an instance of the class comes into scope a special function called 

______ is executed 

a) inline  b) friend  c) member  d) constructor 

43. The constructor defined in the absence of user defined constructor is called 

a) default    b) compiler generated    

c) non-parameterized  d) none of these 

44. Which is the most powerful feature of an object oriented programming 

a) encapsulation  b) inheritance  c) classes d) functions 

45. A ____ class is a class from which other classes are derived 

a) inherited  b) abstract  c) base  d) derived 

46. When a base class is inherited with private visibility mode the public and 

protected members become  

a) protected  b) public  c) private d) inherited 

47. There are ________ types if inheritance 

a) 3  b) 4  c)5  d) 6 
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48. The _______ of the base classes are not inherited but executed in order of 

inheritance 

a) members  b) constructors  c) static data  d) all of these 

 

49. The default visibility mode is ________ 

a) pivate  b) protected  c) public  d) friend 

 

 

Read the following program and answer the questions from 50 to 53 

#include <iostream.h> 

class minus 

{ 

 int  i; 

 public: 

 void accept() 

 { 

  cin >> i; 

 } 

 void display() 

 { 

  cout << i ; 

 } 

 void operator – () 

 { 

  i = - i; 

 } 

}; 

void main() 

{ 

 minus n ; 

 n.accept(); 

 n.display(); 

} 

 

50. Identify the operator that is overloaded 

a) +  b) =  c) -  d) = - 

51. The prototype of the overloaded member function is  

a) negative operator – ()  b) void operator minus() 

c) void operator – ()  d) void operator minus(- negative) 

52. Which statement invokes the overloaded function? 

a) minus n  b) - - n  c) – n   d) -i 

53. The scope of the operator overloaded function is  

a) private  b) public c) static d) protected 

54. Which of the following statement is wrong 

a) class b : public class A 

b) class b : public A 
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c) class b ; public A 

d) both a & c 

55. With respect to inheritance which of the statement is true 

a) private members of the base class are inherited to the derived 

class with private accessibility 

b) private members of base class are not inherited to the derived 

class with private accessibility 

c) public members of the base class are inherited but not visible to 

the derived class 

d) none of the above 

56. Which refers to protecting data and computer system against dishonesty and 

negligence of employees 

a) physical security  b) personal security 

c) personnel security  d) medical security 

57. The unit that enables data storage and management is 

a) Archives b) Emotion containers        c) Ware housing        d) none  

58. India has ______ to prevent the computer crime 

a) Indian penal code b) Cyber laws  c) zero laws      d) penality 

59. The illegal access to the computer hardware and software is ____ 

a) hacking  b) cracking         c) data piracy      d) computer crime 

60. CBT stands for  

a) computer based training  b) computer based tools 

c) computer based tutorials  d) coded binary tools 

61. BPO stands for 

a) business publication online  b) business process outsourcing 

c) business publication outstanding d) business processing online 

62. A self replicating program that causes damage to data and files stored on the 

computer is  

a) virus  b) anti virus  c) language  d) cracking 

63. Which is the easy means of interaction with other  people through touch 

screens, scanner and microphone facilities 

a) memo frame b) book shelf  c) archive units d) Karo-ke 

64. A facility that allows the user to speak into a special device while typing a 

letter using a computer is ________ 

a) cell phone b) telephone  c) Dictaphone  d) speaker 

65. The 2 dimensional table nm[‘A’][‘E’] has how many number of rows and 

columns 

a) 97, 101  b) 3,3   c) 65,69  d) none 

66. A C++ program has how many sections 

a) 2  b) 3   d) 4   d) 5 

67. Find the value in the given expression  1 + pow(3,2) *[(3+2)*(8-7)+2] 

a) 55  b) 23   c) 64   d) 13 

68. Range of char data type is  

a) -128 to 127 b) 0 to 255   c) -127 to 128 d) -32767 to 32768 

69. The modifier that defines the local variable to its block 

a) auto  b) extern  c) register  d) local 
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70. The functions that return no value is called as 

a) null  b) static  c) public  d) void 

71. Which  are the building blocks of C++ programs 

a) classes  b) functions  c) inheritance  d) data hiding 

72. What is the value stored in x if  a = 10, b=10 ;  x = (a<b) ? a * b : b % a 

a) 0  b) 1   c) false   d) 100 

73. Determine the output of the following program 

#include <iostream.h> 

void main() 

{ 

 char  ch [] = {‘a’,’b’,’c’,’d’}; 

 for ( int i = 0; i< 4; i ++ ) 

  cout<<ch[i]; 

for ( int i = 3; i>= 2; i -- ) 

  cout<<ch[i]<<”\t”; 

a) abcd dcba b) a b c d d c b a c) abcdd   c  d) abcddc 

74. What is the output of the following program 

#include <iostream.h> 

void main() 

{ 

 char  ch[] = “END”; 

 cout<<ch; 

} 

a)END  b) E   c) 0    d) error 

75. Find the size of the array   -  float num[4][6]  

a) 24  b) 96   c) 10   d) 48 

     

II Answer Any Twenty of the Following                  10 X 2 = 20 

76. What is ITES 

77. What is a computer Virus 

78. Write a note on Medical Transcription 

79. What is computer crime 

80. How are derived classes indicated? 

81. Write about the access specifiers of a class 

82. What are the functions of a constructor? 

83. How are functions invoked in function overloading 

84. When do the copy constructors get executed? 

85. Define an object and give its significance 

86. Distinguish between break and continue statement 

87. What are pointer variables and explain its types 

88. What are modifiers and write the impact of C++ modifiers 

89. Explain type definition and enumerated data types 

90. Write down the advantages of using functions 

91. Write a note on different storage classes in C++ 

92. Write the output of the following 

for ( int i = 1, x = 0; i<=5 ; i ++ ) 

www.Padasalai.Net                                          www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 x =  x + i % 2 = = 0 ? i * 1 : i * -1 ; 

cout x; 

93. How is memory representation done for 2D arrays 

94. Evaluate the following expression     where  x and y are integers and have 

values 2 & 3 respectively 

a) x – 2 % y +2 

b) y ++ / x -- 

95. Determine the order of evaluation 

a) ( c = = d ) && ( y = = ‘y’ ) || (choice ! = t) 

b) a < b && c || d > a 

96. What is the output of the following code 

#include <iostream.h> 

void main() 

{ 

 clrscr(); 

 int bool = 2 , b = 4; 

 while ( bool) 

 { 

  cout<<bool << “\t”<< ++b << “\n”; 

  bool -- ; 

  b -- ; 

 } 

} 

97. What are inline functions 

98. Write down the string manipulators defined in string.h 

99. Discuss the types of arrays with its syntax 

100. What are the advantages of inheritance 

 

III Answer any Seven questions                7 X 5 = 35 

101. Explain the different types of loop structures with suitable examples 

102. Write a note on the different scopes of variables by giving examples 

103. Explain switch case structure with its syntax & give an example 

104. Explain the methods of passing parameters to functions 

105. Define a class, give the general declaration and explain the points to know 

when declaring a class 

106. Explain function overloading with an example 

107. List out the rules for Operator overloading and Function overloading 

108. Predict the output of the following program 

#include<iostream.h> 

class  base 

{ 

 public : 

  base() 

  { 

   cout<<”\n in constructor of base “; 

  } 
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  ~base() 

  { 

   cout<<”\n executing the destructor of base “; 

  } 

}; 

class  derived : public base 

{ 

 public : 

  derived() 

  { 

   cout<<”\n in constructor of derived 1 “; 

  } 

  ~base() 

  { 

   cout<<”\n executing the destructor of derived 1 “; 

  } 

}; 

class  derived2 : public derived 

{ 

 public : 

  derived2() 

  { 

   cout<<”\n in constructor of inherited class “; 

  } 

  ~base() 

  { 

   cout<<”\n executing the destructor of derived2 “; 

  } 

}; 

void main() 

{ 

 derived2  obj; 

} 

 

109. Debug the following program to get the output 

constructor 1 

constructor 2 

The Numbers are 5 and 50 and the sum is 55 

#include<iostream.h> 

class  addition 

{ 

 Int n1, n2, sum = 0; 

 addition () 

{ 

 cout<<”\n constructor 1”; 
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 n1=0;         n2=0;          } 

addition (int x,y) 

{ 

 cout<<”\n constructor 2”; 

 n1 = n2 = x; 

} 

addition (&a) 

{ 

 cout<<”\n copy constructor”; 

 void add() 

  { 

 sum = n1 + n2  

} 

 void  put() 

  cin>>the numbers are ; 

  cout<<n1<<n2: 

 } 

}; 

Main [] 

{ 

 Addition  a, b(5,50) 

 add(); 

 a.put(); 

}} 

 

110. Read the following program and answer the questions given below 

class vehicle 

{ 

 int  wheels; 

 public : 

  int x; 

  void input( int , int); 

  void output ( ); 

 protected : 

  int pass; 

}; 

class  truck : protected vehicle 

{ 

 int  petrol; 

 protected : 

  int  load; 

  void get( ); 

 public : 

  int  speed; 

  void read ( int, int ); 

  void write( ); 
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}; 

 

 

class  car : private truck 

{ 

 private : 

  char name[20]; 

  int  size; 

 public : 

  void fetch( char ); 

  void  display( ); 

 protected : 

  char colour ; 

}; 

 

a) Name the base class and derived class of the class truck 

b) Name the data members that can be accessed from the function display( ) 

c) Name the data members and the member functions that can be accessed by 

the object of  car class 

d) Are the variables of vehicle class accessible to the objects of car class  

give reasons 

e) Name the members that are accessible by the object of the  truck class 

 

   

www.Padasalai.Net                                          www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



COMPUTER SCIENCE – VOLUME I – CHAPTER 1 TO 9 
2MARK, 5 MARKS QUESTION & ANSWER

Chapter 1
2marks

1.What is meant by Text Editing
 Entering a new text or modifying the existing text in a document is known as text editing. 
 The common text editing features are cut, copy, find and replace.

2.How would you select the required portion of the text in a document
     Text can be selected in 3 ways
     Using Mouse

 Insertion point is moved to the start of the text.
 The left mouse button should be clicked, hold down and dragged across the text.
 Release the mouse button – the text is selected

    Using Keyboard
 Place the insertion point at the start of the text
 Hold the shift keys and use the movement keys to select the text
 When the text is selected release the shift key

   Using Shortcuts
 Click Ctrl + A  to select the entire document
 Double click on a word to select a word
 Click once next to the line to select a line

3.How would you switch over between insert and type over mode
 When the user is in insert mode the new text will be inserted and the existing text moves to the right.
 When the user is in the type over mode the new text is inserted and the existing text disappears.
 The user can toggle between the insert mode and type over mode using the insert key.
 The status bar shows the information about the current mode.

4. What is meant by word processing
The term word processing refers to the activity carried out using a computer and suitable software to create, view, edit, 
manipulate, transmit, store, retrieve and print documents.

5 marks

1. What are the steps to be followed in Finding and replacing a text
 To search for a word and replace it star office writer uses the Find and Replace option
 Click on Edit -> Find & Replace 
 Find and Replace dialog box appears, in the Search For box type the word to be found, in the Replace 

with box type the word to be replaced.
 Click Replace button to replace the current instance
 Click Replace All button to replace all the instances
 To skip the search click Find once again
 To finish the search click Ok button

Chapter 2
2 marks

1.   What is meant by indenting the text
 To make a long document easy and inviting to read indenting can be done to each paragraph. 
 Setting off the paragraph from the main body text is called as indenting the text.
 To Indent a paragraph one can click the increase indent icon – each time the user presses the icon the paragraph 

moves ½ inch from the left margin.
 If one wants to remove the indent the decrease indent icon is clicked.

2.  What is meant by hard formatting and soft formatting
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Hard formatting
 Formatting done manually is called as hard formatting. 
 Each time the user presses the enter key it is followed by a hard return.

Soft formatting
 Formatting done by star office writer is called as soft formatting.

Soft returns are inserted as line breaks by star office writer when a text is inserted or deleted.

3. How is formatting done with respect to fonts
A font is a set of characters and numbers in certain style.
Font size

 The size of the font in measured in points – 72 points make an inch
 To change the font size the command format->character is used & from the character dialog box the font is 

selected.
Font color

 To use a different text color, select the text & click font color icon 
 From the color palette the required color is selected.

Font style
 To change the style of the font use format->character 

From the character dialog box choose required font from the fonts combo box.

4. What are the 4 paragraph alignments
     The four types of paragraph alignments are

 To left align the text    -   ctrl+L
 To right align the text    -  ctrl+R
 To justify align the text    -  ctrl+J
 To center align the text   -   ctrl + E

5. How is formatting done with styles
 This is an alternative way of formatting the text.
 A style is a named set of defaults.
 Styles need more advanced planning.
 The style needs to be created initially only then it can be applied to the text using the typeface list.

5 marks
1. How would create a bulleted and numbered list

Bulleted list
 One way to set off a list of points in a documents is to create a bulleted list.
 The fastest way to create a bulleted list is to use the bullets icon on the formatting tool bar.
 Select the text for which the bullets has to be added.
 Click on the bullets icon from the formatting tool bar
 Star office writer will add bullets to each paragraph & any blank line within the selection.

Numbered list
 For items to appear in a specific order like series of steps one can create a numbered list.
 Select the text to be numbered.
 Click on the numbered list icon.
 Star office writer adds the numbers automatically & also indent the paragraph.
 Blank lines within the selection also will be numbered.

Remove bullets & numbers
 To remove bullets & numbers from a list, select the list & click the bullets or numbered icon once again.

2. What does indenting the text mean
 Indenting the text improves the readability of the document.
 Setting off the paragraph from the main body text is called as indenting the text.
 To Indent a paragraph one can click the increase indent icon – each time the user presses the icon the paragraph 

moves ½ inch from the left margin.
 If one wants to remove the indent the decrease indent icon is clicked.
 If one wants special kind of indenting paragraph dialog can be used
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 Select Format->Paragraph, Paragraph dialog box appears
 Click Indents & Spacing Tab
 To move the paragraph towards the right type the value to be indented in the Before Text Spin box
 To move the paragraph towards the left type the value to be indented in the After Text Spin Box
 First line of the paragraph can be indented using First line option, Negative value in the first line option will 

result in Hanging Indent, the paragraph will hang outside the margin.

Chapter 3
2 marks

1. What does automatic spelling correction mean?
 Star office writer recognizes some common misspelling & typographical mistakes & makes the replacement 

automatically.
 For eg; if a word is typed as ‘teh’ it is automatically corrected to “the”.

 Star office writer has automatic spell-check feature which checks for spelling mistakes  when the document is being 
typed.

 This feature can be turned on by clicking the AutoSpellcheck icon ON or OFF.
 When the autospell check feature is on star office writer compares the word typed with the words in the dictionary & 

under lines the misspelled word with a red squiggly line.

5marks

1. What is Autocorrect option? How would you add a word in the Auto correct list box
 Star office writer automatically corrects some spelling mistakes
 Star office writer recognizes common misspellings and typographical mistakes and makes the replacement 

automatically
 For eg :  if a word is typed as “teh”  star office writer automatically corrects the word as “the”
 In addition to this one can also add the other words to the list.
 Choose Tools -> Autocorrect
 Autocorrect dialog box appears.
 In the replace tab type the word to be replaced in the replace text box
 And the replacement word in the with text box
 Click replace / add button to add in the auto correct list box

2. How would you correct the spelling mistakes after the document is typed
 Click on Tools->Spelling->check
 Alternatively F7 key is also pressed 

 Click the   spell check icon – spell check dialog box appears
 Not in Dictionary text area displays the misspelled words
 Suggestion list displays alternative spellings
 To skip the current occurrence click Ignore once button
 To skip all the occurrences click Ignore all button
 To replace the current occurrence click Change button
 To replace all the occurrences click Change all button
 Correction can be done manually in the Not in Dictionary area if none of the replacement is correct.
 Add button is clicked to add the word in the dictionary

Chapter 4
2 marks

1. How would you create table in Star Office Writer
 Click on Table -> Insert -> Table
 Table dialog box appears
 Specify the number of rows and columns in the row, column spin box
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 Star office writer displays the table as a  grid of cells

2. How would you add a required number of rows and columns in a table
 The easiest way to add a row is to press the tab key (will add one row at the last)
 To add more number of rows and columns click on

1. Table -> insert -> rows  or Table -> insert -> columns
2. To add a row / column  click on the insert row / column icon on the table formatting tool bar

4. How would you make the selected rows and columns of the same size
 Select the row and right click on it – choose Row -> space equally from the  pop Up menu
 Select the column and right click on it – choose Column -> space equally from the Pop up menu

5 marks

1. What are the various functions of the icons of the table formatting tool bar

The function of each icon in the toolbar is indicated below:
- Table Fixed
- Table Fixed, Proportional
- Table, Variable
- Merge Cells - This icon is used to combine two or more cell into a single cell.
- Split Cells - This icon is used to split a cell into two or more cells.
- Optimise - Clicking on this icon displays a pop up menu with options like Space columns equally, Space rows equally, 
Optimum row height and Optimum column width.
- Inserting Row - This icon is used to insert a row below the current row.
- Inserting Column - This icon inserts a column to the right of the current column.
- Delete Row - This icon deletes the current row from the table.
- Delete Column - This icon deletes the current Column from the table.
- Borders - This icon displays a floating toolbar with different border option   for the table.
- Line Style - This icon is used to choose the style of line to be used for the border.
- Border Colour - Clicking on this icon displays a palette of colours that can be  used as a border  colour for the table.

Chapter 5
2marks

1. What is meant by page formatting
 Changing the page orientation, setting the margins, inserting header and footer in a document is called 

page formatting

2. What are the two types of page orientation
 The two types of page orientation are Landscape & Portrait
 When the length of the document is more than the width then the orientation is said to be portrait
 When the width of the document is more than the length then the orientation is said to be landscape
 Portrait is the default orientation. 
 Most of the documents are printed in 8.5 inch by 11 inch paper.
 Page orientation can be changed using the radio buttons

3. How can the ruler be used to change the margins
 If the user is not having the exact values for the margin then
 Click View -> Ruler option to display the ruler
 The gray area indicates the margins top area
 The mouse pointer is moved between the gray and white area, when the pointer changes into a line
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 The margin guide is dragged it to a new position

4. What is meant by header and footer
 Header is the area at the top of the document
 Footer is the area at the bottom of the document
 Header and footer are some reference remarks added at the top and bottom margins of every page

5.  How can the margins be changed using the page style dialog box
 If the user knows the exact value for the margins then the page style dialog can be used
 Click Format -> Page, page style dialog appears
 Click the page tab
 In the margins group type the new value in the spin boxes, click ok button

6.  How would you insert page numbers on every page of the document
 Once the header and footer are created, the text can be inserted 
 Click on the header or footer area
 Click on Insert -> Fields, a sub menu with list of options will appear
 Click Insert -> Fields -> page number
 This will insert page number on every page of the document

Chapter 6
2marks

1. Define briefly a spread sheet
 An electronic spread sheet is a work sheet used in a computer to create & quickly perform “what if 

analysis”.
 Spread sheets are like a grid of cells with a programmable calculator attached to each cell.

2. Describe the structure of a spread sheet
 Open File->new->spread sheet
 At the top of the window is the menu bar -  displays a list of options
 Below the menu bar is the main tool bar  -  displays the short cut icons
 Below the main tool bar is the function bar & the object bar
 Below this is the formula bar – displays the current cell & its contents
 At the extreme bottom is the status bar & the scroll bar

3. When entering a formula in a cell does it matter in which order you enter the values & operators? Explain  
• Calculations in a worksheet can be done by using formulae
• The syntax of the formula begins with the equal to( = ) symbol
• Followed by a combination of operators values and references
 

4. Write a note on different types of operators  (Each operator 2 marks)
The different types of operators are 
Arithmetic operators   -  These operators return numerical results

+ (plus) Addition
-(minus) Subraction
-(Minus) Negation
*(asterisk) Multiplication
/(slash) Division
%(percent) Percent
^(caret) Exponentiation

Comparitive Operators - These operators return either true or false

= equal
> greater than
< less than
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>= greater than equal to
<= less than equal to
<> inquality

Text Operators
These operators combines sections of text to the entire text.
& (And) text operator

Reference Operators
These operators combines areas
! (Exclamation) intersection   : (Colon) range operator

5. What is relative and absolute cell referencing (Write a note on different types of cell referencing or cell 
addressing)

Relative Cell addressing
 This is the default type of cell addressing 
 With relative cell addressing formula’s are automatically recalculated every time the contents of the cells used in 

the formula change
 Eg: a4:c4

Absolute cell addressing
 A cell address can be made absolute by using the dollar sign in front of the row and column names
 Absolute cell address do change when copied
 Eg: $c$4

6. What is autoformat sheet
The autoformat sheet facility of star office calc helps to format the worksheet with different predefined styles and colors
Click on Autoformat option from the Format menu

7. List some of the spread sheet applications
 Payment of bills
 Account statements
 Financial accounting
 Result analysis of students
 Income tax calculations

5 marks

1. Write a note on Inserting objects in spread sheet
Star office calc provides tools for inserting objects like charts, images, formula’s etc in a worksheet.
Click on Insert object from View -> Tool bar

 Insert char icon - Used for presenting the data in the worksheet in the form of charts
 Insert formula icon  -  This is used for inserting formula in the worksheet for   performing calculations
 Insert floating frame icon - This icon is used to generate a scrolling screen within a worksheet
 Insert movie and sound icon - This icon is used to insert sound or video files into the current worksheet
 Insert OLE object icon  - This icon is used to insert objects from other applications into a worksheet
 Insert Applet icon - This icon is used to insert applets written in Java programming
      Into the worksheet

2. List the formatting options available in star office calc

Note : draw the icons page no : 82
 Number Format Currency icon - on clicking this icon the contents of the selected cells will be displayed in 

currency format with $ sign in the front & 2 decimal digits.
 Number Format Percent icon - on clicking this icon the contents of the selected cells will be displayed in 

percentage format, it multiplies the contents of the cell by 
100 and displays the result with 2 decimals

 Number Format Standard icon - on clicking this icon the contents of the cells will be displayed in the default 
format
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 Number Format Add Decimal & Delete Decimal    -  these are used to increase or decrease the number of decimal 
digits displayed in the selected cells

 Font colour icon  - this is used to change the font colour
 Align Left, Center, Right icon -  these are used to align the contents of the selected cells

3. List the advantages of using Electronic spreadsheets
 Calculations are done automatically using built in mathematical and statistical functions
 Accurate results are possible with any desired level of decimal points
 Worksheets can be quite big in size
 Worksheets can be saved for later use
 Any  part of the worksheet can be viewed or edited
 Worksheet data can be viewed in the form of graphs or charts
 Any part of the worksheet can be printed in a desired format
 Any part of the worksheet can be merged with existing or new worksheet

4. Write a note on Inserting objects in spread sheet
Star office calc provides tools for inserting objects like charts, images, formula’s etc in a worksheet.

 Click on Insert object from View -> Tool bar
 Insert char icon - Used for presenting the data in the worksheet in the form of charts
 Insert formula icon  -  This is used for inserting formula in the worksheet for   performing calculations
 Insert floating frame icon - This icon is used to generate a scrolling screen within a worksheet
 Insert movie and sound icon - This icon is used to insert sound or video files into the current worksheet
 Insert OLE object icon  - This icon is used to insert objects from other applications into a worksheet
 Insert Applet icon - This icon is used to insert applets written in Java programming
      Into the worksheet

5. How can you generate a series of values ? Explain with example
 Auto fill feature of spread sheet automatically generates a data series based on a defined pattern.

o Type a number in the cell
o Click in the cell & drag the fill handle 
o Release the mouse button.

 Fill command allows you to generate a series of data  directly from the values of the selected cells.
 First select the cells, choose the command edit->fill->series 
 Select the type of series from the options.

Eg:
 To create a series in increasing order of 3
 Enter the number 3 in the initial cell
 Select the cells,  choose the command edit->fill->series
 Specify the direction as down, type as linear & the increment value as 3.
 Click ok button – the values are automatically generated.

   Eg:          Command  -  Edit->fill->series
                  2 as start value                          output
                  2 as increment
                  Type as growth

6. What are functions and how can you use them in your worksheet
 Functions are predefined formulae available in star office calc
 The functions are available in the pull down menu of the function wizard.
 The different categories are available in the category pull down menu.
 Functions can be selected using the command Inset -> function 
 A list of functions is displayed in the function box when  is All is selected from the category box.

2
4
8
16
32
64
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 The function wizard icon f(x) on the formula bar can also be used to insert functions.
 Eg: to insert SQRT function – place the cursor in an empty cell
 Click the function wizard icon
 Select mathematical from the category box and select SQRT from the function list.
 The function wizard box prompts you to enter the number for which the function should work.
 Type the number 64 and click Ok button, the result will be displayed in the cell in the worksheet.

7. What spread sheet feature allows you to represent the data visually as a data analysis tool?
 The most popular feature of spread sheet is to generate charts based on numeric data.
 Select the data and click Insert -> chart or click the Insert chart icon.
 When the cursor becomes a + sign, place the cursor on the worksheet and drag it, Autoformat chart window 

appears.       Select the type of the chart and click next
 The next window displays different formats for each type of the chart, select the format and click next.
 In the next window provisions to enter the title for the chart, X-axis, Y-axis and legends is displayed.
 Then click create.

Chapter 7
2 marks

1. What is a database
 A database is a repository of collections of related data or facts.
 It arranges them in a specific structure
 It is a collection of related tables
 The biggest asset of the DBMS is its ability to provide extremely quick access and retrieval from large databases.

Eg:  name = vijay marks in maths  = 80

2. What is database Management system
 A DMBS is a program, or collection of programs that allows any number of users to access data, modify it and 

construct simple and complex requests. 
3. List and define the three components that make up a database

 Data in a database is most commonly viewed in one or more two dimensional tables each consisting of rows and 
columns

 The entire collection of related data in one table is referred to as a File
 Each row in a table represents a record -  a set of data for each database entry
 Each column in a table represents a field – groups each item of data among the records into specific categories

4. List the various field types that exist in a database
There are 20 field types 
Text(fix)                                      Text(varchar) Text (varchar ignorecase)
Number Date/time Date
Time Yes/no Binary field(fix)
Binary field Integer Tiny integer
Small integer Big integer Decimal
Float Real Double
Image

5. What does it mean to filter database record (OR What is a filter and explain its types)
 A filter is a type of a query, it is used to select and display records which match a condition
 The remaining records are hidden from the user.

There are two types of filters
Auto filter - clicking on this icon displays only the records that match the value of the current field
Standard filter – filter used with a condition is called as default filter, on clicking this icon conditions can be 

specified 

6

7. How will you integrate a spread sheet cell range into a text document
 To insert a range of cells into a writer document
 Open the star writer document
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 Open the star calc document that contains the text
 Select the range of cells    Choose edit -> copy
 In the writer document choose edit -> paste special
 In the paste special dialog box choose DDE(dynamic data embedding) link and click OK

8. What is DBMS and what are the three main tasks of a DBMS
 DBMS is a collection of programs that allow any number of users to access data modify it and construct simple 

and complex requests, and work with selected records.
 The biggest asset of the DBMS is its ability to provide quick access and retrieval from large databases.
The main tasks are
 Entering data into the database
 Reordering records in the database
 Obtaining subsets of the data.

9. Define a primary key
 A primary key is a field in a table that uniquely identifies every record in a table.
 To assign a primary key right click on the left of the field.
 A small yellow key appears to the left of the field.

5 marks
1. . Describe what a query is and what it is used for

 Queries are special views of the data in a table. 
 The output of the query does not affect the original table. 
 The result of a query is stored separately and can be viewed at any time.
Uses 
 Establish relationships between tables to update records
 List a subset of records
 Perform calculations
 Search the database to locate records
 Delete obsolete records

2. Explain the steps involved in manipulating the database
7 Steps involved in manipulating the database are

1. Searching 2. Sorting 3. Merging 4. Editing the database
5. Performing calculations 6. Filtering 7. Report generation

Searching
Searching is a process to select a desired specific data from a database
Eg: Selecting the students ranking first in a class with respect to total marks

Sorting
Sorting is the process of arranging the data in a table in some order either ascending 
Or descending.
Eg: arranging the list of staff members in alphabetical order

Merging 
Merging is a process of joining data from two or more tables of the same or 
Different databases.
Eg: preparing a mark list that shows the first ranking students of each class

Performing Calculations
Arithmetic calculations can be done on the data
Eg: calculating the total marks of a students for all subjects

Filtering
Using filter is a way of limiting the information that appears on the screen
Filters are used to display and browse a selected list or subset of records.
The records that satisfy the condition are displayed and that do not satisfy the 
condition are hidden from the user

Editing the database
Editing is a process of performing corrections, deleting the fields or records,
adding new fields or records, changing the format of the database.

Report generation
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You can generate any kind of report from the data stored in a database.
Eg: generate a report of all the students who scored less than the minimum marks.

3. Write a note on different types of database types
Based on the structure database can be classified as 5 types
Flat File Database

A database file that consists of a single table is called a flat file database.
Flat file database are useful for single user or small group situations.
Flat file database do not allow complex requests.
Eg: spreadsheets – used for maintaining address list or inventories

Relational Database
A relational database structure is made up of related tables
In a relational database one or more common fields from two or more tables
create a relationship between the tables.
The common fields are called keys.
Eg: relational database is most common in business organizations

Hierarchical Database
In hierarchical database records are organized in tree like structure by type.
The relationship between the record is said to be parent-child relationship, where
any child can relate to only single parent type
eg: hierarchical database are used in main frame computers.

Network database
They are similar to hierarchical database
Here any one record type can relate to any number of other record types

Object oriented database 
An object oriented structure is an newer structure that groups data items and their associated characteristics, 
attribute and procedures into complex requests.
An object is defined by its characteristics, attributes and procedures
An objects characteristics can be text, sound, graphics, video etc.
Attributes are colour, size, style, price etc.
Procedure refers to processing that can be associated to the object

Chapter 8
2 marks

1. What is multimedia
 Multimedia is a computer based presentation technique that incorporates text, graphics, sound, animations and 

video elements.
 Multimedia applications are being used in a variety of different fields like education, research, entertainment etc.

2. What are the different types of 2D animation
They are used in computer games.

 Animations are used to illustrate or demonstrate an concept.
 2D animations are classified as cell-based and object based animations
 Cell Based

 These consists of multiple drawings.
 When displayed in a rapid sequence these drawings appear to 

Move
 Object Based

They are also referred as slide or path animations created by moving an object across a screen.

3. Explain the steps involved in creating a 3D animation
The 3 steps involved in creating a 3D animation are

 Modeling  - first create the broad shapes & structures of the 3-D objects.
 Animating – Animate these objects by defining the motions.
 Rendering  - Render these objects by giving them attributes, colors & textures           

4. What is compression and what are the types of video compression
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 Compression is a technique by which a recurring set of information is identified and replaced by a single piece of 
information.

The 2 types of compression are 
 Lossless Compression – Retains the exact image throughout the compression
 Lossy Compression – Provides a comparatively higher ration of compression but results in loss of quality

5. What is inline sound & video
 When sound or video is included as a part of the web page then it is called as inline sound or video.
 The disadvantage of using this is it plays automatically whenever the web page is loaded.
 This can be added to the web page using the <bgsound> and <img> tags.
 Helper applications can be included using <embed>,<applet> and <object> tags.

6. What are helper applications
 A helper application is also called as plug-in.
 This is a program that can be launched by the browser to help play sound or video.
 The advantage of this is the viewer can have control of the player settings.

Chapter 9
1. List and describe the features of Impress (describe briefly about impress)

 Star office Impress is an application that allows you to create attractive and professional presentations.
 It provides various tools that allow you to save, modify, view and print them.
 Allows you to import and modify Microsoft Power point preosentations.
 It also allows you to export as HTML pages.

2. Describe how to create a presentation
o To create a new presentation click on File-> New -> Presentation
o Use the short cut key Shift + ctrl + N
o When you create a new presentation  :-
o The first page of the presentation wizard displays three options

1. Create an empty presentation
2. Use a template to create a presentation
3. Open an existing presentation

 The second page of the wizard allows you to select a background for all the slides 
 The third page of the wizard allows you to specify the transition effects.

3. What is Rehearse timings explain in detail
 Star office assists you in defining the right rehearse timings for automatic slide changes.
 Star office records the display time for each slide, so that the next time you play the slide show it uses the 

recorded time to advance the slides automatically.
 Open a presentation and Click Normal view   
 Start the show with Rehearse timings from slide show menu
 When it is time to advance to the next slide, click the timer.
 If you want the whole presentation to auto-repeat click

Slide Show -> slide show settings
 Select Auto and click OK

4. Explain about Custom slide show in detail
 Star Office Impress allows you to start slide show from the current slide as well as hide the slides during slide 

show
 Select Slide show -> custom slide show and click New
 Enter a name for the slide show in the Name box
 Under existing slides select the slides you want to add and click >> button
 You can change the order of the slides by dragging and dropping the slides under Selected slides
 Click OK button

5. Explain how would  you change the slide background

www.Padasalai.Net                                          www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



Choose Format -> Page -> Background
Select the Background fill from the 4 options

Color
Gradient
Hatching
Bit map

6. Write a note on Master page options
Master page can be used to specify basic background information that needs to be included in all the slides. 
A master slide determines the text formatting style for title, outline and the background design for individual slides or all 
slides.
Eg: inserting a company logo in the master slide will appear in all the slides
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