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MULTIPLE CHOICE QUESTIONS 
Volume I 

1. STAR OFFICE WRITER 
[Blue print 1-5 chapters – 9 questions]  

1. AN INTRODUCTION TO STAROFFICE WRITER 
1.  Entering a new text or modifying the existing text in a document is known as 
 a) Inserting   b) Hanging   c) Formatting   d) Text Editing 
2.  StarOffice was developed by 
 a) Microsoft Corporation  b) Sun Micro Systems c) IBM    d) Oracle Corporation 
3.  A document may contain 
 a) Text    b) Tables   c) Pictures  d) All of these 
4.  Which one of the following is a Spreadsheet? 
 a) StarOffice Draw   b) StarOffice Calc c) StarOffice Base  d) StarOffice Writer 
5.  In StarOffice Writer, the file can be saved by the command 
 a) Save   b) Print    c) New    d) Open 
6.  To cut the selected text in Star Office Writer, use 
 a) Search, Replace   b) Search, Cut   c) Edit, Insert   d) Edit, Cut 
7.  Which of the following is use d to create presentations? 
 a) StarOffice Base   b) StarOffice Draw  c) StarOffice Writer  d) StarOffice Impress 
8.  Text documents can be created in StarOffice, using 
 a) StarOffice Draw   b) StarOffice Writer c) StarOffice Calc  d) StarOffice Impress 
9.  The keyboard shortcut to save a document file is 
 a) Ctrl + S    b) Shift + S   c) Alt + S   d) Ctrl + F 
10.  Which button is used to hold down and drag across the text to select? 
 a) Right mouse   b) Left arrow   c) Left mouse  d) Right arrow 
11.  The keyboard shortcut to copy a text is 
 a) Ctrl + D    b) Ctrl + X   c) Ctrl + V   d) Ctrl + C 
12.  The flashing vertical bar is called 
 a) Cursor    b) End-of-document marker  c) Insertion bar  d) Insertion point 
13.  The key combination to be pressed to cut a selected text is 
 a) Ctrl + V    b) Ctrl + X  c) Ctrl + C   d) Ctrl + E 
14.  StarOffice Writer is a 
 a) Spread sheet   b) Word processor c) DBMS   d) Presentation software 
15.  The shortcut key that is used to select the entire document in StarOffice. 
 a) Ctrl + C    b) Ctrl + V   c) Ctrl + X   d) Ctrl + A 
16.  The command used to start StarOffice is 
 a) Start→ AllPrograms→ Staroffice    b) Start → All Programs → Staroffice 8 
 c) Start→ File→ Text     d) File→  New→ Text 
17.  The key used to paste a text is 
 a) Ctrl + A    b) Ctrl + Z   c) Ctrl + V   d) Ctrl + X 
18.  Which key deletes the character to the right of the insertion point? 
 a) Backspace   b) End    c) Delete  d) Home 
19.  In StarOffice Writer, to move one character right, press the key 
 a) Right Arrow  b) TAB    c) Shift + Right Arrow  d) Left Arrow 
20.  The key used to delete the character to the left of the insertion point is 
 a) Delete    b) Backspace  c) Enter   d) Space Bar 
21.  Which is a word processor? 
 a) StarOffice Writer b) UNIX   c) HTML   d) Spread Sheet 
22.  How many sets of scroll arrows are available in StarOffice Writer? 
 a) 5    b) 4   c) 2    d) 3 
23.  Naming a file is used to 
 a) Find a file   b) Find & Open that file again c) Open a file  d) Close a file 
24. Which movement key is pressed to move one word to the right? 
 a) Ctrl + A    b) Shift + A   c) Ctrl + Right arrow d) Ctrl + Left arrow 
25.  In StarOffice Writer, the thick horizontal line in the page area is called as 
 a) End-marker   b) End-of-document marker c) Page-marker  d) Page-end marker 
26.  Which key is to be pressed to move to the end of the document? 
 a) Ctrl+←   b) Ctrl+Home   c) Ctrl + End  d) Ctrl + →  
27.  By using which command a new document can be opened? 
 a) File→ Document→ New  b) File→ Text→ Newc) File → New → Text Document   d) File→ Text→ Document 
28.  Which command is used to reopen a document? 
 a) File→ New   b) File→ Save   c) File → Open  d) File→ Document 
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29.  The button used to perform the replacement without confirmation i s 
 a) Cancel    b) Replace All  c) Replace   d) Select 
30.  The key combination used to move the insertion point to the beginning of a document is 
 a) Ctrl + Home  b) Ctrl + Esc   c) Ctrl + Up arrow  d) Ctrl + End 
31.  Word processing package is 
 a) Excel    b) Lotus AmiPro c) Windows 95   d) Foxpro 
32.  Which key is used to correct mistakes? 
 a) Erase    b) Delete   c) Delete or Backspace d) Backspace 
33.  The user cantoggle between type-over mode and the insert mode by using 
 a) Esc key    b) Insert key  c) Backspace key  d) Delete key 
34.  Which button is clicked to close the find and replace dialog box? 
 a) Close   b) Cancel   c) Abort   d) Ok 
35.  The insertion point can be moved one cell to the right in a table by pressing 
 a) Shift+Tab   b) Tab   c) Alt+Tab   d) Ctrl+Tab 
36.  To go to the beginning of a line in a StarOffice Writer document, press 
 a) End    b) Home  c) Alt + Home   d) Ctrl + Home 
37.  In StarOffice Writer, Which key is used to move one word to left? 
 a) Ctrl + Home   b) Ctrl + Right Arrow  c) Alt + Right Arrow  d) Ctrl + Left Arrow 
38.  Which of the following is not a word processor? 
 a) MS Word   b) Notepad  c) StarOffice Writer  d) Word Star 
39.  The insertion point can be moved to anywhere in the document using 
 a) Mouse    b) Keyboard   c) Mouse or Keyboard d) Mouse Pointer 
40.  Which key should be pressed at the end of each par graph? 
 a) Space bar   b) Shift    c) Enter  d) Ctrl 
41.  To scroll a relative distance in the document, use 
 a) Combo box   b) Scroll box  c) List box   d) Check box 
42.  Which of the following always indicates where the new text will appear? 
 a) Text area   b) Insertion point c) Vertical scroll bar  d) End-of-document marker 
43.  In which combo box, the word to be searched is typed? 
 a) Search    b) Replace   c) Search for  d) Replace with 
44.  The key combination to be pressed to find & replace the text is 
 a) Ctrl + R    b) Ctrl + S   c) Ctrl + F  d) Ctrl + X 
45.  StarOffice uses its own desktop called as 
 a) Program Desktop  b) Windows Desktop  c) Desktop   d) Star Desktop 
46.  The title of the new StarOffice Writer document is 
 a) No title    b) Untitled  c) Blank space   d) Untitled1 
47.  How many applications Star Office consists of? 
 a) 4    b) Several   c) 5    d) 3 
48.  Which button is to be clicked to skip the found text and to continue the search? 
 a) Ignore   b) Find    c) Cancel   d) Replace 
49.  Which bar gives the current mode information about insert mode or type-over-mode? 
 a) Status bar  b) Tool bar   c) Title bar   d) Menu bar 
50.  In StarOffice Writer, Which one of the following is not used for editing? 
 a) Paste    b) Save   c) Cut    d) Copy 
51. The extension name of Star Office Writer file is 
 a) .odw    b) .odb    c) .ods    d) .odt 
52. Which menu option is used for working with multiple documents? 
 a) Format    b) File    c) Window  d) View 
53.  In Star Office Writer, under which menu all the formatting options are available? 
 a) Edit    b) File    c) View    d) Format 
54.   Which StarOffice function is used to draw pictures? 
 a) StarOffice Draw   b) StarOffice Calc c) StarOffice Base  d) StarOffice Writer 
55.  The command  to move a selected text is 
 a) Ctrl + V    b) Ctrl + X  c) Ctrl + C   d) Ctrl + E 
56.  The key combination to copy the text 
 a) Ctrl + V    b) Ctrl + X  c) Ctrl + C   d) Ctrl + E 
57.  Which of the following is not a word processor? 
 a) Lotus AmiPro  b )Word Pro  c) MS Word                  d) Lotus 1-2-3 
58.  Which consists of several applications? 
        a) StarOffice          b) StarOffice Calc c) StarOffice Base  d) StarOffice Writer 
59.  Which key should be pressed to insert a blank line in a Star Writer document? 
         a) Home          b) End   c) Delete  d) Enter 
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60.  Which key is used to move down on screen in the document? 
         a) Page Up  b) Page Down  c) Home  d) End 
61. The button used to skip the found text in StarOffice Writer is 
         a) Find All  b) Find  c) Replace d) Replace All 
 
 

2. TEXT FORMATTING 
1.  In a certain style, a set of characters and numbers is called as 
 a) Paragraph   b) Alignment   c) Indentation   d) Font 
2.  When typing in StarOffice Writer, all text aligned in 
 a) Right    b) Center   c) Left   d) Justify 
3.  How many types of formatting are available in StarOffice Writer? 
 a) One    b) Two    c) Five    d) Three 
4.  How many types of paragraph alignment can be selected in StarOffice Writer? 
 a) 5    b) 3    c) 4   d) 6 
5.  When an increase indent icon is selected the paragraph is indented by 
 a) 1/2 inch  b) 3/4 inch   c) 1 inch   d) 1/4 inch 
6.  Which key combination is use to right al ign a text? 
 a) Ctrl + E    b) Ctrl + L   c) Ctrl + J   d) Ctrl + R 
7.  StarOffice Writer default line spacing 
 a) 1.5 line    b) Single line  c) Double line   d) Fixed 
8.  In StarOffice Writer, Soft returns are inserted as 
 a) Comma    b) Blank space   c) Line breaks  d) Page breaks 
9  Which keyboard shortcut is used to underline the selected text? 
 a) Ctrl + L    b) Ctrl + B   c) Ctrl + U  d) Ctrl + I 
10.  Which key combination is used for left aligning the selected paragraph? 
 a) Ctrl + L   b) Ctrl + R   c) Ctrl + E   d) Ctrl + J 
11.  Which font looks like professional? 
 a) Arial    b) Fajita   c) Lucida   d) Times New Roman 
12.  Different colours can be utilized in a text by clicking the icon 
 a) Font colour icon b) File icon   c) Colour icon   d) Open file icon 
13.  The size of a font is measured in 
 a) Inches    b) Dots    c) Pixels   d) Points 
14.  A paragraph is any text followed by 
 a) Hard format   b) Hard return  c) Soft format   d) Soft return 
15.  The visual clue that helps the reader to see how the document divided into paragraph is 
 a) Spacing    b) Highlighting   c) Numbering   d) Indenting 
16.  Which fonts are actually sets of symbols? 
 a) Wingdings  b) Thorndale   c) Fajita   d) Times New Roman 
17.  How many types of line spacing are available in StarOffice Writer? 
 a) 12    b) 10    c) 7   d) 6 
18.  The suitable FONT for business documents 
 a) Professional   b) Business   c) Fajita   d) Times New Roman 
19.  The most common type of text formatting is 
 a) Bold    b) Italic    c) Underlined  d) All of these 
20.  Which of the following shortcuts is used to make the selected text bold? 
 a) Ctrl + I    b) Ctrl + L   c) Ctrl + U   d) Ctrl + B 
21.  One of the StarOffice help facilities  is called as 
 a) On-line   b) Automatic   c) Interactive   d) Non  Interactive   
22.  A paragraph can be justified using 
 a) Ctrl + R    b) Ctrl + L   c) Ctrl + E   d) Ctrl + J 
23.  A negative indenting value will result in 
 a) Hanging indent  b) Increase indent  c) Positive indent  d) Decrease indent 
24.  A named set of defaults for formatting text 
 a) Bullet    b) Style  c) Indent   d) Forms 
25.  To call attention to key ideas in a document, we can 
 a) Formatting   b) Highlighting  c) Indenting   d) Numbering 
26.  The decorative font symbol in StarOffice Writer 
 a) Times New Roman  b) Lucida   c) Arial    d) Fajita 
27.  Which dialog box can be displayed when you make a click on Format→ Character Menu? 
 a) Character  b) StarOffice Writer window  c) StarOffice Help  d) Replace 
28.  The equivalent points to an inch in font size is 
 a) 72   b) 102    c) 75    d) 82 
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29.  Which is used to list the important points and messages? 
 a) Bullets    b) Shortcut keys  c) Bullets and Numbers           d) Numbers 
30.  All the for matting options are available under 
 a) Format menu  b) Edit menu   c) Tools menu   d) File menu 
31.  Some splash can be added to the documents with the help of the 
 a) Printer    b) Buttons   c) Pointer   d) Colour printer 
32.  To remove the highlighting in StarOffice Writer, select the text and from the colour palette list select 
 a) No Highlight   b) Remove Fill   c) No Fill  d) Clear 
33.  When typing in StarOffice Writer, which margin is ragged or uneven? 
 a) Bottom    b) Right  c) Left    d) Top 
34. To change the line spacing in StarOffice Writer, select 
 a) Format → Paragraph b) Paragraph→ Format  c) View→ Format  d) Edit→ Format→  Paragraph 
35.  Which indent is used in Numbered Lists? 
 a) Hanging Indent  b) Increase Indent  c) Left Indent   d) Right Indent 
36.  Which keyboard shortcut is used to display an Extended Tip in StarOffice Writer? 
 a) Shift + F1  b) F1    c) Ctrl + F1  d) F7 
37.  The key to access the Star Office Help 
 a) F1   b) F12    c) F2    d) F7 
38.  Which of the following windows is used to change the help content depending on what is being done in the 

mainwindow? 
 a) Help Tip    b) Extended Help Tip  c) Help Agent  d) Online Help 
39.  Which of the following helps in providing the document more readability? 
 a) Spacing    b) Numbered & Bullets  c) Indentation  d) Paragraph 
40.  Which type of printer is required to get the hard copy of the document in colour? 
 a) Graphic    b) Line    c) Dot-Matrix   d) Colour 
41.  Which is used for setting off a paragraph from the main body text? 
 a) Positive indent   b) Right indent   c) Left indent  d) Center indent 
42.  Which box can be used to search for help on other StarOffice elements? 
 a) Help Agent   b) Help Tip   c) Choose Help File d) Extended Tip 
43.  Which icon is to be clicked to undo the indent? 
 a) Right indent   b) Increase indent  c) Left indent   d) Decrease indent 
44.  Which one of the following statements is false? 
 a) A paragraph is any text followed by a soft return      b) StarOffice offers an online help facility 
 c) The colour printer is required to get colour hard copy    d) A paragraph can be justified by pressing ctrl + J key 
45.  The keyboard shortcut used while aligning to make the text centered is 
 a) Ctrl + J    b) Ctrl + E  c) Ctrl + L   d) Ctrl + C 
46.  By default, the Star Office Writer document font size is 
 a) 10    b) 12   c) 11    d) 9 
47.  The command used to open Star Office he lp to search for a help topic is 
 a) Help→ StarOffice Help  b) Format→ Help  c) File → Help  d) Help→ Online Help 
48.  How many types of help systems are provided by StarOffice? 
 a) Several   b) 1    c) 3    d) 2 
49.  Which of the following StarOffice help appears automatically when you perform a complex task? 
 a) Online Help   b) Help Agent  c) Extended Help Tip  d) Help Tip 
50.  Which spin arrows are used to enter the amount to indent text from the right in paragraph dialog box? 
 a) Before text   b) After text  c) Before paragraph  d) Above paragraph 
51.  Bullets and Numbering option is available under the menu 
 a) View    b) Edit    c) Format  d) File 
52.  In StarOfficeWriter, the key pressed to enter a hard return 
 a) Esc    b) Backspace   c) Enter  d) Space bar 
53.  If the value of first line spin box in the paragraph dialog box is negative it will create 
 a) Hanging Indent  b) Indent   c) Left Indent   d) First line Indent 
54.  In StarOffice Writer, the menu used to apply different styles for the bullets and numbers 
 a) Insert    b) Format  c) View    d) Edit  
55.   Which menu is used to achieve all the formatting options? 
 a) Window   b) Format  c) Tools   d) Edit  
56.   Which is named set of defaults for formatting text? 
 a) Command  b) Format  c) design  d) Style 
57.  A special kind of indent used for numbered lists. 
         a) right indent  b) left indent c) numbered indent  d) hanging indent 
58.  Which keyboard shortcut is used to display Help in StarOffice Writer? 
        a) F1   b) F7  c) Shift+F1   d) Ctrl + F1 
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59.   Which of the following is true to change the fonts in StarOfficeWriter? 
 a) Format → Character b) Insert→ Font        c) View→ Font   d) Format →  Font 
60.   One way to set off a list of points or topics in a document is  
 a) Line space  b) Paragraph alignments        c) bulleted list  d) Using style 
61. The command used to open Character dialog box is 
 a) Edit → Character  b) Format → Character        c) View → Character  d) Tools → Character 
62.    In StarWriter the command used to make several changes at once or to preview the changes before applying them is 
 a) Format →  Paragraph b) Format → Character        c) Format →  Font  d) Format →  Page 
 
 

3. CORRECTING SPELLING MISTAKES 
1.  Which of the following includes a dictionary and spell-check program in StarOffice? 
 a) StarOffice Base   b) StarOffice Draw  c) StarOffice Calc  d) StarOffice Writer 
2.  Which key is pressed to select the spelling command? 
 a) F4    b) F6    c) F7   d) F2 
3.  Which button is clicked to replace all occurrences of a word? 
 a) Change all  b) Ignore all   c) Ignore once   d) Change 
4.  Which of the following displays alternative spellings for a misspelled word in Spell check dialog box? 
 a) Not in dictionary   b) Autocorrect   c) Add    d) Suggestions list 
5.  Which command is used to add the error and its correction to the auto correct list? 
 a) Tools→ Correct   b) Tools→ Spellcheck  c) Format→ AutoCorrect d) Tools → AutoCorrect 
6.  StarOffice Writer puts a squiggly line for not matching dictionary words with the colour of 
 a) Blue    b) Green   c) Black   d) Red 
7.  Which button is clicked to add the word to the dictionary in Spelling check dialog box? 
 a) Cancel    b) Add   c) New    d) Insert 
8.  In how many ways StarOffice Writer can identify the spelling mistakes? 
 a) Four    b) Two   c) Many   d) Three 
9.  To open spelling dialog box, we 
 a) Edit→ Spelling→ Check    b) Tools → Spelling → Check  
 c) File→ Spelling→ Check    d) Format→ Spelling→ Check 
10.  StarOffice Writer can automatically correct some spelling mistakes using 
 a) SpellCorrect   b) AutoCheck   c) AutoSpelling   d) AutoCorrect 
11.  Which of the following icons is used to turn ON or OFF automatic spell check feature? 
 a) AutoCorrect   b) Spelling   c) Auto Spellcheck d) Spellcheck 
12.  Which button is used to skip the spelling change for the current word? 
 a) skip    b) Ignore once  c) Change   d) Ignore all 
13.  The number of tabs in AutoCorrect dialog box 
 a) 3    b) 4    c) 2    d) 5 
14.  The only Check box in the AutoCorrect dialog box is 
 a) Match Case   b) Text Only  c) Numbers   d) Whole Words Only 
15.  The command to open a spell check dialog box is 
 a) Edit→ Spelling→ Check  b) Tools → Spelling → Check     c) Edit→ Check→ Spelling  d) Tools→ Check→ Spelling 
16.   StarOfficeWriter compares each word typed with the words in the dictionary and underlines words that do not match 

with a squiggly __________line 
 a) Blue    b) Green   c) Black   d) Red 
17.  Which of the following keys is pressed to delete a misspelled word and the word is retyped?  
         a)End    b)Home   c)Shift+Delete   d)Backspace 
18.  Which command is used to check the spell check after the entire document is typed? 
 a) Edit→ Spelling→ Check    b) Tools → Spelling → Check     c) Edit→ Check→ Spelling  d) Tools→ Check→ Spelling 
19.  Which button is clicked button is clicked to add the word to the dictionary. 
 a) Enter  b) Add   c) Change  d) Replace 
20. Which option is very useful for correcting the spelling of the commonly misspelled words? 
 a) Autoformat  b)Auto Correct    c)Auto spell check  d)Auto check 
21. The only check box in the auto correct dialog box is …  

        a) text only   b)numbers   c)match case   d)whole words only 

22. To skip all occurrences of the misspelled word in spell check which button is clicked?  
      a) Change all   b) Ignore all  c) Not in dictionary   d) Using Styles 

 
4. WORKING WITH TABLES 

1.  The intersection of a column and a row is 
 a) Grid    b) Cell   c) Border   d) Table 
2.  In StarOffice Writer, a table is a grid with a specified number of 
 a) Columns    b) Rows and Columns c) Rows or Columns  d) Rows 
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3.  Which command is used to delete the selected row? 
 a) Table → Delete→ Rows   b) Table→ Rows→ Delete  
 c) Format→ Delete→ Rows    d) Table→ Delete→ Columns 
4.  The simplest way to add a row at the last row of the table is to press 
 a) Insert    b) Tab   c) Enter   d) Right arrow 
5.  The entire table can be selected by choosing Select All 
 a) File    b) Format   c) View    d) Edit 
6.  Which icon is used to split a cell into two or more cells? 
 a) Table fixed   b) Merge cells   c) Split cells  d) Line style 
7.  The command used to bring out the table formatting toolbar is 
 a) View→ Toolbars→ Table  b) Table→ Insert→ Table  c) Format → Table d) Table→ Insert 
8.  Which key is pressed to move backward through the cells in a table? 
 a) Shift + Tab  b) Tab    c) Shift    d) Back space 
9.  To make all columns even, the command used is 
 a) Column → Space Equally    b) Format→ Column Equally c) Format→ Row Equally    d) Row→ Space Equally 
10.  Which key is pressed to move forward through the cells? 
 a) Shift    b) Shift + Tab   c) Backspace   d) Tab 
11.  Which command is selected to create a simple, default-style table? 
 a) View→ Toolbars→ Table  b) Table→ Insert   c) Format→ Table  d) Table → Insert → Table 
12.  Which icon is used to delete the current row from the table? 
 a) Delete Column   b) Insert Column  c) Delete Row  d) Insert Row 
13. By default each cell includes a 
 a) Border    b) Column   c) Grid    d) Row 
14.  The entire table is selected using 
 a) Edit → Select All  b) Format→ Select All  c) Format→ Select  d) Edit→ Select 
15.  Which icon is used to combine two or more cells into a single cell? 
 a) Split cells   b) Table fixed   c) Optimise   d) Merge cells 
16.  By default, the insertion point in the__________ cell of the table. 
 a) First   b) Second   c) Last    d) Center 
17.  Which command is used to insert more than one row in the table? 
 a) Table→ Add→ Rows  b) Insert→ Rows  c) Table→ Insert→ Rows d) Table→ Insert→ Rows 
18.  When the insert table dialog box appears on the screen, the name of the table is given in 
 a) Name text box  b) Header box   c) Columns text box  d) Rows text box 
19.  Which of the following commands is used to delete the selected table? 
 a) Format→ Table→ Delete  b) Format→ Delete→ Table c) Delete→ Table  d) Table→ Delete→ Table 
20.  Which menu is used to select the entire table? 
 a) File    b) Format   c) Edit   d) View 
21.  The command used to delete the selected column in a StarOffice Writer table is. 
 a) Tools→ Column→ Delete    b) Table→ Delete→ Columns 
 c) Format→ Delete→ Columns   d) Tools→ Delete→ Columns 
22.  The combination of rows and columns are called as 
 a) Cell   b) Table   c) Row    d) Column 
23.  Which command is used to add the required quantity of columns to the table? 
 a) Table→ Column→ Insert  b) Insert→ Columns  c) Table→ Insert→ Columns d) Table→ Add→ Columns 
24. How many options are available under Optimise icon of Table Formatting Toolbar? 
 a) 2    b) 5    c) 3    d) 4 
25.  Which icon is used to insert a row below the current row? 
 a) Delete Column   b) Inserting Row c) Inserting Column  d) Delete Row 
26.  In Insert Table dialog box, the number of columns and rows are entered using 
 a) Spin Arrows  b) Check Boxes   c) Radio Buttons  d) Grids 
27.  Using which dialog box, the column width can be changed in a table? 
 a) Mouse    b) Table Format c) Keyboard   d) Ruler 
28.  By clicking which icon, apalette of colours is displayed? 
 a) Border colour  b) Merge cell   c) Borders   d) Line Style 
29.  Which is used to specify the number of rows and columns? 
 a) Menu    b) Tool bar   c) Insert Menu   d) Grid 
30.  Which icon is used to display a floating toolbar with different border options? 
 a) Line style   b) Borders  c) Optimise   d) Table fixed 
31.  Which icon is used to choose the style of line to be used for the border? 
 a) Line style  b) Merge cells   c) Optimise   d) Borders 
32.  When the text or data reaches the cell border, StarOffice Writer will wrap the text to the next line and expand the 
 cell making it 
 a) Wider or Taller   b) Wider and Taller  c) Taller  d) Wider 
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33.  To delete a row or column in a table, select the menu 
 a) Tools    b) Format   c) Table  d) Insert 
34.  Which of the following toolbars is used to choose the line style for the StarOffice Writer Table? 
 a) Formatting   b)Table Formatting c) Table   d) Style 
35.  To make the column narrower, the border is dragged towards 
 a) Right    b) Left    c) Up   d) Down 
36.  To delete only the entries and not the table, the command used 
 a) Table→ Delete→ Rows   b) Table→ Delete→ Columns   
 c) Table→ Delete→ Table   d) Entire Table is selected and delete key is pressed 
37.  The keyboard shortcut used to create the table in StarOffice Writer is 
 a) Ctrl + F2    b) Ctrl + F   c) Ctrl + F12   d) Shift + Tab 
38.  Which keyboard shortcut is used to increase the column width? 
 a) Alt + Right arrow b) Ctrl + Left arrow c) Alt + Left arrow  d) Ctrl + Right arrow 
39.  Which keyboard short cut is used to decrease the column width, without changing the width of the table? 
 a) Alt + Right arrow  b) Alt + Ctrl + Right arrow c) Alt + Ctrl + Left arrow d) Alt + Left arrow 
40.  Which keyboard short cut is used to increase the row height? 
 a) Alt + Down arrow b) Ctrl + Up arrow  c) Ctrl + Down arrow  d) Alt + Up arrow 
41.  In Star Office Writer, which of the following commands is used to get a table format dialog box? 

 a) Table→ Table properties b) Table→ Table Format       c) Insert→ Table  d) Insert→ Table properties 

42.  If  Table → Table Properties command is used, which of the following dialog box is opened? 
 a) Table Format  b) Table properties  c) Format Table   d) Cell properties 
43.   Which button is  hold down and then press the left or the right arrows to resize a column width? 
 a) Ctrl     b) Shift   c) Alt   d) Tab 
44.  Which of the following is a grid with a specified number of columns and rows in StarOfficeWriter? 

 a)Cell   b)File    c)Border   d) table 

45. Which of the following key is pressed to resize the column without changing the width of the table? 
         a)Alt    b) Alt +Ctrl     c)Ctrl     d) Shift 
46.  In a table when the text is wrapped in a cell it grows 
        a) wider    b) taller    c) wrap    d) border 
47.  In StarWriter the first icon in the floating tool bar for insertion function is 
        a) Merge cell  b) Borders   c) Insert Table   d) Split Cell 
 

5. PAGE FORMATTING 
1.  The default width of left and right margins in StarOffice Writer is 
 a) 1.75 inch   b) 1.25 inch  c) 1.5 inch   d) 1 inch 
2.  Ruler option is used to change 
 a) Margins  b) Paper Orientation  c) Footer   d) Header 
3.  If the length of the document is more than the width, it is called 
 a) Landscape   b) Footer   c) Portrait  d) Margin 
4.  If the width of the paper is more than the length, it is called 
 a) Footer    b) Landscape  c) Portrait   d) Header 
5.  The default orientation for a document is 
 a) Margin    b) Portrait  c) Landscape   d) Header 
6. To create footer, which tab is clicked in Page style dialog box? 
 a) Header   b) Page    c) Footer   d) Borders 
7.  The Header & footer are separated from the rest of the text by 
 a) A gray box   b) A thick line   c) A grid   d) A thin line 
8.  The area at the bottom of the page is called 
 a) Bottom space   b) Footer  c) Header   d) Margin 
9.  The default top and bottom margins 
 a) 0.5 inch    b) 1.5 inches   c) 1 inch  d) 1.25 inches 
10.  Which command is clicked to insert page numbers? 
 a) Insert→ Fields→ Page Number b) Footer→ Page→ Number c) Insert→Page Number d) Insert→ Page 
11. The margin settings for a page is displayed by clicking the tab 
 a) Header    b) Page  c) Organizer   d) Background 
12.  Which command is clicked to appear the page style dialog box? 
 a) Format→ Page  b) Tools→ Page   c) Format→ Page Style  d) Edit→ Page 
13.  Which is normally used to contain the page numbers? 
 a) Footer   b) Header   c) Text area   d) Border 
14.  Which is normally used to contain n the titles or topics? 
 a) Header   b) Footer   c) Text area   d) Border 
15.  Which tab is used to create a header on the page style dialog box? 
 a) Header Toolbar   b) Header File   c) Header Tab  d) Header Taskbar 
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16.  Which dialog box is used to set the width of the paper r? 
 a) Character dialog box  b) Header dialog box  c) Page Style dialog box    d) Table Format dialog box 
17.  In StarOffice Writer, the Page Preview option is available under the menu, 
 a) File   b) View    c) Edit    d) Format 
18.  If the ruler is not displayed in StarOffice Writer screen, which option is clicked? 
 a) Format→ Ruler   b) Tools→ Ruler   c) View→ Ruler  d) Edit→ Ruler 
19.  Which of the following are some references and remarks added at every page of the document? 
 a) Margins and Borders  b) Borders and Columns  c) Portrait and Landscape d) Header and Footer 
20.  Which spin boxes are used to enter the size of the paper? 
 a) Top and Bottom   b) Left and Right  c) Width and Height d) Length and Breadth 
21.  The new margin setting is entered using the---------------arrow. 
 a) Up    b) Right   c) Left    d) Spin 
22.  The margins for a particular page can be set to an exact value using 
 a) Scroll bars  b) Tool box   c) Rulers   d) Page Style dialog box 
23.  Most documents are printed in the paper with the size of 
 a) 10 inch by 9.5 inch  b) 8.5 inch by 11 inch  c) 8 inch by 11.5 inch  d) 8.5 inch by 11.5 inch 
24.  The margins for a particular page can be set approximately using 
 a) Page Style dialog box  b) Marker   c) Scale    d) Ruler 
25.  How many spin boxes will be displayed when the header check box is clicked? 
 a) 4   b) 3    c) 2    d) 5 
26.  Which buttons are used to change the page orientation? 
 a) Radio   b) Option   c) Round   d) Command control 
27.  Which option gives an overall picture of the document visually? 
 a) Print view   b) Print Preview  c) File view   d) Page Preview 
28.  Which one of the following statements is false? 
 a) The default orientation is portrait    b) A cell is the intersection of a row and a column 
 c) Header is an area at the bottom of the page d) StarOffice Writer includes spell check program 
29.  The default height of a page in default orientation is 
 a) 8.6 inch    b) 1 inch   c) 1.25 inch   d) 11 inch 
30.  The default width of a page in default orientation is 
 a) 8.5 inch   b) 11 inch   c) 8 inch   d) 11.5 inch 
31.  How many types of page orientations are there? 
 a) 2   b) 4    c) 1    d) 3 
32.  The ruler option in StarOfficeWriter is available under 
 a) Edit    b) View   c) Format   d) File 
33.  In a text document, the area at the top of the page is called as 
 a) None of the three choices  b) Footer   c) Header  d) Page number 
34.  How many methods are used to change the page margins? 
 a) Four    b) Two   c) Six    d) Three 
35.    Which tab is selected to change the orientation? 
          a) Header    b) Page   c) Organizer   d) Background 

36.   The default size of a page in default orientation is 

 a) 10 inch by 9.5 inch  b) 8.5 inch by 11.5 inch  c) 8 inch by 11.5 inch  d) 8.5 inch by 11 inch 

37.  The default margins for top, bottom and left , right margins  are 

 a) 0.5 inch    b) 1.5 inches   c) 1 inch,1.25 inch  d) 1.25 inches 
38.   In StarOfficeWriter which option in the File menu can be used to see the changes? 
         a) Preview    b) Print Preview  c) Page Preview  d) Page View 

 
6. SPREADSHEET 

 [Blue print - 7 questions] 
1.  A data file created with spreadsheet is called a 
 a) Chart    b) Formula   c) Cell    d) Worksheet 
2.  StarOffice Calc is a part of 
 a) Windows   b) Linux   c) MS Office   d) StarOffice 
3.  Which is a tool for working with numbers? 
 a) StarOffice Impress  b) Database   c) StarOffice Writer  d) Spreadsheet 
4.  The first electronic Spreadsheet is (or) The first commercial spreadsheet package is 
 a) Visicalc   b) StarOffice Calc  c) Lotus 1-2-3   d) QPro 
5.  Every formula should begin with the symbol ____________ 
 a) =   b)>   c) +    d) ! 
6.  A cell address is made absolute by using the 
 a) !    b) =    c) $   d) * 
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7.  The text operator in StarOffice Calc is 
 a) $    b) &   c) !    d) * 
8.  The active cell is identified by the 
 a)    b) Cursor   c) Cell pointer  d) Insertion point 
9.  A continuous group of cells is known as 
 a) Row    b) Column   c) Range  d) Group 
10.  To preview a worksheet before printing, click Page View from 
 a) Edit menu   b) View menu   c) File menu  d) Format menu 
11.  Two or more adjacent cells are referred to as 
 a) Column    b) Range  c) Row    d) Cell 
12.  Which of the following is an example of spreadsheet package? 
 a) Improve    b) Excel   c) Quattro Pro   d) All of these 
13.  Which is the default type of cell addressing? 
 a) Both Relative & Absolute  b) Reference   c) Relative  d) Absolute 
14.  Which icon is used for inserting a formula in the worksheet? 
 a) Insert Formula icon b) Insert Chart icon  c) Insert Applet icon  d) Insert Object icon 
15.  The format for entering Time is 
 a) HH:MM:SS  b) SS:MM:HH   c) MM:HH:SS   d) HH:SS:MM 
16.  Which of the following is a reference operator? 
 a) : (or) !    b) ;    c)&   d) = 
17.  The Insert_Function option is used to select a 
 a) AutoFormat   b) Chart   c) Function   d) Graph 
18.  In order to shift the content of a cell to the right and create an empty cell, select the cell and click the icon 
 a) Insert Cells Right b) Insert Rows   c) Insert Columns  d) Insert Cells Down 
19.  Which command is used to print a part of a worksheet? 
 a) Format→ Print Ranges→ Edit b) Format→ Print Ranges→ Delete c) File→ Print  d) Print icon 
20. In StarOffice Calc Screen, below the menu bar is the function bar and 
 a) Tool bar    b) Formula bar   c) Status bar   d) Object bar 
21.  One of the most commonly used functions in Star Office Calc is 
 a) SUM   b) AVERAGE   c) SQRT   d) ABS 
22.  Which operator combines sections of text to the entire text? 
 a) =    b)>   c) !    d) & 
23.  Which icon is selected to display the numbers in currency format? 
 a) Currency  b) Add Decimal   c) Percent   d) Standard 
24.  The date format is 
 a) MM/DD/YY  b) DD/MM/YY   c) YY/MM/DD   d) DD/YY/MM 
25.  The syntax of formula begins with the sign 
 a)<   b)   c) +    d) = 
26.  The predefined formulae that are available in Star Office Calc are 
 a) Keywords   b) Constants   c) Functions  d) Variables 
27.  The option used to open a worksheet that has been saved is 
 a) File→ Save   b) File→ SaveAs  c) File→ New   d) File → Open 
28.  To change the height of a row, the command used is 
 a) Format→ Row→ Height  b) Format→ Row→ Width 
 c) Format→ Column→ Width  d) Format→ Column→ Height 
29.  Which command is used to save a worksheet? 
 a) File → Save  b) File→ Open   c) File→ Quit   d) File→ Exit 
30.  In order to insert a column, use the icon 
 a) Insert Columns   b) Insert Cells Down  c) Insert Cells Right d) Insert Rows 
31.  The intersection of rows and columns are called 
 a) Spreadsheets   b) Labels   c) Grids    d) Cells 
32.  The option used to close the worksheet is 
 a) File→ Exit   b) File → Close  c) File→ New   d) File→ Open 
33.  StarOffice Calc was developed 
 a) Microsoft International  b) Sun Microsystems c) Lotus Corporation  d) Borland International 
34.  Which cell addresses do not change when copied? 
 a) Reference   b) Absolute  c) Relative   d) Both Relative & Absolute 
35.  The full form of Visicalc is 
 a) Visicalculation  b) No full form it is a company name c) Visicalculator   d) Visible Calculator 
36.  The command used to generate a series of data in a spreadsheet is 
 a) Auto number   b) Auto    c) Auto generate  d) Fill 
37.  Which is the first cell of the Spreadsheet? 
 a) 1    b) 1A    c) A    d) A1 
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38.  Who invented Visicalc for AppleII? 
 a) Bon Frankston   b) Dan Bricklin and Bon Frankston c) Dan Bricklin  d) Charless Babbage 
39.  Which operators combine cell areas? 
 a) Comparative   b) Reference  c) Arithmetic   d) Text 
40.  Electronic spreadsheet uses the concept of 
 a) 'Where to' analysis  b) 'What if' analysis c) WYSISWYG   d) 'Why if' analysis 
41.  The PCs became popular due to the invention of 
 a) Excel    b) Visicalc  c) QPro    d) Lotus 1-2-3 
42.  The command used to gene rate a series of data is 
 a) Edit→ Series   b) Insert→ Series  c) Fill→ Series   d) Edit→ Fill→ Series 
43.  What is the function used to find the square root of a number? 
 a) SQTR    b) SQR    c) SQT    d) SQRT 
44. To draw in spreadsheet, click 
 a) Image icon   b) Draw icon   c) Insert Picture icon  d) Show Draw Functions icon 
45.  Which of the following functions calculates the total of a given set of numbers? 
 a) SQRT    b) ADD    c) COUNT   d) SUM 
46.  Visual representation of data is referred as 
 a) Charts   b) Frames   c) Bar diagrams   d) Graphs 
47.  Which formula is for working with multiple sheets in StarOffice Calc? 
 a) 2-D    b) 1-D    c) Mathematical   d) 3-D 
48.  Dan Bricklin and Bon Frankston invented 
 a) Lotus 1-2-3   b) Visicalc  c) StarOffice Calc  d) Excel 
49.  To insert objects like charts, images and formula in a worksheet, click the option 
 a) Insert Object  b) Insert Chart   c) Insert Picture   d) Insert Formula 
50.  Graphical representation of numbers is known as 
 a) Bar diagrams   b) Graphs   c) Frames   d) Charts 
51.  The cells are addressed in terms of 
 a) Row labels   b) Row and Column labels c) Labels  d) Cell labels 
52.  Which key is used to edit data in a worksheet? 
 a) Ctrl + F    b) F6    c) F2   d) F7 
53.  To format the data in a cell, click 
 a) Tools→ Cells   b) Format→ Cells c) Insert→ Cells   d) Edit→ Cells 
54.  Which command is used for preparing the chart in Star Office Calc? 
 a) Chart→ From File  b) Insert→ From File  c) Insert→ Objects d) Insert→ Charts 
55.  Automatic fill command of StarOffice Calc is equivalent to 
 a) Cut and Paste   b) Copy and Insert  c) Cut and Insert  d) Copy and Paste 
56.  The combination of column and row headings is known as 
 a) Cell Address  b) Cell    c) Cell Pointer   d) Cell Range 
57.  Which is the shortcut icon for Function Wizard in Spreadsheet? 
 a) Insert→ Function  b) Ctrl + F2   c) fan(x)   d) f(x) 
58.  The command used for inserting special characters in Spreadsheet is 
 a) Insert→ Special Characters  b) Insert→ ASCII Characters  
 c) Insert→ Picture→ From File   d) Insert→ Special Symbols 
59.  The OLE stands for 
 a) Object Linking Embedding  b) Object Linking Enrolled 
 c) Object Linking Environment  d) Object Linking Enrichment 
60.  Over the time, the term spreadsheet has come to refer specifically to 
 a) File   b) Tabular column  c) Software package d) Worksheet 
61.  Which of the following bars is used to display the current cell and its content in StarOffice Calc? 
 a) Formula bar   b) Tool bar   c) Status bar   d) Menu bar 
62.  To remove print range setting, click 
 a) Format→ Print Ranges→ Erase   b) Format→ Print→ Delete 
 c) Format→ Print Ranges→ Edit   d) Format→ Print Ranges→ Delete 
63.  Data and formula can be entered into the 
 a) Cell address bar   b) Status bar   c) Menu bar   d) Cell 
64.  Data and formula can be entered into the 
 a) Cell address bar   b) Status bar   c) Menu bar   d) Cell 
65.  The function bar is below the 
 a) Menu bar   b) Scroll bar  c) Status bar   d) Object bar 
66.  Lotus 1-2-3 was introduced in the year 
 a) 1982   b) 1980    c) 1985    d) 1984 
67.  In order to insert an empty row, the icon to be selected is 
 a) Insert Cells Right   b) Insert Cells Down c) Insert Columns  d) Insert Rows 
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68.  Visicalc contained______ of columns. 
 a) 65    b) 62    c) 63   d) 64 
69.  The spreadsheet developed by Lotus Development Corporation is 
 a) Quattro Pro   b) Improve  c) StarOffice Calc  d) Excel69 
70.  Which icon is used to import objects from other applications into a worksheet? 
 a) Insert OLE Object b) Insert Formula  c) Insert Chart   d) Insert Applet 
71.  Borland International introduced 
 a) Quattro Pro  b) Improve   c) StarOffice Calc  d) Excel 
72.  Which facility of StarOffice Calc helps to format the worksheet with different predefined styles and colours? 
 a) AutoPilot sheet   b) AutoStyle Sheet c) AutoCorrect sheet  d) AutoFormat sheet 
73.  To change the width of a column, the command used is 
 a) Format→ Row→ Height    b) Format→ Column→  Width  
 c) Format→ Row→ width    d) Format→ Column→ Height 
74.  In Spreadsheet, each cell is referred to by its 
 a) Insertion Point   b) Record Pointer  c) Cell Address  d) Cursor 
75.  Which function key is pressed to appear a vertical cursor on the formula bar? 
 a) F7    b) F1    c) F5    d) F2 
76.  Which icon provides to generate a scrolling screen within a worksheet? 
 a) Insert Applet   b) Insert OLE Object  c) Insert Floating Frame d) Insert Chart 
77. Which menu is selected to quit from StarOffice? 
 a) File→ Exit   b) File→ Quit   c) Menu→ Exit  d) Menu→ Quit 
78.  In which menu, Function option is a vailable? 
 a) Open    b) Reference   c) Insert  d) File 
79.  Exponentiation is represented by 
 a) +    b) %   c) /    d) ^ 
80.  Which one of the following is not a comparative opera tor? 
 a) =    b)<>   c) /   d)> 
81.  The option under the File menu used to print the worksheet is 
 a) Page View   b) Print Preview  c) Print Range   d) Print 
82.  In Fill Series dialog box, the equivalent type for multiplication 
 a) Growth   b) Date    c) Autofill   d) Linear 
83.  The percentage (% ) icon multiplies the contents of the cell by 
 a) 1000    b) 10    c) 1    d) 100 
84.  Which of the following is an inter section operator? 
 a) ;    b)&   c) !   d) : 
85.  To view data in the form of charts, use 
 a) Spreadsheet  b) StarOffice Base  c) StarOffice Writer  d) Table 
86.  Which reference operator is used to set the range in a spreadsheet? 
 a) :   b) !    c) ;    d) $ 
87.  Which number format icon is used to display the contents of the selected cells in default format? 
 a) Percent    b) Currency   c) Add Decimal   d) Standard 
88.  Spreadsheet columns are labeled from 
 a) A to IV    b) A to IU   c) A to Z  d) A to IA 
89.  The number of icons appeared in the Insert Cell floating tool bar are 
 a) Four   b) Five    c) Three   d) Six 
90.  In StarOffice Calc, rows are numbered from 1 to 
 a) 21000    b) 22000   c) 31000   d) 32000 
91.  The status bars and scroll bars are at the 
 a) Extreme right  b) Extreme bottom  c) Top    d) Extreme left 
92.  Visicalc for Apple II was invented in the year 
 a) 1977    b) 1981    c) 1982    d) 1979 
93.  Lotus 1-2-3 became very popular because of its ability to combine 
 a) Graphics features     b) Both Graphics and Database Management features 
 c) Database management features    d) Mathematical formulae 
94.  Excel was introduced by 
 a) Borland International  b) Microsoft Corporation c) Lotus Corporation  d) Sun Microsystems 
95.  The automatic fill feature of StarOffice Calc is used for the purpose of 
 a) Moving    b) Inserting  c) Copying   d) Deleting 
96.  Which option is used to delete a row? 
 a) Edit→ Delete Cells b) Edit→ Delete   c) Edit→ Delete Rows  d) Edit→ Delete Contents 
97.  To increase the width of a column, the mouse is clicked and dragged towards the 
 a) Right   b) Upward direction  c) Left   d) Downward direction 
98.  To decrease the width of the cell, the mouse is dragged 
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 a) Upwards   b) Towards the right  c) Downwards   d) Towards the left 
99.  In StarOffice Calc, the non-numeric entries are referred with-------- 
 a) Character   b) String   c) Label   d) Non-numeric 
100.  The Personal Computer was introduced in the yea r 
 a) 1976    b) 1982    c) 1975  d) 1979 
101.  Which is not a comparative operator? 
 a)<>   b)>=    c)<   d) & 
102.  Visible calculator package was developed for 
 a) Super Computers  b) Mainframe Computers c) Micro Computers  d) Mini Computers 
103.  Lotus1-2-3 was introduced by 
 a) Sun Microsystems  b) Microsoft Corporation  c) Borland International  d) Lotus Development Corporation 
104.  The automatic fill feature is used to 
 a) Type the formula  b) Draw charts   c) Create a series  d) Copy the cell contents 
105.  Visicalc was an essential program f or 
 a) Cost benefit analysis  b) Tender evaluation  c) Inventory control  d) Financial analysis 
106.  The cell A4 becomes absolute when you enter 
 a) A$$4    b) A$4$    c) $A4$    d) $A$4 
107.  In spreadsheet of multiple sheets, a list of sheets appear as tabs 
 a) at the bottom  b) at right   c) at left   d) at the top 
108. Cells B3 B4 C3 C4 D3 D4 in StarOffice Calc can be referred as 
 a) B3:D4   b) B3:D3   c) B4.D4   d) B3.D4 
109.  The cell D7 in StarOffice Calc becomes absolute, when you type it as 
 a) $D*7    b) *D$7   c) *D*7    d) $D$7 
110.  The cells A4, A5, A6, B4, B5 & B6 are referred in a Worksheet as 
 a) A1:B6    b) A4:A6 ; B4:B6  c) A4:B6  d) A1:A6 ; B1:B6 
111.  How many rows and columns are in Visicalc? 
 a) 254, 36    b) 524, 36   c) 63, 254   d) 254, 63 
112.  How many cells are available in the worksheet range C1:E2? 
 a) 6   b) 10    c) 4    d) 8 
113.  Which cell of worksheet is referred as Home Cell? 
 a) 1A    b) AA    c) First cell   d) A1 
114.  Which refers to the files that you create with spreadsheet software? 
 a) Rows and columns  b) Spreadsheet   c) Table   d) Worksheet 
115.  Which of the following statements is false? 
 a) Small red triangles indicate column width is enough b) Spreadsheets are made up of rows and columns 
 c) Exit under File can be used to quit from StarOffice  d) At the top of Spreadsheet window is the Menu bar 
116.  The Inequality comparative operator symbol is 
 a)><   b) <>   c) =    d)>= 
117.  Which Series type option can be used for both positive and negative increment? 
 a) Linear   b) Date    c) Growth   d) AutoFill 
118.  The 3D formula to calculate the sum of the numbers in the cell A1 of Sheet1 and A1 of Sheet2 is 
 a) =SUM(Sheet1.A1:Sheet2.A1)   b) =SUM(Sheet1.A1;Sheet2.A1) 
 c) =SUM(Sheet1:A1;Sheet2:A1)   d) =SUM(Sheet1.Sheet2.A1:A2) 
119.  Which command is used to print the worksheet with grids? 
 a) Format→ Borders  b) Format→ Grids  c) Format→ Sheet  d) Format→ Page 
120.  By default, how many numbers of sheets are available in a spreadsheet? 
 a) 4    b) 3   c) 1    d) 2 
121.  Which of the following data can be typed into a spreadsheet cell? 
 d) Formulae  b) Text    c) Numbers   a) All of these   
122.  Which bars have shortcut icons for frequently done tasks in the spreadsheet? 
 a) Menu bar   b) Formula bar   c) Object bar  d) Main Tool bar 
123.  The operator <> is used to check 
 a) greater than   b) equal   c) inequality  d) less than 
124.  Fill command in Star Office Calc is available under the menu is 
 a) Edit   b) Format   c) Mouse   d) Keyboard 
125.  The process of arranging the data in some order in a table is cal led 
 a) Merging    b) Sorting  c) Filtering   d) Searching 
126.  Which of the following has short cut icons for frequently done tasks in spreadsheet? 
 a) Function bar & Object bar b) Formula bar c) Main Tool bar  d) Menu bar 
127. The intersection of rows and columns creates 
 a) pointer   b) address  c) cells   d) sheet 
128. Visicalc contained______ of columns and ______ rows. 
 a) 63,254   b) 256,63  c) 32000,63  d) 256,32000 
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129. Starcalc was introduced by _______ 
 a) Microsift   b) Borland International c) Lotus corporation d) Sun Microsystems 
130. Which company introduced Improve? 
 a) Microsoft  b) Lotus Corporation c) Sun Microsystems d) Borland International 
131. To begin with in a work sheet the cell pointer is always in cell _____ 
 a) 1A   b) A1   c) AA1   d) 1AA 
132. In which format date should be entered in Star Office calc? 
 a) DD/MM/YY  b) MM/DD/YY  c) YY/DD/MM  d) YY/MM/DD 
133. Which of the following is used for intersection? 
 a) :    b) ;   c) !   d) & 
134. Which symbol is used in absolute cell addressing? 
 a) &   b) $   c) #   d) % 
135. Which operator combines sections of text to the entire text? 
 a) Arithmetic  b) comparative  c) text   d) Reference 
136. To draw an ellipse in the worksheet click the ________ icon 
 a) Show draw function b) Draw function c) Draw Ellipse  d) Draw rectangle 
137. Which is used to calculate and analyze set of numbers? 
 a) Spreadsheet  b) Formula  c) Charts  d) Function 
138. Which is a spreadsheet program? 
 a) Staroffice Impress b) Improve  c) Lotus Amipro  d) Flash 
139. The number of rows in visicalc 
 a) 64   b) 256   c) 254   d) 255 
140. In star calc which menu contains Auto Format 
 a) File   b) Edit   c) Format  d) Style 
141. In Star calc amongst arithmetic operators which one of the following is executed first in the rules of precedence? 
 a) Exponentiation  b) Negative  c)  Multiplication & Division d) Addition & Subtraction 
142. The option under the File menu used to print the worksheet is 
 a) Close    b) Quit   c) Exit   D) End 
143. To do the calculations for different worksheets in a particular worksheet we use 
 a) 2D formula  b) Function  c) 3D formula  d) Selection 
144. The option under the File menu used to preview the worksheet before printing 
 a) Page View   b) Page setup   c) Page setup default d) Print 
145. The cell B4 becomes absolute when you enter 
 a) $B$4   b) B$4$   c) $B4$   d) B$$4 
146. A grid of cells with a programmable calculator attached to each cell is 
 a) Computer  b) Visicalc  c) Spreadsheet  d) Datasheet 
147. Which operator is not an arithmetic operator (in Starcalc)? 
 a) %   b) *   c) ^   d) <> 
 
 

7. DATABASE 
 [Blue print - 9 questions] 

1.  The term data comes from the word 
 a) Datus    b) Datum  c) Datem   d) Datas 
2.  A database is a repository of collections of related 
 a) Row    b) Table   c) Data   d) Column 
3.  Which of the following is used to arrange data in some order? 
 a) Sorting   b) Form   c) Query   d) Filter 
4.  How many field types are there in Star Office Base? 
 a) 11    b) 20   c) 13    d) 14 
5.  The entire collection of related data in one table is referred to as 
 a) Query    b) File   c) Field    d) Record 
6.  Which key uniquely identifies a record in a database table? 
 a) F1 key    b) Primary key  c) F5 key   d) Secondary key 
7.  Editing the data includes 
 a) Deleting a record   b) Changing the format of the database  
 c) All the other three choices   d) Appending a record 
8.  Which database file consists of a single data table? 
 a) Relational   b) Flat-File  c) Network   d) Hierarchical 
9.  Which is a process of joining data from two table s of different databases? 
 a) Filtering    b) Searching   c) Merging  d) Sorting 
10.  To edit a record, we have to select the record by clicking on 
 a) Record pointer  b) Record button  c) Tab key   d) Record key 
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11.  Process of performing correction on the existing data is called as 
 a) Filtering    b) Editing  c) Searching   d) Sorting 
12.  Printed information that is assembled by gathering data is called 
 a) Table    b) Form   c) Query   d) Report 
13.  By clicking on the Delete Rows option the selected record will 
 a) Appended   b) Changed   c) Deleted  d) Edited 
14.  Sorting on more than one field of a table at the same time is called 
 a) Multi Sorting   b) Multiple sorting c) Searching   d) Sorting 
15.  DBMS is an acronym for 
 a) Data Base Management System   b) Data Base Maintaining System 
 c) Data Binary Management System    d) Data Base Manipulating System 
16.  Which is simply a screen that displays fields of a record in a well-spaced out manner? 
 a) Filter    b) Table   c) Query   d) Form 
17.  In How many ways the Manipulation of database can be done? 
 a) 7   b) 6    c) 10    d) 8 
18.  Standard Filter is also called as 
 a) Conditioned Filter  b) Complete Filter  c) Default Filter d) AutoFilter 
19.  The process used to select a desired specific data from a database is 
 a) Filtering   b) Sorting   c) Merging  d) Searching 
20.  The shortcut key used for saving a table in StarOffice Base is 
 a) Ctrl + F    b) Ctrl + A   c) Ctrl + E   d) Ctrl + S 
21.  A Database is a collection of 
 a) Fields    b) Columns   c) Rows   d) Tables 
22.  A repository of collections of related data or facts 
 a) Program    b) Database  c) Data    d) Information 
23.  SQL stands for 
 a) Standard Query Link b) Structured Query Language     c) Standard Query Language   d) Structured Query Link 
24.  The accurate length of decimal digits in a single precision number is 
 a) 7   b) 14    c) 13    d) 8 
25.  Sorting is a process of 
 a) Joining the data  b) Performing corrections c) Arranging the data d) Selecting a desired specific data 
26.  Which one of the following databases is very powerful? 
 a) Relational  b) Hierarchical   c) Network   d) Flat-File 
27.  Which command is used to create a new database in StarOffice Base? 
 a) New→ File→ database  b) File→ New→ Table  c) New→ Database  d) File→ New→ Database 
28.  The collection of Tables, Queries, Forms and Reports are generally referred to 
 a) Multimedia   b) Document   c) Database  d) Spreadsheet 
29.  What are the two types of report in StarOffice Base? 
 a) Static and Dual   b) Static and Standard  c) Standard and Dynamic  d) Static and Dynamic 
30.  In case of double precision, decimal values are accurate upto the length of 
 a) 8 Places    b) 6 Places   c) 14 Places  d) 7 Places 
31.  To send text outline into presentation, select 
 a) File→ Outline to Presentation    b) File→ Presentation 
 c) File→ Send→ Presentation    d) File→ Send→ Outline to Presentation 
32.  The keyboard shortcut used to switch over from one software window to another window is 
 a) Alt + Tab  b) Shift + Tab   c) Tab    d) Ctrl + Tab 
33.  DDE means 
 a) Dynamic Data Exchange    b) Dynamic Data Exchange   
 c) Dynamic Data Enrichment   d) Dynamic Data Environment 
34.  The Paste Special menu is available under the menu 
 a) Insert    b) File    c) Edit   d) View 
35.  A row in a StarOffice Base table represents a ________________. 
 a) File    b) Structure   c) Field    d) Record 
36.  In which database, records are organized in a tree like structure? 
 a) Relational   b) Network   c) Hierarchical  d) Object oriented 
37.  Which is the defined screen to view data from a table or a query? 
 a) Report    b) Form   c) Filter  d) Query 
38.  Which one of the following is a type of query? 
 a) Table    b) Filter  c) Report   d) File 
39.  Which is the most prevalent database in today’s business organizations? 
 a) Flat-File    b) Network   c) Relational  d) Hierarchical 
40.  Which of the following icons is used to remove the filter? 
 a) Filter    b) Remove Filter  c) Remove Filter / Sort d) Sort 
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41.  Spreadsheet is an example for 
 a) Flat-file   b) Network   c) Relational   d) Object Oriented 
42.  Which is used to browse through selected records to meet a set of criteria? 
 a) Searching   b) Filter  c) Query   d) Sorting 
43.  Which database is very similar to hierarchical structure? 
 a) Flat-file    b) Object-oriented  c) Relational   d) Network 
44.  Filter used with a condition is called 
 a) Default Filter (Standard Filter) b) Conditioned Filter  c) AutoFilter  d) Unconditioned Filter 
45.  Which one of the following can be saved for later use? 
 a) Questions   b) Filters   c) Queries  d) Filters and Queries 
46.  Users can define their own more sophisticated data types are called as 
 a) Primitive   b) System defined c) Built-in   d) User-defined 
47.  Records that are organized in parent-child type relationship is 
 a) Hierarchical  b) Flat File   c) Network   d) Relational 
48.  Which of the following limits the information on the screen of database? 
 a) Viewing    b) Arranging   c) Sorting   d) Filtering 
49.  Based on the conceptual structures, the Star Office Base databases are classified into 
 a) 7    b) 5   c) 2    d) 8 
50.  How many options are there in the pane of StarOffice Base screen? 
 a) 3    b) 4   c) 5    d) 2 
51.  In StarOffice Base, each table column represents a 
 a) Field   b) Record   c) Cell    d) File 
52.  Which database defines data characteristics, attributes, and procedures as complex objects? 
 a) Relational Database  b) Object Oriented Database c) Flat-File Database  d) Hierarchical Database 
53.  In which database, one record type can be related to any number of other record types? 
 a) Hierarchical   b) Relational   c) Flat-file   d) Network 
54.  Which of the following options is used to insert the field names of the database table as headings for each of the text 

table columns? 
 a) Create column name  b) Create row only  c) Insert column name  d) Apply column name 
55.  Which of the following options is used to insert an empty heading line into the text table? 
 a) Create row only  b) Create row name  c) Create empty row  d) Apply column name 
56.  Which dialog box is use d to select the option DDE link? 
 a) Paste    b) Paste Data   c) Paste Link   d) Paste Special 
57.  Which of the following features is for displaying and browsing a selected list or subset of records from a table? 
 a) Searching   b) Sorting   c) Filtering  d) Merging 
58.  Which database represents different approach for the data? 
 a) Network database  b) Hierarchical database  c) Object oriented database d) Relational database 
59.  Which option of form designing is similar to creating a query using AutoPilot option? 
 a) Default Filter   b) Remove Filter  c) AutoFilter   d) Auto Pilot 
60.  The language designed specifically for communicating with a database is 
 a) PASCAL    b) SQL   c) OQL   d) BASIC 
61.    To view or modify the design of an existing table, click the Tables from _____ pane. 
 a) <Database>  b) Query   c) Report d) Filter 
62.  Multiple reports can be created and stored f or 
 a) A table   b) A query   c) A table or a query  d) A filter 
63.  Which of the following is displayed in the lower part of the Table Design window? 
 a) Field Properties pane b) File Properties pane  c) Field pane   d) Properties pane 
64.  The filter used to display only the records, which match the value of the current field is 
 a) Limiting Filter   b) Default Filter   c) Auto Filter  d) Query Filter 
65.  Which database concept is used to assemble information from data? 
 a) Report    b) Table   c) DBMS  d) Query 
66.  What are user- constructed statements? 
 a) Reports    b) Filters   c) Queries  d) Forms 
67.  Which data type can be integer, float, double precision, date, time, etc.,? 
 a) User-defined   b) Non-numeric   c) Information   d) Numeric 
68.  Which of the following database structures were primarily used on Mainframe computers? 
 a) Relational   b) Flat-file   c) Hierarchical  d) Object Oriented 
69.  Which one of the following statements is incorrect? 
 a) SQL is a structured query language   b) Collection of related fields is called a record 
 c) StarOffice Base is a Spreadsheet software   d) Merging is a process of joining data 
70.  The option used to specify the maxi mum characters can be entered in a StarOffice Base field is 
 a) Entry required   b) Format Example  c) Length  d) Default Value 
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71.  Character, Number or Boolean are 
 a) User-defined data types b) Primitive data types  c) Data types  d) Information 
72.  The field type that is not allowed by StarOffice Base is 
 a) Picture  b) Project   c) Text    d) Binary Field 
73.  In StarOffice Base, Integer and Float data types are called as 
 a) Primary data types  b) Primitive data types c) Secondary data types  d) Computer data types 
74.  In database creation, which option of field property specifies the user should enter a value for that field? 
 a) Entry Required  b) Default value   c) Format   d) Length 
75.  In StarOffice Base, field alignment is a part of 
 a) Query design   b) Form design   c) Table design  d) Report design 
76.  The menu for creating a new table in Star Office Base is 
 a) Table→ Table Design  b) New→ Table→ Table Design c) Insert→  Table Design  d) New→ Table 
77.  Which of the following is a program, or collection of programs that allows any number of users to access data? 
 a) Table    b) Query   c) Report   d) DBMS 
78  Which one of the following are special views of the data in a table? 
 a) Reports    b) Tables   c) Queries  d) Forms 
79.  How many steps are available in Query wizard window? 
 a) 2    b) 4    c) 8    d) 6 
80.  The common fields of two or more tables of relational database is called as 
 a) Primary Key   b) Cell    c) Key    d) Row 
81.  How many steps are available in Report wizard window? 
 a) 4    b) 8    c) 6   d) 2 
82.  Which of the following is not a valid field type in Star Office Base? 
 a) Memo    b) Picture   c) Image  d) Date 
83.  To update data automatically in a text document which is copied from a spreadsheet, the option used is 
 a) DDE link   b) RTF    c) GDI metafile   d) HTML 
84.  To transfer heading together with its accompanying paragraphs to presentation, select 
 a) File→ Send→ AutoAbstract to Presentation  b) File→ Send→ Outline to Presentation 
 c) File→ Send→ AutoHeading to Presentation   d) File→ Send→ Autoformat to Presentation 
85.  While inserting a database table into a text document, the data should be inserted as 
 a) Text    c) Table   d) Fields  b) all of these 
86.  To insert the Spreadsheet Calc cell in StarOfficeWriter, select 
 a) Edit→ Paste Special b) Edit→ Paste   c) Format→ Paste  d) Tools→ Paste Special 
87.  Which of the following is not a step in data processing? 
 a) Validation   b) Verification   c) Collection   d) Computation 
88.  Which involves data collection, verification, validation and report generation? 
 a) Data processing b) Table   c) Database   d) Data 
89.  In which Computers Hierarchical Database were used? 
 a) Super    b) Micro   c) Mainframe   d) Mini 
90.  Queries are_________ statements. 
 a) user-defined   b) predefined   c) structural   d) user-constructed 
91.  The key combination used to save the database table is 
 a) Ctrl + V    b) Ctrl + A   c) Ctrl + C   d) Ctrl + S 
92.  Which of the following is not a step in data processing? 
 a) Computation  b) Validation   c) Collection   d) Verification 
93.  To sort the records in the ascending order, select the field and click on 
 a) Sort icon   b) Sort Ascending icon c) Ascending icon  d) Sort / Filter icon 
94.  Which icon is pressed to display the records in original order after sorting? 
 a) Delete Sort/Filter  b) Exclude Filter/Sort  c) Remove Filter/Sorter d) Delete Filter/Sort 
95.  The hierarchical database structures were primarily used for 
 a) micro computers   b) super computers  c) mainframe computers d) mini computers 
96.  A filter is also type of 
 a) Form    b) Report   c) Query  d) Table 
97.  To copy the selected cell range in text document, which option in the paste special dialog box has to be selected? 
 a) Link    b) OLE link   c) DDE link  d) Paste 
98.  A set of processed data is called 
 a) Procedure   b) Information  c) Database   d) Datum 
99.  In StarOffice Base, which of the following icons is used to display the records in the original order? 
 a) Standard Filter icon  b) Remove Filter/Sort icon c) Auto Filter icon  d) Default Filter icon 
100.  How many general categories are there in DBMS? 
 a) 3   b) 2    c) 6    d) 4 
101. ______ is a set of processed data that convey the relationship between the data considered. 
 a) data   b) datum  c) database  d) information  
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102.  Each row in table represents _________ 
 a) field   b) record  c) database  d) data 
103.  A database file that consists of a single data table is a _____ database. 
 a) Relational  b) Hierarchical  c) Flat file  d) single base 
104. Spreadsheet is an example of  ________ database. 
 a) Flat file   b) Relational  c) Hierarchical  d) Object oriented 
105. Which of the following is not a data type? 
 a) Text   b) information  c)  Boolean  d) Number 
106. There are ______ types of filters in Staroffice Base. 
 a) 3   b) 4   c) 5   d) 2 
107. Example for flat file database is 
 a) Word Processor  b) Presentation  c) Animation  d) Spreadsheet 
108. Which database is not suited for processing form multiple data tables? 
 a) Relational  b) Flat file  c) Hierarchical  d) Network 
109. Each row and column in a table represents 
 a) Record, Field  b) Data, Field  c) File, Field  d) Data, Record 
110. Which language is used to query the database? 
 a) C++   b) SQL   c) HTML  d) DBMS 
111. Which data type accepts only whole numbers? 
 a) char   b) decimal  c) integer  d) float 
112. In computers, the value assigned to a variable is called 
 a) Key   b) Information  c) Data   d) Report 
113. The command used to save the database table is 
 a) File ⟶ Save  b) File ⟶ Tools ⟶ Save c) Edit ⟶ Save  d) Edit ⟶ Fill ⟶ Save 

***************************** 
 

8. INTRODUCTION TO MULTIMEDIA 
 [Blue print - 5 questions] 

1.  Which of the following is a computer based presentation technique that incorporates text, sound, animations 
andvideo elements? 

 a) Multimedia  b) Animation   c) Modeling   d) Compression 
2.  Which application allows us to send and receive message s over cell phones? 
 a) MMS   b) CBT    c) MNS    d) MOS 
3. The act of allowing the users to participate actively is called as 
 a) Interactive multimedia  b) Active multimedia  c) Internal multimedia  d) Innovative multimedia 
4.  The conversion of analog sound waves to a digital format is called as 
 a) Sampling  b) Amplitude   c) Pitch    d) Crest 
5.  The technique used to blend two or more images to form a new image is 
 a) Sampling   b) Morphing  c) Rendering   d) Warping 
6.  What are the processes used to create a 3-D animation? 
 a) Animating   b) Rendering   c) Modeling   d) All of these 
7.  In which technique, the recurring set of information is identified and replaced by a single piece of information? 
 a) Compression   b) Help    c) Vector Graphics  d) Virtual reality 
8  MIDI stands for 
 a) Musical Interface Digital Instrument   b) Modeling Instrument Digital Information 
 c) Modeling Instrument Digital Interface   d) Musical Instrument Digital Interface 
9.  MPEG stands for 
 a) Movie Pictures Experts Group    b) Motion Pictures Experts Group 
 c) Moving Pictures Experts Group    d) Music Pictures Experts Group 
10.  Which 2-D animations are usually seen in computer games? 
 a) Object-based animations   b) Procedure-based animations  
 c) Attributes-based animations    d) Cel-based animations 
11.  How many frames per second causes the video to look jerky? 
 a)<10    b) <15    c)<9    d)<20 
12.  Which technique is used to distort a single image to represent something else? 
 a) Rendering   b) Animating   c) Morphing   d) Warping 
13. GIF stands for 
 a) Graphic Interchange Format   b) Graphic Information Format 
 c) Graphic Interconnection File    d) Graphical Interface Format 
14.  The two categories of image (or) video file compressions are 
 a) Modeling and Animating  b) 2D and 3D  c) Morphing and Warping  d) Lossy and Lossless 
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15.  MMS means 
 a) Microwave Media Service     b) Multimedia Messaging System  
 c) Multimedia Media Service    d) Microwave Messaging Service 
16.  Which special hardware card is used to improve the efficiency in the display of images on the screen? 
 a) Vector graphics  b) Static graphics  c) Dynamic graphics  d) Scalar graphics 
17.  JPEG may be expanded as 
 a) Joint Physical Exports Group    b) Joint Physical Experts Group 
 c) Joint Photographic Experts Group  d) Joint Photographic Expression Group 
18.  How much of color depth results in the image looking murky? 
 a)<255    b)<16    c)<8    d) <256 
19.  The sound editing program, which can be added to enhance the quality of converted sound waves are 
 a) Sound Merge   b) Sound Edit   c) Sound Forge   d) Sound Mix 
20.  What are the two types of animations? 
 a) 1D or 3D   b) any dimensional  c) 2D or 3D  d) 1D or 2D 
21.  What are the categories of 2-D animations? 
 a) Only Frame-based animations     b) Only Object-based animations 
 c) Cel-based animations and Object-based animations d) Only Cel-based animations 
22.  Which of the following is widely used to add special effects to movies? 
 a) Multimedia  b) Sound   c) Graphics   d) Text 
23.  AIFF stands for 
 a) Audio Interchange File Format   b) Audio Information File Format 
 c) Audio Interchange File Form    d) Audio Internal File Format 
24.  How many attributes control the characteristics of sound? 
 a) 2    b) 4   c) 1    d) 3 
25.  Which of the following are examples of static images? 
 a) Bitmap images   b) MPEG files   c) Photographs   d) a & c 
26.  The full form of HTTP is 
 a) Hyper Text Transfer Process    b) Hyper Text Transport Protocol 
 c) Hyper Text Transmission Protocol   d) Hyper Text Transfer Protocol 
27.  Which special software is used to view the multimedia presentations? 
 a) Windows Music Player  b) Windows Movie Player   c) Windows Motion Player    d) Windows Media Player 
28.  The full form of HTML is 
 a) Hyper Text Machine Language    b) Hyper Text Markup Language 
 c) Hyper Text Manipulation Language   d) Hyper Text Marking Language 
29.  When sound or video is included as part of a web page, then it is called as 
 a) inbuilt    b) internal   c) built-in   d) inline 
30.  Which is a program that can be launched by the browser to "help" play sound or video? 
 a) Plug-out    b) Play-out   c) Plug-in  d) Play-in 
31.  Helper Application is also called as 
 a) Play-in    b) Plug-in  c) Plug-out   d) Play-out 
32.  The extension for the video files stored in the MPEG file format is 
 a) .mpg or .mpeg   b) .mpeg or .mpe  c) .mpg or .mpe   d) .mpig or .mpg 
33. The full form of AVI is 
 a) Audio Video Instruction  b) Audio Video Interleave    c) Audio Visual Instruction     d) Audio Visual Interleave 
34.  Which of the following are frequently used to make computer games thrilling and realistic? 
 a) High-end graphics  b) High-end graphics and Animations c) Animations  d) Cartoon strips 
35.  GIF is limited to 
 a) 8 bit palette  b) 12 bit palette   c) 4 bit palette   d) 16 bit palette 
36.  Which animation consists of multiple drawing, each one a little different from the other? 
 a) Cel-based animations b) Frame-based animations    c) Object-based animations   d) Width-based animations 
37.  Sound files in the MIDI format have the extensions 
 a) .mid or .midi  b) .md or .mi   c) .md or .mid   d) .midi or .md 
38.  The popular web browsers are 
 a) Windows Explorer   b) Both Netscape Navigator and Internet Explorer 
 c) Netscape Navigator   d) Internet Explorer 
39.  The various multimedia components are coordinated with a technique called 
 a) Vector graphics   b) Virtual Reality c) Morphing   d) Warping 
40.    The JPEG (Joint Photographic Experts Group) image files are in _______format.  
 a) Lossy   b) lossless  c) GIF and MPEG  d) GIF and Animated GIF 
41.  The Real Audio formats have the extension 
 a) .rm or .rad   b) .ram or .rf   c) .rm or .ram  d) .rm or .rf 
42.  Which of the following file formats are developed by Apple? 
 a) AU/SND    b) SND/AIFF  c) AIFF/MIDI   d) SND/MIDI 
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43.  Which one of the following image files is an example for lossy format? 
 a) WAVE    b) SND    c) JPEG   d) GIF 
44.  The shockwave format is used to store multimedia components created using 
 a) Netscape Navigator  b) Media Player   c) Flash  d) Internet Explorer 
45.  Which attributes are controlling the characteristics of sound? 
 a) Analog and digital  b) Amplitude and Frequency c) Length and Breadth  d) Crest and Valley 
46.  The height of each crest in the analog wave pattern is called as 
 a) Time    b) Volume  c) Amplitude   d) Frequency 
47.  The distance between the crests of the analog wave pattern is called as 
 a) Volume    b) Valley   c) Pitch  d) Amplitude 
48.  AIFF format was developed by 
 a) Real Networks   b) Apple  c) Microsoft   d) IBM 
49.  Which is the most common version of e-learning packages? 
 a) CBT/WBT  b) WBT/SBT   c) MMS/SMS   d) CBT/XBT 
50.  Files in the AIFF format have the extension 
 a) .aiff or .aifi   b) .aif or .aiff  c) .aiff or .aff   d) .aif or .aifi 
51. The sound format developed by Macromedia is 
 a) QuickTime   b) Wave   c) AIFF    d) Shockwave 
52.  Which sound format is more popular for transfer of data over the Internet? 
 a) MIDI   b) AIFF   c) AU    d) RealAudio 
53.  Which animations are referred to as slide or path animations, create d by moving an object across a screen? 
 a) Object-based animations    b) Frame-based animations    c) Cel-based animations   d) Width-based animations 
54.  Which of the following is the commercial multimedia content development software? 
 a) Flash    b) Maya   c) Dream Weaver d) All of these  
55.  In which industry, Multimedia is heavily used? 
 a) Research   b) Education   c) Entertainment  d) Business 
56.  The extension name of files in QuickTime format is 
 a) .qck    b) .mov  c) .qtf    d) .quk 
57.  The multimedia sound format developed by IBM and Microsoft was 
 a) AIFF    b) WAVE  c) SND    d) AU 
58.  In which file, more complex techniques than GIF are applied to compress images, like photographs where thecolor of 

every pixel is different? 
 a) MPEG    b) JPG    c) NxView   d) GIF 
59.  Which file format is being suited for simple graphic images with relatively few colors? 
 a) NxView    b) MPEG   c) JPG    d) GIF 
60.  Which image format supports full color and produces relatively small size files? 
 a) Animated GIF   b) MPEG   c) GIF    d) JPEG 
61.  Which compression algorithm takes advantage of the limitations of human visual senses? 
 a) Lossy   b) Vector graphics  c) Lossless   d) Lossless and Lossy 
62.  The extension name for Windows Media Format is 
 a) .wam    b) .wmf    c) .wmv  d) .wma 
63.  Which of the following multimedia formats is commonly used for transfer ring music information betweenelectronic 

music devices? 
 a) SND    b) WAVE   c) MIDI    d) AIFF 
64.  MIDI was developed in the year of 
 a) 1992    b) 1972    c) 1962    d) 1982 
65.  Which multimedia file format supports both Audio and Video? 
 a) AIFF    b) AU   c) RealAudio  d) MIDI 
66.  The inline sound can be added to a web page by using the HTML tag 
 a)<bgsound> or <img> b) <bgsound> or <img> c)<bgsound> d)<img> 
67.  Helper applications can be launched using the HTML tag 
 a)<applet>  b)<object>  c) <embed>  d)All of these  
68.  Which of the following multimedia formats is used to store only sounds? 
 a) AVI    b) MPEG   c) MP3    d) QuickTime 
69.  Which of the following multimedia formats was developed by Microsoft? 
 a) WAVE    b) Windows Media c) AVI   d) All of these 
70.  Multimedia incorporates features like 
 a) Text    b) Sound   c) Video   d) All of these 
71.  Shockwave format was developed by 
 a) Apple    b) Microsoft   c) IBM    d) Macromedia 
72.  The compression that retains the exact image throughout the compression is called 
 a) lossless compression b) animating   c) lossy compression  d) rendering 
 

www.Padasalai.Net                                                www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

Simon-Adarsh Vidya Kendra                           Question Bank-Computer Science Page 20 
 

73.  In which year AVI format sound files are developed? 
 a) 1992   b) 1985    c) 1995    d) 1991 
74.  The technique that provides an environment experienced by users as similar to reality is 
 a) Animations   b) Vector graphics  c) Virtual reality d) Modeling 
75.  In which year was RealAudio format developed? 
 a) 1995   b) 1994    c) 1982    d) 1981 
76.  All digital cameras have the option to save images in 
 a) Bitmap format  b) GIF format   c) WMF format   d) JPEG format 
77.  The AVI format was developed by 
 a) Microsoft  b) Macromedia   c) IBM    d) Apple 
78. Which of the following is not a step in the process of creating a 3-D animation? 
 a) filtering   b) modeling  c) animating  d) rendering 
79.  SND format was developed by 
 a) Apple    b) Microsoft   c) IBM    d) Real Networks 
80.  The QuickTime format was developed by ________ primarily to store videos. 
 a) Macromedia  b) Apple  c) Microsoft  d) Real Networks 
81. The extension name for Shockwave Format is 
 a) .swf   b) .swa   c) .sfw   d) .snf 
82. Which of the following tags is not used to launch helper applications? 
 a) <embed>  b) <name>  c) <applet>  d) <object> 
83. Which of the following formats creates a perfect reproduction of images? 
 a) MIDI   b) GIF   c) JPEG   d) BMP 
84. WBT stands for  
 a) Web Based Tutorials b) World Based Training c) Web Based Training d) Window based Training 
85. Which is not well fitted for photographic works? 
 a) MIDI   b) GIF   c) JPEG   d) BMP 
86. In multimedia the pattern of the sound that you hear is   
 a) Analog Wave  b) Digital wave  c) Hybrid wave  d) Frequency 
87. Which of the following animation is referred to as slide or path animations? 
 a) Modeling   b) Object based  c) Cel based  d) Rendering 
 88. Which of the following is not a multimedia element?  
 a) Text   b) Video  c) Database  d) Sound 
 

********************************** 
9. PRESENTATION 

 [Blue print - 5 questions] 
1.  Which key is used to create a new presentation using a template? 
 a) shift + Alt + N   b) Shift + Ctrl + N c) ctrl + Alt + N   d) Shift+ Tab 
2.  Which of the following view allows creating and editing slides? 
 a) Normal   b) Outline   c) Notes   d) Handouts 
3.  Which command is used to insert a picture in a slide? 
 a) Insert → Picture  b) Format → Picture c) Insert ⟶ Picture ⟶ From file d) Insert →From →Picture 
4.  How will you change the background color of the entire slide? 
 a) Format → Background  b) Format ⟶ Page ⟶ Backgroundc) Format → Page d) Insert → Page → Background 
5.  Which key combination is used to print slides in Star Office? 
 a) Alt + P    b) Ctrl + P  c) Shift + P   d) Shift + Ctrl + P 
6.  Select ------------ Colors to apply the colors supported by browser 
 a) use HTML   b) use HTTP   c) use browser   d) use link 
7.  In presentation the view that allows us to view miniature image of the all slide is ____ 
 a) Slide sorter  b) Master page   c) Notes view   d) Layout 
8.  Which of the following is used to import objects from other application into a presentation? 
 a) Insert ODBC object  b) Insert OLEDB object  c) Insert OLE object d) Insert DBMS object 
9.  The shortcut key for opening style list is …………….. 
 a) F8    b) F7    c) F5    d) F11 
10.  The star office application that allow to create attractive and professional looking presentation is 
 a) Star office writer   b) Star office calc  c) Star office impress d) Star office base 
11.  In star office impress, the page used to specify basic background information that needs to be included in all the slides 

is 
 a) Slide Transition   b) Custom Animation  c) Master Page  d) Layout 
12.  The number of option displayed in the first page of the presentation wizard is…….. 
 a) 2    b) 3    c) 4    d) 5 
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13.  Which of the following options display “Created with Star Office” message during the pause between each 
presentation? 

 a) Automatic  b) Effect   c) Show Logo   d) Default 
14.  The view used to reorder is ……………. 
 a) normal    b) outline  c) notes   d) handouts 
15.  To open media player window, choose ………… 
 a) Tools ⟶ Media player b) Edit→ Media player  c) Insert→ Media player  d) View→ Media player 
16.  Which is not a Background fill option? 
 a) Color    b) Gradient   c) Picture  d) Hatching 
17.  In Star Office Impress, the windows allows to quickly jump from one slide to other slide or move between open file 

is -----------. 
 a) Desktop    b) Navigator   c) Preview   d) Moving slider 
18.  Which command that is used to create a new impress presentation is 
 a) File⟶New⟶Presentation  b) File→ New→ Star office Impress  
 c) File→ Presentation    d) File→ New→ Star office presentation 
19.  To insert a slide, choose 
 a) Slide→ Insert   b) Insert→ Slide  c) Format→ Slide Insert  d) Presentation→ Slide 
20.  Which one of the following displays various transition effects that can be attached to a slide? 
 a) Custom animation  b) Slide transition c) Animation effects  d) Slide sorter 
21.  Which button is pressed to start the slide show in Star Office Impress? 
 a) F1    b) F3    c) F5    d) F7 
22.  To open media player window, choose 
 a) Tools ⟶ Media Player b) Slide Show_Media Player c) Insert_Media Player  d) View_Media Player 
23.  To rename a slide choose slide→ 
 a) rename slide  b) new slide   c) rename   d) slide rename 
24.  Which is used for performing calculation s in presentation? 
 a) Insert formula  b) Insert OLE object  c) Insert Applet   d) Insert Object 
25.  Which of the following views allows recording slides, editing slide titles and heading? 
 a) Normal view   b) Notes view   c) Handouts view  d) Outline view 
26.  Which of the following commands is used to open HTML export view? 
 a) File ⟶ Export  b) HTML → Export  c) File → HTML Export  d) File → HTML Export 
27.  --------------is the Star Office application that allows us to create attractive presentations? 
 a) Star Office Impress b) Star Office Writer  c) Star Office Draw  d) Star Office Calc 
28.  To change the slide order, in the switching presentation view tab click ………… 
 a) Slide Sorter  b) Layout   c) Outline   d) None of these 
29.  Which key is used to select multiple slides? 
 a) Ctrl   b) Alt    c) Shift    d) Tab 
30.  Which key combination is used to print slides in star office? 
 a) Alt + P    b) Shift + P   c) Ctrl + P  d) Shift + Ctrl + P 
31.  A ------------ box on the right allows you to view a preview of the slide with the selected background. 
 a) preview  b) print    c) speed   d) automatic 
32.  The --------- section in the lower half of the page allows you to specify the final output medium for presentation. 
 a) Output medium   b) slide   c) select an output medium  d) select a medium 
33.  The ------------ page of the wizard allows you to specify the transition effects to be used in presentation. 
 a) first    b)second   c)third   d) fourth 
34.  The select a slide transition section at the -------- of the page allows you to choose the transition effect and speed in the 

slides. 
 a) Bottom    b) right top corner  c) top   d) left 
35.  To create a new presentation using a template, choose ------------ 
 a) File → New → Presentation    b) File → New → Template 
 c) File → New → Document     d) File ⟶ New ⟶ Templates and documents 
36.  StarOffice Impress allows us to ------------ and modify Microsoft Powerpoint presentation. 
 a) import   b) export   c) report   d) compile 
37.  StarOffice Impress Window contains ------------ Panes 
 a) 2    b) 3   c) 4    d) 5 
38.  The task pan on the right displays ------------ pages 
 a) 2    b) 3    c) 4   d) 5 
39.  Which dialog box appears when Shift + Ctrl + N buttons are clicked from star office impress? 
 a) Academic presentation  b) Templates  c) Documents   d) Templates and Documents 
40.  ------------ view allows to reorder, edit slide titles, and headings. 
 a) Normal    b) Notes   c) Handout   d) Outline 
41.  ----------- view is used by a presenter to add additional information to a slide 
 a) Notes   b) Handout   c) Outline   d) Layouts 
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42.  We can choose a ------------ while creating a new slide. 
 a) Notes    b) Layout  c) Outline   d) custom 
43.  ---------- Menu is used to start a presentation. 
 a) View    b) Tools   c) Slide Show   d) Window 
44.  The onscreen presentation starts automatically in the ------------ mode 
 a) Minimized   b) full screen  c) maximized   d) normal 
45.  End the presentation by pressing the ---------- key 
 a) End    b) Enter   c) Esc   d) Break 
46.  Select -------------- to run a custom slide show in the order that you defined. 
 a) Slide Show   b) Custom Slide Show c) View Show   d) any the above 
47.  The new slide uses the page layout of the ------------slide 
 a) first    b) previous  c) last    d) any of the above 
48.  To define the order in the slide show, click on ------------ 
 a) slide show   b) view show   c) custom slide show d) outline 
49.  To insert movie in a slide, click on -------------- 
 a) Insert → Picture Sound    b) Insert → Audio and Video 
 c) Insert ⟶  Movie and Sound  d) Insert → Picture and Sound 
50.  To play a movie or sound file click play on the -----------Tool bar 
 a) Movie    b) Sound   c) Media   d) Media Playback 
51.  For movie files, the bar contains a list box where we can select the ----------- for the playback. 
 a) volume slide   b) zoom factor  c) position slider  d) any of the above 
52.  The media player supports ---------- different media formats 
 a) 2    b) 3    c) 4    d) many 
53.  To insert an object in a slide, choose ------------ 
 a) Insert ⟶ Object  b) Insert → Chart  c) Insert → OLE   d) Insert → Formula 
54.  Insert OLE object is used to import objects like -------------- 
 a) Formula    b) text    c) Microsoft application objects  d) all of these 
55.  Click ------------ to get slide view 
 a) Insert → Toolbar → Slide View   b) Insert → Slide View  
 c) View → Slide Show    d) View ⟶ Tool Bars ⟶ Slide View 
56.  The objects in your slide can have ------------ effects 
 a) 2    b) 3    c) 4    d) many 
57.  A ----------- determines the text formatting style for title outline and the background for one or for all of slides. 
 a) slide    b) master  c) slide design   d) slide background 
58.  The styles outline one through outline ----------- Enables you to give the outlined headings and topics on your slides a 

uniform look 
 a) 8    b) 9   c) 7    d) 6 
59.  Open stylist by choosing ----------- 
 a) Format ⟶ Styles and Formatting  b) Format → Styles 
 c) Tools → Styles and Formatting    d) Insert → stylist 
60.  If you want a slide show always with current page, use …………… 
 a) Edit → Options → StarOffice Impress   b) Tools → Options → General 
 c) Slideshow → Options→ StarOffice Impress → General d) Tools ⟶ Options ⟶ StarOffice Impress ⟶ General 

61.  Choose ---------- to hide a slide in the slide show 
 a) Tools→ Show/Hide slide                            b) Insert → how/Hide Slide  
          c) Slide Show ⟶ Show/Hide Slide                           d) any of the above 
62.  Open navigator by choosing ---------- menu 

a) View    b) Insert   c) Edit    d) Format 
63.  Which pane displays the slides in the presentation? 
 a) Middle   b) Left    c) Right    d) Top 
64.  By pressing which key in the keyboard the view of the slide can be enlarged? 
 a) F1    b) F3    c) F5    d) F11 
65.  Which of the following can preview movie and sound files in a presentation? 
 a) Flash    b) Media player c) Windows   d) Plug-in 
66.  Which command is used to open a custom slide show? 
 a) Slide Show ⟶ Custom Slide Show  b) Insert→ Custom Slide Show 
 c) Edit→ Custom Slide Show    d) Format→ Custom Slide Show 
67.  Which key is used to save the presentation? 
 a) File→ Save   b) Save Icon   c) Ctrl + S   d) All of these 
68.  Which icon turns sound off and on in Media Playback Toolbar? 
 a) Play    b) Mute   c) Pause   d) Volume Slider 
69.  Which of the following is used to import applets into the presentation? 
 a) Insert Applet  b) Insert OLE Object  c) Insert Formula  d) Insert→ Object 
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70.  The full form of PDF file is---------- 
 a) Portable Document Format   b) Personal Document Format  
 c) Portable Document File   d) Personal Document File 
71.  Which option allows to manually control the transition of slides? 
 a) Automatic   b) Default   c) Normal   d) Show Logo 
72.  Which page allows to add or modify animation effects to elements of a slide? 
 a) Master page   b) Layouts   c) Custom Animation d) Slide Transition 
73.  Which command is used to reduce the size of a slide to be printed? 
 a) Format→ Page   b) File→ Print   c) Format→ Character  d) Fit object to paper format 
74.  In which view all the side show effects can be assigned to the slide? 
 a) Normal    b) Outline   c) Notes   d) Slide 
75.  Which of the following command settings override the default printer options? 
 a) File→ Print         b) Tools ⟶ Options ⟶ StarOffice Impress c) Format→ page  d) Layout settings 
76.  Which key is used to select a range of slides? 
 a) Shift    b) Ctrl    c) Shift or Ctrl   d) None of these 
77.  In which view mode, all the slide titles will appear in a list along with the headings and sub-topics? 
 a) Normal    b) Outline   c) Notes   d) All of these 
78.  Which option in presentation wizard allows to specify the duration for each side and will automatically flip through 

the slides at the specified speed? 
 a) Default    b) Automatic   c) Duration of page  d) Duration of pause 
79.  The key used to move the line one level up in styles and formatting window is 
 a) Tab    b) Alt + Tab   c) Shit + Tab  d) Enter 
80.  Which option should be selected in Publication Type to create HTML pages without frames? 
 a) Standard HTML format  b) Automatic   c) WebCast   d) None of these 
81.  The extension name of Star office Impress file is 
 a) .odt    b) .ods    c) .odp   d) .odd 
82.  A presentation can be exported in ------------format 
 a) PDF   b) SWF   c) Web Page   d) All of these 
83.  A presentation can be created using----------- 
 a) Template  b) Scratch   c) a or b   d) Star office writer 
84.  ------------allows you to display important sides during a presentation. 
 a) Custom Slide Show b) Master Page   c) Custom Animation  d) Media Player 
85.  Which of the following view is the easiest way to assign slide transition effects to slides? 
 a) Normal   b) Slide    c) Handout   d) Format 
86. Which spin box allows you to specify the duration for the slides? 
 a) Duration of slide  b) Duration of Pause c) Duration of Page d) Duration of display 
87. Which check box message “Created with Star Office” during the pause between each presentation? 
 a) Show logo  b) Show message c) Show icon  d) Shoe preview 
88.  The middle pane in the presentation window displays _________ tabs at the top. 
 a) 4   b) 3   c) 5   d) 2 
89.  Which view allows you to create and edit slide? 
 a) Normal View  b) Outline View  c) Notes View  d) Handouts View 
90. Which key is used to end a presentation before the end? 

 a) Esc   b) Alt   c) Shit   d) Ctrl+Alt 
 

**************************** 
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Volume II 
1. OBJECT ORIENTED CONCEPTS USING C++ 

 [Blue print - 2 questions] 
1.  The two separate segments that were realized when viewing the solution of a problem are 
 a) Data and Program  b) Data and Object  c) Data and Operations d) Data and Class 
2.  The ability of an object to respond differently to different messages is called 
 a) Polymorphism   b) Inheritance   c) Encapsulation d) Overloading 
3.  Which is a kind of self-sufficient “subprogram” with a specific functional area? 
 a) Object   b) Class    c) Entity   d) Overloading 
4.  The process of creating new data types from existing data type is called as 
 a) Polymorphism   b) Inheritance  c) Encapsulation  d) Overloading 
5.  Which of the following is a group of related functions and data that serves those functions? 
 a) Abstraction   b) Data    c) Object  d) Class 
6.  Which is the mechanism that bounds data and functions together within an object definition? 
 a) Inheritance   b) Encapsulation c) Abstraction   d) Polymorphism 
7.  The group of data and operations together are termed 
 a) Program    b) Class    c) Object  d) Function 
8.  The act of revealing the essential features of an object while curtailing the access of data is called as 
 a) Data Hiding  b) Inheritance   c) Polymorphism  d) Class 
9.  Data Hiding is also called as 
 a) Deletion    b) Abstraction  c) Reduction   d) Hidden 
10.  Which of the following is a template for entities that have common behavior? 
 a) Class   b) Object   c) Attribute   d) State 
11.  Which of the following reduces the software complexity with multiple definitions? 
 a) Inheritance   b) Polymorphism c) Data Abstraction  d) Encapsulation 
12.  Which of the following classes is power packed, as they include the functionality of the base class along withtheir own 

unique features? 
 a) New class   b) Parent class  c) Derived class   d) Super class 
13.  An example for Object Oriented Programming Language is 
 a) C++   b) FORTRAN   c) C    d) BASIC 
14.  Which of the following is the key factor of Object Oriented programming language? 
 a) Functions and Object behaviour  b) Objects and Classes c) Data and Operations  d) Data and Objects 
15.  Which of the following data types allow programs to organize as objects? 
 a) Class   b) Polymorphism  c) Inheritance   d) Data Abstraction 
16.  C++ belongs to which category of programming language? 
 a) Structured   b) Procedural   c) Modular   d) Object Oriented 
17.  Which of the following provides security to data? 
 a) Data hiding or Abstraction   b) Derived class or Base class  
 c) Abstraction or Inheritance    d) Abstraction or Class 
18.  In the early programming languages the input and output data items were represented as __________ 
 a) variables  b) constants  c) operators  d) expressions 
19. Which makes it easy to represent real systems in software program? 
 a) data   b) objects  c) operators  d) operations 
20. The process of acquiring the base class properties is called __________ 
 a) polymorphism  b) encapsulation  c) inheritance  d) processing 
21. ___________ communicate with one another by sending data as inputs. 
 a) objects   b) programs  c) operations  d) variables 
 

2. OVERVIEW OF C++ 
 [Blue print - 4 questions] 

1.  C++ was developed by -------------- 
 a) James Gosling   b) Rick Mascitti   c) Bjarne Stroustrup d) Dan Bricklin 
2.  The basic types of elements essential for programming coding are collectively called as 
 a) Identifiers   b) Keywords   c) Tokens  d) Constants 
3.  Which is the smallest individual unit in a program? 
 a) Variable    b) Keyword   c) Tokens  d) Constant 
4.  Which are reserved words with special meaning to the language compiler? 
 a) Tokens    b) Constants   c) Keywords  d) Identifiers 
5.  Which are also called as variables? 
 a) Statements   b) Constants   c) Identifiers  d) Tokens 
6.  The hexadecimal integer is a sequence of digits starting with 
 a) 0x   b) hex   c) 0    d) 16 
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7.  Which of the following letters is used to represent the floating-point constant in exponent form? 
 a) F or e    b) F    c) E Only   d) E or e 
8.  Which constant contains a single character enclosed within single quote s? 
 a) integer    b) string   c) floating point   d) character 
9.  Escape sequences are represented using characters prefixed with a 
 a) *    b) /    c) \   d) | 
10.  Non-graphic character constants are represented using 
 a) Statements   b) Escape sequences c) Variables   d) Comments 
11.  The full form of ASCII is ---------------- 
 a) American Standard Code for Information Interconnect 
 b) American Standard Code for Interchange Information 
 c) American Standard Code for Instruction Interchange 
 d) American Standard Code for Information Interchange 
12.  Which is a sequence of characters surrounded by double quotes? 
 a) string   b) character   c) word    d) numbers 
13.  Which of the following is the simple assignment operator? 
 a) +=    b) ==    c) !=    d) = 
14.  How many classifications of operators are there in C++? 
 a) 3    b) 13   c) 14    d) 12 
15.  The combination of operands and operators is called as 
 a) Identifier   b) Equation   c) Variable   d) Expression 
16.  Which of the following operators is used to compare numeric values? 
 a) Logical    b) Relational  c) Arithmetic   d) Assignment 
17.  Which of the following operators is a logical operator? 
 a) OR    b) NOT    c) AND   d) All of these 
18.  Which of the following are characters with a specific function? 
 a) Operators   b) Identifiers   c) Punctuators  d) Constants 
19.  Which of the following data types is used to declare a generic pointer? 
 a) char    b) string   c) int    d) void 
20.  Which data type indicates the compiler that the function does not return a value? 
 a) string    b) int    c) char    d) void 
21.  Which variable holds the memory address of other variables? 
 a) Pointer    b) Static   c) Dynamic   d) Temporary 
22  Which of the following is user defined named entities of memory locations that can store data? 
 a) Tokens    b) Constants   c) Keywords   d) Variables 
23.  Which qualifier specifies that the value of a variable will not change during the run time of a program? 
 a) short    b) long    c) int    d) const 
24.  The operators use d only by the preprocess or are ------- 
 a) ++ and - -   b) # and ##  c)&& and ||   d)> and < 
25.  Which operator returns the memory requirement size of the given expression or data type in terms of bytes? 
 a) signed    b) struct   c) static    d) sizeof 
26.  Which refers to the process of changing the data type of the value stored in a variable? 
 a) Type cast  b) Conversion   c) Type modification  d) Data conversion 
27.  Which of the following punctuators is used to terminate a C++ statement? 
 a) :    b) }    c) ]    d) ; 
28.  In C++, the single line comment should be preceded or prefixed 
 a) \\    b) /** */   c) /* */    d) // 
29.  In which year, C++ was developed? 
 a) 1985    b) 1990  c) 1975    d) 1980 
30.  A variable name must begin with ----------- 
 a) Alphabet or Underscoreb) Number   c) Alphabet   d) Underscore 
31.  Which is an invalid identifier? 
 a) test12    b) 1test  c) _test    d) test 
32.  The constant that should not have fractional part is called as a/an 
 a) exponent   b) float    c) double   d) integer 
33.  The escape sequence used to produce bell sound is 
 a) \t    b) \n    c) \b    d) \a 
34.  The end of a string literal is by de fault added with a special character 
 a) \x    b) \\    c) \0    d) \a 
35.  Which is a scope access resolution operator in C++? 
 a) ::   b) ?:    c) .*    d) -> * 
36.  Which is a ternary operator in C++? 
 a) .*    b) ::    c) ?:   d) ->* 
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37.  Which of the following operator requires two operands? 
 a) Binary   b) Conditional   c) Ternary   d) Unary 
38.  Increment and decrement operators are called as 
 a) Ternary    b) Unary  c) Arithmetic   d) Binary 
39.  Which of the following is an example for pre-increment operator? 
 a) --a    b) ++a   c) a++    d) a— 
40.  The conditional operator is 

a) --    b) ?:   c) ?:;    d) ++ 
41.  The punctuator used to enclose the block of comment statement is 
 a) /* */   b) //    c) [ ]    d) { } 
42.  Which data type helps in improving the credibility and readability of the program? 
 a) Type defined  b) User defined   c) Built-in   d) Derived 
43.  Which of the following user defined data types allow users to define a variable that would represent an existing data 

type? 
 a) typedef   b) union   c) class    d) enumeration 
44.  The user defined data type helps users in creating a list of identifier called 
 a) class    b) enumeration c) union   d) typedef 
45.  Auto variables get undefined values known as 
 a) Scalar    b) Register   c) Garbage  d) Data type 
46.  The modifier that allows the variable to exist in the memory of the computer, even after losing its scope is 
 a) global    b) auto    c) static  d) extern 
47.  Which variables are global variables known to all functions in the current program? 
 a) register    b) auto    c) static    d) extern 
48.  Which of the following is the fundamental (or) built in (or) basic data types? 
 a) Void    b) Float    c) Integral  d) All of these 
49.  Integral data type is classified into 
 a) float and double   b) int and char  c) int and float   d) int and double 
50.  The address of the operator in a pointer data type is 
 a) $    b) &   c) *    d) # 
51.  Which of the following is not a C++ keyword? 
 a) new    b) this   c) cont   d) if 
52.  Which of the following is not a C++ keyword? 
 a) signed    b) size of   c) static    d) struct 
53.  The ASCII value of the character ‘a’ is 
 a) 97    b) a    c) 90    d) 65 
54.  How many fundamental data type s are there in C++? 
 a) 4   b) 1    c) 3   d) 2 
55.  The enumeration integer const ants are starting with the value of 
 a) 0   b) 2    c) 1    d) any one value 
56.  The range of integer data type is 
 a) -32768 to 32767  b) -32767 to 32768  c) -32678 to 32678  d) -32768 to 32768 
57.  How many bytes doe s the unsigned int data type occupy? 
 a) 2   b) 1    c) 3    d) 4 
58.  Predict the output 
 #i nclude < ios tre am.h> 
 void mai n( ) 
 { 
 int i=25; 
 cout << i << i++ << ++i; 

} 
 a) 25 26 27   b) 27 26 26   c) 25 25 26  d) 25 25 27 
59.  int a ,b, c; 
 a=6; 
 b=7; 
 c = ( a++) - (--b) ; 
 cout << c; 
 The output of the above code, when it is executed is 
 a) error    b) 9    c) 0   d) 11 
60.  Evaluate the expression a+=b* c where a =5, b=6, c=7. 
 a) 37    b) 77    c) 42   d) 47 
61.  The statement int A; b; is invalid because 
 a) Capital A is not allowed    b) Only one variable should be given 
 c) Variables should be separated by comma d) All the other three choices 
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62.  int i =6; 
 unsigned int j =10; 
 cout << sizeof (i *j) ; 
 The output when the above code is executed is 
 a) 4    b) 2   c) 8    d) error 
63.  If a=5 and b=4, the value of the expression a+b/2* 6 is 
 a) 18    b) 16    c) 15    d) 17 
64.  Which brace is used to enclose the body of the C++ program? 
 a) ()    b) {}   c) []    d)<> 
65  Which of the following defines a Local variable? 
 a) Auto   b) Static   c) Register   d) Extern 
66.  Based on operand requirements, operators are classified as --------- type. 
 a) 4    b) 5    c) 3   d) 2 
67.  The storage specifiers that instruct the compiler to store the variable in the CPU register to optimise access 
 a) static    b) auto    c) register  d) extern 
68.  What is the maximum range of unsigned integer data type? 
 a) 255    b) 65535  c) 3.4e+10   d) 32768 
69.  By default, the local variable is 
 a) Extern    b) Static   c) Register   d) Auto 
70.  Which variables are automatically initialized to zero when they are declared? 
 a) Static and Extern   b) Static and Register c) Auto and Static  d) Register and Extern 
71.  Which of the following is the invalid variable declaration? 
 a) int a,b;    b) int a; b;  c) int a; int b;   d) int a; float b; 
72.  Ternary operators require how many operands? 
 a) Two    b) One    c) Four    d) Three 
73.  Relational operators have lower precedence than 
 a) Boolean operators  b) Relational operators  c) Logical operators  d) Arithmetic operators 
74.  What is the value assigned to x? 
 float x; 
 int a =7, b=3; 
 x= a/(float)b; 
 a) Error    b) 3.0    c) 2.0    d) 2.33 
75.  Find the output: 
 #include <iostream.h> 
 #include <conio.h> 
 void main( ) 
 { 
 int n1=10, *n2 
 n2=&n1; 
 n2++; 
 cout << n1; 
 } 
 a) 12    b) 10    c) 13    d) 11 
76.  Which of the following modifiers increases the bytes for a particular data type? 
 a) Signed    b) Long  c) Short   d) Unsigned 
77.  Which of the following operators is also called conditional operator? 
 a) Binary    b) Unary   c) Relational   d) Ternary 
78.  0.5864E1 represents 
 a) 5.864   b) 0.05864   c) 58.64   d) 0.5864 
79. C++ was developed at  
 a) Sun Micro systems b) AT & T Bell laboratories c) Microsoft d) L & T Bell 
80.  Identifiers are also called as 

 a) keywords  b) variables  c) constants  d) operators 

81.  Data items whose values cannot be changed 

 a) variable  b) keywords  c) constants  d) operator 

82. Which symbol is used in character constants? 

 a) /   b) \   c) ~   d) # 

83. The escape sequence for New line/line feed is __________ 

 a) \n   b) \o   c) \b   d) \a 

84.  String literals are surrounded by _______________ 

 a) ‘ ‘   b) “ “   c) ( )   d) < > 
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85. Which are used to group a set of C++ statements? 

 a) //   b) { }   c) [ ]    d) “ “ 

86.  Which data type helps users in creating a list of identifiers of type int? 

 A_ Type def  b) Derived  c) enumerated  d) Type cast 

87.  How many storage specifiers are there in C++? 

 a) 3   b) 2   c) 4   d) 5 

88.  The range of character data type is 
 a) 128 to +127  b) -128 to +128  c) 127- to +128  d) -32768 to 32767 

89.  __________ variables are sensitive to the data type they point to  

 a) static   b) extern  c) pointer  d) auto 

90. Which of the following is a derived data type? 

 a) Union  b) Float   c) Double  d) Array 

91. Value of 1+pow (3,2) is 

 a) 7   b) 6   c) 10   d) 13 

92. Which of the following is a user defined data type? 

 a) Public  b) Private  c) Protected  d) Class 

93. Which one of the following is not a keyword in C++? 

 a) inline   b) this   c) struct   d) test 

94. If a=5 and b=8, what is the value of expression a+b/2*4;? 

 a) 20   b) 36   c) 21   d) 24 

95. Which of the foolowing is not a qualifier in C++ 

 a) static   b) extern  c) auto   d) register 

********************* 

3. BASIC STATEMENT 
 [Blue print - 5 questions] 

1.  Which is a predefined object that corresponds to a standard input stream? 
 a) cin   b) cout    c) cinput   d) coutput 
2.  Data is read from the keyboard during runtime by using the object 
 a) c++in    b) cin   c) c++out   d) cout 
3.  In C++, which file comprises the combined properties of istream and ostream? 
 a) iostream.h  b) stdio.h   c) string.h   d) conio.h 
4.  A preprocessor directive starts with the symbol 
 a) \    b) #   c) %    d) $ 
5.  The operator >> is called as ------------ 
 a) Stream operator   b) Abstraction operator  c) Insertion operator  d) Extraction operator 
6.  The extraction operator is also called as 
 a) Get from   b) Get to   c) Put to   d) Put from 
7.  Which of the following operators is called as insertion operator or put to operator? 
 a)>>   b)>   c)<   d) << 
8.  How many primarily sections are there in C++ program? 
 a) 5    b) 2    c) 3    d) 4 
9.  Which of the following functions will be executed automatically when a C++ program is executed? 
 a) call by reference   b) main   c) recursive   d) void 
10.  The program statements that cause a jump of control from one part of a program to another are called as 
 a) Assignment   b) Control Structures c) Loop    d) Declaration 
11.  How many major categories of control structures are there in C++? 
 a) 5    b) 2   c) 3    d) 4 
12.  Which is the simplest of all the decision statements? 
 a) nested if    b) switch   c) Simple if  d) if – else 
13.  Which of the following execute a set of instructions repeatedly for a certain number of times? 
 a) Loops   b) Selections   c) Statements  d) Operators 
14.  How many kinds of loops are there in C++? 
 a) 3   b) 4    c) 2    d) 1 
15.  Which loop is called as exit-check loop? 
 a) while    b) do-while  c) do loop   d) for 
16.  Which of the following is an entry-check loop? 
 a) while   b) switch   c) if    d) do-while 
17.  Which loop is called as an entry controlled loop? 
 a) while    b) do loop   c) do-while   d) for 
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18.  Which of the following statements forces the next iteration of the loop to take place by skipping the remaining code? 
 a) break    b) end    c) continue  d) begin 
19.  Which of the following statements accomplishes jump from the current loop? 
 a) Break    b) Switch   c) While   d) Continue 
20.  A program written in high level language is called as 
 a) Executable code   b) User code   c) Object file   d) Source code 
21.  The machine-readable form of a program is called as --------------- 
 a) User code   b) Computer code  c) Object file  d) Source code 
22.  Which translator programs create a machine-readable program from the source code? 
 a) Assembler   b) Interpreter   c) Converter   d) Compiler 
23.  Which operator extracts data from the input stream object and places the value in the variable to its right? 
 a) Extraction  b) Abstraction   c) Stream   d) Insertion 
24.  Which operator directs the contents of the variable to its right to the object to its left? 
 a) Abstraction   b) Extraction   c) Stream   d) Insertion 
25.  Which of the following variables get defined only when memory is fetched to store data? 
 a) Function   b) Global   c) Local   d) Pointer 
26.  Which of the following statements chooses between two alternatives? 
 a) switch    b) nested if   c) Simple if   d) if...else 
27.  Which decision statement creates branches for multiple alternatives sections of code, depending on the value of 

asingle variable? 
 a) switch    b) if...else   c) while   d) for 
28.  Every action block of switch statement should be terminated using 
 a) break    b) continue   c) stop    d) return 
29.  Based on the position of the condition, how many classifications of loops are there in C++? 
 a) 3    b) 2   c) 4    d) 1 
30.  In which loop, condition marks the last statement of the body of the loop? 
 a) while    b) for    c) switch   d) do-while 
31.  In for loop, which segment is evaluated before the commencement of  every iteration? 
 a) Increment   b) Initialization  c) Test condition d) Any one of the choices 
32.  Nested if statement can be replaced by the statement of 
 a) for   b) do-while   c) select case   d) switch case 
33.  An outer loop and an inner loop having the same control variable leads to 
 a) Syntax error   b) Software error  c) Semantic error  d) Logical error 
34.  Which C++ file comprises of all standard declarations and definitions for predefined functions? 
 a) Footer    b) Pointer   c) Program   d) Header 
35.  How many times the following loop will be executed? for (i=1;i<6;i++) 
 a) 5   b) 7   c) 6    d) 1 
36.  The break statement would exit only the 
 a) Current function   b) Current program  c) Current loop  d) None of these 
37.  The declarations for the object cin are available under the header file 
 a) inputstream.h   b) stream.h   c) stdstream.h   d) istream.h 
38.  The statement which is used to exit from switch statement is 
 a) exit    b) break  c) default   d) quit 
39.  Statement used in C++ to display messages and result is 
 a) cin    b) print   c) printin   d) cout 
40.  Basic statements in C++ are constructed using 
 a) operators   b) tokens  c) constants   d) variables 
 Read the following C++ program: 
 #include < iostream.h> 
 void main() 
 { 
 int num=2; 
 do 
 { 
 cout << num*num <<'\t'; 
 num +=1; 
 } 
 while (num<6); 

} 
41. Name the control variable used in the program. 
 a) \t    b) num    c) +=1   d) None of these   
42.  What is the test expression (condition) used? 
 a) num    b) num * num   c) (num<6)  d) None of these   
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43.  How many times will the loop be executed? 
 a) 4   b) 5    c) 3   d) 6 
44.  What is the output of the following program? 
 a) 4 9 16 25  b) 0 4 9 25   c) 2 4 9 16 25   d) 6 4 6 8 
45.  The break statement would exit only the 
 a) Current loop   b) Current program c) Current function  d) None of these 
46.  How many times will the following loop be executed? for(i =1; i<30; i++) 
 a) 1    b) 31    c) 29   d) 30 
47.  Which creates object files from source code? 
 a) Program    b) C++    c) Compiler  d) Computer 
48.  What is the error thrown by the compiler for the following snippet? 
  
 
 if(a>b); 
 cout <<"Greater"; 
 else 
 cout <<"Lesser"; 
  
 
 a) Misplaced if ...... else  b) Misplaced if   c) Misplaced else d) Misplaced else..... if  
 
49.  Which statement is used to skip a part of loop and start the next cycle of loop? 
 a) Continue  b) Stop    c) Skip    d) Break 
50.  for(i =1;i<=10;i++) How many times is this loop executed? 
 a) Ten times  b) Nine times   c) Not executed   d) Only one 
51.  Which is linked with libraries to create an executable file? 
 a) Object code  b) Compiler   c) Programs   d) Source code 
52.  The declaration for the object cin is available in a header file called 
 a) string.h    b) istream.h  c) conio.h   d) stdio.h 
53.  The appropriate declaration statement to initialize the variable 'name ' with the value 'Abdul Kalam' is 
 a) char name[]= "Abdul Kalam";   b) char name= "Abdul Kalam";  
 c) char[] name= "Abdul Kalam";    d) char []name= "Abdul Kalam"; 
54.  Which of the following is an assignment operator? 
 a)<<   b) =   c) +    d) == 
55.  While <( condition)> {...} loop is called as 
 a) exit-check loop   b) nested loop   c) entry-check loop d) multi-check loop 
59.  How many methods are there for assigning data to the variables? 

 a) 3   b) 2   c) 4   d) 5 

60. _____________ is a predefined object of standard output stream. 

 a) cin   b) input   c) cout   d) output 

61. Which operator directs the contents of the variable to its right to the object to its left? 

 a) <<   b) <<=   c) >>=   d) >> 

62. Which statements transfers control to one of the many possible points? 

 a) Switch  b) if   c) do….while  d) for 

63. Include _____________ statement in action block in order to exit from switch statement. 

 a) continue  b) break  c) stop   d) go 

64. Which loop is used when an action is to be repeated for a predetermined number of times? 

 a) while   b) for   c) do while  d) switch 

65. The statement int A;b; is invalid because 

 a) Only one variable should be given  b) Capital A is not allowed. 

 c) Variables should be separated by comma d) All of these 

66. In C++, which should be declared or defined before they are used in a program? 

 a) Data type  b) variable  c) Objects  d) Class 

67. The variable used in for loop is called 

 a) Static variable  b) Counting variable c) Control variable d) for variable 
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68. What is the output of the following snippet? 

        int b=10>10; 

        if (b) 

 { 

  cout<<”True Block”; 

 } 

 else 

 { 

  cout<<”Else Block”;   

 } 

 a) Else Block  b) True Block  c) True Block Else Block d) Else Block True Block 

69. How many times the given loop will be executed? 

        For (int i-0; i<6; i++) 

 a) 1   b) 5   c) 6   d) 0 

***************************** 

4. FUNCTIONS C++ ENHANCEMENTS 
 (1 Mark – 4 Questions, 2 Marks – 1 Questions and 5 Marks - 1 Questions: Total 11 marks) 

1.  The building blocks of C++ programs are 
 a) Functions  b) Arrays   c) Classes   d) Statements 
2.    Which of the following statements marks the end of the function and also transfers control to the statement aftercall 

statement? 
 a) return   b) continue   c) main    d) break 
3.  Which induce the reusability of the code? 
 a) Variables   b) Functions  c) Keywords   d) Instructions 
4.  A function can be called or invoked from another function by using its 
 a) Parameters  b) Name  c) Reference   d) All the other three choices 
5.  Which of the following can be shared by other programs by compiling and loading them together? 
 a) Function  b) Variable   c) Statement   d) Token 
6.  Parameters are separated or delimited by 
 a) scope resolution operator  b) period  c) commas  d) semicolon 
7.  Which communicates with the function through arguments or parameters? 
 a) data type   b) call statement c) name   d) variable 
8.  What are channels through which data flows from the call statement to the function? 
 a) Parameters  b) Function names  c) Operators   d) Data types 
9.  In how many ways functions that have arguments can be invoked? 
 a) 3    b) 2   c) 1    d) 4 
10.  The parameters associated with function header is called as 
 a) Function   b) Formal parameters c) Actual parameters  d) Arguments 
11.  The function that returns no value is declared 
 a) void   b) float    c) int    d) default 
12.  Which of the following refers to the accessibility of a variable? 
 a) void    b) storage class   c) Scope  d) inline 
13.  How many scopes are there in C++? 
 a) 3    b) 1    c) 2    d) 4 
14.  Which operator reveals the hidden scope of a variable? 
 a) Scope   b) Relational   c) Assignment   d) Binary 
15.  Which of the following act as place holders in function prototype? 
 a) Statements   b) Constants   c) Variables  d) Keywords 
16.  The calling function parameters are called as 
 a) duplicate parameters b) actual parameters c) dummy parameters  d) formal parameters 
17.  Which of the following reduce the size of the program? 
 a) Variables   b) Functions  c) Arrays   d) Classes 
18.  In which method, any change made in the formal parameter is not reflected back to the actual parameters? 
 a) void    b) inline   c) call by value  d) call by reference 
19.  Which functions execute faster but require more memory space? 
 a) regular    b) normal   c) void    d) inline 
20.  The return type of the function prototype float power (float, int) is 
 a) double    b) float    c) char    d) int 
21.  Which of the following keywords is just a request to the compiler? 
 a) inline    b) extern   c) auto    d) register 
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22.  Which scope variable’s life time is the life time of a program? 
 a) Function   b) Local   c) File    d) Class 
23.  In which method, any change made in the formal parameter is reflected back in the actual parameter? 
 a) call by reference  b) inline   c) call by value   d) void 
24.  Which looks like a normal function in the source file but inserts the function’s code directly into the calling program? 
 a) inline    b) main    c) scope   d) void 
25.  Which variables die when its block execution is completed? 
 a) Function   b) Local  c) File    d) Class 
26.  Which scope is valid within block and all sub-blocks of function? 
 a) Function  b) Class    c) File    d) Local 
27.  Which operator is used to distinguish local and file scope variables having the same name? 
 a) Relational operator  b) Binary operator  c) Assignment operator  d) scope resolution operator  
28.  The default return data type of a function, if no data type is explicitly mentioned is 
 a) double    b) char    c) int    d) float 
29.  Which of the following is NOT true, related to functions? 
 a) The default value in the formal parameters can be given in the form of variable initialization 
 b) The default value for an argument can be given in between the argument list 
 c) The actual parameters can be passed in the form of constants to the formal parameters of value type 
 d) The actual parameters can be passed only as variables to formal parameters of reference type 
30.  In the following code, the scope of the variable 'a' is 
 if (x < y) 
 { 
 int a; 
 a++; 

 } 
 a) File scope   b) Function scope  c) Class scope   d) Local scope 
31.  The scope of any variable used in the entire program is 
 a) Class    b) Function   c) File    d) Local 
32.  The variable declared above all blocks and functions is called as 
 a) Class Scope   b) File Scope  c) Local Scope   d) Function Scope 
33.  Which scope is not known outside their own code block? 
 a) Class    b) Local  c) Function   d) File 
34.  Which is used to help the compiler to check the data requirements of the function? 
 a) Function prototype b) Function calling  c) Function Definition  d) Header files 
35.  In which method, the called function creates new variables to store the value of the arguments passed to it? 
 a) Formal parameter  b) Call by value c) Call by reference  d) Actual parameter 
36.  In C++, what can be assigned to the formal parameters of a function prototype? 
 a) Values    b) Program   c) Default values d) Default arguments 
37.  Parameters that are associated with function call statement are 
 a) global parameters  b) local parameters  c) formal parameters  d) actual parameters 
38. Each  over loaded member function must differ 
 a) both by the number of its arguments and their data types 
 b) both by the number of its formal parameters and their data types 
 c) either by the number of its arguments or their data types 
 d) either by the number of its formal parameters or their data types 
39.  Which of the following is used to separate a set of actual parameter function? 
 a)&   b) ;(semi-colon)   c) .(dot)   d) ,(comma) 
40.  The return type of the function prototype fact( float, char, double ); is 
 a) float    b) double   c) int    d) char 
41.  Which of the following is called scope resolution operator? 
 a) ?:    b) ::   c)&   d) * 
42.   The starting point for the execution of a program is  
          a) main ( )    b)void    c) #include<iostream.h>  d) cin /  cout 

43.  Which statement transfers control to the statement aftercall statement? 

 a) return   b) continue   c) main    d) break 
44.   Declaration of a function is made through a ___________. 
          a) Function name   b) Function Definition   c) Parameters   d) Function prototype 
45.   The function name may include a set of actual parameters, enclosed in parentheses separated by     
          a) semicolon ;     b) commas   ,    c) #    d) $ 
46.    In _________________________  the flow of data is always from the call statement to the function definition. 
          a) call by reference    b) call by value    c) call by address   d) call by variable 
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47.   In which  method, the called function arguments - formal parameters become alias to the actual parameters in the 
calling function. 

          a) call by reference    b) call by value    c) call by address   d) call by variable 

48.  The actual parameters can be passed only as _________________to formal parameters of reference type 

        a) Constants     b) variables      c) expressions    d) characters 

49.  The default values can be included in the function prototype from______, 
        a) in between b) right to left  c)beginning  anywhere 
50.  By default the return value of a function in C++ is of type _________. 
          a) float  b) char  c) int  d) void 
51.  Which variable is defined within a block. 
           a)  Function  b) local  c) File  d) class 

52.     A ___________ variable cannot be accessed from outside the block of its declaration. 
        a) Function  b) local  c) File  d) class 

53.    A _______ variable is created upon entry into its block and destroyed upon exit. 
          a) Function  b) local  c) File  d) class 

54.   Which of the following about functions is false ? 
 a) Functions are also the executable segments in a program. 
  b) Functions reduce the size of the program 
  c) Functions induce the reusability of the code 
 d) Functions provide data security. 
55.  Which amongst the following can only be passed to formal parameters of reference type in C++? 
           a) Variable   b) values  c) Constants  d) Expression 

56. Find the output 
 

 #include<iostream.h> 
Void main( ) 
{ 
Int n1=10,n2=&n1; 
N2++; 
Cout<<n1; 
} 
 

 a) 11  b) 10  c) 12  d) 13 
57.  Which of the following is a valid function prototype? 
        a)float average (a, b);                    b) float prd (int a,b);   
        c) int fun (int a, int b, float pi = 3.14);     d) int display (int a = 5, int b); 
58.  The life time of a file scope variable is the life time of  
         a) program   b) variable    c) Block   d) Function 
59.   Which value will be taken by the formal parameter if there is no actual parameter? 
          a) float  b)constant  c) Default  d) actual 

60.    The return type of the function prototype add(int, int) is 

        a) float  b) int  c) void  d) char 

61. What is the scope of the variable x in the following code? 

#include<iostream.h> 
Int x=100; 
Void main( ) 
{ 
cout<<x; 
} 

           a)  Function  b) local  c) File  d) class 
62.  A block of code begins and ends with___________ 
         a) < >    b) ( )    c) [  ]       d) { } 

63.   ________ variables exist only while the block of code in which they are declared is executing. 
         a) Function  b) local  c) File  d) class 

64.  The call statement communicates with the function through  
        a) data types  b) tokens   c) arguments or parameters   d) parameters or tokens 

65.  In a function declaration,the names of the arguments are dummy _________and therefore they are optional. 
         a) keywords  b) variables   c) data types   d) characters 
66.   With function prototyping, a _____________is always used when declaring and defining a function. 
          a) token    b) parameter    c) template     d) data type 
67.   Which method copies the values of actual parameters into the formal parameters? 
           a) call by reference  b) call by value    c) call by address   d) call by variable 
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68.   The actual parameters can be passed in the form of _____________ to the formal parameters of value type 
           a) constants or variables                b)    variables or expression 
           c)  constants or  expression          d)     constants or variables or expression 
 69.  The ________________facilitate the function call statement with partial or no arguments. 
          a) formal parameters    b) default arguments    c) variables   d) constants 
70.    In which method when the function is working with its own arguments, it is actually working on the original data. 
           a) call by reference      b) call by value  c) call by address   d) call by variable 
71.  The actual parameters are matched with formal parameters on the basis of 
           a) place value     b) precedence    c) data type      d) one- to –one correspondence 
72.  A function returning a reference can appear on ____________________________of an assignment. 
        a)  left-hand side   b)  right-hand side  c) middle  d)  both a  &  b 
73.   The formal parameters for a reference function should always be of ___________parameter type 
        a) reference   b) value    c) character   d) constant 

****************************** 
5. STRUCTURED DATA TYPE ARRAY 

 [Blue print - 3 questions] 
1.  Which of the following is a derived data type that can hold several values of the same type in C++? 
 a) Function   b) Pointer   c) Array  d) Reference 
2.  The collection of variable s of the same type that are referenced by a common name is 
 a) Structure   b) Function   c) Pointer   d) Array 
3.  The size of the array should always be 
 a) Positive  b) Negative   c) Float    d) Double 
4.  How many types of arrays are there in C++? 
 a) 5    b) 3    c) 2   d) 4 
5.  The process of rearranging the data in an order in a given array is called 
 a) Sorting    b) Filtering   c) Merging   d) Searching 
6.  Which are treated as single dimensional array of characters? 
 a) Literals   b) Integers   c) Floats   d) Characters 
7.  A character array should be terminated with a symbol 
 a) /0    b) \x    c) 0    d) \0 
8.  Which is the member function of standard input stream? 
 a) puts( )    b) gets( )   c) read( )   d) getline( ) 
9. Which is the member function of standard output stream? 
 a) write( )    b) cin    c) getline( )   d) gets( ) 
10.  How many parameters are re qui red for write ( ) function? 
 a) 3    b) 2   c) 5    d) 4 
11.  In which header file, string manipulators are defined? 
 a) string.h    b) ctype.h   c) conio.h   d) iostream.h 
12.  Which string function copies source string to target string? 
 a) strlen( )    b) strcmp( )   c) strcopy( )   d) strcpy( ) 
13.  Which string function returns the number of characters stored in an array? 
 a) strcmp( )   b) strlen( )  c) strlength( )   d) strcpy( ) 
14.  Which array is stored in sequential memory blocks? 
 a) 1-D    b) 4-D    c) 3-D    d) 2-D 
15.  In which type of arrays, matrices can be represented? 
 a) 1D-arrays   b) 2D-arrays  c) 4D-arrays   d) 3D-arrays 
16.  An array of strings is a character array of the type 
 a) 4-D    b) 3-D    c) 2-D    d) 1-D 
17.  Which array is an array in which each element is itself an array? 
 a) 1-D    b) Literal   c) 2-D    d) String 
18.  The array subscripts always commences from 
 a) 0   b) any one number  c) 1    d) 2 
19.  The memory required for the integer array num_array[5]; is 
 a) 5 bytes    b) 4 bytes   c) 10 bytes  d) 15 bytes 
20.  The second index of the 2-D array refers to 
 a) Column    b) Length   c) Size    d) Row 
21  An integer array with indexes from 0 t o 4, all having value 1 may be declared and initialized as 
 a) int x[4] = {1};   b) int x[4] = {1,1,1,1};  c) int x[ ] = { };   d) int x[5] = {1,1,1,1,1}; 
22.  To treat spaces as part of string literal, one has to use 
 a) getline( )   b) gets( )   c) gets( ) or getline( ) d) puts( ) 
23.  Which member function treats white space or carriage return as terminator for string? 
 a) getline( )   b) gets( )   c) cin   d) cout 
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24.  The function strcpy(s1, s2) 
 a) Appends s2 to end of s1  b) Copies s1 to s2  c) Appends s1 to end of s2  d) Copies s2 to s1 
25.  What will be output of the following snippet? 
 char s1[ 3]=”exam”; 
 char s2[ 3]=”exam”; 
 st rcmp(s1,s2); 
 a) 0   b)>0    c) error    d)<0 
26. What will be the size of the array float num[4] [6];? 
 a) 10 bytes    b) 96 bytes   c) 48 bytes  d) 24 bytes 
27. How many number of elements can be stored in the array int sales[2][4]; ? 
 a) 7    b) 6    c) 8    d) 16 
28.  Determine the number of elements in the following array declaration int array[10][12]; 
 a) 480    b) 240    c) 120    d) 22 
29.  Determine the number of elements in the following array declaration int x[ ][2]={0,1,1,2,2,3}; 
 a) 2    b) 3   c) 6   d) can't determine 
30.  short fine [ 'A']['E']; declares a two dimensional array with number of rows and columns of 
 a) 26, 30    b) 65, 69  c) 1,5    d) 97, 101 
31.  Arrays in C++ belong to which of the following data type? 
 a) Primitive   b) Derived  c) Basic    d) User defined 
32.  In a 2-D array, the first sub-script stands for 
 a) column    b) diagonal   c) object   d) row 
33.  Which of the following is a 2-dimensional character array? 
 a) Array of strings  b) Literals   c) Matrix   d) Strings 
34.  Which of the following is an invalid array declaration? 
 a) int array[];  b) const int i=10; int array[i]; c) Both int array[]; and int array[i];     d) int array[i]; 
35.  Which of the following functions compares the two given strings? 
 a) cmpstr()   b) strcpy()   c) cpystr()   d) strcmp() 
36.   Strings are otherwise called as 
 a) characters   b) literals  c) names   d) constants 
37.  write() is a member function 
 a) All of these three choices  b) string.h   c) istream.h   d) ostream.h 
38.  Memory allotted for int num[2][4]; is 
 a) 16 bytes  b) 10 bytes   c) 120 bytes   d) 60 bytes 
39.  Array parameter by de fault behaves like which parameter? 
 a) Reference  b) Variable   c) Constant   d) Value 
40.  In the array, int sales[2][4]; the first row and second column is 
 a) sales[1][2]   b) sales[2][1]   c) sales[0][1]   d) sales[1][0] 
41. cin>> number[4] reads the ___________ element of the array. 
         a) second   b) third   c) fifth   d) fourth 

42. Which are otherwise called as 
          a) characters   b) Strings c) names   d) constants 

43.  gets( ) function is defined in the header file __________. 
a)istream.h   b) ostream.h    c) stdio.h    d) iomanip.h  

44. There are ______ methods  to display the contents of string. 

a) 3        b)2   c)4  d) 5  
45. A set of mn numbers arranged in the form of a rectangular array of m rows and n columns. 

a) array  b) pointer   c) matrix   d) function  

46. In a 2-D array declaration the first subscript represents the number of ____________. 

a) Columns   b) rows   c) elements    d)  pointer  

47.  In a 2-D array declaration the second subscript represents the number of ____________. 

a) Columns   b) rows   c) elements    d)  pointer 

48.  Which array comprising of finite homogenous elements 

a) one dimensional  b) multidimensional  c) array of functions   d) array of parameters 

49. Which array comprising of elements, each of which is itself a one- dimensional array 
          a) one dimensional  b) multidimensional  c) array of functions   d) array of parameters 

**************************** 
6. CLASSES AND OBJECTS 
 [Blue print - 6 questions] 

1.  Which is a new way of creating and implementing a user defined data type? 
 a) Polymorphism   b) Class   c) Encapsulation  d) Inheritance 

www.Padasalai.Net                                                www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html

www.Padasalai.Net



 

Simon-Adarsh Vidya Kendra                           Question Bank-Computer Science Page 36 
 

2.  Which provides a new method for packing together data of different types? 
 a) Inheritance   b) Encapsulation  c) Polymorphism  d) Class 
3.  Which is a way to bind the data and it s associated functions together? 
 a) Encapsulation   b) Inheritance   c) Class   d) Polymorphism 
4.  How many parts are there in a class specification? 
 a) 4    b) 3    c) 5    d) 2 
5.  The body of a class is enclosed within a 
 a) [ ]    b)<>   c) { }    d) ( ) 
6.  Every class declaration is terminated by 
 a) :: (double colon)   b)  ; (semicolon) c) . (dot)   d) , (comma) 
7.  How many access specifiers are there in a class? 
 a) 4    b) 5    c) 3   d) 2 
8.  The class body contains the declaration of 
 a) Variables and Functions b) Variables and Arrays c) Pointers and Functions d) Functions and Arrays 
9.  Which of the following class visibility label is optional? 
 a) public    b) all the other three choices  c) protected  d) private 
10.  Which members can be accessed only from within the class? 
 a) protected   b) global   c) public   d) private 
11.  Which members can be accessed from within the class and the members of the inherited classes? 
 a) public    b) global   c) protected  d) private 
12.  Which members can be accessed from outside the class also? 
 a) protected   b) global   c) public  d) private 
13.  The binding of data and functions together into a single entity is referred to as 
 a) Data Hiding   b) Abstraction   c) Inheritance   d) Encapsulation 
14.  Data abstraction in C++ is achieved through 
 a) Polymorphism   b) Inheritance   c) Data Hiding   d) Encapsulation 
15.  Which of the following is achieved through data hiding? 
 a) Class Members   b) Class    c) Data Abstraction d) Polymorphism 
16.  Class comprises of 
 a) Data members & Member function          b) Data types    c) Pointers  d) Arrays 
17.  Which of the following are data variables that represent the features or properties of a class? 
 a) Data members  b) Structures   c) Arrays   d) Member functions 
18. Which access specifier is used to access friend functions? 
 a) private   b) protected   c) class    d) public 
19.  How many classifications of members are there? 
 a) 2   b) 3    c) 4    d) 5 
20.  What are the special member functions of classes? 
 a) Constructors and Destructors  b) Constructors and Methods 
 c) Constructors and Attributes   d) Constructors and Abstractors 
21.  In how many ways, the methods of a class can be defined? 
 a) 2    b) 5   c) 3    d) 4 
22.  A member function can call another member function directly without using dot operator is called as 
 a) Friend functions   b) Inline functions c) Nesting functions  d) Recursive functions 
23.  The variable that is initialized only when the first object of it s class created is 
 a) static    b) private   c) protected   d) public 
24.  The static member variable is initialized to 
 a) true    b) 0   c) 1    d) false 
25.  Which is the default access specifier? 
 a) private    b) static   c) public   d) protected 
26.  A class which contains more than one object is called as 
 a) Nested objects   b) Linked objects  c) Arrays of objects d) Multi objects 
27.  Initially C++ was called as 'C with Classes' by 
 a)Ken Thompson   b) James Gosling  c) Bjarne Stroustrup d) Charles Babbage 
28.  In the class, by default the members will be treated as. 
 a) public    b) global   c) private  d) protected 
29.  The members and functions declared under private are not accessible by members outside the class is  referred as 
 a) Inheritance   b) Data hiding   c) Polymorphism  d) Encapsulation 
30.  Instruments allowing only selected access of components to object and to members of other classes is called as 
 a) Data Hiding   b) Encapsulation  c) Polymorphism  d) Data Abstraction 
31.  In C++, the member functions are called as 
 a) Methods  b) Attributes   c) Operators   d) Operands 
32.  In C++, Data members are called as 
 a) Member functions  b) Attributes  c) Pointers   d) Methods 
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33.  In C++, the class variables are known as 
 a) Constants   b) Functions   c) Methods   d) Objects 
34.  The members of a class are accessed using the operator 
 a) :: (double colon   b) : (colon)   c) , (comma)   d) . (dot) 
35.  The private data of a class can be accessed only through the member functions of its own class and certain special 

functions are called as ------------functions. 
 a) recursive   b) inline   c) friend  d) nested 
36.  The members defined within the class behave like  
          a) inline functions   b) arrays   c) user defined functions  d) structures 
37.  A class belongs to which of the following data types? 
 a) user defined    b) built-in   c) Derived  d) array 
38.  Which member variable’s initial value is done outside the class? 
 a) auto    b) static  c) extern   d) register 
39.  Which data members are not related to any specific object of the class but are shared by all the objects of   the class? 
 a) public    b) private   c) protected   d) static 
40.  Which of the following is not a valid class access specifier? 
 a) protected   b) private   c) class   d) public 
41.  Which is the key feature of OOPS? 
 a) Abstraction   b) Encapsulation  c) Data hiding  d) Data cancelling 
42.  The function associated with the class data type is called 
 a) Arrays    b) Methods  c) Pointers  d) User defined data types 
43.  Which of the following statements is NOT true ? 
 a) The return type of a member function cannot be of object data type 
 b) A non-member function cannot access the private data of a class 
 c) Several different classes can use the same function name 
 d) Member functions can be of static type 
44.  Which of the following is the part s of a class specification? 
 a) Arrays and Functions    b) Pointers and Arrays 
 c) Datatypes and Pointers    d) Class declaration and Class function definitions 
45. class product 
 { 
 int c, q; 
 float p; 
 } p1; 
 The number of bytes occupied by p1 is 
 a) 7    b) 9    c) 8   d) 10 
 
46.  The member function declared under ------------ scope can be accessed by the objects of that class. 
 a) protected   b) public  c) private   d) global 
47.  The variable shared by all the objects of a class, it behaves like 
 a) Static   b) Private   c) Extern   d) Auto 
48.  Which of the following is the most important feature of C++? 
 a) Function   b) Array   c) Class  d) Pointer 
49.    Class comprises of___________ members. 
 a) 2            b) 3      c) 4   d) 5 
50.  How many copies of the static member variable is (are) created ? 
 a) Two    b) Three   c) One    d) Four 
51. class product 
 { 
 int a,b; 
 float P; 
 public: 
 void assign_data(); 
 void display( ); 
 }; 
 void main( ) 
 { 
 product P1, P2; 
 } 
 The number of memory bytes allotted for the variable P1 is 
 a) 8   b) 12    c) 4    d) 10 
52.  Class name is also called as 
 a) function    b) method   c) member   d) tag 
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53.  Which of the following class access specifiers is optional? 
 a) Private    b) Protected   c) Public   d) Class 
54.  How many copy of the member variable is created if it is static memory? 
 a) 1   b) 2    c) 4    d) 3 
55.  Which of the following is true? 
 a) Member function cannot be defined outside the class 
 b) A class cannot have more than three member functions 
 c) Member functions must all have same name  
 d) Member function can be defined outside the class also 
56.  When objects are created, no separate space is allotted 
 a) member functions b) static member  c) data member   d) objects 
57. class example 
 { 
 int x,y, z; 
 float m,n; 
 }p[5] ; 
 
 In the above snippet how many objects are created? 
 a) 5   b) 4    c) 3    d) 1 
58.          
         # include <iostream.h> 

 # include <conio.h> 
 class item 
 { 
 int code, quantity; 
 float price ; 
 void getdata( ) 
 { 
 cout<< "\n Ente r code , quantity and price :"; 
 cin>> code>> quantity>>price ; 
 } 
 protected: 
 void compute ( ) 
 { 
 if( quantity>100) 
 tax=2500; 
 else 
 tax=1000; 
 } 
 public : 
 float tax; 

void putdata( ) 
{ 
cout<< "\n Code :"<< code ; 
cout<< "\n Quantity:" << quantity; 
cout<< "\n Price :" << price ; 
cout<< "\n Tax:"<< tax; 
} 
}; 
void main() 
{ 
item i; 
} 
 

 Memory allocation for instance "i" in the above program is 
 a) 8 bytes    b) 12 bytes   c) 10 bytes   d) 16 bytes 
59.  public data member in the above class definition is 
 a) code    b) price    c) tax   d) quantity 
60.  Method that can be accessed by object "i" is 
 a) putdata()   b) getdata()   c) compute()   d) quantity() 
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61. Read the following snippet and answer the questions 61 to 63: 
 

class student 
{  
private; 
int roll_ no, mark1;  
public: 
student( ); 
{ 
cout<<“\n Constructor executed  “; 
} 
void accept( ) 
{ 
cin>>name>>rollno>>marks1; 
 
} 

}; 

62. What is the name of the class? 

a) student    b) accept c) Public  d) Class 

63. What is the name of the member function? 

a) accept   b) mark1 c) void  d) roll_no 

64. What is the name of the constructor? 

a) accept   b) mark1 c) student d) roll_no 

65. The return type of a member function cannot be of which data type 
a) integer   b) object c) double d) class 

66.                           

class student 

{ 

   int x,y; 

} a,b; 

 

In the above segment of coding a,b are  

a) super class of student b) object class of student c) subclass of student d) class 

61.  Which has  scope or visibility is within the class but its lifetime is the lifetime of the program? 
a) Data members    b) Member function          c) Data members    d) constructors 

62. Which are  functions that perform specific tasks in a class. 
a) Data members    b) Member function          c) Pointers    d) class 

63. Data members are also called as. 
a)Member function   b) pointers   c)methods   d) attributes 

64.  Which operator is used to define function outside a class? 

a) ;  b) :   c)::   d) ?: 

65. In C++ objects of a class are also called 

a) instance   b) constants    c)  tag    d)  data type  

66. Member functions can be of _______type. 

a) auto    b) static   c) extern  d) class  

67. Which of the following is called Scope resolution operator in C++? 

a) ;    b) :   c)::   d) ?: 

68. The static member variable is initialized to ____. 

a) 0   b)  1   c) true    d) false  

*********************** 

7. POLYMORPHISM 
[Blue print - 3 questions] 

1. In C++, polymorphism is achieved through 
a) Inheritance   b) Encapsulation  c) Data hiding   d) Overloading 

2. In how many ways polymorphism is achieved in C++? 
a) 3    b) 4    c) Many   d) 2 
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3. Which of the following terms means a name having two or more distinct meanings? 
a) Inheritance   b) Overriding   c) Encapsulation  d) Overloading 

4. Which refers to a function having more than one distinct meaning? 
a)Overloaded operator b) Overloaded operand c) Overloaded expression d) Overloaded function 

5. The ability of function to process the message in more than one form is called as 
a) Function overloading  b) Data abstraction  c) Operator overloading   d) Data hiding 

6. Which strategy is adopted by the compiler when functions are invoked in function over loading? 
a) First Match   b) Matching   c) Match Best   d) Best Match 

7. Which adopts best match strategy to invoke function over loading? 
a) Compiler b) Overloaded function  c) Interpreter   d) Overloaded operator 

8. The mechanism of giving special meaning to an operator is called as 
a) Function overloading  b) Operator overloading  c) Data overloading  d) Variable overloading 

9. How many explicit argument(s) are taken by binary operators overloaded through a member function? 
a) 4    b) 3    c) 1   d) 2 

10. During integral promotion, a char data type can be converted to 
a) float    b) integer   c) double   d) all of these  

11. Which of overloaded functions are not considered by the C++ compiler as part of the parameter list? 
a) Formal arguments  b) Default arguments c) Actual arguments  d) Dummy parameters 

12. Which of the following operators can be overloaded? 
a) Membership (.)  b) Unary(++)  c) sizeof ( )  d) :: (Resolution operator) 

13. Which function is used to concatenate strings? 
a) strcmp( )   b) strplus( )   c) strcpy( )   d) strcat( ) 

14. The sign for membership operator is 
a) ?: (question colon)  b) :: (double colon)  c) . (dot)  d) : (colon) 

15. Which operator is used to concatenate two objects of the type Strings? 
a) +   b) *    c)&   d) and 

16. Which is one of the facts of C++ that supports object oriented programming? 
a) Data hiding   b) Operator overloading  c) Data abstraction  d) Function overloading 

17. In operator overloading, the operator functions must be defined as 
a) member function    b) either member function or friend function 
c) None of these three choices   d) friend function 

18. Which of the following operators cannot be over loaded? 
a) +=    b) ++    c) +    d) :: 

19. The functionality of  '+' operator can be extended to strings through 
a) operator overloading  b) function overloading c) class   d) inheritance 

20. The over loaded operator must have atleast one operand of 
a) user-defined type b) derived   c) array    d) built-in type 

21. During over loading of which of the following operators, the left hand object must be an object of their relevant 
class 
a) Unary    b) Ternary  c) Binary  d) None of these 

22. The over loaded function definitions are permitted for which of the following data types? 
a)Built in   b) User defined c) Derived   d)All of these 

23. Which of the following is not true related to function over loading? 
a) Do not use the same function name for two unrelated functions 
b) The return type of overloaded functions may be the same data type. 
c) Each overloaded function must differ by the number of its formal parameter. 
d) The default arguments are considered by the C++ compiler as part of the parameter list 

24. Integral promotions are purely ------- 
a) program oriented  b) compiler oriented c) data oriented   d) computer oriented 

25. The function operator() is declared in which part of the class ? 
a) static    b) private   c) public   d) protected 

26. Which of the following statement is false in case of operator overloading? 
a) Only existing operators can be overloaded 
b) Binary operators overloaded through member function take one explicit argument 
c) The overloaded operator must have at least one operand of user defined type 
d) The basic definition of an operator can be replaced 

27. The word polymorphism means  
a)many variables  b) many forms  c) many pointers     d) many functions 

28. During integral promotion, a double data type can be converted to 
a) float    b) integer   c) double   d) a or b 

29. Which overloading, refers to giving additional functionality to the normal C++ operators? 
a) method    b)function     c) operator    d)object 
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30. The overloaded operator must have at least of_________ user defined type. 
a)four   b) three    c) two    d) one  

31.  Which operators overloaded through a member function take one explicit argument. 
a) unary    b)Binary   c) ternary    d) logical 

32. Overloaded operators behave in the same way as the operators in terms of their operands. 
a) binary    b) user defined    c) basic    d) unary 

33. By integral data promotion int data type can be converted into which of the following type? 
a) float    b) double   c) char    d) All of these 

34. The parameter list in function overloading must differ by 
a) function name  b) number of arguments      c)function size        d) number of functions 

35. In C++ each  overloaded must differ by either by the number of 
a) function name          b) actual parameter      c) default parameter      d) formal parameter       

36. The word poly means  
                 a)class               b) many    c) shape     d) constructor 

37. Read the following snippet and answer the questions 38 to 40: 
 

# include <iostream.h> 

# include <conio.h> 

class negative 

{ 

int i; 

public : 

void accept() 

{ 

cout << “\nEnter a number ...”; 

cin >> i; 

} 

void display() 

{ 

cout << “\nNumber ...”<<i; 

} 
 

void operator-() 

{ 

i = -i; 

} 

}; 

void main() 

{ 

clrscr(); 

negative n1,n2; 

n2.accept(); 

-n2; 

n2.display(); 

getch(); 

} 

38. Identify the operator that is overloaded? 
a) Negative  b) – (unary)  c)- (binary)   d)= 

39. Write out the prototype of the overloaded member function. 
a) Negative  operator-( )  b) void operator minus  c) void operator-( )   d) void operator –(negative) 

40. Write out the statement that invokes the overloaded member  function 
a) n2+ ;  b) –n2( );   c) –n2;     d) negative  n1,n2; 

41. Which of the following is an invalid function prototype in overloading? 
a) void fun(int x); void fun(int y); 
b) void fun(int x, int y); void fun(int x, float y); 
c) int fun(int x); void fun(float x); 
d) void fun(char  x); void fun(char  x ,int y); 

*************************** 
8. CONSTRUCTORS AND DESTRUCTORS 

 [Blue print - 4 questions] 
1. Which of the following initializes the class object? 

a) friend function  b) member function  c) inline function  d) constructor function 
2. When a class object goes out of scope, a special function that gets executed is 

a) Destructor  b) Destroy   c) End    d) Constructor 
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3. The constructor and the destruct or have the same name as the 
a) Function   b) Object   c) Variable   d) Class 

4. Which are special functions of classes? 
a) Encapsulation  b) Both Constructors and Destructors c) Constructors  d) Destructors 

5. Which of the following functions return nothing? 
a) Destructor  b) Both Constructors and Destructors c) Pointer  d) Constructor 

6. The constructor add(add &a ) is called as 
a) New   b) Non-parameterized  c) Parameterized  d) Copy 

7. Which is a function that removes the memory of an object? 
a) Destructor  b) Scope   c) Pointer   d) Constructor 

8. The destructor is prefixed with the symbol 
a) ~   b)&   c) ::    d) ?: 

9. Which is executed at the time of program termination? 
a) Polymorphism   b) Class    c) Constructor   d) Destructor 

10. Which of the following are not associated with any data type? 
a) Constructor and destructor  b) Functions c) Destructors   d) Constructors 

11. The memory space is allocated to an object using 
a) Instance    b) Constructor  c) Destructor   d) Overloading 

12. The constructor without any parameter is called as 
a) Parameterized constructor b) Copy constructor c) Default constructor d) Standard constructor 

13. The constructor defined by the computers in the absence of user defined constructor 
a) Parameterized   b) Default  c) Destructor   d) Copy 

14. The constructor add( add &a ) is called as ----------- constructor. 
a) Parameterized   b) Default   c) Copy   d) Non-parameterized 

15. The constructor add( int s1, int s2) is called as ----------- constructor. 
a) Copy    b) Parameterized c) Non-parameterized  d) Default 

16. Which is executed automatically when the control reaches the end of the class scope? 
a) Destructor  b) Constructor   c) Function   d) Overloading 

17. When an object is passed by reference to constructor, the constructor that is executed is 
a) Parameterized   b) Non-parameterized  c) Default   d) Copy 

18. Which of the following cannot be overloaded? 
a) Constructor   b) Operator   c) Destructor  d) Function 

19. How many destructors are present in a class? 
a) any number   b) 2    c) 3    d) 1 

20. Which of the following cannot have arguments? 
a) Function overloading  b) Operator overloading   c) Constructor   d) Destructor 

21. Constructor should be declared under the scope 
a) private    b) pointer   c) public  d) protected 

22. Which of the following is not true? 
a) Constructors can have parameters   b) Destructors cannot be overloaded 
c) Constructors cannot be overloaded  d) Constructors is executed automatically 

23. Read the following snippet and answer the questions 24  &  25: 
 

class simple 
{ 
private : 
int x; 
public: 
simple(int y) 
{ 
x=y; 
} 
~simple () 
{ 
}}; 
 

24. What is the name of the constructor? 
a) simple    b) public   c) private   d) ~simple 

25. What type of constructor is used in this snippet? 
a) Parameterized   b) Copy    c) Non-parameterized d) Data hiding 

26. Which of the following is true? 
a) A destructor can have arguments   b) Constructor returns int type 
c) Constructor can have arguments   d) A destructor has a return type 
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27. Which of the following constructors is executed when a member function returns an object? 
a) Compiler generated constructor    b) Default constructor  
c) Non-parameterized constructor    d) Copy constructor 

28. Read the following snippet and answer the questions 29  &  30: 
class simple 
{ 
private : 
int x; 
public: 
simple (int y) 
(x=y); 
}; 
void main() 
{ 
simple S(6); 
} 

29. How many objects are created? 
a) 7    b) 1    c) 0    d) 6 

30. What type of constructor is used in this snippet? 
a) Parameterized   b) Copy    c) Non-parameterized d) Data hiding 

31. Which function has the same name as the class tag? 
a) constant   b) constructor    c) destructor    d) constructor and destructor 

32. When the program is executed   ____________ is automatically executed when the class object is created? 
a) constructor    b)operator overloading    c) destructor   d) constants 

33. Which overloading can be applied to constructor? 
a)operator   b) procedure   c) function    d) class 

34. Which constructors are referred to compiler generated constructors? 
a) user defined  b) default    c) operator    d) destructor 

35. The constructor with any parameter is called as 
a) Parameterized constructor b) Copy constructor  c) Default constructor d) Standard constructor 

36. Which of the following functions return nothing? 
a) istream.h b) Constructors  c) friend d) conio.h 

37.  Which function can be overloaded? 
a) constant   b) constructor    c) destructor    d) constructor and destructor 

38.  Which of the following cannot have the same name as the class name? 
a) Member function   b) overloaded Constructor c) Constructor   d) Destructor 

39.  Which of the following has no return type and cannot be overloaded? 
a)operator   b) constructor    c) destructor    d) function   

40. When an object is passed as a parameter to a member function which constructor is executed?      
a) user defined  b) default    c) copy    d) special 

41. Which of the following is default constructor? 
a) add( )   b) add( int s1)   c) add(int s1, int s2)   d) add(add &a )   

42. Which of the following must have the same name as the class name? 
a) variable  b) string literal   c) ) constructor  d) constant 

43.  In C++ the compiler generated constructor is called 
a) defined   b) default    c) function  d) destructor 

44.   Which of the following is not true? 
a) Member function returns an object  
b) An object is passed as a parameter to any of the member functions 
c) An object is passed by reference to constructor 
d) Destructor can be overloaded 

45.  Which of the following has the same name of both constructor and destructor? 
a)  function   b) variable c) Object d) Class 

46. Which of the following is the copy constructor for the class  add? 
a) copy (add &a ) b) add ( copy &a)   c) add(&a add )   d) add(add &a )   

47.  Which of the following is copy constructor? 
                 a) Myclass( )  b) Void show( )   c) Myclass (int a, int b)  d) Myclass (Myclass &a )   

48. Which of the following gets executed, when an instance of a class comes into scope? 
a) Overloading   b) Destructor   c) Constructor  d) Encapsulation 

9. INHERITANCE 
 [Blue print - 3 questions] 

1. The process of creating new classes from the existing classes is 
a) Polymorphism  b) Encapsulation  c) Inheritance   d) Data Abstraction 
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2. Inheritance is a process of creating new classes namely 
a) Base classes   b) Parent classes  c) Super classes   d) Derived classes 

3. The existing class is called as 
a) Sub class   b) Abstract class  c) Derived class   d) Base class 

4. The default visibility mode is 
a) static    b) protected   c) private  d) public 

5. A derived class inherits from multiple base classes is known as 
a) Multiple inheritance b) Hybrid inheritance  c) Multilevel inheritance  d) Single inheritance 

6. When a derived class inherits only from one base class is known as 
a) Multipath inheritance  b) Multiple inheritance c) Multilevel inheritance d) Single inheritance 

7. The class from which the new classes are derived is known as 
a) Base   b) Child    c) Derived   d) Sub 

8. Which of the following class is a power packed class with additional attributes and methods? 
a) Derived    b) Static   c) Abstract   d) Base 

9. Which of the following class inherits all the properties of the base class? 
a) Abstract    b) Super   c) Base    d) Derived 

10. Which keyword is used to define a derived class? 
a) base    b) class    c) derived  d) sub 

11. Access specifier is also referred to as 
a) Accessibility  b) Visibility mode c) Acceptability or Accessibility  d) Acceptability 

12. The symbol that must be used between derived and base class is 
a) :   b) ::    c)&   d) # 

13. Which are not inherited but are executed first when an instance of the derived class is created? 
a) Data Members   b) Member functions  c) Destructors   d) Constructors 

14. Which form of inheritance is reflected by the transitive nature of inheritance? 
a) Multilevel  b) Multiple   c) Hierarchical   d) Single 

15. Classes used only for deriving other classes are called as 
a) Super classes   b) Abstract classes c) Static classes   d) Concrete classes 

16. Read the following declarations: 
 

class vehicle 
{ 
int wheels ; 
public: 
void inputdata(int, int); 
void outputdata( ); 
protected: 
int passenger; 
}; 
class heavy_vehicle : protected vehicle 
{ 
int diesel _petrol; 
protected: 
int load; 
public: 
void readdata(i nt, int); 

  void write data() ; 
}; 
class bus:private heavy_vehicle 
{ 
char marks[20]; 
publ ic: 
void fetchdata(char) ; 
void displaydata( ); 
}; 

17. Which is the base class of the heavy_vehicle? 
a) vehicle    b) both bus and vehicle  c) heavy_Vehicle        d) bus 

18. The data member that can be accessed from the function displaydata() is 
a) load    b) passenger   c) marks  d) all of these  

19. The member function can be accessed by an object of bus class is ___________ . 
a) None   b) inputdata, outputdata c) readdata, writedata  d) fetchdata, displaydata 

20. The most powerful feature of an object oriented programming language is 
a) Encapsulation   b) Class    c) Polymorphism  d) Inheritance 
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21. Which of the following is a class from which other classes are derived? 
a) Derived class   b) Base class  c) Function class  d) Super class 

22. How the derived class should be indicated? 
a) Class der_name, visibility mode, base class_id     b) Class der_name :: visibility mode base class_id 

  c) Class der_name : visibility mode base class_id  d) Class der_name ; visibility mode base class_id 
23. Read the following declarations: 

class A 
int  x,y; 
protected: 
int  s,t; 
public: 
int  u, v; 
}; 
class B : public A 
{ 
}; 

24. The data members that inherit from Class A to Class B 
a) u, v    b) x, y    c) Both (A) and (D) d) s, t 

25. u, v data members contain which visibility mode in Class B? 
a) Public  b) Private   c) Either Private or Protected  d) Protected 

26. s,t data members contain which visibility mode in Class B? 
a) Static    b) Protected  c) Private   d) Public 

27. What must be used between derived and visibility modes? 
a) ;    b) ::    c) :   d) ! 

28. For which class, objects cannot be declared? 
a) Abstract   b) Destructor   c) Void    d) Constructor 

29. While defining a derived class the name of the derived class is to be given after the keyword? 
a) base    b) class   c) derived  d) sub 

30. Which members in the base class are not inherited? 
a) Static    b) Protected  c) Private   d) Public 

31. When a class is derived from a class which is a derived class itself then it is referred to as_____________ 
inheritance. 
a) Multilevel  b) Multiple   c) Hierarchical   d) Single 

32. Which are executed in the order of inherited class? 
a) constructors   b) destructors    c)operators   d) success specifiers 

33. Which are executed in the reverse order of inherited class? 
a) constructors   b) destructors    c)operators   d) success specifiers 

34. The new class created from the existing class is   
a) base    b) abstract  c) derived  d) void 

35. Derived class inherits what from its base class? 
a) Name   b) Properties   c)Size     d) Scope 

36. Which of the following is not a type of inheritance? 
a) Multilevel  b) Multiple   c) Multiplex  d) Single 

37. New class created from the base class is called 
a) new class   b) secondary class   c) derived class   d) third class 

38. Which amongst these is not a visibility mode in C++? 
           a) global   b) Protected  c) Private   d) Public 

**************************** 
Chapters: 10 to 12  [Blue print - 6 questions] 

10. IMPACT OF COMPUTERS ON SOCIETY 
1.  85% of computer usage is 
 a) Spreadsheet   b) Presentation   c) Word processing d) Database 
2.  Which of the following permits banking from the comfort of the home by using internet facilities? 
 a) e-Learning   b) e-Commerce   c) e-Banking  d) e-Shopping 
3.  CBT stands for 
 a) Computer Based Tools    b) Computer Based Techniques 
 c) Coded Binary Tools    d) Computer Based Tutorials 
4.  The technical element used to reach out the benefits of IT to the common man is 
 a) Connectivity   b) Affordable computers   c) Software d) All of these 
5.  Which enables data storage and management at home? 
 a) Emotion Container  b) Memo frame   c) Personal Archives  d) Archive unit 
6.  Which is an easy interaction with other people through touch screen? 
 a) Archive unit   b) Bookshelf   c) Memo frame  d) Personal creativity tool 
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7.  Which of the following units will prevent people from acquiring bad habits? 
 a) Archive unit   b) Personal Archives  c) Memo frame   d) Emotion Container 
8.  We can purchase any product, any brand, and any quantity from anywhere using 
 a) e-Shopping  b) e-Learning   c) e-Commerce   d) e-Market 
9.  Which is an advanced data accessing system? 
 a) Bookshelf   b) Memo frame   c) Archive unit   d) Personal creativity tool 
10.  Which of the following enables online educational programs leading to degrees and certifications? 
 a) e-Commerce   b) e-Learning  c) e-Education   d) e-Shopping 
11.  ATM is an example for 
 a) e-shopping   b) e-banking  c) digitization   d) transcription 
12.  Which of the following functions is used as electronic pets in computerized home? 
 a) Robot   b) Interactive screen  c) Creative line   d) Projection TV 
13.  What is useful in computer based education? 
 a) Teaching   b) e-shopping   c) CBT   d) Transcription 
14.  ATM means 
 a) Auto Teller Machine   b) Arithmetic Teller Machine  
 c) Automatic Teller Machine d) Automated Teller Machine 
15.  How many technical elements are require by a common man reach the benefits of IT? 
 a) 4    b) 3   c) 6    d) 5 
16.   Which became a key component in the national economy. 
          a) Education   b) banks   c)Healthcare    d)Computer 
17.     In computer usage the usage of word processing is 
           a) 40 %     b)50%     c) 85 %    d) 70 % 

********************* 
11. IT ENABLED SERVICES 

1.  IT that helps in improving the quality of service to the users is called 
 a) IT Evolution Studies  b) IT Enabled Studies c) IT Environment Studies  d) IT Enabled Services 
2.  ITES stands for 
 a) IT Enabled Services b) IT Evolution Studies c) IT Enabled Studies d) IT Environment Studies 
3.  Which of the following traditional services are IT Enabled? 
 a) Spreadsheet   b) Word Processors  c) Databases  d) All of these 
4.  Which can be collected for one purpose that may be useful for some other purpose? 
 a) Program    b) ITES    c) Computer   d) Data 
5.  BPO may be expanded as. 
 a) Business Process Online     b) Business Publication Outsourcing 
 c) Business Process Outsourcing   d) Business Publication Online 
6.  Which is defined as a telephone based shared service center for specific customer activities? 
 a) Data Management  b) Call Centers  c) Medical Transcription   d) Digitization 
7.  The process of collecting, digitizing, and processing data is called as 
 a) Data Management b) Digitization   c) Call Centers   d) Medical Transcription 
8.  Which of the following is a permanent, legal document that formally states the result of a medical investigation? 
 a) Medical Transcription b) Digitization   c) Data Management  d) Call Centers 
9.  How many steps are involved in medical transcription? 
 a) 4    b) 2    c) 5    d) 3 
10.  Which refers to the conversion of non-digital material to digital form? 
 a) Medical Transcription  b) Tele-Medicine  c) Call centers   d) Digitization 
11.  Which increases the employment opportunities? 
 a) KPO    b) ITES    c) IT    d) BPO 
12.  A facility that allows the user to speak into a special device while typing a letter using computer is called 
 a) Telephone   b) Cell phone   c) Speaker   d) Dictaphone 
13.  Which is the key for effective and profitable use of IT in organizations? 
 a) Data Management b) Digitization   c) Call Centers   d) Medical Transcription 
14.  Which services comprise punching data from manually filled forms and images? 
 a) Tele-Medicine   b) Call Centers   c) Data Processing  d) Medical Transcription 
15.  Which is critical for the success of ITES? 
 a) Computer Crime   b) Computer Virus  c) Computer Time  d) Computer Ethics 
16.  Which of the following is not an IT enabled services? 
 a) Data management  b) e-Governance  c) Reservation  d) Tele-medicine 
17.  The two important aspects that must be ensured by the ITES provider are 
 a) Customer security and needs    b) better look and feel 
 c) Data security and customer privacy   d) personal security and customer satisfaction 
18.   Which is useful in customer related functions? 
 a) e-banking   b) e-shopping   c) e-mail   d) Call centers 
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19.   How many steps are there in data digitization? 
          a) 5   b) 7   c) 6   d) 4 
20.   BFSI and Pension Services are high growth areas of 
         a) ITES   b) Medical Transcription  c) Public telecom  d) Call centers 
21.  Which of the following is not an IT enabled services? 
 a) Data management  b) Website Services  c) Starcalc  d) Call centers 

************************ 
12. COMPUTER ETHICS 

1.  Which is the set of rules for determining moral standards? 
 a) Programs   b) Cracking   c) Ethics  d) Crimes 
2.  Which refers to the protection of hardware? 
 a) Data security   b) Physical security c) Personnel security  d) Personal security 
3. Making and using duplicate hardware and software is called 
 a) Crime    b) Publicity   c) Piracy  d) Security 
4.  Which is a  self-replicating program ? 
 a) Antivirus   b) Virus  c) Language   d) Bacteria 
5.  How many new viruses are found each day? 
 a) 57000    b) 6   c) 55000   d) 5700 
6.  The software runs on an idle computer without the knowledge of the organization is called 
 a) Software time   b) theft of Computer time c) System time   d) Hardware time 
7.  Which of the following laws prevent computer crimes in India? 
 a) Crime    b) Illegal   c) Cyber   d) Zero 
8.  The illegal access to the network is called 
 a) Cracking  b) Accessibility   c) Security   d) Management 
9.  The illegal access to the computer hardware and software 
 a) Browsing   b) Hacking   c) Chatting   d) Cracking 
10.  ''Cracking'' comes under 
 a) Transcription   b) Website Service  c) Data Security   d) Computer Crime 
11.  Which refers to software setups that permit only authorized access to the system? 
 a) Personal security b) Personnel security  c) Physical security  d) Data security 
12.  Which security refers to protecting data and computer system against dishonesty? 
 a) Personnel  b) Physical   c) Data    d) Personal 
13.  How many percent of computer crimes happen within the company? 
 a) 80   b) 90    c) 60    d) 70 
14.  How many known virus programs are in existence? 
 a) 6    b) 55000   c) 5700    d) 57000 
15.  Which of the following is not a way of protection? 
 a) Physical Security   b) Personal Security  c) Piracy  d) Personnel Security 
16.  Which of the following is the telephone based Shared Centre? 
 a) Website Services   b) Call center  c) Medical Transcription  d) e-Governance 
17.  Computer ethics has its roots in the work of ___________________during World War II. 
 a) Norbert Wiener  b) Herman Hollirith  c) Charles Babbage  d) Blaise Pascal 
18.    Which security refers to the protection of hardware, facilities,magnetic disks, and other items that could be illegally 

accessed, stolen, damaged or destroyed. 
 a) Physical Security   b) Personal Security  c) Piracy  d) Personnel Security 
19.   Which can cause damage to data and files stored on the computer is 
 a) Antivirus   b) Virus  c) Language   d) Bacteria 
20.   Which amongst the following is computer crime? 
          a) Telemedicine   b) Call Center    c) Cracking    d) e-Banking 
21. Ten Commandments of Computer Ethics was written at 
          a) Microsoft Corporation      b) AT & T Laboratory    c)Sun Micro Systems       d) Computer Ethics Institute 

 
 
 
 

*********************** 
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